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Introduction 
 

 
 
 
 
 
 
 

The N6820ES Signal Monitoring System is a high- speed signal monitoring 
system designed to find and collect information on wireless communications. 
It covers the spectrum from 100 kHz to 27.4 GHz (depending on the hardware 
configured) with sweep rates up to 4 GHz per second across multiple 
antennas, and controls as many as 100 handoff receivers. 

 

The topics in this chapter are as follows: 

• Options (page 10) 

• What’s New (page 12) 

• Documentation Organization (page 13) 

• Hardware Configuration (page 16) 

• Application Resources (page 17) 

• Starting the Program (page 19) 

• Basic Operation Concepts (page 22) 

• System Block Diagram (page 23) 

• Process Overview (page 33) 

• Opening Window (page 43) 



 

 

Options 
 

Hardware 
Options 

The N6820ES works exclusively with the Agilent N6841A RF Sensor.  It has a 
frequency range of 20 MHz to 6 GHz.  An optional 3rd party Up/Down Converter is 
available to extend the frequency range down to 100 kHz and up to 27.4 GHz. 

 

Refer to Agilent publication # 5990-3839EN, N6841A RF Sensor Technical 
Datasheet or http://www.agilent.com/find/N6841A for a complete description of 
the product and its specifications.

http://www.agilent.com/find/N6841A


 

 

 

Software Options 

 

The N6820ES Signal Surveyor 4D software is available in a variety of configurations. A 
complete list of options and upgrades are available from your Agilent sales representative 
or at www.agilent.com/find/N6820ES 
 

• 114:  Signal Surveyor 4D has all the basic capabilities including energy detection and 
alarm processing, user libraries to enhance signal characterization and identification.  It 
includes a well-developed interface to PostgreSQL database and signal external 
triggering schemes and recording options.  It can also be used as a development 
platform for creating new user- defined libraries. 

 
• ASD:  User Programming provides the ability to create new applications components, 

processes, and drivers as listed here: 
o receiver drivers 
o menus and panes 
o energy features and feature filters 
o wide band energy feature characterization and filtering 
o custom threshold definitions 
o alarm tasks 

 
•  USD:   Universal Signal Detection. Create signal detection algorithms for signals of 

interest without the need to develop a customized program. 
 

• EDF:  Enable direction finding applications provide the ability to use Direction Finding 
(page 395) applications with the N6820ES software. 

 
• MR1:   Basic Modulation recognition application. In search mode can be used to 

perform modulation recognition on time snapshots between sweeps. 
 

• SSY:   Sensor Sweep Synchronization.  This option supplies a client tool and GUI to 
facilitate synchronous sweeps of multiple instances of Signal Surveyor 4D and requires 
programming skill to implement.  Consulting services are recommended.

http://www.agilent.com/find/N6820ES


 

 

What’s New in E3.4? 
 

Current version • Please refer to the Version Differences guide, part number 35688- 90106. 



 

 

 
 
 

Document Organization 
 

This document explains how to use the N6820ES Spectrum Monitoring and 
Interference Detection Software.   We assume you are familiar with the basic 
operation of the host PC and operating system.   If you are unfamiliar with 
such terms as dialog box or double- clicking, or basic file handling and 
printing procedures, please read the appropriate documentation supplied with 
your computer prior to continuing with this document. 

 

The N6820ES Spectrum Monitoring and Interference Detection Software 
documentation is provided in book form and as online help, which is 
available by clicking Help in the menu bar and then clicking Index, or by 
clicking the Help button in any dialog box for information about the controls 
in use of that particular dialog box. 

 

You can also press the F1 function key to get help for any menu that is pulled 
down or window element that is active (outlined) or press Shift- F1 to get 
contextual help. In the latter case, the mouse pointer changes to a question- 
mark pointer so that you can use it to click on the component for which you 
want help. For more information about using Help, see The Help Menu (page 
505). 

 

If you are reading this text online, some of the words are underlined. These 
are hyperlinks; and clicking them displays help on that topic. In the PDF 
version of the text, these words are displayed in a different color; and clicking 
on them displays the text on that topic. In the printed book, these topics are 
followed by a page number; and that page contains the referenced topic. 

 

 

Document Conventions 
 

This document uses several conventions you should be aware of: 
 
Computer Font Words that appear like this are names of files, directories, or are lines in a 

file that you can expect to find exactly as they appear in the documentation. 
 

Path: The Path: identifier is a description of how to find the feature being 
described. It usually starts with one of the entries in the main Menu Bar 
(page 49). 

 
Option: The Option: identifier marks features that are options and may not be 

installed. 
 

N6820ES 
Directory 

The application files are installed in the N6820ES home directory.   The 
definition of this directory depends on the operating system in use. 

 

The suggested home directory for Windows systems is \E3238S. 



 

 

 
 

Documentation Terminology 
 

Energy Energy is either noise, a signal, or part of a signal. In general, energy or 
energy peak is used instead of signal until more information is collected in 
the signal development process.   Energy feature types (sometimes called 
externals) include: 

 

• Frequency 
• Bandwidth (min, max, avg, current) 
• Amplitude (min, max, avg, current) 
• Duration (min, max, avg, current) 
• Detections (number of) 
• Intercepts (number of) 
• Intercept time (first and last) 
• Number of sweeps (since first intercept) 
• Occupancy (%) 
• User- defined (e.g., power) 

 
Energy History This is a history, somewhat like a database, of detected energy. This history 

contains all of the common energy feature parameters listed above as well as 
any user- defined features created with software option ASD feature libraries. 
See Energy History (page 37). 

 
Features Features are basic energy characteristics that are derived from the frequency- 

domain data stream (signal externals) provided by the N6820ES system 
hardware.   The Energy History Database contains data collected for various 
energy features.  Alarm criteria are based on feature values and determine 
when to launch a task. 

 

Feature 
Extraction 

Feature Extraction is part of option ASD (User Programming).   This user- 
defined library addition to the N6820ES system allows you to derive new 
features that are tracked in Energy History and can be used as alarm 
criteria.   See Feature Extraction (page 35). 

 

Filter Generally refers to methods that minimize the number of entries in the energy 
history.   Pre-filters limit new entries that are made and post-filters remove 
existing entries in the energy history (e.g. inactive signals).   See Energy Pre-
filter (page 36). 

 
Signal Signal indicates that more information exists for an “energy peak.” A “signal” 

may be composed of one or more pieces of “energy”. Examples of information 
that contribute to identifying a signal’s type are: 

 

• Modulation type 
• Baud rate 
• Peak spacing/offset 

 

Signal 
Processing 

Signal Processing refers to the narrow- band signal analysis (via DDC) used 
to identify, locate, demodulate or collect signals.  



 

 

 
 

Spew/Subscribe Spew is the process by which the N6820ES provides data or system 
information to other processes. These processes gain access to that data by 
subscribing to it.   With option ASD, an external process or library program 
can subscribe to system information via a sockets (LAN) interface. The 
requested data is distributed to the connected system/process when the 
connection is first made and thereafter, whenever the information changes or 
new information is available.   See Process Overview (page 33) and Socket 
Connections (page 490). 

 
Polling Polling is another way for a process to gain information from the N6820ES. 

The Command Reference1  documents queries that return information about 
configuration and current operation values, like marker position 
(traceA.markerValue?).   Data provided in this manner is supplied once, in 
response to the query. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 See the file \E3238s\manuals\command_ref.pdf. 



 

 

 
 
 

Hardware Configuration 
 

New systems are shipped from the factory configured correctly and ready to 
run.   The installed hardware is defined in a configuration file.  This file is, by 
default, \E3238S\N684X_RF Sensor\e3238s.n6841.cfg1.   This file should 
be changed when the hardware is changed or when libraries are changed. 

 

See the Installation & Configuration Reference2  for information on installing 
hardware and editing configuration commands in the e3238s.n6841.cfg file. 

 

The configuration file may be placed in another directory and given a 
different name by changing the E3238s resource file (see Application Resources 
(page 17)) as follows: 

 

*hardwareConfiguration: /temp/hwConfig.cfg 

It can also be specified in a command prompt or a desktop icon as follows: 
 

C:\E3238s\bin\e3238s.exe -cfgFile "/temp/hwConfig.cfg" 

When the program is running, you can determine which configuration file was 
used to start it by opening the Loaded Libraries (page 495) dialog box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

1 An example file, named d.e3238s.n6841.cfg (“d” = default) is installed in the same 
directory.   This file should be treated as a source file that you copy to another file 
and modify the copy; because it is replaced when the N6820ES application is 
updated.   The file named e3238s.n6841.cfg may be replaced as part of a Sensor 
software or firmware update. 

2 This document is provided in printed form and as a PDF file.   See the file 
\E3238s\manuals\install_ref.pdf. 



 

 

 
 
 
 
 
 

N6820ES 
Resource 

File 

Application Resources 
 
The E3238s file is an X- Window application resource file1.   Resources are 
application variables that the user can redefine by editing the application’s 
resource file.   Resources typically define fonts, colors, line thickness, window 
sizes, file lengths, path names, and many other things for each part of the 
e3238s program. Other application parameters defined in this file are: 

 

• Hardware configuration file location (see Hardware Configuration (page 
16)) 

• Function key definitions 
• Accelerator key definitions (see Accelerator Keys (page 508)) 
• Memory usage parameters 
• Capacity of the log views 
• Initial size of the help windows 
• Titles of trace panes and the handoff log pane 

 

This allows you to change the application’s appearance and functionality.   For 
more information about application resources, see Volume Four of the X 
Window Series published by O’Reilly & Associates, Inc. 

 

Multiple 
Configurations 

To use a custom version of the resource file, copy the file E3238s (see 
footnote) to your profile directory, then modify it to suit your needs.   The 
system searches until it finds the E3238s file, looking in the following paths: 

 

1. $USERPROFILE\E3238s 

2. $HOMEDRIVE:\$HOMEPATH\E3238s 

3. $E3238s\E3238s 

4. C:\Exceed.nt\user\app-defaults\E3238s 

These paths are checked in the order given above.   To determine the 
definition of the system variables (shown with the $ sign), open a command 
window and use the set command.  

 

You can specify a resource when you start the program by using the -xrm 
option: 

 
e3238s -xrm resourcestring 

This option specifies a resource name and value to override any defaults.  It 
is also very useful for setting resources that don’t have explicit command line 
arguments. 

 

If no resource file is found, the fallback resources are used.   If you wish to 
modify these default settings, print the fallback resource to a file named 
E3238s and use it as a starting point.   For a listing of the fallback resources, 
see Print To File (page 142), Fallback Resources.   Also, see the discussion of 
application resources in the Installation & Configuration Reference. 

 

 
 
 

1 As shipped, there is no “E3238s” file.   There is a file named d.E3238s (“d” = 
default) which should be treated as a source file (it is replaced when the soft- 
ware is reinstalled or updated).   If you need to redefine application resources, 
copy the d.E3238s file to E3238s and edit the new file. 



 

 

 

 
 

Note In some cases, the Signal Surveyor 4D software is shipped from Agilent 
Technologies installed, configured, and ready to use.   If you wish to reinstall 
the software, please refer to the Installation & Configuration Reference. 



 

 

 
 
 

Starting the Program 
 

Log in First, login at the workstation.   To do this, you need to know your username 
and password. 

 

• If your system was configured at the factory and this is the first time you 
have started the system, the user name is Administrator and the password 
is empty (press Enter). Factory- configured systems have been configured to 
have network settings provided by a DHCP server and the system name auto- 
generated. 

 

• If your system was not configured at the factory but the system has 
previously been configured, contact your system administrator for the 
username and password.   Substitute the correct entries when you are 
prompted on the display as follows: 

 

user: username 
password: password 

 

Start the program 

Select Start, All Programs, Agilent E3238S, “ E3238S Signal Survey for N684X RF Sensor” 
Software.   Or start t he program using the command- line options. 

 

Usage: 

e3238s [options] 
-audio audio 

Specifies the name of the audio server to use. 
-cfg resourcestring 

Specifies a configuration resource and value. See the file 

C:/E3238s/e3238s.n6841.cfg for available resources. If multiple 
resource/value pairs are required, separate them with a 
semi-colon. 

-cfgFile filename 
Specifies the hardware configuration file to use. 

-classic 
Causes the GUI to be displayed in the classic Motif mode. 

-display display 
Specifies the name of the X server to use. 

-hideDisplay 
Causes the software to not display a X window. 

-remoteMode 
Causes the software to not display a X window and to not 
display any error or message dialog boxes. Any unwritten 
information at exit time will be deleted without warning. 

-geometry geometry 
Specifies the initial size and location of the window. 

-macro filename 
Specifies a macro to run at start-up. 

-missionSetup filename 
Specifies the mission setup to recall at power up. 

-noHardware 
Causes the software to run without the need of hardware. 

-openingScreen 
Causes the software to not display the opening screen. 

-recover 
Causes the software to try and run with the previous setup. 

-siteFile 
Specifies a site configuration file to use at startup. 

-surveyor 
Causes the software to run as a surveyor application. 

-systemBackground color 
Specifies the background color for the GUI when in Microsoft 
Windows mode. 

-systemName name 

Specifies the system name to show in the title bar of the GUI. 



 

 

-usage 
Displays this message. 

-windows 

Causes the GUI to be displayed as a Microsoft Windows mode. 
-xrm resourcestring 

Specifies a resource name and value to override any defaults. 
See the README file in the C:/E3238s directory for the 

description of the application specific resources. 

 

 

Exporting 
Display and 

Audio 

The N6820ES Signal Surveyor 4D Software can run as a remote XWindows 
application.   The workstation running the program doesn’t necessarily display 
the user interface or sound the audible signals.   The window’s display 
location can be defined with a command line option, as can other program 
features.   Most X programs use the same names for common command line 
options and arguments. 

 

Notes • The host system to which the N6820ES will export its display must be 
configured to allow the connection.   Use the xhost program to add or 
delete host names or user names to the list allowed to make connections 
to the X server. 

• If the remote system is a Windows workstation, it must be running an 
XWindows server, such as Exceed. 

 

To redirect the display and audio, use the following: 
 

e3238s -display display_name -audio audio_name 

 
Display Options The -display option specifies the name of the X server to use.   From the 

user’s perspective, every X server has a display_name of the form: 
 

hostname:displaynumber.screennumber 

hostname Specifies the name of the host machine to which the display is 
physically connected.   If the hostname is not given, the most efficient way of 
communicating to a server on the same machine is used. 

 

displaynumber The term “display” is defined as a collection of monitors that 
share a common keyboard and pointer (mouse, tablet, etc.).   Workstations 
usually have only one keyboard, and therefore, only one display.   Larger, 
multi- user systems frequently have several displays so that more than one 
person can do graphics work at the same time.   Each display on a machine is 
assigned a displaynumber (beginning at 0) when the X server for that display 
is started.   The display number must always be included in a display name. 

 

screennumber Some displays share a single keyboard and pointer among two 
or more monitors.   Since each monitor has its own set of windows each 
screen is assigned a screennumber (beginning at 0) when the X server for that 
display is started.   If the screen number is not given, screen 0 is used. 

 
GUI Options The N6820ES software runs, by default, as a Motif- based application with 

the look and feel of Windows applications. However, for users more familiar 
with Unix X Window applications, the N6820ES software can run in classic 
Motif mode. 

The - classic option displays look and feel of the original X Window GUI. 

The - windows option displays the look and feel similar to a Microsoft 
Windows application, with several small differences. 



 

 

 
 
 

Basic Operation Concepts 
 

To learn about the N6820ES Signal Intercept and Collection Software 
main window, see N6820ES Main Window (page 45). 

 

To learn about signal detection, see Process Overview (page 33). 

To learn how to handoff signals, see Handoff Source (page 77). 

To learn how to use the mouse to do things faster, see Mouse Features (page 
507). 

 

 

Sweep Range vs. Trace Span 
 

Sweep range generally refers to the start and stop frequencies that define the 
search receiver’s frequency range.   These settings are defined in the Search, 
Setup dialog box.   See General Search Setup (page 290). 

 

Trace span is the range of frequencies displayed in a trace pane, which may 
not be the same as the search receiver’s sweep range.  A Trace Pane (page 52) 
displays frequency information created by the search receiver, but a trace 
doesn’t necessarily display all of the sweep.  Trace start and stop 
frequencies may be set independent of the RF tuner sweep range - to any span, 
within or beyond the swept range of the search receiver.   As many as four 
trace panes may be displayed, all of which could display the same span, 
possibly using different trace types as shown in the discussion on Trace Type 
(page 427); or each could be set to show part of the sweep span to expand 
the frequency axis. 

 

You could set one trace’s span to monitor the entire sweep and use one or 
more other traces to zoom in (show more detail) on spans of special interest. 
See Trace Scale (page 57). 

 
Trace Handoff A trace can be used to specify handoff settings (priority, detection, and 

duration) for signals within its span.  Since these settings may be different for 
each trace, the traces can be used to assign different handoff settings for 
specific parts of the sweep. 

 

See also, Alarms Setup (page 336). 
 

 

Trace Settings 
 

For a full discussion of trace features, see Trace Setup (page 424). 
 

• The spectrogram trace type can be used to monitor signal activity over 
time. 

 

• Each trace has a marker and delta- marker that can be used to read 
absolute or relative frequency and amplitude information from a trace. 

 

• A trace marker can be linked to a handoff receiver such that the receiver 
automatically tunes to the marker frequency.   See Handoff Receiver Link 
(page 434). 

 

• Grids can be used to mark signals that have been handed off, signals that 
appear in the Energy History Pane (page 88), frequency lists that appear 
in the Frequency Lists Pane (page 118), or frequency and amplitude ranges 
covered by Alarms Setup (page 336).   See Grid Type (page 429). 



 

 

 
 

System Components 
 

 
Antenna(s) The signal is captured by the receiving antenna.  Switch modules may be used to 

connect to multiple antennas. 
 

RF and IF switching may be used to implement special- purpose antennas and 
tuners to optimize performance (such as frequency response and directional 
sensitivity) or to use antennas at different locations.   Custom configurations can 
be implemented to serve special needs.   See Antenna Configuration (page 
226) and Switch Configuration (page 228). 

 
N6841A  The N6841A RF Sensor is an integrated software defined wideband receiver that 

consists of the following elements: 
 2 x 1 solid state RF switch 
 RF tuner covering the frequency range of 20MHz to 6 GHz 
 14-bit ADC (analog to digital converter) operating at 56 MSamples per second 
 FIFO RF Memory with capacity to capture up to 4.8 seconds of IQ data at full sample 

rate 
 FPGA processor where all fft’s and averages are performed 
 GPS receiver that sources precise time and location to the RF Sensor operations 
 Single Board computer to facilitate command and control and data output 

 
Controller The N6820ES application runs on the system Host PC.   The data provided by the 

measurement hardware is passed by the network connection to the application and it 
performs the process described in Process Overview (page 33). 

 

The controller uses storage media (such as internal or external disk drives) to store 
and retrieve information associated with the N6820ES and it can be connected to a 
network to provide communication with external processes. 

 
 

With respect to other processes that interact with the N6820ES program, the 
controller is sometimes referred to as the application “Host.” 

 

Handoff 
Receivers 

The N6820ES can manage as many as 100 handoff receivers.   These are self- 
contained radios that can be remotely controlled to tune to and demodulate 
signals of interest.   The interface varies depending on the receiver used, but 
some examples are GP-IB, RS232, or LAN.  The RF Sensor DDC can also be used 
as an internal audio Handoff Receiver. 
 

See Handoff Manager under Process Overview (page 33). 
 

Note External handoff receivers must each have their own independent antenna 
connection for proper operation. 

 
 
 
 
 
 
 
 
 

1 This document is provided in PDF format in \E3238s\manuals\install_ref.pdf. 



 

 

 
 
 
 

Setting Sweep Measurement Parameters 
 

This section discusses measurement parameters and how they influence 
system performance such as dynamic range and sweep rate.   See also, System 
Block Diagram (page 23). 

 

Shape Factor 
and RBW 

Shape factor defines IF filter characteristics.   It is the ratio of the filter’s 
bandwidth at 60 dB to the bandwidth at 3 dB.   The ratio is a measure of the 
filter’s selectivity, where larger numbers are associated with increased 
selectivity. 

 

Shape 

Factor 

Passband 

Flatness 

Sideband 

Level 

FFT Window 

Equivalent 

9.0:1 +0, -1.50 dB -31 dBc Hanning 

4.0:1 +0, -0.68 dB -125 dBc Gausstop 

2.6:1 +0, -0.01 dB -95 dBc Flattop 
 

• 9.0:1 has the highest selectivity, the worst passband flatness (amplitude 
accuracy), and the worst sideband level performance.   Use this setting 
when the signal density is high (signals are close together). 

 

• 4.0:1 has the best sideband level performance, selectivity performance, and 
better amplitude accuracy than the 9.0:1 setting. 

 

• 2.6:1 has the best amplitude accuracy, worst selectivity, and much better 
sideband level performance than the 9.0:1 setting. 

 

Resolution bandwidth (RBW) has the biggest effect on the ability to 
distinguish signals.   Pick a value just small enough to resolve the signal.   Use 
larger RBW settings to improve sweep performance and optimize memory 
usage. 

 

Shape factor and RBW can be changed automatically across the sweep when 
the Sweep Search Type (page 287) is directed. See Directed Search Setup 
(page 291). 



 

 

 
 

Data Storage vs. 
RBW 

High resolution (low bandwidth) settings require storing more data for a given 
sweep range.   The following table shows some example number of spectral 
values and amount of memory required for a range of RBW values. 

 
Span: 1 GHz   Shape Factor:  9.0:1 

 

 

RBW (Hz) 
Data Storage 

points (k) MB 

7.3 204,800 819.2 

15 102,400 409.6 

29 51,200 204.8 

60 25,600 102.4 

120 12,800 51.2 

240 6,400 25.6 

470 3,200 12.8 

940 1,600 6.4 

1,900 800 3.2 

3,800 400 1.6 

7,500 200 0.8 

15,000 100 0.4 

30,000 50 0.2 

60,000 25 0.1 

120,000 12.5 0.05 
 

Data memory is allocated by the dataBufferSize resource, which is set to 
8,000,000 words (32 MB) at the factory.   For smaller RBW values and/or 
larger spans than this value supports, you may need to change the value.  See 
the discussion in Application Resources (page 17). 



 

 

 
 

Bin spacing is the frequency separation between spectral values 
(in Hz). Given the shape factor filter characteristic, this can be 
interpreted as a resolution bandwidth value. 

 

In the N6820ES, shape factor and bin spacing determine the resolution 
bandwidth values.   If you change the shape factor setting, the values in 
the RBW list change.   What you really choose when you pick an RBW 
value, is bin spacing, given the current shape factor.   Also, when you 
save a measurement state, bin spacing is what is saved in the state file, 
not RBW. 

 



 

 

 
 

Averaging After setting the RBW, set the averaging type and number of averages. Using 
averaging to lower the noise variance may reduce the sweep speed.  
However, since all averaging is done in the RF Sensor’s FPGA, choosing the right 
number of averages can optimize your sweep speed when considering the 
capacity of the network connection to the sensor.  Experimentation has shown 
that 32 averages is a good compromise between sweep speed and trace noise 
quality.  If the user wishes to tune and listen to audio on a remote RF Sensor, a 
larger number of averages (greater than 256) may be required. 

 

Peak displays the largest value in the specified number of averages.   It is not, 
strictly speaking, averaging as it does not reduce t h e  v a r i a n c e  o f  t h e  
noise.   Peak should be used for "transient" signals such as push- to- talk 
transmissions and signals using some modulation types.   For example, when 
no averaging is used, a 4 Level FSK signal might appear as only one of the 
single tones but when peak averaging is used, samples from all the tones can 
be collected and the full modulation envelope observed. 

 

RMS averaging reduces noise variance by calculating the square root of the 
sum of the squared values.   It should be used to search for non-transient 
signals and for small signals in a noisy environment or near large signals. 

 
 

together. 
where n is the number of samples to average 

 
RMS averaging reduces noise floor variance but should only be used when 
the signal of interest is present for a significant amount of time (not 
transient).  If the signal is not present for the time required to collect the 
number of signal samples specified, RMS averaging does not give accurate 
amplitude readings. 

 

Note When you specify a number of averages, that determines the number of data 
blocks taken at each step as the tuner works through the entire sweep. Each 
block of time- domain data is converted to frequency- domain data, then the 
specified averaging type is applied; either RMS or Peak.   You do not wait n 
sweeps to collect n samples.   See Averaging (page 301). 

 
Average settings and values can be changed automatically across the sweep 
when the Sweep Search Type (page 287) is directed. See the discussion under 
Directed Search Setup (page 291). 

 
Tuner Settings Input selection.  The N6841A RF Sensor has two RF inputs to accommodate two 

different antennas that cover the bands of interest.  Antenna selection can be 
made manually or automatically (in directed search mode).  

 

 
 
 
 



 

 

 
 
 
 

Tuner 
Attenuation 

Tuner attenuation or gain is probably the only parameter you need to adjust 
regularly to compensate for changes in input level based on the RF 
environment and proximity to strong emitters. 

 

Attenuation values can be changed automatically across the sweep when the 
Sweep Search Type (page 287) is set to directed.   See the discussion under 
Directed Search Setup (page 291). 

 

Note Tuner overloads are not detected by the N6820ES system. 
 

ADC overloads are detected; they are indicated in the application window by 
changing the Trace Identifier (page 54) background color to red. Also, if the 
marker is on and its location is in a sweep segment with overloaded ADC 
data, “OVLD” appears in the Marker Readout (page 61). 



 

 

 
 
 

Process Overview 
 
 

 
 
 

Search System 
 

Overview The purpose of the search system is to discriminate signal energy from noise, 
isolate signals of interest (SOI) and perform one or more tasks such as tuning a 
handoff receiver, logging spectral data, or recording time series (IQ) snapshots.   
Classification and survey is accomplished by selective filtering using signal 
external and internal parameters.  This is accomplished in two stages: 

• Wide- band processing, described in Energy Detection Process (page 34) 
• Narrowband processing using the RF Sensor’s Digital Down Converter (DDC) 

 
Search Receiver This block consists of the measurement hardware settings. The N6841A RF 

Sensor hardware provides averaged spectral data (16k FFT) to the host PC to 
be processed.   The hardware (antennas, tuner, and ADC) is configured with 
entries in The Configure Menu (page 225).   Measurement concepts are 
discussed in Setting Sweep Measurement Parameters (page 27). 

 

When one or more narrow- band signal processing libraries are loaded, the 
hardware configuration enables the DDC to collect times series data that is then 
sent to the Host PC for processing. 



 

 

 
 

The search functions discussed in the following text are described in more 
detail under The Search Menu (page 285). 

 
Energy Detection Process 

 

 
 

 
 

Energy Detection evaluates wideband spectral data and isolates signal 
candidates from the noise.  These candidates are classified based on signal 
externals and entered in the Energy History database where the information is 
continuously- updated.  

 

The Energy Detection Process accomplishes this by applying a threshold, detecting 
peaks, calculating bandwidth, extracting features, and filtering out much of the 
environmental “noise.” 

 
Threshold   The threshold is the first part of the energy detection process. A threshold is 

a set of amplitude values, like a signal trace, which can be used to signal 
candidates from a noisy spectral environment. See Threshold Setup (page 
310).  The threshold types are: 

 

• Level is a single absolute power value (i.e. dBm), energy- independent 
threshold. 

• Auto calculates a dynamic noise energy- dependent threshold. 
 

• Environment captures the ambient spectral environment (high resolution 
max-hold).  This can be saved as a file on the system disk, which can be 
loaded, manipulated and used at a later time or in a different location. 

 

• File allows you to load a saved threshold. 
 

Energy 
Detection 

This step uses the Peak Criteria parameter value to identify signals of 
interest.   The energy’s amplitude must be above the threshold by at least the 
peak criteria value (in dB).   Also, to identify an “energy peak” among several 
large values close together, the peak criteria value is added to the amplitude 
of nearby nulls. 

 

Note No energy is detected if “Energy Detection” is not selected.  See the discussion 
under Energy Detection (page 309) for more information. 

 
Calculate 

Bandwidth 
This part of the process calculates the bandwidth for the energy detected in 
the previous stage, given their frequency and amplitude and the value of the 
Bandwidth Criteria.   This step measures the bandwidth of the energy peak. 

 

See Bandwidth under Energy Detection (page 309) for information on 
calculating bandwidth or Bandwidth under Single- Alarm Setup (page 338) for 
information about taking action based on a measured bandwidth. 



 

 

 
 

Feature 
Extraction 

This block allows you to derive new energy characteristics or features such as 
power that can be tracked in the Energy History and used to define alarm 
conditions. 

 

Features are added by writing a library program as described in the 
N6820ES ASD Programming Guide1.   To include a new library program in 
the operation of the N6820ES software, add a line to the e3238s.n6841.cfg 
configuration file with the featureExtraction: command followed by the 
path and filename of the program. Library programs are loaded when the 
program starts. 

 

Note There is no user interface (e.g., dialog box) associated with feature extraction, 
but the feature names appear in the lists in Energy History. See View > 
Energy History > Edit > Format (Column Setup) (page 91), Energy History > 
View > Plot (page 95), and Alarms Definition (page 342). 

 
The impact of ASD on the search processing loop is shown in red on the 
following flow chart. 

 
 

ASD Impact on Search Processing Loop 

 
Energy Pre-filter This block allows you to control which   features are placed in the Energy 

History.   It is part of option ASD, User Programming. Commands used to 
configure its operation begin with pre-filter.  Pre-filter and post- filter 
functions are defined and loaded with the energyHistoryFilter: command 
in the e3238s.n6841.cfg configuration file.   See Hardware Configuration 
(page 16). 

 

 
 

1 See the \E3238s\manuals\program_guide.pdf file. 



 

 

 
 

If no library exists, no pre-filter functions are defined, or the pre-filter 
functions are not enabled, all detected energy is entered in the Energy 
History. 

 

The user interface for this block and the Post Filter block is discussed under 
Energy History Filter (page 332). 



 

 

 
 

Energy History The Energy History Block receives data from the Energy Detection Process. 
That data is displayed in the Energy History Pane (page 88). 

 

The Energy History pane (#2) displays as many as 8 pieces of information 
(features) for each entry.   You can display all features for any one entry (3) 
by clicking the Energy History Pane (page 88) and you can show a plot (4) of 
one feature data for the entire trace with the Energy History > View > Plot 
(page 95). Features may be linked to a particular trace marker (1), as shown 
in the following figure. 

 

 
1. The energy history can be linked to a trace marker so that selecting an 

entry in the Energy History Pane (#2) moves the marker to the peak. 

2. This is the Energy History Pane with an entry selected.  Note that markers 
in the trace (#1) and Plot (#4) appear at the signal’s frequency and that 
all the signal’s statistics are displayed in the Entry table (#3). 

3. The Energy History Entry table shows all the features of the entry selected 
in the Energy History Pane (#2). 

4. The Energy History Plot shows feature statistics for the spectrum, with a 
marker at the frequency of the entry selected in the Energy History Pane 
(#2). 

 
Energy Post-filter This block is used to remove entries from the Energy History. It is part of 

option ASD, User Programming.   An example of the usefulness of this feature 
is the featureAGE filter included with option ASD that removes entries that 
have had no activity (new data) for a given period of time. 

 

Pre-filter and Post-filter functions are defined and loaded with the 
energyHistoryFilter: command in the e3238s.n6841.cfg configuration 
file.   See Hardware Configuration (page 16). 

 

If no library exists, no post- filter functions are defined, or the post- filter 
functions are not enabled, and no entries are removed from the Energy 
History. 



 

 

 
 

The user interface for this block and the Post Filter block is discussed under 
Energy History Filter (page 332). 

 
New Energy Log The New Energy Log Pane (page 86) displays a listing of energy that meets the 

criteria in the Energy Detection process.  This log records the date and time 
of first intercept as well as the energy’s measured frequency, bandwidth, and 
amplitude. 

 
Energy Alarms The purpose of alarms is to launch a task when a defined pattern of energy 

or signal activity occurs.   The Alarms Setup (page 336) dialog box is used to 
define the criteria and specify which task(s) to launch. Energy alarms are 
triggered by statistics in the Energy History block and signal alarms are 
triggered by information in the Signal Database block.  As many as 100 alarms 
may be defined.   When energy activity matches one of the alarm definitions, 
one or more alarm tasks may be launched.   Each alarm is recorded in the 
Alarm Log Pane (page 87). 

 
Frequency Lists Frequency lists allow you to limit alarm criteria to a specific set of frequency 

values. They may also be used as trace grids and by user- defined components 
such as feature extraction. The lists may be created with an ASCII editor and 
they may be viewed and edited in the Frequency Lists Pane (page 118). 

 
Alarm Tasks Each alarm definition includes the task(s) to be launched when the alarm is 

triggered.   These tasks are as follows: 
 

• Capture a time snapshot file.   See Time Snapshot Task (page 360). 
• Capture a frequency snapshot file.   See Frequency Snapshot Task (page 

359). 
• Sound an audible alarm.   See Audio Task (page 358). 
• Display an icon in the visual alarm pane.   See Visual Task (page 357). 
• Perform user- defined task.   See Alarm Tasks in the ASD Programming 

Guide. 
• Handoff the signal to the Handoff Manager.   See Handoff Task (page 355). 
• Modify a Frequency List.   See Frequency Lists Pane (page 118). 

 

Handoff 
Manager 

The handoff manager takes handoff requests from the alarm tasks, markers, 
trace panes, handoff log, and energy history pane and controls the handoff 
receivers such that the requests are properly serviced and makes entries in 
the Handoff Log to record the handoff activity.   See the figure below. 

 

 



 

 

 
 

To view handoff activity, see Handoff Log Pane (page 75). 
To control/change handoff receiver settings, see Handoff Receiver Pane (page 
70). 

 

Handoff 
Receiver Drivers 

Part of option ASD, User Programming, provides the ability to create 
custom handoff receiver drivers.   These are created as library programs.   
See the N6820ES Programming Guide for more information. 

 

 
 

Signal Database This block is a pane in the N6820ES application window that displays the 
results of the signal processing in the same way that the Energy History pane 
displays the results of feature extraction.  These results can be used to launch 
alarm tasks. 

 

See Signal Database Pane (page 107). 
 

Signal Alarms This block corresponds to the Energy Alarms block.  It tracks signal data in 
the signal database and may be used to launch any of the alarm tasks when 
the signal data satisfies the specified alarm definition. 

 



 

 

Signal Alarm 
Tasks 



 

 

These blocks represent user- defined programs that may be executed when an alarm 
criteria are satisfied.  Energy alarms may launch any of these tasks and signal alarms 
may also launch any of the energy alarm tasks described earlier. See Alarm Tasks 
Overview under Energy Detection Process (page 34). 

 

Signal Processing is divided into three categories: 

• Signal ID (Modulation format and/or symbol rate of signal) 

• Location (e.g., link to the Agilent N6854A Geolocation Server Software) 

• Collection (e.g., attributes of IQ or Frequency trace recording) 
 

These may be implemented as library “programs” or alerts to other systems via the 
socket server.   All information about a particular signal is stored in the Signal 
Database and may be viewed in the Signal Database Pane (page 107). 



 

 

 
 

Control Layer 
 

 
 
 

The following discussion applies, for the most part, to systems that have 
option ASD (User Programming) installed. 

 

The N6820ES system is typically controlled via the windows graphic user 
interface (GUI) by the user/operator sitting at the system display.   Option 
ASD allows system control from external processes or user- defined library 
additions.   Also with option ASD, information generated by the search 
system can be passed to other processes via a socket server process. 

 

Command 
Processor 

The command processor collects the incoming commands and converts them 
into system control sequences.   System commands are described in the 
N6820ES Command Reference1. 

 

Mission Setup The mission setup (system state) can be saved in a file and 
loaded again later to quickly configure the N6820ES to a previous state.  All user 
settings are stored in the mission setup file including receiver settings, search setup 
(energy detection and alarm configuration) and display settings.   The information is 
stored in ASCII format as commands that specify parameter settings. When a 
mission state file is loaded, these commands are processed in the same way as 
they are from the Command Line Pane (page 115). 

 
Command Line The command line interface is a pane within the graphic user interface; see 

Command Line Pane (page 115).  This is a convenient way to experiment with 
the commands and see their effects.   The command documentation is in the 
N6820ES Command Reference. 

 
Libraries Libraries are used to implement all of the user- defined features shown in the 

shaded blocks of the N6820ES process diagram as well as handoff receiver 
drivers.   Functions in the libraries can pass commands directly to the 
command processor and receive responses to queries. 

 

The libraries are loaded based on entries in the e3238s.n6841.cfg 
configuration files.   To determine what libraries are loaded while the program 
is running, see Loaded Libraries (page 495). 

 
1 See the \E3238s\manuals\command_ref.pdf file. 



 

 

 
 

Graphic User 
Interface (GUI) 

Normal operation of the N6820ES Signal Intercept and Collection Software is 
done with the graphic user interface (GUI).   The GUI appears in the 
application window described in N6820ES Main Window (page 45).  The 
process diagram also shows two user- defined components attached to the GUI 
process, user menus and user pane. 

 

User- defined 
Menus 

With option ASD, User Programming, you can add as many as 4 menu groups 
to the main menu bar.   Each menu group may have as many as 8 entries in 
the menu and each entry has a corresponding icon button in the tool bar. 
This is accomplished by writing a library program that is loaded at run time 
(when the N6820ES program starts).   For information about writing this 
program, see the N6820ES ASD Programming Guide1. 

 

User- defined 
Pane 

Option ASD, User Programming, allows you to create as many as 4 window 
panes, which may be displayed like any of the other panes (trace, log, energy 
history, etc.).   A user- defined pane is created by writing a library program 
that is loaded at run time (when the N6820ES program starts).  For 
information about writing this program, see the N6820ES ASD Programming 
Guide. 

 

Socket Server This process allows as many as 10 external processes to send commands, 
query, and subscribe to information from the N6820ES system via a 
sockets protocol.   This feature is part of option ASD, User Programming. 

 

Library 
Interface 

This interface allows libraries to use the socket server to manage socket 
connections to other processes.   See the N6820ES Programming Guide. 

 

Spew Control This process allows data from various parts of the N6820ES system to be 
sent to external processes via a sockets protocol.   The data is sent whenever 
new data/settings occurs/changes (i.e., a subscription method). Command 
queries are also available.   Command queries employ the polling method (the 
data is sent only when your process requests it).   This feature is part of 
option ASD, User Programming. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 See the \E3238s\manuals\program_guide.pdf file. 



 

 

 
 
 

Opening Window 
 

This window appears when the N6820ES program starts.   Its startup 
characteristics are defined in the N6820ES resource file. 

 

 
 

1. Software Information is the version of the program and operating system. 

• Version is the software version. 

• Date Code is the month/day/year that the executable was created. 
 

2. Initialization Status is displayed as a scrolling list of status, error, and 
warning messages that appear as the program begins running. 

 

3. Close Window Click this button the to close opening window.   This does 
not affect the startup procedure, other than the window is not displayed. 
Otherwise, the window closes when the startup procedure finishes, just 
before the main window opens. 

 

4. Exit Application When you click this button, the startup procedure is 
interrupted, program execution is stopped, and the program exits. 
 
 
 
 
 



 

 

After the opening screen presents, another window will follow 
immediately prompting the user to select the RF Sensor to be used by 
Signal Surveyor 4D.  The window is shown below. 

 
 

 
 

By clicking on “Find Sensors”, another screen presents that enables the user to 
identify any N6841A RF Sensors on the local subnet.  If RF Sensors are present, 
they will populate the fields in this window, allowing the user to select one to 
operate with the N6820ES software. 
 

 





 

 

N6820ES Main Window 
 

 
The N6820ES window is made up of a menu bar (2) and panes (3- 5).   Panes 
are added to or removed from the main window with the Display Layout (page 
422) dialog box.   The panes may be organized in many different ways. 

The topics in this chapter are as follows: 

• Introduction to the N6820ES Graphic User Interface (page 46) 

• Undocking and Docking Panes (page 48) 

• Menu Bar (page 49) 

• Tool Bar (page 50) 

• Trace Pane (page 52) 

• Handoff Receiver Pane (page 70) 

• Handoff Log Pane (page 75) 

• New Energy Log Pane (page 86) 

• Alarm Log Pane (page 87) 

• Energy History Pane (page 88) 

• Signal Database Pane (page 107) 

• Visual Alarms Pane (page 112) 

• Text Editor Pane (page 113) 

• Command Line Pane (page 115) 

• Frequency Lists Pane (page 118) 



 

 

 
 
 

Introduction to the N6820ES Graphic User Interface 
 

The figure shown here is an example of the N6820ES application window. 
 

 
 

1. The Menu Bar (page 49) contains the controls for the N6820ES program. 

2. The Tool Bar (page 50) offers quick access to three of the menus. 

3. A Trace Pane (page 52) displays sweep data as spectrum, spectrogram, or 
color spectrogram. There may be as many as four trace panes. 

4. The Energy History Pane (page 88) displays information on detected 
energy. 

5. The Handoff Receiver Pane (page 70) provides control and status of 
receivers. 

 

Panes can be resized by positioning the mouse arrow over the edge you wish to 
move and performing a click- and- drag action. Individual panes can be undocked 
from and then re-docked to the main application window. 



 

 

 
 

Other panes that may be added to the main application window are: 
 

• The Signal Database Pane (page 107) displays the results of signal 
processing. 

• The Handoff Log Pane (page 75) displays the entries in the handoff log. 
• The Text Editor Pane (page 113) allows you to create, edit, and print text 

files. 
• The Command Line Pane (page 115) allows you to execute 

N6820ES commands. 
• The New Energy Log Pane (page 86) lists peaks the first time they appear. 
• The Alarm Log Pane (page 87) lists all the alarms that have occurred. 
• The Visual Alarms Pane (page 112) displays images and instructions for 

alarms. 
• The User- Defined pane is part of option ASD, User Programming.   The 

contents of this pane can be defined by a user- written program. See the 
N6820ES ASD Programming Guide1  for more information. 

• The Frequency Lists Pane (page 118) is used to view, create, and modify 
lists of frequencies for trace grids and alarm criteria. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 See the \E3238s\manuals\program_guide.pdf file. 



 

 

Undocking and Docking Panes 
 
 

 

You can undock individual panes in the N6820ES application’s main 
window and position them separately on the display. You can later re-dock 
the separated panes back into the main application window. 

 

To undock a pane from the main application window, double click the vertical 
bar icon (  ) located at the left of the pane’s Trace Identifier (page 54). The 
application redisplays the pane as a separate window. 

 

To re-dock a pane, double click   the vertical bar icon at the far left of the 
pane’s menu bar. The application replaces the pane in the application’s main 
window. 

 

To close a pane, click on the “ X ”  close icon in the pane’s top right- handed 
corner. 



 

 

 
 
 

Menu Bar 
 

 

 
 

The menu bar contains pull-down menus that organize the N6820ES Signal 
Intercept and Collection Software features as follows: 

 

• The File Menu (page 125) entries allow activities having to do with system 
files, including printing. 

 

• The Edit Menu (page 145) entries allow you to clear the log views, log 
files, energy history, and audio alarm output. 

 

• The View Menu (page 153) entries allow you to view additional panes. 
 

• The Configure Menu (page 225) entries allow you to set the system 
hardware parameters that can be controlled by the program. 

 

• The Search Menu (page 285) entries allow you to set up and execute 
search activities. 

 

• The Display Menu (page 421) entries allow you to set up the display. 
 

• The Macros Menu (page 477) allows you to create, edit, and list macro files 
associated with function keys or toolbar buttons. 

 

• The Utilities Menu (page 485) entries allow you to control the 
N6820ES software’s display and toolbars and to display library and 
licensing information 

 

• The Help Menu (page 505) entries provide information on how the 
N6820ES Signal Intercept and Collection Software works and how to use 
it. 

 

In addition to the menus shown above, users can create as many as 4 user- 
defined menus using option ASD, User Programming.   Each menu group may 
have as many as 8 entries and each may have its own button in the Tool Bar 
(page 50). 



 

 

Tool Bar 
 

The tool bar offers quick access to the features found in the Configure, 
Search, and Display menus.   Any item in the Configure, Search, and Display 
menus that is accessible (as defined in Menu/Toolbars (page 488)) has a 
button in the tool bar. 

 

 

 
Note that some of these buttons do not appear in Signal Monitor (Option - 
113). See Software Options (page 10). 

1. Antenna Configuration (page 226) 

2. RF Sensor setup (page 227) 

3. Handoff Receiver Configuration (page 271) 

4. System Reference (page 274) 

5. PostgreSQL Database Export (separate manual) 
 

 
6. Search On/Off (page 286) 

7. Search Type (page 287) (general or directed) 

8. Search Setup (depending on Type) 
General Search Setup (page 290) 
Directed Search Setup (page 291) 

9. Energy Detection (page 309) 

10. Energy History Filter (page 332) 

11. Alarms Setup (page 336) 

12. Direction Finding (page 395) 

13. Modulation Recognition (page 402) 



 

 

 
 
 

 
14. Display Layout (page 422) 

15. Trace Setup (page 424) 

16. Trace Scaling (page 458) 

17. Mouse (page 466) 

18. Colors (page 471) 

19. Tool tips appear when the mouse cursor pauses over a button. 
 
Toolbar Notes • If the tool bar does not appear, you can activate it as you would any other 

window element, by putting it in a pane.   Also, you can change the 
position of the tool bar (vertically) by taking it out of one pane and 
putting it in another.   See Display Layout (page 422). 

• You can remove buttons from the tool bar by changing their status under 
Menu/Toolbars (page 488). 

• When custom menus are added, corresponding buttons are added to the 
toolbar.  This makes the initial width of the application window wider.  To 
allow the toolbar buttons to wrap, add *toolbarWrap:True   to the E3238s 
resource file.   See the Installation reference for details. 



 

 

 
 
 

Trace Pane 
 
 
 

 
 

The trace panes above are configured as follows: 

• Trace Type: A = Color Spectrogram, B = Spectrum 
• Grid Type: B = Graticules 
• Marker: A = Off, B = On 

Other trace components are as follows: 

1. A Trace Title (page 53) (if defined) 

2. A Trace Identifier (page 54) 

3. Undocking Icon. See Undocking and Docking Panes (page 48) 

4. Vertical scale labels.   See Trace Scale (page 57) 

5. Color bar (for color spectrogram).   See Trace Type (page 427) 

6. The grid lines.   See Trace Setup (page 424) 

7. Trace Amplitude Arrows (page 59) 

8. dB/Div value. 

9. The Trace Popup Menu (page 456) 

10. The Amplitude Autoscale Button (page 59) 

11. The Frequency Full Scale Button (page 60) 

12. Horizontal scale labels. See Trace Scale (page 57) 

13. The Marker Readout (page 61) (if the marker is on) 

14. A trace line.   See Trace Setup (page 424) 

15. The Threshold line (if on).   See Trace Setup (page 424) 

16. The Marker (if on).   See Trace Setup (page 424) 



 

 

Trace Pane 

Trace Title 
 

17. Marker Search, Next Peak Left (page 63) (if marker on). 

18. Marker Search, Peak (page 63) (if marker on). 

19. Marker Search, Next Peak Right (page 63) (if marker on). 

20. Marker Snapshot (page 64) 

21. Task Handoff Rx (page 63) (if option available). 

22. Task DF (page 65) (if option available). 

23. Task Mod Rec (page 66) (if option available). 

24. Resolution Bandwidth. See Trace Scale (page 57) 
 

Tips • The N6820ES application window may contain as many as four trace panes. 
• Panes are added or removed with the Display Layout (page 422) dialog 

box. 
 

 

Trace Title 
 

By default, traces do not have a title.  A title can be assigned in the command 
line or by editing a (saved) mission state file and loading it. 

 

To enter a title for trace A use the following command: 
 

traceA.title: Trace title text 

The trace title can be as long as 1023 characters.   To get multiple lines, use 
\n to get a new line.   The title can be aligned beginning, centered, or left by 
entering one of the following lines in the E3238s resource file: 

 

*trace_pane.*.title.alignment: XmALIGNMENT_BEGINNING 

*trace_pane.*.title.alignment: XmALIGNMENT_CENTER 

*trace_pane.*.title.alignment: XmALIGNMENT_END 

If you want to assign different alignments to each trace, you can do so by 
specifying the trace as follows: 

 

*trace_paneA.*.title.alignment: XmALIGNMENT_BEGINNING 

*trace_paneB.*.title.alignment: XmALIGNMENT_CENTER 

 
Tips • To activate the command line, click on the Display Layout button. See 

Display Layout (page 422). 
 

• To find the name and location of the mission state file, see Save Mission 
Setup (page 129). 

 

• To edit a text file, see the Text Editor Pane (page 113). 



 

 

Trace Identifier 
 

Trace Identifier 
 
 

 
 

There may be as many as four trace panes displayed in the window. They are 
identified by the letters A, B, C, and D located in the upper- left corner of the 
pane. 

 

If your system has multi- channel option EMC installed, see Trace and Channel 
Indicators (page 521). 

 

These identifiers are used to make changes to traces in the Trace Setup and 
Scaling dialog boxes.   Refer to Trace Setup (page 424). 

 

Note Clicking the trace identifier displays the Trace Setup (page 424) dialog box 
with the particular trace activated. 

 
The background of the trace ID square turns red when the system ADC 
receives an input signal large enough to cause an overload.   See the 
discussion of ADC Input Range under Setting Sweep Measurement Parameters 
(page 27). 



 

 

Trace File Menu 
 

 

Trace Pane Menus 
 

When trace pane is undocked and displayed as a separate window it displays 
a set of menus to control that individual trace pane. The menus are: 

 

Trace File Menu 

Trace View Menu 

Trace Scale Menu 

Trace Marker Menu 

Trace Snapshot Menu 

 
 
 

Trace File Menu 
 

 

 

 
The Trace File Menu contains the following menu selections: 

• Print allows you to print the current trace screen. 
 

• Print to File allows you to save the current screen as a TIFF file in a 
selected directory. 

 

• Close allows you to close the current Trace Window. 
 
 

 
Trace View Menu 

 

 

 
 

The Trace File Menu contains the following menu selections: 

• Trace Type allows you to change the current trace window’s display type. 
Clicking this menu entry displays the trace types available. 

 

• Threshold allows you to save the current screen as a TIFF file in a 
selected directory. 



 

 

Trace View Menu 
 

• Grid Type   allows you to close the current Trace Window. 



 

 

 
 

Trace Scale 

Trace Scale 

 

On the left- hand side of the trace screen several sets of numbers describe the 
amplitude range of the spectrum trace type.   The top number displays the 
maximum Y- axis value of the screen, sometimes referred to as the reference 
value. The number directly beneath the maximum Y- axis value describes the 
trace screen’s dB/division value. This value is shown only on the spectrum 
trace. For more information on trace scaling, see Trace Scaling (page 458). 

 

 
 

The numbers near the bottom of the trace screen describe the frequency range 
of the trace and the resolution bandwidth. The frequency range of the trace 
can be different from the search span. If it is less than the search span, the 
trace is said to be zoomed. 

 

To zoom a trace scale with the right mouse button be sure the right mouse 
button is set to Trace Scaling. See Mouse (page 466).   Then perform the 
following steps: 

 

1. Place the mouse cursor at one corner of a box that defines the new scale 
settings. 

 

2. Right- click and drag the cursor to the opposite corner of the box (see 
figure). 

 

3. Release the mouse button. 
 

 
 

Use the right mouse button to zoom. 

 

 

After the zoom the scroll button is smaller. 
 

You can zoom more than once.   The scale values associated with each zoom 
selection are saved so that you can “un-zoom” back through the settings. 



 

 

 Trace frequency range is larger than sweep. 

Note  When the trace scale is zoomed the trace displays only part of the sweep 
range being measured.   Therefore, the trace display may seem to slow down 
and/or update sporadically. 

  
 

To reset the frequency scale of a zoomed trace to match the search receiver’s 
start and stop frequency, use the Frequency Full Scale Button (page 60). 

  
 

To increase the revisit rate for a trace, click the right mouse button anywhere 
on the trace background to display the Trace Popup Menu (page 456) and 
click Tune To Trace. 

  
Tips 

 
• To autoscale the amplitude, use the Amplitude Autoscale Button (page 59). 

  • To change scale, use the mouse or the trace manual scale menu.   Clicking 

 

Trace Scale 
 

To return to the previous scale settings, double- click the right mouse button 
in the trace display.   If the scale has been zoomed more than once, each 
double- click returns the scale to the previous scale setting in the order they 
were changed. 

 

To quickly set the trace scale to match the hardware sweep range, click the 
Frequency Full Scale Button (page 60). 

 

To change the sweep settings to match the zoomed trace frequencies, use Tune 
To Trace under Trace Popup Menu (page 456).  This maximizes the revisit rate 
on a zoomed trace by changing the search sweep setup such that the start and 
stop frequencies match those of the trace’s scale.   When you do this the trace 
is no longer zoomed.   To return the sweep to it’s previous start and stop 
frequencies, see General Search Setup (page 290). 

 

If the trace is zoomed, a scroll bar appears beneath the trace. This scroll bar 
does not appear if the marker is on. The scroll bar may be used to move the 
trace’s frequency “view” within the search span. 

 

If the trace’s frequency range includes frequencies outside the search span, 
the trace line will not reach the end of the trace grid. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

any of the 4 scale labels displays this dialog box. 
 

• The Mouse (page 466) dialog box defines how the mouse buttons and 
wheel work. 



 

 

 
 

Trace Amplitude Arrows 

Trace Amplitude Arrows 

 

The arrows at the top and bottom left of the trace screen control the 
maximum and minimum signal amplitude displayed on the trace screen. 
When the display is in the Min/Max mode, clicking the arrows will affect 
either the minimum or maximum value.   When the display is in the Ref/Div 
mode the arrows will modify the Reference Level.   For more information on 
switching between the Min/Max and Ref/Div modes, see Trace Scaling (page 
458). 

 

 

The arrows on the left of the trace screen control the signal display as follows: 

When the display is in the Min/Max mode, the arrows at the top left of the 
screen increase or decrease the maximum value that can be displayed; the 
arrows at the bottom left of the screen increase or decrease the minimum 
value that can be displayed. In this mode the relative size of the displayed 
signal changes with the changes to the screen. 

 

When the display is in the Ref/Div mode, the arrows at both the top and 
bottom of the screen change the reference level up and down without 
changing the dB/div setting. 

 

The trace amplitude can also be controlled by the mouse wheel.   See Mouse 
(page 466). 

 

 

Amplitude Autoscale Button 
 

This button appears in the bottom- left corner of a trace pane. It sets 
the minimum and maximum amplitude values so that all of the trace is 
displayed. 

 
Tips • To set trace scales manually, see Trace Scaling (page 458). 

• This button has no effect if the trace type is spectrogram. 

• This button does not change the frequency span. 



 

 

Frequency Full Scale Button 
 

Frequency Full Scale Button 
 

This button appears in the bottom- left corner of a trace pane.   This 
button sets the trace’s frequency scale to match that of the 
measurement hardware. 

 

If the marker is off, a scroll bar appears beneath the trace when the trace’s 
frequency scale is less than the whole sweep. (When the marker is on, the 
marker readout appears beneath the trace in either case.) 

 

You can also revert to the previous scale (frequency and amplitude) by 
double- clicking the right mouse button in the trace display area. 

 

To set the trace’s frequency scale to match one of the directed search band’s 
range you can right- click this button.   See the discussion below. 

 
Tips • To set trace scales manually, see Trace Scaling (page 458). 

 

• To change frequency scale (zoom) with the mouse, see Mouse Features 
(page 507). 

 

• This button does not change the amplitude scale.  See Amplitude Autoscale 
Button (page 59). 

 

 

Frequency Band Scale 
 

This menu appears when you right- click the Frequency Full Scale Button 
when the Search Type (page 287) is set to Directed. 

 

 

This is a list of the active bands defined in the Directed Search Setup (page 
291) dialog box.   The individual entry names are either the band’s description 
(see Single- Band Search Setup (page 293)) or the band number if no 
description exists. 



 

 

 
 

Marker Readout 

Marker Readout 

 
 

 
 

When a marker is on, the Trace Marker Readout appears beneath the trace. 
This is frequency and amplitude information associated with current marker 
position. 

 
Delta Marker The trace marker can be used to measure the difference in frequency and 

amplitude between two points.   This is called the delta marker. 

 

 
 

To use the delta marker: 

1. Position the regular marker at the reference point in the trace. 

2. Press and hold the shift key. 

3. Position the mouse cursor at/near the second point, then click and hold 
the left mouse button. 

4. Read the delta values in the marker readout below the trace. 
 

Notes • The delta marker appears only while the mouse button is held down. 
 

• This procedure assumes the mouse configuration is set to use the shift key 
for the delta marker.   See Mouse (page 466). 

 

• You can move the mouse while holding the shift key and left button to 
move the delta marker along the trace. 

 

• To change the color of the markers, see Colors (page 471). 



 

 

Marker Readout 
 

Delta Threshold 
Marker 

The Delta Threshold Marker allows the user to display the threshold level and 
its delta from the actual spectrum in the marker readout area of the trace. 
This feature only works for the Spectrum display type and when a threshold 
is defined. 

 

To use the delta marker: 

1. Position the regular marker at some point in the trace. 

2. Press and hold the Ctrl key. 

3. Position the mouse cursor at/near the threshold line, then click and hold 
the left mouse button. 

4. Read the delta values in the marker readout below the trace. 
 

Notes • The delta marker appears only while the mouse button is held down. 
 

• This procedure assumes the mouse configuration is set to use the Alt key 
for the delta marker.   See Mouse (page 466). 

 

• You can move the mouse while holding the shift key and left button to 
move the delta marker along the trace. 

 

• To change the color of the markers, see Colors (page 471). 
 

 
 

Overload 
Indicators 

If an ADC overload occurs during a sweep and the marker is located in the 
sweep segment in which the overload occurred, an indicator appears in the 
Marker Readout. Also, the trace identifier turns red to indicate an overload. 
See Trace Identifier (page 54). 

 
 

 
ADC Underflow If the ADC data is all zeros, an indicator appears in the Marker Readout. 



 

 

 

Marker Function Buttons 
 

The marker readout and function buttons appear in the trace pane only when 
its marker is on.   See Trace Identifier (page 54) or Trace Setup (page 424). 

 
Marker Search, Peak 

 

When this button is clicked, the marker moves to the peak having the 
largest amplitude on the trace.   “Peaks” are define in Example (page 
323). 

 
Marker Search, Next Peak Left 

 

When this button is clicked, the marker moves to the next peak left of 
the current position.   A “peak” is a local maxima more than 
approximately 6 dB above the computed noise floor of the display 

spectrum.   Example (page 323) 

 
Marker Search, Next Peak Right 

 

When this button is clicked, the marker moves to the next peak right of 
the current position.   A “peak” is a local maxima more than 
approximately 6 dB above the computed noise floor of the display 

spectrum.   Example (page 323) 

 
Task Handoff Rx 

 

When this button is pressed, the N6820ES software hands off the 
signal defined by the frequency of the marker’s position. When a signal 
is handed off this way, the priority, detection, and duration values 
passed 

to the handoff receiver are defined in the Trace Setup (page 424) dialog box. 
This allows you to use traces to specify varying handoff parameters (for 
example) by setting a trace to cover a range you want to have high priority 
and FM detection and setting the trace’s handoff parameters accordingly. 



 

 

 

Marker Snapshot 
 

When this button is pressed, it collects a data record and stores it on 
the system disk. The data may be either time domain or frequency (or 
both). 

 

When the icon is ghosted (dull colored) it indicates that no snapshot is active 
for the trace. No snapshot data is collected until a snapshot setup is made 
active. 

 
Cursor Shortcut To display  Trace Snapshot Setup (page 438) dialog box, right- click the camera 

icon. 
 

Notes • The snapshot setup can be different for each trace such that no snapshot 
is active for one trace and one or both snapshot types are active for 
another. 

 

• If you have more than one trace pane with the marker on (i.e., multiple 
snapshot buttons) be sure to click the snapshot button in the correct 
pane. 

 

• Snapshot files may be loaded and analyzed with the snapview Snapshot 
Viewer program.   See Snapshot Viewer (page 455). 

 

• Snapshot files may be listened to using the Agilent N6829BS 
Snapshot Radio software (a separate product available from 
Agilent). 



 

 

 

Task DF 
 

When this button is pressed, the marker’s frequency is passed to an active 
direction finding process.   See also, Direction Finding (page 395). 

 

Note that this button appears only when the DF option is loaded and 
an appropriate DF system is integrated. See Software Options (page 10). 

 

To specify the task settings, right- click this button to display the DF Trace 
Setup dialog box. 

 
DF Trace Setup 

 

When you right- click a trace’s Task DF button, the following dialog box 
appears. 

 

 
 

The Trace Direction Finding Link Setup dialog box allows you to enter or 
specify the following values: 

 

Priority. This menu defines the channel’s priority level within the channel list. 
Changing the priority is used to avoid having the channel assignment changed 
(bumped) by a signal with a higher priority. 

 

Bandwidth. Clicking this box displays the Bandwidth Entry Dialog Box. 
 

This dialog box allows you to specify the bandwidth of the signal sent to the 
DF process. The dialog box consists of a numeric value box and a set of radio 
buttons that allow you to specify Hz, kHz, MHz, and GHz. 

 

Duration. Clicking this box displays a numeric entry dialog box. Entry allows 
you to specify the length of time after loss- of- signal that the channel should 
stay active. The dialog box consists of a numeric value box and a set of radio 
buttons that allow you to specify Sec, mSec, uSec, and nSec. 

 

System. This menu allows you to specify the DF system to task. 
 

Signal Database. “Enabled” causes the signal information to be saved in the 
Signal Database.   “Disabled” causes the information to not be saved. 



 

 

 

Task Mod Rec 
 

When this button is pressed, the marker’s frequency is passed to the  
modulation recognition processing. 

 

Note this button appears only when the Mod Rec option is loaded. See 
Software Options (page 10). 

 

To specify the task settings, right- click this button to display the Mod Rec 
Link Setup dialog box. 

 
Mod Rec Link Setup 

 

Right- clicking the Modulation Recognition Marker Icon presents you with the 
Trace Modulation Recognition Link Setup dialog box. 

 

 
 

See also, Modulation Recognition (page 402). 
 

The Trace Modulation Recognition Link Setup dialog box allows you to enter 
or specify the following values: 

 

Priority. This menu defines the channel’s priority level within the channel list. 
Changing the priority is used to avoid having the channel assignment changed 
(bumped) by a signal with a higher priority. 

 

Bandwidth Mode. This menu specifies the source of the signal bandwidth sent 
to the Mod Rec process. If you select Manual, you must enter a bandwidth 
value in the Bandwidth entry box below. If you select Energy History, the 
bandwidth is set to match that saved by the search process in the signal’s 
energy history entry. 

 

Bandwidth. Clicking this   box displays the Bandwidth Entry Dialog Box. This 
value and the Oversampling value determine the sample rate. 

 

This dialog box allows you to specify the bandwidth of the signal sent to the 
Modulation Recognition process. The dialog box consists of a numeric value 
box and a set of radio buttons that allow you to specify Hz, kHz, MHz, and 
GHz. Enter the numeric value you need, click on a radio button to pick a 
range, then click on the OK button. 



 

 

 

Over Sampling. Clicking this box displays a numeric entry dialog box. 
You must enter values between 0.5 and 4.00. Entries less than or greater 
than these values are rounded to the nearest legal value. This value and 
the Bandwidth value determine the sample rate. 

 

Duration. Clicking this box displays a numeric entry dialog box. The 
duration value limits the age of the request for modulation recognition 
and limits the time spent processing the modulation recognition task. It 
is similar to the Aging value in the Mod Rec Pending List (page 403), but 
also applies after a signal is assigned to a channel for processing. 

 

This dialog box appears when you click a button to enter a duration 
value. To enter a value: 

 

1. Enter the duration value in the text box. 
 

2. Click one of the frequency units radio buttons or type s, m, u, or n to 
select Sec, mSec, uSec, or nSec, respectively.   You can also enter floating- 
point numbers in the form 1.23e- 4. Numeric values greater than 999999 
are  converted to scientific notation. 

 

3. Click OK, or press the Enter/Return key. 
 

Blocksize. This menu defines size of the data block passed to the 
modulation recognition task. The blocksizes range from 1024 complex 
pairs to 1,048,576 complex pairs in powers of two. 

 

System. This menu allows you to specify the Modulation Recognition 
system to task.   As of the E.01 release it has only one entry. 

 

Signal Database.   Choosing “Enabled” causes the signal information to 
be saved in the Signal Database. Choosing “Disabled” causes the 
information to not be saved. 



 

 

 

Marker Popup Menu 
 

This menu appears when you right- click any of the marker buttons in the 
lower right- hand corner of a trace display.   See following figure. Note that 
these entries are available only when the Search Type (page 287) is General. 
They are unavailable when the search type is Directed. 

 

To turn trace markers on, see Trace Identifier (page 54) or Trace Setup (page 
424). 

 

 
 

These menu entries are used to change the sweep’s start and stop frequencies 
based on the position of the marker. 

 

Ref Level sets the reference level of the trace display to the marker’s level 
value (as shown in the Marker Readout (page 61)). This selection appears only 
when the trace scaling (set in the Trace Scaling (page 458) menu) is set to 
Ref/Div. 

 

Center Freq uses the marker’s frequency value to redefine the sweep’s center 
frequency.   This entry is active only when the Search Type (page 287) is 
General. 

 

Start Freq uses the marker’s frequency value to redefine the sweep’s start 
frequency.   This entry is active only when the Search Type (page 287) is 
General. 

 

Stop Freq uses the marker’s frequency value to redefine the sweep’s stop 
frequency.   This entry is active only when the Search Type (page 287) is 
General. 

 

Scale Trace is a checkbox that controls whether the trace’s X axis is 
automatically rescaled to fit the new sweep range.   This is like automatically 
pressing the Frequency Full Scale Button (page 60) after each change. 

 

• Its default setting is on. 
 

• When it is off, the trace doesn’t necessarily display all the frequencies in 
the sweep range. 

 

These parameters may also be changed using the General Search Setup (page 
290) dialog box. 

 

Note Some entries in this menu are ghosted when the Search Type (page 287) is 
Directed.   To use them the Search Type must be General. 



 

 

Marker Function Buttons 
 

 

Handoff Receiver Pane 
 
 
 

 
 
 

This pane contains a listing of the installed handoff receivers. To add or 
delete panes from the N6820ES window, see Display Layout (page 422). 

 

Note The Handoff Receiver Pane is available only when one or more receivers are 
defined in the configuration file. See Hardware Configuration (page 16). 

 
Handoff Queue: All handoff receiver assignments go through a queue. When 
there are more handoffs than installed receivers, the handoffs accumulate in 
the queue. They are assigned from the queue based on priority and order of 
handoff.   This is tracked and indicated in the Handoff Log Pane (page 75). 

 

If your system has option AU1 receivers installed see Audio Output (AU1) 
Controls (page 74). 

 

1. Rx (receiver) is the receiver number as defined in the e3238s.n6841.cfg 
file. 
There may be as many as 100 handoff receivers installed.   See Handoff 
Receiver Configuration (page 271) for information about the installed 
receivers. 

2. Status indicates what activity the receiver is performing: 

• Waiting indicates that the receiver is available to service the next signal 
handed off (assuming its frequency is within the receiver’s range). 

• Active indicates that the receiver is busy monitoring a signal. An active 
signal can be released by clicking the word Active with either the 
right or left mouse button.   See Handoff Receiver Configuration (page 
271). 

• Manual indicates that the receiver has been taken out of the receiver 
pool and is not available for signal assignment.   See Rx Pool under 
Handoff Receiver Configuration (page 271). 

• Offline indicates that the receiver is present, but is unavailable for use. 
This usually indicates that, for Audio Output receiver (option AU1), the 
tuner is not locked.   To lock the tuner select   Search -  Type -  Lock 
Tuner. 

 

3. Priority indicates a signal’s importance relative to other signals.   See 
Handoff Priority (page 79).   This setting may be changed with the mouse 
buttons.   See Changing Receiver Settings (page 72). 

 

4. Elapsed indicates the time (in seconds) that this receiver has been 
monitoring this frequency.   When the value reaches the value in the 
Duration column, the receiver is given another frequency assignment (if 
there is another one in the queue that it is capable of servicing) or 
changes status to Waiting (if not). 



Handoff Receiver Pane  

 

Marker Function Buttons 
 

If a handoff with a higher priority enters the queue and bumps an 
assigned handoff from a receiver, that handoff’s elapsed time will not 
reach the duration value. 

5. Duration is the time (in seconds) that the signal was initially set to be 
monitored.   This setting may be changed with the mouse buttons.   See 
Changing Receiver Settings (page 72). 

6. Frequency is the frequency to which the receiver is tuned. This may be 
changed with the left mouse button. See Changing Receiver Settings (page 
72). 

7. Bandwidth is the bandwidth setting for the receiver.   This value may be 
changed with the mouse buttons.   See Changing Receiver Settings (page 
72). 

8. Det indicates the detection type used by the handoff receiver.   This value 
may be changed with the mouse.   See Changing Receiver Settings (page 
72). 

9. AGC indicates the automatic gain control setting of the handoff receiver, 
if applicable.   This value can be changed with the mouse buttons.   See 
Changing Receiver Settings (page 72). 

10. BFO indicates the beat frequency oscillator setting of the handoff receiver, 
if applicable.   This value can be changed with the mouse buttons.   See 
Changing Receiver Settings (page 72). 

11. Squelch indicates the squelch control setting of the handoff receiver, if 
applicable. This value can be changed with the mouse buttons.   See 
Changing Receiver Settings (page 72) 

12. Audio is used when option AU1 receivers are used.   See Audio Output 
(AU1) Controls (page 74) 

13. Comment is a short (15- character) text field you can include to convey 
more information.   This and other fields are recorded in the Handoff Log 
Pane (page 75).   This information can be changed with the left mouse 
button.   See Changing Receiver Settings (page 72). 



 

 

Changing Receiver Settings 
 

Changing Receiver Settings 
 

Initial 
Configuration 

The settings in Handoff Receiver Configuration (page 271) determine whether 
an operator can release a handoff receiver or change any of the values.  When 
the Releasable setting is “No,” clicking an Active status does not call the 
Release feature.   When the Interactive setting is “No,” none of the other 
settings can be changed in the Handoff Receiver Pane. 

 

Note                         Changing the Duration or Priority values can have the same effect as trying 
to Release an active signal. If the handoff receiver is not configured to allow 
you to release a signal, try reducing either of these settings. 

 
Left Mouse 

Button 
When you click on a field in the Handoff Receiver Pane that can be modified, 
a dialog box appears at the right end of the pane as shown in the following 
figure: 

 
 

 
 

The dialog box varies depending on the field selected. 

• Status (if Active) has the single button “Release Handoff.” 
• Priority is a list of the four priority values. 
• Elapsed cannot be changed. 
• Duration is a text entry line on which you can enter any value. 
• Frequency (shown above) is a text line entry. 
• Bandwidth is a selection from a list. 
• Det is a selection from a list. 
• AGC is an On/Off toggle where On indicates that the gain selection is 

automatic.   If AGC is Off you set the gain with a slide control. 
• BFO is a text line entry in which you can enter any value. 
• Squelch indicates the squelch control setting of the handoff receiver, if 

applicable. This value can be changed with the mouse buttons. 
• Audio see Audio Output (AU1) Controls (page 74). 
• Comment is a text line in which you can enter or modify a comment up 

to 15 characters in length. 
 

To turn off the dialog box at the right side of the pane, click the same field 
again or click a field that cannot be changed. 



Handoff Receiver Pane  

 

Changing Receiver Settings 
 

Right Mouse 
Button 

When you click a field with the right mouse button, a popup menu appears 
that allows you to change the field setting as shown in the following figure: 

 

 

 
 

 
The menu varies depending on the field selected.  Note that “Frequency” must 
be changed with the left mouse button, since it is a text field. 



 

 

Audio Output Controls 
 

Audio Output Controls 
 

When a handoff receiver is configured, the following control is enabled. 
 

 
 

1. Mute   Clicking this button mutes the audio output and disables all other 
controls in this pane. 

 

2. Volume   Clicking and dragging the marker in this box raises or lowers the 
audio volume level. The solid bar indicates the current volume level. 

 

3. Left/Right   These buttons control the audio output from the two available 
audio output channels. By default both audio channels are enabled.   This 
control allows a user to listen to two channels at once. when two are 
installed. 

 

4. Low Pass/High Pass   Clicking the left box adds a high- pass filter to the 
audio output. The High Pass filter can be used to eliminate CTCSS tones. 
Clicking the right of these two boxes adds a low- pass filter to the audio 
output. The Low Pass filter can be used to reduce noise in the audio 
output. 

 

5. Record  Clicking this button directs the software to begin saving the audio 
signal in a file in the snapshot directory. 

 

6. Record Time   This readout displays the length of time that the current 
audio recording session has been running. Audio Output records up to 10 
seconds of data that occurred before the “Record” button was clicked. 
This enables you to record the segment of the signal that caused you to 
record it. 

 



Handoff Log Pane  

 

 

 

Handoff Log Pane 
 
 
 

 
 

This pane contains the log of handoff activity.   To add it to the display, see 
the Display Layout (page 422) dialog box. 

 

1. Pending shows the number of signals handed off but not yet assigned to a 
receiver.   It is a count of the number of entries whose status is pending. 

2. Auto Scroll keeps the latest log entries log visible by scrolling as new 
entries appear.   You can scroll the list up and down with the Scroll Bars 
(page 133). 

3. Handoff Status (page 76) 

4. Handoff Source (page 77) 

5. Request (page 78) 

6. Grant (page 78) 

7. Release (page 79) 

8. Handoff Rx# (page 79) 

9. Handoff Priority (page 79) 

10. Handoff Duration (page 80) 

11. Frequency (page 81) 

12. Bandwidth (page 81) 

13. Detect (page 81) 

14. Comments (page 83) 
 

Tips • Handoff receivers must be described in the e3238s.n6841.cfg file 
and configured before they can be used.   See Hardware Configuration 
(page 16). 

• The definition of energy that is automatically detected and handed off are 
discussed in Energy Detection (page 309). 

• Signals may also be handed off from a trace pane.   See Trace Setup (page 
424). 

• To control handoff directly, see Handoff Receiver Configuration (page 271). 
• The Handoff Log may be recorded as a file.   See Log Files (page 139). 
• To release pending signals, clear the log view entries with Clear Log (page 

146) or mark the ones to release with the left mouse button and then click 
the right mouse button to get the Handoff Log Popup Menu (page 83). 

 

Advanced Note Each handoff log entry requires 160 bytes of memory.   The number of entries in 
the handoff log view is limited as defined by the handoffLogViewLength 
resource variable in the E3238s. See also, Application Resources (page 17). 
When the number of log entries reaches the limit, new entries cause the oldest 



 

 

Handoff Status 
 

completed entries to be discarded/lost from memory.   Pending entries are not 
discarded.   If the queue is full of pending entries, the new ones are discarded. 
The handoff log file is not affected by this limit. 

 
 

Handoff Status 
 

• Pending:   A pending signal has been handed off (put in the handoff 
queue) but has not yet been assigned to a handoff receiver. You can 
change some settings of a Pending signal.   To change an entry’s priority, 
detection, or duration: 

 

a. Position the mouse cursor anywhere in the line of the entry you wish to 
change. 

 

b. Click the right mouse button.   You can select multiple lines by holding 
the button down and dragging the cursor up or down.   When you 
release the button a popup menu appears. 

 

c. Select the appropriate parameter. 

d. Select the new setting. 
 

Note If the frequency or detection type of a signal are not supported by any 
installed handoff receivers, the status is changed to Unable. 

 
If frequency or detection type limit the signal’s handoff to a receiver that is 
installed but not available (e.g.,  it is Out of the receiver pool or assigned to a 
higher priority signal), the status will continue to be Pending until that 
receiver is available.  See Rx Pool under Handoff Receiver Configuration (page 
271). 

 
• Active:   An active signal is one that has been assigned and is being 

monitored by the handoff receiver identified in the Rx# column.  The time 
that is was assigned is recorded in the Granted column.   When the 
amount  of time specified by duration has past, the status changes to 
released. 

 

You may change the frequency, priority, detection, or duration settings, add 
comments, or release the signal before the duration setting releases it 
automatically in the Handoff Receiver Pane (page 70). 

 

An active signal is flagged in a trace pane with text describing the handoff 
receiver monitoring it when the trace grid type is Handoffs and the Active 
signal frequency is within the span of the trace, as shown below.   A 
trace’s grid type is selected in Trace Setup (page 424). 
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Handoff Source 

 

 
 

• Completed:   A completed signal was released at the time listed in the 
Released column.  Completed signals may be handed off again; see Handoff 
Log Popup Menu (page 83). 

 

• Bumped:   A bumped signal was released before the duration time setting 
expired because another signal with a higher priority was handed off and 
all other handoff receivers were assigned to equal or higher- priority 
signals. 

 

• Released means that the operator marked it and clicked the Release 
button while it was pending.   If the number in the Rx column is 0, the 
signal was never assigned to a receiver. 

 

• Unable means that either the frequency of the signal is outside the range 
of all installed handoff receivers or the detection type is not supported by 
any of the installed receivers. 

 

See note under Pending. 
 

Tips • To handoff a logged signal that was released, click it with the middle 
mouse button and drag it to the handoff receiver pane. 

 

• To handoff more than one signal entry, select them by clicking them with 
the left mouse button.  To select contiguous entries, click and drag or hold 
the Shift key when you click the entry at the end of the selection.   To 
select individual entries, hold the Ctrl key when you click them. 

 

 

Handoff Source 
 

This field lists the feature that initiated the handoff. 
 

• Marker means that the signal was handed off from a trace by moving the 
marker to it and then clicking the Task Handoff Rx (page 63). The 
procedure is described under Handoff a Signal (page 507). 

 

• Trace means that the signal was handed off from the Trace Pane with the 
mouse.   See Handoff a Signal (page 507). 

 

• Log means that the signal was listed in the handoff log and its handoff log 
entry was selected with the mouse to tune a handoff receiver to it again. 
See Handoff Log Popup Menu (page 83). 

 

• Alarm 1, Alarm 2, ... means that the signal was handed off as a task from 
the alarm (identified by number).   See Handoff Task (page 355). 

 

• EnergyHist means that the signal was handed off from the Energy History 
Pane (page 88). 
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Request 
 

• Manual means that the signal was handed off with the manualHandoff 
command either remotely (through a socket connection to an external 
process) or from the Command Line Pane (page 115). 

 

 

Request 
 

The date and time that the handoff request occurred.   This time may not be 
the same as the Granted time, if more signals have been handed off than 
there are handoff receivers.  It is also dependent on the priority differences of 
active handoffs and pending handoffs.   The activity times in handoff log have 
a resolution of 1 second. 

 

 

Grant 
 

The time the handoff receiver accepted the signal and began monitoring. The 
activity times in handoff log have a resolution of 1 second. 
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Release 

Release 

 

The time the handoff receiver quit monitoring the signal. The activity times in 
handoff log have a resolution of 1 second. 

 

 

Handoff Rx# 
 

The handoff receiver number used to monitor the signal as defined in the 
Handoff Receiver Configuration (page 271) dialog box. 

 

 

Handoff Priority 
 

This discussion applies to handoff setup parameters in the Energy History 
Pane (page 88) or Trace Setup (page 424) dialog box as well as column 
descriptions in the Handoff Log Pane (page 75) and Handoff Receiver Pane 
(page 70). 

 

A handoff is given a Priority level when it is handed off.   If more than one 
handoff is pending (waiting in the queue to be assigned to a handoff receiver), 
the handoff with the higher priority setting goes first.   If the priority of two 
pending handoffs is the same, the handoff with the earlier request goes first. 
See Handoff Status (page 76) for descriptions of pending and bumped. 

 

The priority levels are: 
 

• Critical priority handoffs have the highest priority. When a Critical 
priority handoff is put in the handoff queue, it will bump any lower- 
priority handoff being monitored. 

 

• High priority handoffs are superseded only by Critical priority handoffs. 
Critical priority handoffs can bump a High priority handoff. When a High 
priority handoff is put in the handoff queue, it will bump any Medium or 
Low priority handoff being monitored. 

 

• Medium priority handoffs can bump Low priority handoffs, but any High 
and Critical priority handoffs will be handed off before a Medium priority 
handoff Handoffs with High and Critical priority will bump a Medium 
priority handoff being monitored. 

 

• Low priority handoffs are handed off in the order they are put in the 
handoff queue when there are no pending handoffs with higher priority. 
If a handoff with higher priority is handed off while a low- priority handoff 
is being monitored, it is bumped; the handoff receiver tunes to the higher- 
priority handoff. 

 

The initial priority value is defined by the Handoff Source (page 77) handoff 
settings.   The priority can also be changed while the handoff is pending (e.g., 
increase priority to get it assigned to a receiver sooner by bumping an active 
handoff) or while it is active (e.g., increase priority to avoid its getting 
bumped by another handoff). 

 
Tips • After Priority, receiver assignment depends on the order in which the 

receivers are listed/installed.   For example, when all active handoffs have 
the same priority and a handoff with a higher priority enters the queue, it 
bumps the handoff on the first receiver on the list.   Receiver order is 
determined by entries in e3238s.n6841.cfg. 
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Handoff Duration 
 

• The log’s priority setting for a pending handoff is used to determine when 
it is assigned to a handoff receiver, given the priorities of all pending and 
active handoffs. 

 

• The log’s priority setting for an active handoff is used to determine 
whether other handoffs in the queue bump it before its duration expires. 

 

• The log’s priority setting for a completed handoff is the priority setting 
that was active when monitoring ended for that handoff. 

 

To set the priority value before the handoff, see: 

• Trace Setup (page 424) for assignments from the trace. 
 

• Handoff Task (page 355) for assignments from the Process Overview (page 
33). 

 

• Energy History > Tools > Handoff Setup (page 102) for assignments from 
the Energy History Pane (page 88). 

 

To change the priority of a pending entry in the handoff log, see Handoff Log 
Popup Menu (page 83). 

 

To change the priority of an active handoff, see Handoff Receiver Pane (page 
70). 

 

 

Handoff Duration 
 

This discussion applies to handoff setup parameters in the Energy History 
Pane (page 88) or Trace Setup (page 424) dialog box as well as column 
descriptions in the Handoff Log Pane (page 75). 

 

Duration is the amount of time a frequency is to be monitored before it’s 
status changes to completed and the handoff receiver takes another 
assignment from the queue.  This value is assigned to a handoff when it is put 
in the handoff queue. 

 

This value is listed in the Handoff Log Pane (page 75) as follows: 
 

For a pending handoff, this is the amount of time the handoff receiver will 
stay tuned to the frequency if no handoffs with higher priority are put in the 
queue. 

 

For a completed handoff, this is the amount of time the handoff receiver was 
tuned to the assigned frequency. 

 

Minimum duration: 1 second 
Maximum duration: 86400 seconds (24 hours) 
Resolution: 1 second 

 
Tips • To set this value before the handoff, see: 

• Trace Setup (page 424) for trace handoffs. 
• Handoff Task (page 355) for alarm handoffs. See Process Overview (page 

33). 
• Energy History > Tools > Handoff Setup (page 102) for handoffs from 

the Energy History Pane (page 88). 
• To change this value for a pending entry in the handoff log, see Handoff 

Log Popup Menu (page 83). 
• To change this value for an active handoff, see Handoff Receiver Pane 

(page 70). 
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Frequency 

Frequency 

 

The frequency of the handoff assignment.  This value may have been measured 
at the peak of detected energy, it may have been assigned as part of a Single- 
BW- Hint Setup (page 325) definition, or it may have been a user- defined value 
specified as part of an alarm task definition in the Handoff Task (page 355) 
dialog box. 

 

 

Bandwidth 
 

This is the bandwidth value associated with the handoff session. 
 

• When the handoff status is released, unable, or pending, this value 
reflects the setup value for the source that requested it (e.g., trace handoff 
setup). 

 

• When the handoff is granted (becomes active), the bandwidth value may 
be rounded up to the receiver’s next largest acceptable setting. 

 

• When the handoff status is active, the bandwidth value reflects the 
receiver’s current setting (which may be changed by the operator). 

 

• For a bumped or completed entry, the bandwidth value indicates the 
bandwidth value in use at the time of release. 

 

 

Detect 
 

This discussion applies to handoff setup parameters in the Energy History 
Pane (page 88) or Trace Setup (page 424) dialog box as well as column 
descriptions in the Handoff Log Pane (page 75). 

 

Detection is the method used to demodulate the signal.   The detection types 
available depends on the capabilities of the installed handoff receivers.   The 
types displayed in the log and detection selection lists may include others. 
The list of standard types is: 

 

• None 
• AM: amplitude modulation 
• FM: frequency modulation 
• CW: continuous wave 
• LSB: lower side band 
• USB: upper side band 
• Log: log modulation 
• Pulse: pulse modulation 

 
Tips • To set this value before the handoff, see: 

• Trace Setup (page 424) for signals handed off from the trace. 
• Handoff Task (page 355) for signals handed off as part of the Process 

Overview (page 33). 
• Energy History > Tools > Handoff Setup (page 102) for signals handed 

off from the Energy History Pane (page 88). 
• To change this value for a pending entry in the handoff log, see Handoff 

Log Popup Menu (page 83). 
• To change this value for an active signal, see Handoff Receiver Pane (page 

70). 
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Detect 
 

See the discussion under Handoff Receiver Configuration (page 271). 
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Comments 

Comments 

 

Comments may be added in the handoff receiver control box while the signal 
is being monitored (status=active). The maximum length of the comment is 15 
characters. 

 

 

Handoff Log Popup Menu 
 

Path: In the Handoff Receiver pane, select one or more pending handoff log 
entries with the left mouse button, click the right mouse button. 

 

 
 

This allows you to assign a handoff receiver to the same settings that appear 
for an entry in the log or, for an active entry, release or change the priority, 
duration, or detection settings originally specified in the Trace Setup (page 
424) or Handoff Task (page 355) dialog boxes. 

1. Handoff Verification (page 83) 

2. Release Verification (page 84) 

3. Priority (page 84) 

4. Detection (page 84) 

5. Duration (page 84) 
 

To add the Handoff Log Pane to the main window, see Display Layout (page 
422). 

 
Handoff Verification 

 

 
 

Path: Perform following steps: 

1. Select one or more entries with the left mouse button. 

2. Click the right mouse button. 

3. Click Handoff. 
 

When you select Handoff, this menu confirms the request before it hands off 
the selected signals. 

 

Yes confirms the handoff. 
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Handoff Log Popup Menu 
 

No cancels the handoff. 

 
Release Verification 

 

 

Path: Perform following steps: 

1. Select one or more pending handoff log entries with the left mouse button. 

2. Click the right mouse button. 

3. Click Release. 
 

When you select Release this menu confirms the release request before it 
releases signals that are pending in the handoff log. 

 

Yes confirms the release and the status is changed to Released in the Handoff 
Log. 

 

No cancels the release and the status is not changed. 

 
Priority 

 

This menu allows you to change the priority of a pending handoff log entry. 
To change the priority setting for one or more pending signals in the Handoff 
Log Pane (page 75): 

 

1. Select one or more pending handoff log entries with the left mouse button. 

2. Click the right mouse button anywhere inside the Handoff Log Pane; an 
option list appears containing time values. 

3. Select a new priority value from the list by clicking it. 

 
Detection 

 

This menu allows you to change the detection type of a pending handoff log 
entry.   To change the detection setting for one or more pending signals in the 
Handoff Log Pane (page 75): 

 

1. Select one or more pending handoff log entries with the left mouse button. 

2. Click the right mouse button anywhere inside the Handoff Log Pane; an 
option list appears containing time values. 

3. Select a new detection value from the list by clicking it. 

 
Duration 

 

This menu allows you to change the duration of a pending handoff log entry. 
To change the duration setting for one or more pending signals in the Handoff 
Log Pane (page 75): 

 

1. Select one or more pending handoff log entries with the left mouse button. 
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Handoff Log Popup Menu 
 

2. Click the right mouse button anywhere inside the Handoff Log Pane; an 
option list appears containing time values. 

3. Select a new duration value from the list by clicking it. 
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New Energy Log Pane 

Handoff Log Popup Menu 
 

 

New Energy Log Pane 
 
 

 
 

This pane displays a log of new energy.   For a general discussion of its place 
in the overall process, see Process Overview (page 33). 

 

1. Number of entries in the log.   “Full” means that it has reached capacity 
and some entries have been shifted out of the log.   See the following note. 

2. Auto Scroll keeps the latest entries visible by scrolling through the log. 
You can move the list up and down in the pane with the Scroll Bars (page 
133). 

3. This is the date and time of the first intercept (the first time the energy 
was detected. For information about the total number of intercepts and 
the time of the last intercept, see Energy History Pane (page 88). 

4. The frequency of the energy the first time it was detected.  This value may 
be at the peak of the detected energy, or it could be the center of a 
predefined band within which the energy was detected.   See Process 
Overview (page 33) and Single- BW- Hint Setup (page 325) for more 
information. 

5. The energy bandwidth on the first detection.   This value may have been 
measured or copied from the Single- BW- Hint Setup (page 325) dialog box, 
if the frequency fell in an active hint.   For information on the current, 
maximum, minimum, or average bandwidth values, see Energy History 
Pane (page 88). 

6. The amplitude of the energy as measured when the intercept occurred. For 
information on the statistical values, see Energy History Pane (page 88). 

 

Advanced Note         Each New Energy Log entry requires 60 bytes of memory.  The number of entries 
in the log view is limited as defined by the newEnergyLogViewLength resource 
variable in the E3238s. See also, Application Resources (page 17). 

 
When the number of log entries reaches the limit, new entries cause the oldest 
entries to be discarded/lost from memory.   To avoid losing this information, turn 
on the log- to- file feature; all entries will be written to a file on the hard disk. 
See Log Files (page 139). 

 

 
Tips • To add this pane to the main window, see Display Layout (page 422). 

• To create a file containing this log, see Log Files (page 139). 
• To clear the New Energy Log, see Clear Log (page 146). 
• To receive help on this or any pane, click Help, On Window or press 

Shift+F1 to activate context- sensitive help and click in the pane. 



87 

 

 

Alarm Log Pane 

Handoff Log Popup Menu 
 

 

Alarm Log Pane 
 
 

 
 

This pane displays a log of triggered alarms.   For a general discussion of its 
place in the overall process, see Process Overview (page 33). 

 

1. The number of alarms in the log. “Full” means that it has reached 
capacity and some entries have been shifted out of the log. See the 
following note. 

 

2. Time of Intercept This is the date and time of the intercept that caused 
the alarm. 

 

3. Frequency The measured frequency of the detected energy peak.   See 
Process Overview (page 33) for more information. 

4. Alarm   The alarm number.   See Alarms Setup (page 336). 

5. Type   Either energy or signal alarm. 

6. Description   The description or name of the alarm as entered in the 
Single- Alarm Setup (page 338) dialog box. 

 

7. Auto Scroll keeps the latest entries visible by scrolling the log as new 
additions appear.   You can move the list up and down in the pane with 
the Scroll Bars (page 133) at the right. 

 

Advanced Note            Each Alarm Log entry requires 90 bytes of memory.   The number of entries in the 
log view is  limited  as  defined  by  the  alarmLogViewLength resource  variable  in 
the  E3238s.  See  also,  Application  Resources  (page  17). 

 
When the number of log entries reaches the limit, new entries cause the oldest 
entries to be discarded/lost from memory.   To avoid losing this information, turn 
on the log- to- file feature; all entries will be written to a file on the system disk. 
See Log Files (page 139). 

 

 
Tips • To add this pane to the main window, see Display Layout (page 422). 

• To create a file containing this log, see Log Files (page 139). 

• To clear the Alarm Log, see Clear Log (page 146). 
 

• To receive help on this or any pane, click Help, On Window or press 
Shift+F1 to activate context- sensitive help and click in the pane. 



Energy History Pane 
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Handoff Log Popup Menu 
 

 

Energy History Pane 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To use the pull- down menus of the Energy History Pane 

• “Energy History > File Pull- Down Menu” on page 89 

• “Energy History > Edit Pull- Down Menu” on page 90 

• “View > Energy History > View Pull- Down Menu” on page 93 

• “Energy History > Tools Pull- Down Menu” on page 101 

• “Energy History > Right- Click Menu” on page 106 
 

To print/save/clear/show Energy History entries 

• Printing entries   -  See “File > Print". 

• Saving entries -  See “File > Print To File". 

• Clearing entries -  See “Edit > Clear Energy History". 

• Showing entries in a trace -  Set the grid type to New Energy. 
 

To change which feature/parameters are displayed 
 

See “View > Energy History > Edit > Format (Column Setup)” on page 91. Up 
to eight feature/parameters can be displayed for each entry in the Energy 
History Pane. 

 

To display all feature/parameters for a selected entry 

See “Energy History > View > Entry” on page 94. 



Energy History Pane 
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Energy History > File Pull- Down Menu 

Energy History > File Pull-Down Menu 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

“View > Energy History > File > Load” on page 89 

“View > Energy History > File > Save” on page 89 

“View > Energy History > File > Close” on page 90 

 

View > Energy History > File > Load 
 

Load is used to read a file containing Energy History data from a file on the 
system disk. Loading an Energy History file removes the existing 
feature/parameter statistic data in the Energy History. You are prompted with 
a question to assure that this is your intention before the data is overwritten. 

 

When you load an Energy History file that contains custom features, be sure 
that the same feature/parameter- defining library programs are loaded in the 
same order as were loaded when the file was created. The Agilent N6820ES 
Signal Detection and Monitoring Solutions tracks user- defined 
feature/parameters with an index/counter that is assigned based on the order 
that they are loaded; for example, the order they are listed in the 
configuration file. 

 
View > Energy History > File > Save 

 

Save writes the feature/parameter data in the Energy History to a file on the 
system disk. Saving Energy History data to a file creates an ASCII file 
containing all the feature/parameter statistics in scientific notation using a 
comma- separated- value format. To pull the data directly into Microsoft Excel, 
save the data as a .csv file. To do this, select All Files (*.*) as the Save as 
type: and <filename.csv> for the File name. 

 

Note Current, Minimum, and Maximum Amplitude data are saved as volts squared. 
Use the following formula to convert to dBM. dBM=10*Log10(20*V2). 

 
For Average Amplitude, use dBM=10*Log10(20*V2/Intercepts) 

 
% Occupancy is not saved as part of the standard Energy History data. To 
calculate the % Occupancy, divide Intercepts by Number Sweeps. 
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Energy History Pane 

Energy History > Edit Pull-Down Menu 

 

 

 

Note The First Intercept and Last Intercept saved values are saved as the number 
of seconds from the epochal date of January 1, 1970. 

 
The following formula will convert a saved intercept value into a Greenwich 
Standard Time (Month/Day/Year Hour:Second) format. GST time = (Saved 
Intercept Value/86400)+25569. 

 
For example, to change GST to Pacific Standard Time you need to subtract 8 
hours or 1/3 of a day. 
PST time = (Saved Intercept Value/86400)+25569−0.33333 

 
 

View > Energy History > File > Close 
 

Closes the Energy History file. 
 
 

 
Energy History > Edit Pull- Down Menu 

 

View > Energy History > Edit Pull- Down Menu 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

“View > Energy History > Edit > Format (Column Setup)” on page 91 

“Energy History > Edit > Add Entry” on page 92 

“Energy History > Edit > Delete Entry” on page 92 

“View > Energy History > Edit > Clear” on page 93 
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Energy History Pane 

Energy History > Edit Pull-Down Menu 

 

 

 

View > Energy History > Edit > Format (Column Setup) 
 

 
View > Energy History > Edit > Format (Column Setup) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Energy History Column Setup dialog box is used to specify what 
feature/parameters appear in the columns of the Energy History Pane. 

 

While there are many fields that can be displayed, only the first eight columns 
listed in the Displayed group appear in the Energy History Pane. 

 
To add a column entry to the displayed energy history group 

 

Select the name of a column from the Available group and click the horizontal 
arrow. 

 
To remove a column entry from the displayed energy history group 

 

• Select the name of a column from the Displayed group and click the 
horizontal arrow. 

 

• OK implements the changes made and closes the dialog box. 

• Apply implements any changes and leaves the dialog box open. 

• Cancel closes the dialog box without making any changes. 
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Energy History Pane 

Energy History > Edit Pull-Down Menu 

 

 

 

Energy History > Edit > Add Entry 
 

View > Energy History > Edit > Add Entry 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Energy History Add Entry dialog box is used to add an entry to the 
Energy History Pane. This may be used to define alarm conditions that 
require energy history entries to monitor for No Signal conditions. 
See “Search > Alarms > Energy Definition". 

• Single Entry 
 

To add one entry to the Energy History Pane, click the radio button 
associated with this selection, and enter values for the frequency and 
bandwidth with the buttons at the right. 

 

• Load from Bandwidth Hint 
 

To add all entries in a defined “Search > Detection Setup > Energy > 
Bandwidth Hints", click the radio button associated with this selection and 
enter the number associated with the Bandwidth Hint you want. 

 
The hint status must be active and channelize = Yes. 

 
 
 

Energy History > Edit > Delete Entry 
 

View > Energy History > Edit > Delete Entry 
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Energy History Pane 

Energy History > Edit Pull-Down Menu 

 

 

 

When Delete Entry is selected and before any data is cleared, a prompt is 
displayed acting as a two- step verification process which helps reduce the 
chances of making an error. 

 

Yes allows the energy history entry deletion process to continue. 
No cancels the energy history entry deletion process. 

 
View > Energy History > Edit > Clear 

 

View > Energy History > Edit > Clear 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

When Clear is selected and before any data is cleared, a prompt is displayed 
acting as a two- step verification process which helps reduce the chances of 
making an error. 

 

Yes allows the energy history clearing process to continue. 
No cancels the energy history clearing process. 

 
View > Energy History > View Pull- Down Menu 

 

View > Energy History > View Pull- Down Menu 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

“Energy History > View > Entry” on page 94 

“Energy History > View > Plot” on page 95 

“View > Energy History > View > Status Bar” on page 99 
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Energy History Pane 

Energy History > Edit Pull-Down Menu 

 

 

 

Energy History > View > Entry 
 

This selection opens a dialog box that lists all the feature/parameter 
information for a single entry from Energy History. 

 

View > Energy History > View > Entry 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Any of the values displayed in this dialog box may be used to trigger an 
alarm. See “Search > Alarms > Single- Alarm Setup". 

 

To select an entry, click on a row in the Energy History Pane. 
 

Note When an Energy History Entry is linked to a trace marker, the trace marker 
appears at the peak of the entry selected (for example, clicking a different 
entry moves the trace marker). Also, moving the marker to another peak 
causes the Energy History Entry information to track the selected entry if it 
falls within the span of an existing entry. 
See “Energy History > Tools > Marker Link” on page 104. 

 
 
 

Note The amplitude, bandwidth, duration, and user- defined feature/parameters may 
be displayed as graphic profiles with the “Energy History > View > Plot” on 
page 95. 

 
The detection counter is incremented when energy is detected on two 
consecutive sweeps; for example, not on first intercept. When the sweep is 
stopped or the sweep setup is changed, any pending detections are cleared. 

 
The accuracy of the duration values depends on how frequently the energy’s 
frequency is swept. The calculation assumes the energy is present 
continuously between intercepts and stopped at the time of the last intercept 
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Energy History Pane 

Energy History > Edit Pull-Down Menu 

 

 

 

if energy is not detected on the current sweep. 
 

The minimum and average duration values are updated only after a valid 
detection; the maximum duration is always updated. 

 

 
 
 

Energy History Entry 
 

• Energy Limits of an Energy History Entry 
 

• Frequency is the energy’s center frequency, recorded at the first 
intercept. If this value falls into an active frequency range in “Search > 
Detection Setup > Energy > Bandwidth Hints" and channelize is active, 
the value recorded is the center of the band rather than the measured 
frequency of the peak. 

 

• Bandwidth is the “current bandwidth” value of the “first intercept” 
event. The value is either the energy’s measured bandwidth, given the 
bandwidth amplitude specified in 
“Search > Detection Setup > Energy > Energy Criteria" or a 
predetermined value from the 
“Search > Detection Setup > Energy > Bandwidth Hints", if the peak is 
in an active frequency range. This bandwidth value is used to determine 
if a peak belongs in this entry or is a new peak. The accuracy of the 
measured value depends on resolution (RBW). 

 
 
 
 
 

Energy History > View > Plot 
 

View > Energy History > View > Plot 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Energy History Plot dialog box displays any single feature versus the 
frequency span of one of the traces or a span you define manually. Display 
this dialog box by clicking Plot on the “Energy History Pane” on page 88. 
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Energy History Pane 

Energy History Plot Y-Axis Scaling 

 

 

 

1. Feature data to be plotted. 
 

The feature data types are described in 
“Energy History > View > Entry” on page 94. Measured analog data types 
can be graphically combined into groups called profiles. These are: 

• Amplitude 
• Duration 
• Bandwidth 

A profile plot displays a vertical line for each entry. 

• The low end of the line is minimum value, 
• the highest end is the maximum value, 
• the green dot on the line is the average value, and 
• the white dot is the current amplitude. 

2. “Energy History Plot Y- Axis Scaling” on page 96 

3. “Energy History Plot X- Axis Scaling” on page 98 

4. Amplitude auto- scale button. 

5. These buttons synchronize the frequency scale with a trace. 
 

6. This line indicates the trace’s marker position, if on, or the selected entry 
in the energy history. 

 

o change the data to be plotted, select an entry from the scrolled list at the right. 

 
To manually define the plot scale 

 

1. Click either a Y- axis button (item #2) or an X- axis button (item #3). A 
new dialog box appears. 

 

2. Change the scale settings. 
 

3. Click “OK” to apply the change and close the dialog box or click “Apply” 
to apply the change and leave the dialog box open. 

 

Note The plot colors can be modified in the E3238s resource file with *plotColor 
commands. 
See “Application Resources” on page 17. 

 
 
 
 

Energy History Plot Y- Axis Scaling 
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Energy History Plot Y-Axis Scaling 
 

View > Energy History > View > Plot (Y- Axis Scaling) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This dialog box is used to specify the Y- axis scale for the Energy History Plot. 
You can display this box by clicking in either of the Plot Y Scale buttons on 
the “Energy History > View > Plot” on page 95. 

 
To specify the energy history scale with min/max values 

 

1. Click the button corresponding to the parameter you wish to change. A 
new dialog box appears. 

 

2. Make sure the mouse cursor is in the new dialog box. 

3. Change the value using a numeric value only (don’t enter units). 

4. Click OK. 
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Energy History Plot Y-Axis Scaling 

 

 

 

Energy History Plot X- Axis Scaling 
 

View > Energy History > View > Plot (X- Axis Scaling) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This dialog box is used to set the X- axis (frequency) scale of the energy 
history plot. You can display this box by clicking in either of the Plot X Scale 
buttons on the “Energy History > View > Plot” on page 95. 

 

To select automatic frequency scaling, click the radio button of the trace 
whose frequency scale it should match. 

 

To display data for frequency ranges that do not correspond to trace 
frequency spans, set the scale to start and stop frequencies entered manually: 

 

1. Click the radio button in the Manual Scaling field. The numbers on the 
scale buttons become active. 

 

2. Click the X Minimum (or Maximum) button. A new dialog box appears. 
 

3. Enter the new value in the box. The cursor must be in the box while you 
type. 

 

4. Click OK. The new value should appear on the button face. 



99 

Energy History Pane  

 

Energy History > View > Plot (Scale Value) 
 

Energy History > View > Plot (Scale Value) 
 

 
 

View > Energy History > View > Plot (Scale Value) 

 
 

 
 
 

View > Energy History > View > Status Bar 
 

View > Energy History > View > Status Bar 
 
 
 
 
 
 
 
 
 
 

Status 
Bar 

 

 
 
 
 

Status Bar adds an additional information to the bottom of the Energy History 
Pane that displays statistics related to Active Energy and Past Energy along 
with how much disk space the active and past energy are using. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Energy History Full 
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Energy History Full 
 
 

 
 

This dialog box appears when the number of entries in the Energy History exceeds the 

maximum allowed. 
 

Note Each Energy History entry requires approximately 128 bytes of memory. The 
number of entries in the pane is limited by the maxEnergyHistorySize 
resource variable in the configuration file. The default is 5000. 

 
Another way to control the number of entries is to implement filters that limit 
new entries and/or delete existing entries. 
See “Search > Energy History Filter (Option ASD)". 

 
 

Don’t show this dialog box again 
 

when the energy history gets full, new entries are lost/ignored and no warning 
is given. This resets when the application is restarted. 

 
Disable Energy Detection 

 

stops the creation of new entries. This may be reenabled in “Search > 
Detection Setup > Energy Tab". 

 
Clear Energy History 

 

deletes all of the entries in the database. This has the same effect as 
described in “Edit > Clear Energy History" and “View > Energy History > Edit 
> Clear” on page 93. 

 

When the number of entries reaches the limit, new entries will not be added 
until some or all of the current entries are deleted: individual entries can be 
deleted with “Energy History > Edit > Delete Entry” on page 92. 

 
Do Nothing 

closes the warning dialog box. New entries will continue to be ignored. 

Another method that can be used to minimize the total number of energy 
history entries is the use of the energy history filters. 

 
Verify Energy History Recall 

 

This dialog box is displayed to point out that recalling an Energy History file 
clears the feature data currently in the Energy History. 
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Energy History > Tools Pull-Down Menu 
 

To avoid losing this data click No, save the current Energy History in another 
file, and then load the desired Energy History file. 

 

 

Energy History > Tools Pull- Down Menu 
 

View > Energy History > Tools Pull- Down Menu 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Handoff: displays the frequency of the entry that is to be handed off to a 
handoff receiver. 

 

Handoff remains grayed out until an entry is selected from the 
Energy History Pane. Handoff Receivers must be designated in the 
configuration file before starting the Agilent N6820ES Signal Detection and 
Monitoring Solutions software. 

 

“Energy History > Tools > Handoff Setup” on page 102 

“Energy History > Tools > Marker Link” on page 104 
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Energy History Pane 

Energy History > Tools > Handoff Setup 

 

 

 
 
 
 
 

Energy History > Tools > Handoff Setup 
 

View > Energy History > Tools > Handoff Setup 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
When you click Handoff Setup, another menu appears that allows you to set 
the Priority, Detection, and Duration parameters for signals handed off from 
the Energy History Pane. 

 

• <Hyperlink>“Handoff Log Priority 

• “Handoff Log Detect” on page 103 

• “Handoff Log Duration” on page 103 
 

Handoff Log Priority 
 

A handoff is given a Priority level when it is handed off. If more than one 
handoff is pending (waiting in the queue to be assigned to a handoff receiver), 
the handoff with the higher priority setting goes first. If the priority of two 
pending handoffs is the same, the handoff with the earlier request goes first. 

 

The priority levels are: 
 

• Critical priority handoffs have the highest priority. When a Critical 
priority handoff is put in the handoff queue, it will bump any lower- 
priority handoff being monitored. 

 

• High priority handoffs are superseded only by Critical priority handoffs. 
Critical priority handoffs can bump a High priority handoff. When a High 
priority handoff is put in the handoff queue, it will bump any Medium or 
Low priority handoff being monitored. 

 

• Medium priority handoffs can bump Low priority handoffs, but any High 
and Critical priority handoffs will be handed off before a Medium priority 
handoff. Handoffs with High and Critical priority will bump a Medium 
priority handoff being monitored. 
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Energy History > Tools > Handoff Setup 
 

• Low priority handoffs are handed off in the order they are put in the 
handoff queue when there are no pending handoffs with higher priority. If 
a handoff with higher priority is handed off while a low- priority handoff 
is being monitored, it is bumped; the handoff receiver tunes to the higher- 
priority handoff. 

 

• The priority can also be changed while the handoff is pending (for 
example, increase priority to get it assigned to a receiver sooner by 
bumping an active handoff) or while it is active (for example, increase 
priority to avoid its getting bumped by another handoff). 

 
Handoff Log Detect 

 

is the method used to demodulate the signal. The detection types available 
depends on the capabilities of the installed handoff receivers. The types 
displayed in the log and detection selection lists may include others. 

 

The list of standard types is: 

• None 

• AM: amplitude modulation 

• FM: frequency modulation 

• CW: continuous wave 

• LSB: lower side band 

• USB: upper side band 

• Log: log modulation 

• Pulse: pulse modulation 
 

Handoff Log Duration 
 

is the amount of time a frequency is to be monitored before its status changes 
to completed and the handoff receiver takes another assignment from the 
queue. This value is assigned to a handoff when it is put in the handoff 
queue. 

 

This value is listed in “Energy History > Tools > Handoff Setup” on page 102 
as follows: 

 

• For a pending handoff, this is the amount of time the handoff receiver will 
stay tuned to the frequency if no handoffs with higher priority are put in 
the queue. 

 

• For a completed handoff, this is the amount of time the handoff receiver 
was tuned to the assigned frequency. 

 

• Minimum duration: 1 second 

• Maximum duration: 86400 seconds (24 hours) 

• Resolution: 1 second 
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Energy History > Tools > Marker Link 
 
 
 
 
 

Energy History > Tools > Marker Link 
 

View > Energy History > Tools > Marker Link 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Marker Link allows one of the feature/parameters to be lined to a particular 
trace marker. 

 

When the Energy History is linked to a trace marker, the marker appears at 
the peak of the entry selected in the Energy History Pane (for example, 
clicking a different entry moves the trace marker). Also, moving the trace 
marker to another peak causes the Energy History Entry information to track 
the selected entry if it falls within the span of an existing entry. 

 
To link a trace marker to entry in the Energy History Pane 

• Set up energy detection. 

• Add the Energy History Pane to the main window. 

• Click one of the entries (lines) in the Energy History Pane. 
 

• Click the right- mouse button anywhere in the Energy History Pane’s list 
area to display a popup menu. 

 

• Continue to hold the mouse button down and move the cursor down to 
the Marker Link entry and release the button. The display should now 
appear as shown in <Hyperlink>Figure . 

 

• Click the entry for the trace you wish to select. 

When a trace is selected and its marker is on 
(see “Trace Setup” on page 424), the marker moves to the frequency of the 
entry selected in the Energy History Pane 
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Energy History Pane  

 

Energy History > Tools > Marker Link 
 

Linking a Trace Marker to the Energy History Pane 
 

 
 

Also, when the marker is moved (in the trace) to a frequency value within the 
bandwidth of an entry in the Energy History Pane, that entry is selected 
(highlighted) in the pane. 
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Energy History > Right-Click Menu 
 

Energy History > Right- Click Menu 
 

View > Energy History > Right- Click Menu 
 

 

Right-Click Menu appears when the right-mouse button 

is clicked anywhere in the Energy History Pane.  

 

The right- click menu appears when the right- mouse button is clicked 
anywhere in the Energy History Pane. 

 

“Energy History > Edit > Delete Entry” on page 92 

“Energy History > Edit > Add Entry” on page 92 

“Energy History > View > Entry” on page 94 

“Energy History > Tools > Handoff Setup” on page 102 

The right- click menu is used as a shortcut to: 

1. Identify the selected entry’s frequency. 
 

2. Add a signal to the handoff queue. Set the handoff’s priority, detection, 
and duration. 

 

3. Delete an entry from the history listing. 
 

4. Add an entry to the Energy History Pane. This may be useful for defining 
alarm conditions that require energy history entries to monitor for No 
Signal conditions. 
See “Energy History > View > Entry” on page 94. 

5. Pick a trace whose marker is coupled to entry selection. 
See “Energy History > Tools > Marker Link” on page 104. 

 

6. Specify handoff settings (priority, detection, and duration) for handoffs 
performed from this pane. 
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Energy History > Right-Click Menu 
 

 

Signal Database Pane 
 
 
 

 
 

 
This pane displays the signal information collected by narrow- band signal 
processing assets. 

 

These assets are described in DSP Block Diagram (page 25).   See also, the 
discussion of the processing diagram in Process Overview (page 33). 

 

The maximum number of entries in the Signal Database is specified in the 
E3238s Resources file with the variable signalDatabaseSize. By default the 
maximum number is 500,000. When this limit is reached, no new signals are 
added to the database. 

 

The signal processing activity and channel control appears in the Signal 
Processing (page 380) dialog box. 

 

1. File Menu allows you to perform file manage operations such as load, 
save,  merge, delete, and print.   See Signal Database File Menu (page 109). 

 

2. Time is the date and time that the signal was identified. 
 

3. Frequency is the frequency associated with the signal. This can mean 
different things for different types of signals. 

 

4. Duration is a value whose definition depends on the signal class and/or 
type as determined by the user- defined library.   For typical signals it is 
the time the signal was “up”. 

5. Bandwidth is the computed signal bandwidth. 
 

6. Class is one of the three signal processing activities: 

• Signal Identification 

• Location (e.g., Geolocation) 

• Collection 
 

7. Type is a designation given the signal by the library used to process this 
signal.   It is used to sort signals in the database with the Type Menu. 

 

8. Description This field is used to specify which user- defined signal 
data to display. 
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Energy History > Right-Click Menu 
 

When the “ All Types” selection is active, only the common characteristics 
are displayed in the listing.   When a particular Class is selected for display 
(such as Mod Rec), its special characteristics are displayed as shown in the 
following figure. 

 

 
 

 
Tips • To add this pane to the main window, see Display Layout (page 422). 
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Signal Database File Menu 

Signal Database File Menu 

 

 

 
 

This menu appears in the Signal Database Pane (page 107).   It allows you to 
perform file management as follows: 

 

• Load loads a previously- saved database file. This replaces the current 
contents of the database pane. See Save/Load/Merge/Export Signal 
Database (page 110). 

 

• Save allows the current database to be written to a system file. See 
Save/Load/Merge/Export Signal Database (page 110). 

 

• Merge allows you to load a previously- saved file, adding it to the current 
contents of the database.  

 

• Age displays a dialog box that allows you to enable or disable the aging of 
Signal Database entries. If aging is enabled, entries older than a specified 
age are automatically removed from the database. 

 

• Print appears in the menu if a printer is configured for the system (the 
file print exists in the e3238s directory) and the *textPrintCommand is 
given within it. 

 

• Modify Entry exists only if it has been implemented in the user- defined 
library for a given signal type.   The action it allows is defined by that 
code. 

 

• Delete Entry is used to delete the selected entry. 

• Clear is used to delete entries in the pane. 

• Statistics displays the number of entries in the Signal Database. 
 

Note Caution  -   Database  Loss 
 

This message appears when information in the Signal Database Pane may be 
lost because the user selected to exit while unsaved database data exists. 

 
Save allows you to save the information using the Save/Load/Merge/Export 
Signal Database commands. 

 
Lose means to continue the exit process without saving the signal database 
information; the contents of the current database are lost. 
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Save/Load/Merge/Export  Signal  Database 
 

Save/Load/Merge/Export Signal Database 
 

Path: Signal Database Pane, File, Load 
 

 
 

This dialog box is used to save, load, merge, or export a signal database file 
(.sdb). 

 

Save means the information is stored on the system disk in a form that can 
be reloaded. 

 

Loading a file replaces the current contents of the Signal Database Pane. 
 

Merge causes the contents of the selected file to be combined with the 
current contents of the signal database. 

 

Export causes the contents of the signal database to be saved to a file in 
comma- separated variable (csv) format.   This supports use with a spreadsheet. 

 

The Filename Dialog box shown above has the following components: 
 

1. Filename Filter text line.   Shows the current directory path and wildcard 
filter used to display the Files list (3).   See also, Filter Text Box (page 
130). 

2. Directories list.   Allows you to view directory names and define the path 
by selecting with the mouse.   See also, Directories List (page 130). 

3. Files list.   Displays the files matching the wildcard pattern in the selected 
directory.   To open one of the files, double- click it.   See also, Files List 
(page 130). 

4. Signal Type Database Selection.   This section allows you to limit the 
database entries loaded from a selected file by signal type and/or time 
range. 
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Save/Load/Merge/Export  Signal  Database 
 

5. Load Signal Database text line.   Shows the current path and filename as 
selected in the Directories and Files lists (2 & 3).   See also, Filename Text 
Box (page 132). 

 

Note Since signal types are defined and named by user- defined programs, the signal 
names that appear will vary. 

 
 

Caution -  Database Loss 
 

This message appears when information in the Signal Database Pane (page 
107) may be lost because the user elected to exit while unsaved database data 
exists. 

 

Save allows you to save the information via the Save/Load/Merge/Export 
Signal Database (page 110) dialog box. 

 

Lose means to continue the exit process without saving the signal database 
information. 
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Visual Alarms Pane 

Save/Load/Merge/Export  Signal  Database 
 

 

Visual Alarms Pane 
 
 

 
 

This pane is used to display visual alarm indicators as well as text that could 
describe the situation and give instructions as defined in the Visual Task 
(page 357) dialog box. 

 

Note You must add the Visual Alarms pane to the N6820ES window via the 
Display Layout (page 422) dialog box to be able to see them. 

 
1. This area (inside the dashed line) displays the alarm icons for the active 

alarms. 
 

2. This area displays alarm information when a triggered alarm icon is 
clicked.   The information is the alarm’s number, its name/description, and 
instruction text, if any has been defined.   See Visual Task (page 357). 
Each icon represents an alarm that has a visual “task” defined and 
selected in the Tasks section of the Single- Alarm Setup (page 338) dialog 
box. 

 

3. This icon represents a triggered alarm.   Clicking on this icon displays the 
alarm information in area #2.   It may also be set to rearm the alarm’s 
trigger.   See Visual Task (page 357). 

 

4. This icon represents an alarm that is not triggered. 
 

Note  If an alarm’s trigger type is “Once,” and the Clear Alarm parameter is set, the 
  trigger may be cleared (rearmed) by clicking the alarm’s icon in this pane. 
  See Alarm Control (page 340) and Alarm, Visual Task (page 357). 

  
 
 

Tips 

 

See also, Process Overview (page 33). 
 

• Audio alarms may also be used to sound an alert when an alarm occurs. 
See Audio Task (page 358). 

• To add this pane to the main window, see Display Layout (page 422). 

• To change the size of a pane, see Undocking and Docking Panes (page 48). 
 

• To receive help on this or any pane, click Help, On Window or press 
Shift+F1 to activate context- sensitive help and click in the pane. 
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Text Editor Pane 

Save/Load/Merge/Export  Signal  Database 
 

 

Text Editor Pane 
 
 

 
 

This pane contains a text editor.   The editor can be used to view and modify 
ASCII text files such as saved state files, log files, or search band database 
files as well as create new files such as reports. 

 

Its File Menu (page 114) button lets you open or save text files on the system 
hard disk. 

 

When a file is open in the editor, its name appears after the words Text 
Editor: centered above the text area. 

 

• To load an existing file, click Open and specify the directory and filename. 
See Filename Entry (page 140). 

 

• To add text, place the cursor anywhere in the text editor window and 
click.   Then type the new text.   Line wraps occur only where there are 
end- of- line characters (when you press Enter). 

 

• To select text: 
 

• Place the mouse cursor at one end of a segment of text, click and hold 
the left mouse button, move the cursor to the other end of the segment, 
and release the mouse button.   This action is called wiping text. 

 

• Holding down the Shift key and clicking the left mouse button selects all 
text between its present position and its previous position. 

 

• To select a word, place the cursor anywhere on it and double- click. 

• To select a line, place the cursor anywhere on it and triple- click. 
 

• To select all text in the file, place the cursor anywhere in the text area 
and click rapidly, 4 times. 

 

• To delete text: 
 

• Use the Backspace key to remove single characters on the left side of 
the cursor position. 

 

• Use the Delete key to remove single characters on the right side of the 
cursor position. 

 

• Select the text then press the Delete key. 

• To toggle between insert and overwrite modes, press the Insert key. 
 

• To move text, select it and drag it (click and hold the middle mouse 
button) to the destination, then release it. 
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Text Editor Pane 

File Menu 
 

• To copy text, select it and then press the Ctrl key and drag it (click and 
hold the middle mouse button) to the destination. 

 

• To save the text you are working on, click File, Save. 

The first time you save a new file, you must specify a name. 
 

If you specify a filename that already exists, the file will be overwritten 
with the text file.   A message appears before this happens to assure that 
it is what you want to do. 

 

• To print the file, click File, Print. 
 

• Panes are added to or removed from the main window in the Display 
Layout (page 422) dialog box. 

 

• To change the size of a pane, see Undocking and Docking Panes (page 48). 
 

• To receive help on this or any pane, click Help, On Window or press 
Shift+F1 to activate context- sensitive help and click in the pane. 

 

 

File Menu 
 

New clears a file from the text editor. 

Open allows you to select a file to edit.   See Filename Entry (page 140). 
 

Save writes a copy of the file to the disk using the same file name you 
opened it with.   Use save to update disk files that already have names.   If it 
is a new file that has not yet been named, you are prompted for the path and 
name. 

 

Save As writes a copy of the file to the disk, prompting you for a directory 
and filename.   See Filename Entry (page 140). 

 

Print causes the system line printer manager to print the text file.   The 
system printer must be properly configured and specified in the print file. 
See the example file (d.print) for further explanation. 
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Command Line Pane 
 

 

 
 

This pane allows you to control the N6820ES Signal Intercept and 
Collection Software with the commands typed in the Command Line text 
field. 

 

1. Command Line Log is a record of commands that have been issued at the 
Command Line.   This may also be saved as a file.   See Log Files (page 
139). 

 

2. Auto Scroll is a button that scrolls the text in the command line log as 
necessary so that the latest commands issued appear in the log text area. 

 

3. Command Line is the text line in which the command are typed.  You can 
type them or select them from a list in the Command Syntax dialog box. 

 

4. Command Reference. Click this button to display the Command Reference 
(page 116) dialog box. 

 

Note  Each Command Log entry requires 80 bytes of memory.   The number of 
entries in the log view is limited as defined by the 
commandLineHistoryLength resource variable in the E3238s. See also, 
Application Resources (page 17). 

  
 

When the number of log entries reaches the limit, new entries cause the oldest 
entries to be discarded/lost from memory.   To avoid losing this information, 
turn on the log- to- file feature; all entries will be written to a file on the 
system disk.   See Log Files (page 139). 

  
Tips 

 
• To add this pane to the main window, see Display Layout (page 422). 

 • To create a file containing this log, see Log Files (page 139). 
• To clear the Command Line Log, see Clear Log (page 146). 
• To receive help on this or any pane, click Help, On Window or press 

Shift+F1 to activate context- sensitive help and click in the pane. 
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Command Line Pane 

Command Reference 
 

Command Reference 
 

 

 
 

1. Search is a text line that allows you type in a string of characters and 
find the pattern in the command names.   The list is searched from 
beginning to end and stops on the first match found. Every time a change 
is made to the pattern in the text line, the search is repeated.   To search 
again for the same pattern, use the Next button. 

 

2. Next is a button that lets you find other matching patterns in the 
command names if the last command name isn’t the one you were looking 
for.   You can click it multiple times to search through the list of 
commands. 

 

3. Commands lists the commands that may be executed at the command line. 
Use the scroll bar to move up and down through the list or the 
Search/Next features above it. 

 

• When a command entry is selected, it’s syntax appears in the lower 
pane. 

 

• Double- clicking a command brings up the detailed description 
window. This is the same as clicking the Description button at the 
bottom of the window. 

 

• You can drag the commands to the command line with the middle 
mouse button. 

 

4. Syntax displays the syntax of the command selected in the Commands list. 
This gives the form(s) of the command and a description of acceptable 
parameters. 

 

5. Description displays the Command Reference Help explanation of the 
command selected in the Commands list.   A shortcut for bringing up the 
Command Reference Help for a particular command is to double- click the 
command in the Commands listing. 
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All of this information exists in the \E3238s\manuals\command_ref.pdf file. 
 

Query Dialog 
Boxes 

When the command is a query, the information requested is displayed in a 
popup dialog box as shown below for the tunerInfo? query. 
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Frequency Lists Pane 
 

 

 

This pane is used to create, display, and modify frequency lists. 

To add this pane to the application window, see Display Layout (page 422). 
 

Using Frequency 
Lists 

Frequency lists are used in a number of ways: 

• as alarm criteria (i.e., in list #1, or not in list #1) 
• as a trace grid (see Grid Type (page 429)) 

Lists can be changed by an alarm task (values added to or deleted from a list) 

Lists also can be used in user- defined programs.   So frequency list 
information could be employed as a source of information for an energy 
feature calculation or to specify energy filter activity. 

 

The three parameters that affect how frequency entries are entered and used 
are: 

 

• Resolution All entries are rounded to the nearest multiple of this value. 
 

• Merge Frequency   This provides another “resolution” parameter.   The 
combination of the Resolution and Merge settings allows a strategy where 
one parameter (Resolution) can be used as a base which is never exceeded 
and the other (Merge) can be adjusted according to need. 

 

Frequency values may be manually added/deleted in the Frequency List 
Pane or as the result of an alarm task. Any new values are rounded by 
both Resolution and the Merge frequency settings before they are entered 
in a list. 

• Compare Frequency   A value used to evaluate alarm criteria.   See (6). 

The Frequency List pane has two scrolled text areas: the list table (1) and a 
list’s contents (2). 

 

1. List Table   The left text area is a table of frequency lists.   As many as 10 
lists may be defined; but the number of frequencies within a list is 
unlimited. 

 

• A list is identified by both a number and a name or label.   See (3). 
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Command Reference 
 

• The contents of a selected list appears in the text area on the right. 
• A list may be defined by loading information from a file on the system 

disk.   Use the Load List (7) button to replace the list contents or the 
Merge List (8)   button to combine the contents of a file with the 
selected list. 

• A list’s name (3), Resolution (4), Merge Freq (5), and Compare Freq (6) 
settings are changed with the Modify list button (10). 

 

2. List Contents   This list area shows the entries of the selected list 
(highlighted) at the left. You may add or delete entries to this list with the 
buttons below it. 

 

3. Frequency List   This column identifies the frequency list by its number 
and “name.”  The name may be modified with the Modify List button.  See 
Modify Frequency List (page 122).   Since the list number is part of the 
identifier, the name need not be unique.   These identifiers appear in the 
Single- Alarm Setup (page 338) dialog box (under Description, Feature, 
Frequency) and in the Trace Setup (page 424) dialog box. 

 

4. Resolution is the spacing of the frequency values in the list.  For example, 
given a resolution of 100 Hz, valid frequency values exist only every 100 
Hz.   When other values are added to the list, they are “rounded” up or 
down  to a multiple of 100. 

 

The Resolution value may be changed by selecting a list entry and then 
clicking the Modify List button below it.   See Modify Frequency List (page 
122)). 

 

5. Merge Freq is the frequency value used to sort new (added) entries into 
valid list values. This is typically equal to or greater than the Resolution 
value. 

 

The Merge Freq value may be changed by selecting a list entry and then 
clicking the Modify List button below it.   See Modify Frequency List (page 
122)). 

 

6. Compare Freq   is used to determine whether a frequency value exists in 
the list during the process of checking alarms.   Consider this to be the 
“footprint” of the energy’s frequency for the sake of determining whether 
the alarm value exists in the list.   The comparison checks for existence of 
entries in the list freq ± compare_freq/2   where freq is the frequency of 
the  energy that caused the alarm.   The value of Compare Freq is typically 
equal  to the Merge Freq or larger. 

 

The Compare Freq value may be changed by selecting a list entry and then 
clicking the Modify List button below it. See Modify Frequency List (page 
122)). 

 

7. Load List is used to load a file containing a frequency list. When you click 
this button the Filename Entry (page 140) dialog box is displayed. 

 

When a frequency list is loaded from a file, the list’s Resolution, Merge, 
and Compare frequency settings are replaced by those in the file. 

 

8. Merge List is used to load a frequency list file, adding its contents to 
those  already in the selected list.   Clicking this button displays the Merge 
Frequency List (page 121) dialog box. 

 

When the list is merged, the Resolution, Merge, and Compare frequency 
values in the file are ignored. 
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9. Save List allows you to save the selected list as a file. When you click this 
button, the Filename Entry (page 140) dialog box is displayed. You can 
also preserve the list information by saving the current state with Save 
Mission Setup (page 129).   See the following note. 

 

10. Modify List allows you to change the name and merge value of the 
selected frequency list.  Clicking this button displays the Modify Frequency 
List (page  122) dialog box. 

 

11. Add Freqs allows you to add frequency values to the selected list. When 
you  click this button, the Add Frequencies to List (page 123) dialog box is 
displayed. 

 

12. Delete Freqs   deletes selected frequency value(s) from the list.   To do 
this: 

 

a. Select a list in the left pane.   Its entries appear in the right pane. 
 

b. Select one or more frequency value(s) that you wish to delete.   You can 
use the Shift or Ctrl buttons with the mouse button to select multiple 
entries. Shift is used to select contiguous selection and Ctrl for non- 
contiguous selection. 

 

c. Click the Delete button. 
 

Defining or 
Changing 

Frequency List 
Files 

A frequency list can be stored on the system disk. These files have a .frq 
extension and are in ASCII format. Such a file can be created or modified 
with an editor like Notepad. 

 

Each list the following attributes: 

• a name (like “List #1”) 
• a resolution value 
• a merge value 
• a compare value 
• a list of frequency values (in Hz) 

 

Note Frequency lists are part of the mission state which may be saved and recalled 
from the File Menu (page 114).   They may also be saved as individual files 
that can be recalled.   If you create frequency lists in the pane and don’t save 
the mission state or save the work in files, the frequency list information is 
lost when the program stops running. 

 
The information saved in the state file is the frequency information; not 
filenames containing the frequency lists. 
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Merge Frequency List 

Merge Frequency List 

 

 

 
 

This dialog box is used to select a file containing a frequency list to merge 
with a previously selected frequency list.   The process of selecting the file is 
the same as for any other Filename Entry (page 140) selection. 

 

The file merging process is different from other load processes, however. 
When a frequency list file is merged with one of the 10 frequency lists in the 
Frequency Lists Pane (page 118), the name and parameter information in the 
file are ignored and the frequency values are added to the selected list 
according to the Resolution and Merge Frequency rounding values that are 
active for the selected list. 

 

A frequency list file is an ASCII file containing: 

• a name (like “List #1”) 
• a resolution value 
• a merge value 
• a compare value 
• a list of frequency values (in Hz) 

 

name:Pagers 
resolution:-1 

merge:12500 
compare:-1 
929512500 

929537500 

929562500 
929612500 
929662500 
929712500 
929737500 
929862500 
929937500 
930000000 
931187500 

931212500 
 

The negative values for Resolution and Compare indicate that the Merge value 
is used for these settings. 
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Modify Frequency List 
 

Modify Frequency List 
 

 

 
 

This dialog box is used to change the Name, Merge frequency, Resolution, or 
Compare Frequency values as defined in the Frequency Lists Pane (page 118). 

 

1. Name is an identifier or short description.   It appears with the list 
number wherever frequency lists are listed (alarm criteria and trace grid). 

 

2. Merge Frequency is a rounding value used to place frequencies in a list. 
 

3. Resolution is one of two rounding values used to place frequencies in a 
list. 

 

4. Compare Frequency is used to compare values in the list to alarm 
criteria. 

 

These parameters are explained under Frequency Lists Pane (page 118). 
 

Changing 
Settings 

To display this dialog box, the Frequency Lists pane must be displayed in the 
application window.   To add it to the window, see Display Layout (page 422). 

 

1. In the Frequency Lists pane, select the frequency list entry you wish to 
modify (click on it and it becomes highlighted). 

 

2. Click the Modify List button at the bottom of the pane.   The dialog box 
shown above appears.   This dialog box was designed to make it easy to 
use the merge frequency value for both the resolution and compare 
frequency settings. 

 

3. Make the necessary changes.   To use a value other than the Merge 
Frequency value for either Resolution or Compare Frequency, click the 1- 
of- N (radio) button beside the labeled button and enter the new value in 
the Frequency Entry (page 352) dialog box. 

 

4. Click OK. 

A resolution or merge value of 0 Hz allows any frequency to be entered. 
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Add Frequencies to List 
 

When you change a list’s merge value, existing entries in the list are not 
modified to fit the multiple pattern; only new entries are constrained. 

 

 

Add Frequencies to List 
 

 

 

This dialog box is used to add frequency values to a frequency list in the 
Frequency Lists Pane (page 118). 

To add one or more frequency values to a list: 
 

1. Select the frequency list entry you wish to modify from the Frequency 
Lists Pane (page 118) (click an entry and it becomes highlighted). 

 

2. Click the Add button at the bottom of the pane (the dialog box shown 
above appears). 

 

3. Click in the text area of the dialog box and enter the new values. 

4. Click a button at the right side to select frequency units. 

5. Click OK. 
 

Note The new values must be a multiple of the merge frequency.   Values that are 
within 1/2 the merge range of an existing entry create no new entry.   Values 
more than 1/2 the merge range above or below an existing entry are entered 
at the next multiple above or below the entry.   New entries are added at the 
closest multiple of the Merge Freq. 

 
These values aren’t saved unless you save the state (see Save Mission Setup 
under The File Menu (page 125)) or save the individual list as a file. 

 

The number of entries in a frequency list is unlimited.
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The File Menu 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The File Menu contains entries having to do with system file operations as 
well as the control used to stop the execution of the program. 

 

A. Several of the entries in the File Menu have text at the right side of the 
list. These are accelerator descriptions. They allow you to activate the feature 
very quickly, using the keyboard. You can define new ones and change existing 
accelerators as described under Accelerator Keys (page 508). 

 

1. Load Mission Setup (page 127) is used to load mission states. 

2. Save Mission Setup (page 129) is used to save the current settings 
(configuration, sweep parameters, and display). 

3. Preset Mission Setup (page 134) sets the mission state to default settings. 

4. Working Directory (page 135) defines the default working directory. 

5. Snapshot Directory (page 136) defines where snapshot files are saved. 

6. Log Files (page 139) controls use of log files and their names. 

7. Print (page 141) is used to print system information. 
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8. Print To File (page 142) is used to “print” information to files on the 
system disk. 

9. Exit (page 143) stops the search receiver program. 
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Load Mission 
Setup 

 
Path: File, Load Mission 
Setup 

 

 

This dialog box is used to recall a mission setup that was saved. The above 
illustration shows the dialog box.   For detailed information, see the following 
references: 

 

1. Directories List (page 130) 

2. Don’t stop Recall if errors occur (page 132) 

3. Mission Setup Sections (page 132) 

4. Filename Text Box (page 132) 

5. Files List (page 130) 

6. Scroll Bars (page 133) 
 

Mission files are referred to as state files.   To make them easy to filter and 
list by themselves, use filenames that end with .sta. 

 

State files are ASCII text files that you can load in the text editor to view or 
modify.   See the discussion on the Text Editor Pane (page 113). 

 
 

Note A mission file may be loaded when the program starts with the - 
missionSetup command option.  See Usage under Starting the Program (page 
19). 



Save Mission Setup 
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Save Mission Setup 
 

Path: File, Save Mission Setup 

 

 
 

This dialog box is used to save the mission setup state so that you can 
recall it. The above illustration shows both the remote (Motif) and the 
Windows native versions of the dialog box.   For detailed information, 
see the following references: 

 

1. Directories List (page 130) 

2. Mission Setup Sections (page 132) 

3. Filename Text Box (page 132) 

4. Files List (page 130) 

5. Scroll Bars (page 133) 
 

Mission files are state files.   To make them easy to filter and list by 
themselves, use filenames that end with .sta. State files are ASCII text 
files that you can load in the text editor to view or modify.   See the 
discussion on the Text Editor Pane (page 113). 

 

Note To control file size, state files contain only pertinent state information.   
This can seem to cause ambiguities when recalling a state file into a 
second N6820ES system with a different configuration file, different 
options or user libraries loaded.    



Save Mission Setup 
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Don’t stop Recall if errors occur 
 

This button allows you to recall states saved with earlier versions of the 
program.   These state files have valid information but may be missing 
parameters associated with the later revision. 

 

 

Mission Setup Sections 
 

These buttons select the parts of the mission setup to be saved or loaded. 
This allows you to do things like load a different display setup without 
changing the configuration or sweep parameters. 

 

Configuration selects the hardware configuration.   See the discussion for the 
Configure menu entries Antenna Configuration (page 226), Search Receivers 
(page 227), and Handoff Receiver Configuration (page 271). 

 

Sweep Parameters selects the parameters that define the sweep configuration. 
See the discussions for Search Type (page 287), Energy Detection (page 309) 
(including threshold), Single- BW- Hint Setup (page 325), and Alarms Setup 
(page 336). 

 

Display selects the parameter values that define the display configuration, the 
log filename definitions and view states, and the definition of the working 
directory.   See the discussion for The Display Menu (page 421).   Sash 
positions are not saved. 

 

Alarms selects the settings that define the alarm states that are entered in 
Single- Alarm Setup (page 338). 

 

Freq Lists selects the frequency list information used for trace grids and 
alarm criteria.   These lists are displayed and edited in the Frequency Lists 
Pane (page 118). 

Filename Text Box 
 

The name of the file.   If you click an entry in the Files List, the selected 
filename appears here.   If you would rather type in the path name and 
filename, just click in this box and type it in.   The name should follow the 
conventions of the operating system. 

 

If no extension is appended to the end of the filename, one is automatically 
added as shown in the following table.   If you want no extension added, end 
it with a period “.”.   This period will not be a part of the filename. 
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Filename 
Extensions 

 

File Types Directory R/Wa 

Frequency Lists Working R/W .frq 

 

Typical Extensions 

Audio Alarm Task Working R .u, .al, .au, .wav, .snd, .l16, .l8, .lo8 
Visual Alarm Task Working R .pm, .bm 

Directed Search Band 
database 

Working R/W .csv 

Test Editor Working R/W .txt 

Energy History Working R/W .his 

Hardcopy    
Screen Print Working W .tif, .xwd 

Feedback Form Working W .txt 

Fallback Resources Working W .txt 

Widget Hierarchy Working W .txt 

Energy History Working W .txt 

Log Files    
Handoff Working W .hol 

Command Working W .sta 

New Energy Working W .nel 

Alarm Working W .all 

Mission Setup Working R/W .sta 

User Color Map Working R/W .ucm 

Time Snapshot Snapshot W .cap 

Frequency Snapshot Snapshot W .fss 

Environment Threshold Working R/W .thd 

Signal Database Working R/W .sdb 

Feature Studio Working R/W .fsp 

a Indicates whether the application reads and/or writes the file 
type. 

 
Scroll Bars 

 

If the list is longer than can be displayed in this list area, the vertical scroll 
bar can be used to move up and down the list. 

 

• To move down the list, click the down arrow at the right side of the list 
area. 

 

• To move down as many lines as the list holds, click in the area between 
the down arrow and the scroll bar. 

 

• You can also click the scroll bar, hold the mouse button down, and drag 
the scroll bar up or down. 

 

The horizontal scroll bar can be used in the same manner to move right and 
left if an entry is too long to display all of it.
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Preset Mission Setup 
 

Path: File, Preset Mission Setup 
 

This entry in the File menu sets the configuration, sweep setup, and display 
to the preset state. 

 

Mission files are state files.   To make them easy to filter and list by 
themselves, use filenames that end with .sta. 

 

State files are ASCII text files that you can load in the text editor to view or 
modify.   See the discussion on the Text Editor Pane (page 113). 

 

To list the default settings: 

1. Save the current state, if you want to return to it. 

2. Preset the mission state 

3. Save the mission state in a file 

4. Load the mission state file in the text editor 

5. Print it from the editor 
 

 

Verify Preset 
 

This menu appears when you select the Preset Mission Setup (page 134) entry 
in the File menu.   This two- step verification process reduces the chance of 
making an error. 

 

Yes allows the preset process to continue. 

No cancels the preset process. 
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Working Directory 

Verify Preset 
 

 

Working Directory 
 

Path: File, Working Directory 
 

This dialog box allows you to change the working directory.   The mechanism 
is explained under Filename Entry (page 140). 

 

The working directory is the directory that you want to do most of your file 
work in.  This applies to saving or loading mission setups and text files that 
are loaded and saved from the text editor.  It is highly recommended to 
establish a working directory outside of the C:/E3238s directory.  For example, 
create a folder C:/Working and copy the .cfg and .sta files from the 
C:/E3238s/N684x_RF_Sensor into the new folder.  Next copy the Program 
shortcut into the Working folder.  Modify the shortcut properties to start in the 
Working folder and alter the Target line to use the .cfg and ,sta files in that same 
folder.  Modify the Shortcut name to personalize it.  After completing this 
process, you should be able to launch the Surveyor 4D application from the 
Working directory.  This is very useful for backing up your setups, program files 
and for moving the setup to another PC.  

 

The definition of the working directory is saved as part of the mission setup. 
See Save Mission Setup (page 129). 

 

If Working Directory is ghosted in the File menu, see Menu/Toolbars (page 
488). 

 

 

Snapshot Directory 
 

Path: File, Snapshot Directory 

 

 
 

This dialog box allows you to specify the directory in which snapshot files are 
saved. By default this directory is C:\snapshot. See Filename Entry (page 
140).  At startup, the N6820ES working directory is set to the current 
working directory.   The snapshot directory is used to store snapshot files.  



Snapshot Directory 

Verify Preset 
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Log Files 
 

Path: File, Log Files 

 

 
 

This dialog box is used to control whether log information is written to files 
on the system disk and, if so, specify their filenames. 

 

If the Log Files entry in the File menu is ghosted (inactive), see the 
discussion under Menu/Toolbars (page 488). 

 

1. Status:   These buttons are toggle buttons that change status when clicked. 
 

Active means that the log information is recorded in a file.   The location 
and file name is defined with the Filename button. 

 

Inactive means that the log information is not recorded in a file. 
 

2. Filename:   The buttons in this column display the current name of the 
associated log file.   Clicking it displays the dialog box used to change the 
filename.   To change the name of the log file, see Filename Entry (page 
140). 

 

If the specified filename already exists, new entries are appended at the 
end of the file. 

 

• OK makes the specified changes and closes the dialog box. 

• Apply makes the specified changes and leaves the dialog box open. 

• Cancel closes the dialog box; no changes are applied. 
 

See Also To clear the log file, see Edit, Clear Log File (page 147). 





 

 

Log Files 

Filename Entry 
 

Filename Entry 
 

 
 

This dialog box appears whenever you need to specify the name of a file on 
the system disk.   The example above shows the Handoff Log File version of 
this dialog box. Note that Windows © treats the *.hol extension as an Outlook file. 

 

For detailed information, see the following: 

1. Directories List (page 130) 

2. Filename Text Box (page 132) 

3. Files List (page 130) 

4. Scroll Bars (page 133) 
 

Tips • To limit the file names that appear in Files List (page 130), enter a 
wildcard pattern in the Filter Text Box (page 130) text line. 

 

• To change directories, double- click an entry in the Directories List (page 
130).   The entry ending in /.. represents moving up one level in the 
directory hierarchy (toward the root directory). 

 

• To select an existing file, double- click it from Files List (page 130). 
 

• To specify a filename, type it in the Filename Text Box (page 132) text 
line. 

 

• To abandon this process without making changes, click Cancel. 



 

 

Print 

Filename Entry 
 

 

Print 
 

Path: File, Print 
 

 
 

 This entry displays print options for application- related files. 

Note  A system printer must be configured before using these entries. See the 
d.print file for more information. 

  
Screen 

 
Prints the contents of the screen to the system printer. 

• To print the screen to a file, see Print To File (page 142). 

• To set up a printer, see Hardware Configuration (page 16). 
 

Widget 
Hierarchy 

Creates the widget hierarchy information to support modifying the Motif 
resources defined in the E3238s file.   See Application Resources (page 17). 

 

Energy History Prints the signal data currently in the Energy History Pane (page 88). If no 
signals have been detected, only the heading prints. 

 

For an overview, see Process Overview (page 33). 
 

Printing other 
things 

• To print the handoff log or command line log, load the file into the Text 
Editor Pane (page 113) and print from there. These log files are created 
by changing their status to active.   See File, Log Files (page 139). 

 

• See Printing the Directed Search Band Table (page 308). 

• To print help information, see The Help Menu (page 505). 
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Print To File 

Filename Entry 
 

 

Print To File 
 

Path: File, Print to File 
 

 
 

The entries in this menu allow you to print to a file. 
 

Screen Prints the screen to a file in either TIFF or XWD graphic format. The graphic 
format selection is specified in the d.print file.   See this file for more 
information. 

 

To print a screen file in Windows, double click the file then print using the 
displayed graphics program. 

 

Fallback 
Resources 

Fallback resources are the resources active when no resource file is present. 
The initial resource file should be created from these fallback resources so 
that the default behavior of other areas of the user interface are not lost.  See 
Application Resources (page 17). 

 

Widget 
Hierarchy 

Creates the widget hierarchy information to support modifying the Motif 
resources defined in the E3238s file.   See Application Resources (page 17). 

 

When this entry is selected from the menu, the Filename Entry (page 140) 
dialog box appears, which lets you specify the directory and filename for the 
print file. 

 

Energy History Prints the signal data currently in the Energy History Pane (page 88). If no 
entries exist, only the heading is printed. 

 

When this entry is selected from the menu, the Filename Entry (page 140) 
dialog box appears, which lets you specify the directory and filename for the 
print file. 

 

To create a file more compatible with spreadsheet programs, use the Save 
button in the Energy History Pane (page 88). 

 

For an overview of the detection/alarm system, see Process Overview (page 
33). 
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Exit 

Filename Entry 
 

 

Exit 
 

Path: File, Exit 

Clicking this menu entry stops the program. 
 

If there any open, unsaved files, you are prompted to save them before the 
program stop.
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The Edit Menu 
 
 
 
 
 
 
 

 

 
 

This menu contains entries used to clear various parts of the system, as 
described below. 

 

1. Clear Log displays a menu listing of the logs.   See Clear Log (page 146). 
 

2. Clear Log File displays a menu listing of the log files.   See Clear Log File 
(page 147). 

 

3. Clear Energy History is used to clear the signal statistics displayed in the 
Energy History Pane (page 88).   See Clear Energy History (page 148). 

 

4. Clear Signal Database is used to clear the signal  See Clear Signal 
Database Menu (page 149). 

 

5. Clear Frequency Lists is used to clear the frequency values in all loaded 
frequency lists.   See Clear Frequency Lists (page 150). 

 

6. Clear Audio Output is used to clear (stop) the audible alarms.   See Clear 
Audio Output (page 151). 

 

7. Clear All clears everything listed in the Edit menu.   See Clear All (page 
152). 

 
Tips Entries in this menu may appear ghosted (inactive).   This occurs when it is 

locked out by the Menu/Toolbars (page 488) and when there is no log 
information to clear. 
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Clear Log 

Verify Clear Log 
 

 

Clear Log 
 
 

 
 

Clicking “Clear Log” in The Edit Menu (page 145) displays a menu of system 
logs plus an “All Logs” entry. Click the name of the log you wish to clear and 
then click “yes” to verify your selection. Before a log is cleared, the request is 
verified with Verify Clear Log. This two- step process reduces the chance of 
accidentally deleting data. 

 
Log Descriptions • Handoff Log Pane (page 75) 

• Command Line Pane (page 115) 
• New Energy Log Pane (page 86) 
• Alarm Log Pane (page 87) 

 
Tips • If the Clear Log entry is ghosted (inactive), see Menu/Toolbars (page 488). 

 

• The logs are displayed by adding their pane to the application window.  To 
add a pane to the N6820ES Main Window (page 45), see Display Layout 
(page 422). 

 

 

Verify Clear Log 
 

 

 
 

This message is displayed to verify that you intend to clear (delete) the 
selected log view.  If you click “yes” the information in the log pane is cleared. 

 

This has no effect on the file version of the log, if it is active. 
 

Note Clearing the handoff log aborts all Pending entries.   See Handoff Log Pane 
(page 75). 
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Clear Log File 

Clear Log File Verification 
 

 

Clear Log File 
 
 

 

This entry in The Edit Menu (page 145) is used to clear one or all of the 
system log files.   Before the file is cleared, the request is verified with the 
Clear Log File Verification (page 147).   This two- step process reduces the 
chance of accidentally losing data. 

 
Log Descriptions • Handoff Log Pane (page 75) 

• Command Line Pane (page 115) 
• New Energy Log Pane (page 86) 
• Alarm Log Pane (page 87) 

 
Tips • If the Clear Log File entry in the Edit menu is ghosted (inactive), see the 

discussion under Menu/Toolbars (page 488). 
 

• To add a log pane to the display, see Display Layout (page 422). 
 

• To create a log file or find the filename being used, see Log Files (page 
139). 

 

 

Clear Log File Verification 
 

 
 

This message is displayed to verify that you intend to clear (delete) the log 
file.   If you click the yes entry, the information in the file is cleared. 
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Clear Energy History 

Verify Clear Energy History 
 

 

Clear Energy History 
 

This entry in The Edit Menu (page 145) clears the signal data kept in the 
Energy History Pane (page 88).   Before the data is cleared, the request is 
verified with Verify Clear Energy History.   This two- step process reduces the 
chance of accidentally losing data. 

 
Tips • If the Clear Energy History entry in the Edit menu is ghosted (inactive), 

see the discussion under Menu/Toolbars (page 488). 
 

• To add the Energy History pane to the display, see Display Layout (page 
422). 

 

 

Verify Clear Energy History 
 

 

 
 

This message is displayed to verify that you intend to clear (delete) the 
information in the Energy History pane.   If you click “yes” the information in 
the pane is cleared. 

 

Note Clearing the Energy History may trigger new alarms.   When an active alarm’s 
trigger type is “New Energy” and a detected signal meets all other alarm 
criteria, an alarm is launched if no entry exists in the Energy History for a 
signal at that frequency.   See Signal Type in Definition (page 342). 

 
Clearing the Energy History may affect active alarms whose definition depend 
history data.   For an overview of the alarm process, see Process Overview 
(page 33). 
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Clear Signal Database Menu 

Verify Clear Signal Database 
 

 

Clear Signal Database Menu 
 

This entry in The Edit Menu (page 145) clears the entries in the Signal 
Database Pane (page 107).   Before the data is cleared, the request is verified 
with the Verify Clear Signal Database (page 149).   This two- step process 
reduces the chance of accidentally losing data. 

 
Tips • If the Clear Signal Database entry in the Edit menu is ghosted (inactive), 

see the discussion under Menu/Toolbars (page 488). 
 

• To add the Signal Database pane to the display, see Display Layout (page 
422). 

 

 

Verify Clear Signal Database 
 

 
 

This message is displayed to verify that you intend to clear (delete) the 
information in the Signal Database pane.  If you click “yes” the information in 
the pane is cleared. 

 

Note                        Clearing the Signal Database may affect active alarms whose definition depend 
on database information. For an overview of the alarm process, see Process 
Overview (page 33). 
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Clear Frequency Lists 

Verify Clear All Frequency Lists 
 

 

Clear Frequency Lists 
 

This entry in The Edit Menu (page 145) clears the entries in the Frequency 
Lists Pane (page 118).   Before the data is cleared, the request is verified with 
the Verify Clear All Frequency Lists (page 150).   This two- step process 
reduces the chance of accidentally losing data. 

 
Tips • If the Clear Frequency Lists entry in the Edit menu is ghosted (inactive), 

see the discussion under Menu/Toolbars (page 488). 
 

• To add the Frequency Lists pane to the display, see Display Layout (page 
422). 

 

 

Verify Clear All Frequency Lists 
 

 

 
 

This message is displayed to verify that you intend to clear (delete) the 
information in the frequency lists.   If you click “yes” the information in the 
lists is cleared. 

 

Note Clearing the Frequency Lists may affect active alarms whose definition depend 
on the frequency values.   For an overview of the alarm process, see Process 
Overview (page 33). 
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Clear Audio Output 

Verify Clear Audio Output 
 

 

Clear Audio Output 
 

This entry in The Edit Menu (page 145) clears the queue of audible alarms as 
defined in the Single- Alarm Setup (page 338) dialog box.   Before the data is 
cleared, the request is verified with the Verify Clear Audio Output (page 151). 
This two- step process reduces the chance of accidentally losing data. 

 
Tips If the Clear Audio Output entry in the Edit menu is ghosted (inactive), see the 

discussion under Menu/Toolbars (page 488). 
 

 

Verify Clear Audio Output 
 

 

 
 

This message is displayed to verify that you intend to clear (delete) the queue 
of audible alarms.   If you click “yes” the queue is cleared and no audible 
alarms currently waiting are sounded. 
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Clear All 

Verify Clear All 
 

 

Clear All 
 

This entry in The Edit Menu (page 145) clears all   the items listed in the 
menu, including logs, log files, Energy History, Signal Database, Frequency 
Lists, and Audio Output (alarm sounds).   Before the data is cleared, the 
request is verified with the Verify Clear All (page 152).  This two- step process 
reduces the chance of accidentally losing data. 

 

 

Verify Clear All 
 

 
 

This message is displayed to verify that you intend to clear (delete) all logs, 
all log files, the Energy History data, and the audible alarm queue.   If you 
click “yes” these are cleared. 

 

Note Clearing the handoff log aborts all Pending entries.   See Handoff Log Pane 
(page 75). 

 
Clearing the Energy History may trigger new alarms.   When an active alarm’s 
trigger type is “New Energy” and a detected signal meets all other alarm 
criteria, an alarm is launched if no entry exists in the Energy History for a 
signal at that frequency.   See Signal Type in Definition (page 342). 

 
Clearing the Energy History may also affect active energy alarms whose 
definition depend on history data.   For an overview of the alarm process, see 
Process Overview (page 33). 

 
Clearing the Signal Database may affect active alarms whose definition depend 
on database information.   For an overview of the alarm process, see Process 
Overview (page 33). 

 
Clearing the Frequency Lists may affect active signal alarms whose definition 
depend on the frequency values.   For an overview of the alarm process, see 
Process Overview (page 33). 
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The View Menu 
 
 
 
 

 
 

The View menu contains entries used to add or remove panes from the main 
application window’s GUI. This is a tear- off menu. Clicking the top of the 
menu places the menu into its own window so that it does not disappear after 
a selection. 

 

Access to any of the Panes can be enabled/disabled from the Utilities > 
Menu/Toolbars. 

 

When enabled, Panes can be added to the main GUI when they are selected 
from the pull- down View menu. Panes are added to the bottom of the current 
GUI when they are selected. Panes that are active are marked in the menu by 
a check mark to the left of the menu entry. 

 

All of the trace Panes and the Energy History pane can be undocked from the 
main GUI by selecting their docking icon located at the top- left corner of their 
individual trace pane. 

 

The following panes may be added to or removed from the main GUI through the View 
pull-down menu: 

 

• Trace Pane (page 52) (A, B, C, D) can be selected. Trace Panes display sweep data as 
spectrum, spectrogram, color spectrogram, color directogram, direction, color direction, 
DF specrogram (with option WDF), or polar. 

 

• View > Handoff Receivers Pane (page 161) contains a listing which 
provides control and status of all installed handoff receivers. 
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• View > Handoff Log Pane (page 166) displays the log of handoff receiver 
activity. 

 

• View > Text Editor Pane (page 175) opens a text editor that can be used 
to view and modify ASCII text files such as saved state files, log files, or 
search band database files as well as create new files such as reports. Its 
File Pull- Down Menu allows opening and saving text files on the system 
hard disk and printing to the system printer. 

 

• View > Command Line Pane (page 177) on page 148 allows commands to 
be executed at the Command Line entry field and display a log of the 
commands that have been issued. This log of the commands may be saved 
as a file. 

 

• View > Toolbar (page 180) consists of three groups of icons that enable 
quick access to the features found in the Configure, Search, and Display 
pull- down menus. 

 

• View > New Energy Log Pane (page 182) lists peaks of new energy the 
first time that they appear and keeps a running count of the total number 
of entries in the log. 

 

• View > Alarm Log Pane (page 183) on page 156 lists all the alarms that 
have occurred. 

 

• View > Energy History Pane (page 184) displays as many as eight of the 
energy features that are tracked for each detected energy. 

 

• View > Signal Database Pane (page 212) displays the results of signal 
processing. 

 

• View > Visual Alarms Pane (page 216) displays images and instructions for 
alarms. 

 

• View > Frequency Lists Pane (page 217) on page 196 is used to view, 
create, and modify lists of frequencies for trace grids and alarm criteria. 

 

• The User-Defined Pane is part of the Agilent 35688E Option ASD,  Host User 
Programming Libraries and Documentation. The contents of this pane can be defined by 
a user-written program. See Agilent N6820ES Option ASD Programming Guide*. 
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Trace (A, B, C, and D)  

 

 
 
 

Trace (A, B, C, and D) 
 

Trace Panes display sweep data. They can display that data as spectrum, spectrogram, color 

spectrogram. 
 

Each trace pane displayed on the main screen has an undocking icon in its 
upper left- hand corner, next to the trace identifier. Clicking this icon 
undocks the trace pane and displays it in a separate window. Clicking the 
icon on an undocked trace window closes that window and places the 
trace pane back into the N6820ES main window. 

 

When a trace pane is displayed in a separate window, it has a menu bar 
added to the window. These trace pane menus provide the trace functions 
and operations that were available in the main window’s menus and in the 
Trace Setup (page 424) dialog box. 

The Trace Pane menus are: 

• Trace File Menu (page 156) 

• Trace View Menu (page 156) 

• Trace Scale Menu (page 157) 

• Trace Marker Menu (page 158) 

• Trace Snapshot menu (page 158) 

• Trace Handoff Menu (page 159) 
 

If the corresponding options are installed, the following menus are 
available from the trace screen: 

 

• Trace ModRec Menu (page 160) 
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Trace (A, B, C, and D)  

 

Trace File Menu 
 

Trace File Menu 
 

 
 

 
 

The Trace File menu has the following selections when the pane is undocked: 

Print This selection prints the current trace window. 
 

Print to File... This selection saves the current trace window to a TIFF 
graphics file with a format and a file extension of .tif. 

 

Close This selection closes the current trace window. 
 
 
 

Trace View Menu 
 

 

 
 

The Trace View menu has the following selections: 
 

Trace Type   This selection controls how information is displayed. See Trace 
Type. 

 

Threshold This selection controls how the energy threshold is presented. See 
Threshold Presentation. 
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Trace (A, B, C, and D)  

 

Trace Scale Menu 
 

Grid Type This selection the line pattern in the trace area background. See 
Grid Type. 

 

Grid Frequency List This selection allows you to select one of the defined 
frequency lists as a grid. SeeGrid Frequency List. 

 

Color Map This selection allows you to choose from a selection of several 
color maps. Color maps can be edited using the Color Map Setup. See User 
Color Map Setup. 

 

Color Map Size This selection allows you to choose the size of the color map 
used in the trace display. See User Color Map Setup. 

 

Setup   This selection displays the Trace Setup Dialog Box. See Trace Setup. 
 

 

Trace Scale Menu 
 

 

 

The Trace Scale menu has the following selections: 
 

Tune to Trace This selection changes the start and stop frequency of the 
sweep. If the trace span is not the same as the span of the search receiver, as 
defined in the Search, Setup dialog box, Tune to Trace changes the start and 
stop frequencies in the sweep setup to match the start and stop frequencies 
of the trace. This gives you the highest update rate (shortest revisit time) very 
quickly. 

 

X Autoscale  This selection sets the minimum and maximum amplitude values 
so that all of the trace is displayed. 

 

Y Autoscale   This selection sets the trace's frequency scale to match that of 
the measurement hardware. 

 

Band   This selection displays the Frequency Band Scale. This menu selection 
appears when the Search Type is set to Directed. See Frequency Band Scale. 

 

Setup   This selection displays the Trace Scaling dialog box. 
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Trace (A, B, C, and D)  

 

Trace Marker Menu 
 

Trace Marker Menu 
 
 

 

The Trace Marker menu has the following selections: 

Marker   This selection allows you to turn the trace marker on and off. See 
Marker On/Off. 

 

Bandwidth   This selection allows you to specify bandwidth markers around 
the trace’s marker. 

 

Link   The menu selection allows you to link the marker in this trace to 
markers in another trace. 

 

To Peak   This selection moves the marker to the peak having the largest 
amplitude on the trace. 

 

Next Peak Left This menu selection moves the marker to the next peak left 
of the current position. A "peak" is a local maxima more than approximately 6 
dB above the computed noise floor of the display spectrum. 

 

Next Peak Right   This menu selection moves the marker to the next peak 
right of the current position. A "peak" is a local maxima more than 
approximately 6 dB above the computed noise floor of the display spectrum. 

 

Marker To...   This selection allows you to send the trace marker to specific 
locations. These locations include the sweep’s center frequency, start 
frequency, stop frequency, and a reference level. 

 
 
 
 
 

Trace Snapshot menu 
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Trace (A, B, C, and D)  

 

Trace Handoff Menu 
 
 
 

 
 

The Trace Snapshot menu has the following selections: 
 

Do Snapshot This menu selection collects a data record and stores it on the 
system disk. The data may be either time domain or frequency (or both). 

 

When this menu selection is unavailable it indicates that no snapshot is active 
for the trace. No snapshot data is collected until a snapshot setup is made 
active. 

 

Setup...   The menu selection displays the Trace Snapshot Setup dialog box. 
 
 

 
Trace Handoff Menu 

 

 

 
 

The Trace Handoff menu has the following selections: 

Do Handoff   This selection initiates a handoff of a current signal. 

Link   This selection lets you specify the receiver link for the handoff. 

Setup... This selection displays the Trace Handoff Setup dialog Box 

 
 
 

Trace DF Menu 
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The DF menu has the following selections: 

Do DF   This selection initiates a DF measurement of a current signal. 
 

Setup... This selection displays the Trace Direction Finding Link Setup dialog 
Box 

 
 

 
Trace ModRec Menu 

 

 

 
 

The Trace ModRec menu has the following selections: 
 

Do ModRec  This selection initiates a Modulation Recognition operation of the 
current signal. 

 

Link   This selection lets you specify the ModRec link for the handoff. 
 

Setup... This selection displays the Trace Modulation Recognition Link Setup 
dialog Box 
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View > Handoff Receivers Pane  

 

Handoff Receivers Queue 
 

 

View > Handoff Receivers Pane 
 

Path: View,   Handoff Receivers 
 
 

 
 

The handoff receivers pane provides control and status of all installed handoff receivers. 
 

Note The “View > Handoff Receivers Pane" on page 128 is available only when one 
or more handoff receivers are defined in the configuration file. 

 
 

Handoff Receivers Queue 
 

All handoff receiver assignments go through a queue. When there are more handoffs than 
installed receivers, the handoffs accumulate in the queue. They are assigned from the 
queue based on priority and order of handoff. This is tracked and indicated in the “View 
> Handoff Log Pane" on page 134. 

 

If your system has the Agilent 35688E Option AU1, Audio Output - AM/FM Handoff 
Receiver Driver installed, see “Handoff Receivers Option AU1 Audio Output Controls" 
on page 132. 

 

 

Handoff Receivers Pane Headings 
 

To change the following settings available from the “View > Handoff Receivers Pane, 
see “Handoff Receivers Settings and Making Changes" on page 130 and “Configure > 
Handoff Receivers" on page 250. 

 

Rx (receiver) is the receiver number as defined in the configuration file. There may be as 
many as 100 handoff receivers installed. 

 

Status indicates what activity the receiver is performing: 
 

• Waiting indicates that the receiver is available to service the next signal handed off 
(assuming its frequency is within the receiver’s range). 

 

• Active indicates that the receiver is busy monitoring a signal. An active signal can be 
released by clicking the word Active with the mouse. 

 

• Manual indicates that the receiver has been taken out of the receiver pool and is not 
available for signal assignment. 

 

• Offline indicates that the receiver is present, but is unavailable for use. This usually 
indicates that, for Audio Output Receiver (Option AU1), the tuner is not locked. 

 

To lock the tuner, select Search > Type > Lock Tuner (Tuner Sweep Control). 
 

Priority indicates a signal’s importance relative to other signals. See “Handoff Log 
Priority" on page 138. 
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View > Handoff Receivers Pane  

 

Handoff Receivers Pane Headings 
 

Elapsed indicates the time (in seconds) that the receiver has been monitoring this 
frequency. When the value reaches the value in the Duration column, the receiver is 
given another frequency assignment (if there is another one in the queue that it is capable 
of servicing) or changes status to Waiting. If a handoff with a higher priority enters the 
queue and bumps an assigned handoff from a receiver, that handoff’s elapsed time will 
not reach the duration value. 

 

Duration is the time (in seconds) that the signal was initially set to be monitored. 
 

Frequency is the frequency to which the receiver is tuned. 
 

Bandwidth is the bandwidth setting for the receiver. 
 

Det indicates the detection type used by the handoff receiver. 

AGC indicates the automatic gain control setting of the handoff receiver, if applicable. 

BFO indicates the beat frequency oscillator setting of the handoff receiver, if applicable. 

Squelch indicates the squelch control setting of the handoff receiver, if applicable. 

Audio is used when Option AU1 receivers are used. See “Handoff Receivers Option 
AU1 Audio Output Controls" on page 132. 

 

Comment is a short (15-character) text field you can include to convey more 
information. This and other fields are recorded in the “View > Handoff Log Pane" on 
page 134. 

 

Note                   Changing the Duration or Priority values can have the same effect as trying to Release an 
active signal. If the handoff receiver is not configured to allow you to release a signal, try 
reducing either of these settings. 

 
 

Handoff Receivers Settings and Making Changes 
 

Initial Configuration 
 

The settings in “Configure > Handoff Receivers" on page 250 determine whether an 
operator can release a handoff receiver or change any of the values. When the Releasable 
setting is “No,” clicking an Active status does not call the Release feature. When the 
Interactive setting is “No,” none of the other settings can be changed in the “View > 
Handoff Receivers Pane" on page 128. 

 
Changing Handoff Receivers Settings with the Left Mouse Button 

 

When you click on a field in the “View > Handoff Receivers Pane" on page 128 that can 
be modified, a control box appears at the right end of the pane as shown. 

View > Handoff Receivers Pane (Changing with Left Button) 

 
 

The controls vary depending on the field selected. 
 

• Status (if Active) has the single button “Release Handoff.” 
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View > Handoff Receivers Pane  

 

Handoff Receivers Pane Headings 
 

• Priority is a list of the four priority values. 

• Elapsed cannot be changed. 

• Duration is a text entry line on which you can enter any value. 

• Frequency (shown above) is a text line entry. 

• Bandwidth is a selection from a list. 

• Det is a selection from a list. 
 

• AGC is an On/Off toggle where On indicates that the gain selection is automatic. If AGC 
is Off, you set the gain with a slide control. 

 

• BFO is a text line entry in which you can enter any value. 
 

• Squelch indicates the squelch control setting of the handoff receiver, if applicable. This 
value can be changed with the mouse buttons. 

 

• Audio See “Handoff Receivers Option AU1 Audio Output Controls" on page 132. 
 

• Comment is a text line in which you can enter or modify a comment up to 15 characters 
in length. 

 

To turn off the dialog box at the right side of the pane, click the same field again or click 
a field that cannot be changed. 

 
Changing Handoff Receivers Settings with the Right Mouse Button 

 

When you click on a field in the “View > Handoff Receivers Pane that can be modified, a 
drop-down list is displayed by the mouse pointer, as shown. 

View > Handoff Receivers Pane (Changing with Right Button) 
 

 
 

The menu varies depending on the field selected. Note that “Frequency” must be 
changed with the left mouse button, since it is a text field. 

 

Handoff Receivers Pane Drop Site 
 

This help information appears when the help key (F1) is pressed while using the mouse 
to drag a signal from a trace to a handoff receiver. 

 

• To complete the handoff, release the mouse button in the control box of 
the handoff receiver that is to handle it. 

 

• To abort the handoff, press the ESC key. 

• To complete the current handoff, click OK. 

• To cancel the current handoff, click Cancel. 
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View > Handoff Receivers Pane  

 

 

Handoff Receiver Audio Output Controls 
 

When an Agilent AM/FM Handoff Receiver Driver is installed, the handoff receivers 
have the following controls. 

 
 

1. Mute Clicking this button mutes the audio output and disables all other 
controls in this pane. 

 

2. Volume Clicking and dragging the marker in this box raises or lowers the 
audio volume level. The solid bar indicates the current volume level. 

 

3. Left/Right   These buttons control the audio output from the two available 
audio output channels. By default both audio channels are enabled. This 
control allows a user to listen to two channels at once. when two are 
installed. 

 

4. Low Pass/High Pass Clicking the left box adds a high- pass filter to the 
audio output. The High Pass filter can be used to eliminate CTCSS tones. 
Clicking the right of these two boxes adds a low- pass filter to the audio 
output. The Low Pass filter can be used to reduce noise in the audio 
output. 

 

5. Record Clicking this button directs the software to begin saving the audio 
signal in a file in the snapshot directory. 

 

6. Record Time   This readout displays the length of time that the current 
audio recording session has been running. Audio Output records up to 10 
seconds of data that occurred before the “Record” button was clicked. This 
enables you to record the segment of the signal that caused you to record 
it. 
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View > Handoff Receivers Pane  

 

Handoff Receivers Option AU1 Audio Output Controls 
 

Tip If the frequency or detection type of a signal are not supported by any 
installed handoff receivers, the status is changed to “Handoff Log Status: 
Unable." 

 
If frequency or detection type limit the signal’s handoff to a receiver that is 
installed, but not available (for example, it is out of the receiver pool or 
assigned to a higher priority signal), the status will continue to be “Handoff 
Log Status: Pending until that receiver is available. See Rx Pool under 
“Configure > Handoff Receivers" on page 250. 

 
Handoff Log Status: Active An active signal is one that has been assigned 
and is being monitored by the handoff receiver identified in the Rx# column. 
The time that is was assigned is recorded in the Granted column. When the 
amount of time specified by duration has past, the status changes to “Handoff 
Log Status: Released. 

 

You may change the frequency, priority, detection, or duration settings, add 
comments, or release the signal before the duration setting releases it 
automatically in the “View > Handoff Receivers Pane" on page 128. 

 

An active signal is flagged in a trace pane with text describing the handoff 
receiver monitoring it when the trace grid type is Handoffs and the Active 
signal frequency is within the span of the trace, as shown below. A trace’s 
grid type is selected in “Display > Trace (Setup)" on page 515. 

 

Handoff Log Status: Completed: A completed signal was released at the time 
listed in the Released column. Completed signals may be handed off again; see 
“Handoff Log Popup Menu" on page 143. 

 

Handoff Log Status: Bumped: A bumped signal was released before the 
duration time setting expired because another signal with a higher priority 
was handed off and all other handoff receivers were assigned to equal or 
higher- priority signals. 

 

Handoff Log Status: Released A released signal means that the operator 
marked it and clicked the Release button while it was pending. If the number 
in the Rx column is 0, the signal was never assigned to a receiver. 

 

Handoff Log Status: Unable An unable signal means that either the frequency 
of the signal is outside the range of all installed handoff receivers or the 
detection type is not supported by any of the installed receivers. 

 

Tip To handoff a logged signal that was released, click it with the middle mouse 
button and drag it to the Handoff Receivers Pane. 

 
To handoff more than one signal entry, select them by clicking them with the 
left mouse button. To select contiguous entries, click and drag or hold the 
Shift key when you click the entry at the end of the selection. To select 
individual entries, hold the Ctrl key when you click them. 
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View > Handoff Log Pane 

Handoff Log Status 

 

 

 

 

View > Handoff Log Pane 
 

 
 
 

 
 

Handoff Log displays the log of handoff receiver activity. 
 

Handoff Log: Pending shows the number of signals handed off, but not yet assigned to 
a receiver. It is a count of the number of entries whose status is pending. 

 

Handoff Log: Auto Scroll Checkbox keeps the latest log entries log visible by 
scrolling as new entries appear. 

 

Handoff receivers must be described in the configuration file and configured before they 
can be used. See “Review Hardware Configuration" on page 17 

 

The definition of energy that is automatically detected and handed off are discussed in 
“Search > Detection Setup (Threshold, Energy, Direction)" on page 333. 

 

Signals may also be handed off from a trace pane. See “Display > Trace (Setup)" on page 
515. To control handoff directly, see “Configure > Handoff Receivers" on page 250. 

 

The Handoff Log may be recorded as a file. See “File > Log Files" on page 105. 
 

To release pending signals, clear the log view entries with “Edit > Clear Log" on page 
112 or mark the ones to release with the left mouse button and then click the right mouse 
button to get the “Handoff Log Popup Menu" on page 143. 

 

Note Each handoff log entry requires 160 bytes of memory. The number of entries 
in the handoff log view is limited as defined by the handoffLogViewLength 
resource variable in the E3238s. See “Application Resources" on page 19. 

 
When the number of log entries reaches the limit, new entries cause the oldest 
completed entries to be discarded/lost from memory. Pending entries are not 
discarded. If the queue is full of pending entries, the new ones are discarded. 

 

The handoff log file is not affected by this limit. 
 
 

Handoff Log Status 
 

Handoff Log Status can be one of the following: 

• “Handoff Log Status: Pending" on page 135 

• “Handoff Log Status: Active" on page 136 

• “Handoff Log Status: Completed" on page 136 

• “Handoff Log Status: Bumped" on page 136 

• “Handoff Log Status: Released" on page 136 

• “Handoff Log Status: Unable" on page 136 
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View > Handoff Log Pane 

Handoff Log Status 

 

 

 

Handoff Log Status: Pending 
 

A pending signal has been handed off (put in the handoff queue), but has not 
yet been assigned to a handoff receiver. You can change some settings of a 
Pending signal. 

 

To change an entry’s priority, detection, or duration: 
 

1. Position the mouse cursor anywhere in the line of the entry you wish to 
change. 

 

2. Click the right mouse button. 
 

3. Select multiple lines by holding the button down and dragging the cursor 
up or down. When the button is released, a popup menu appears. 

 

4. Select the appropriate parameter. 

5. Select the new setting. 
 

Note If the frequency or detection type of a signal are not supported by any 
installed handoff receivers, the status is changed to “Handoff Log Status: 
Unable. 

 
If frequency or detection type limit the signal’s handoff to a receiver that is 
installed, but not available (for example, it is out of the receiver pool or 
assigned to a higher priority signal), the status will continue to be “Handoff 
Log Status: Pending until that receiver is available. See Rx Pool under 
“Configure > Handoff Receivers" on page 250. 

 
 

Handoff Log Status: Active 
 

An active signal is one that has been assigned and is being monitored by the 
handoff receiver identified in the Rx# column. The time that is was assigned 
is recorded in the Granted column. When the amount of time specified by 
duration has past, the status changes to “Handoff Log Status: Released. 

 

You may change the frequency, priority, detection, or duration settings, add 
comments, or release the signal before the duration setting releases it 
automatically in the “View > Handoff Receivers Pane" on page 128. 

 

An active signal is flagged in a trace pane with text describing the handoff 
receiver monitoring it when the trace grid type is Handoffs and the Active 
signal frequency is within the span of the trace, as shown below. A trace’s 
grid type is selected in “Display > Trace (Setup)" on page 515. 
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View > Handoff Log Pane 

Handoff Log Status 

 

 

 

Handoff Log Status: Completed A completed signal was released at the time listed in 
the Released column. Completed signals may be handed off again; see “Handoff Log 
Popup Menu" on page 143. 

 

Handoff Log Status: Bumped A bumped signal was released before the duration time 
setting expired because another signal with a higher priority was handed off and all other 
handoff receivers were assigned to equal or higher-priority signals. 

 

Handoff Log Status: Released A released signal means that the operator marked it and 
clicked the Release button while it was pending. If the number in the Rx column is 0, the 
signal was never assigned to a receiver. 

 

Handoff Log Status: Unable An unable signal means that either the frequency of the 
signal is outside the range of all installed handoff receivers or the detection type is not 
supported by any of the installed receivers. 

 

 
Tip To handoff a logged signal that was released, click it with the middle mouse 

button and drag it to the Handoff Receivers Pane. 
 

To handoff more than one signal entry, select them by clicking them with the 
left mouse button. To select contiguous entries, click and drag or hold the 
Shift key when you click the entry at the end of the selection. To select 
individual entries, hold the Ctrl key when you click them. 

 
 

Handoff Log Source 
 

This field lists the feature that initiated the handoff. 
 

• Handoff Log Source can be one of the following: 

• “Handoff Log Source: Marker 

• “Handoff Log Source: Trace • “Handoff Log Source: Log 

• “Handoff Log Source: Alarm 1, Alarm 2, ... 

• “Handoff Log Source: EnergyHist 

• “Handoff Log Source: Manual 
 

Handoff Log Source: Marker means that the signal was handed off from a trace by 
moving the marker to it and then clicking the “Marker, Task Handoff Rx" on page 82. 
The procedure is described under “Mouse Features > Handoff a Signal from a Marker" 
on page 600. 

 

Handoff Log Source: Trace means that the signal was handed off from the Trace Pane 
with the mouse. See “Mouse Features > Handoff a Signal from a Marker" on page 600. 

 

Handoff Log Source: Log means that the signal was listed in the handoff log and its 
handoff log entry was selected with the mouse to tune a handoff receiver to it again. See 
“Handoff Log Popup Menu" on page 143. 

 

Handoff Log Source: Alarm 1, Alarm 2, ... means that the signal was handed off as a 
task from the alarm (identified by number). “Search > Alarms Setup > Modify Single- 
Alarm" on page 363. 
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View > Handoff Log Pane 

Handoff Log Status 

 

 

 

Handoff Log Source: EnergyHist means that the signal was handed off from the “View 
> Energy History Pane" on page 158. See also, “View > Energy History > Right-Click 
Menu" on page 188. 

 

Handoff Log Source: Manual means that the signal was handed off with the 
manualHandoff command either remotely (through a socket connection to an external 
process) or from “View > Command Line Pane (Option ASD)" on page 148. 

 
Handoff Log Request 

 

The date and time that the handoff request occurred. This time may not be the same as 
the Granted time, if more signals have been handed off than there are handoff receivers. 
It is also dependent on the priority differences of active handoffs and pending handoffs. 
The activity times in handoff log have a resolution of 1 second. 

 
Handoff Log Grant 

 

The time the handoff receiver accepted the signal and began monitoring. The activity 
times in handoff log have a resolution of 1 second. 

 
Handoff Log Release 

 

The time the handoff receiver quit monitoring the signal. The activity times in handoff 
log have a resolution of 1 second. 

 

Handoff Log Rx# The handoff receiver number used to monitor the signal as defined in 
“Configure > Handoff Receivers" on page 250. 

 

Handoff Log Priority This applies to handoff setup parameters in the: 
 

• “View > Energy History Pane" on page 158 

• “Display > Trace (Setup)" on page 515 
 

as well as column descriptions in the 
 

• “View > Handoff Log Pane" on page 134 and “View > Handoff Receivers Pane" on page 
128 

 

A handoff is given a Priority level when it is handed off. If more than one handoff is 
pending (waiting in the queue to be assigned to a handoff receiver), the handoff with the 
higher priority setting goes first. If the priority of two pending handoffs is the same, the 
handoff with the earlier request goes first. See “Handoff Log Status" on page 135 for 
descriptions of pending and bumped. 

 

The priority levels are: 
 

• Critical priority handoffs have the highest priority. When a Critical priority handoff is 
put in the handoff queue, it will bump any lower-priority handoff being monitored. 

 

• High priority handoffs are superseded only by Critical priority handoffs. Critical priority 
handoffs can bump a High priority handoff. When a High priority handoff is put in the 
handoff queue, it will bump any Medium or Low priority handoff being monitored. 

 

• Medium priority handoffs can bump Low priority handoffs, but any High and Critical 
priority handoffs will be handed off before a Medium priority handoff Handoffs with 
High and Critical priority will bump a Medium priority handoff being monitored. 
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Handoff Log Status 
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• Low priority handoffs are handed off in the order they are put in the handoff queue when 
there are no pending handoffs with higher priority. If a handoff with higher priority is 
handed off while a low-priority handoff is being monitored, it is bumped; the handoff 
receiver tunes to the higher-priority handoff. 

 

The initial priority value is defined by the handoff settings in “Handoff Log Source" on 
page 137. The priority can also be changed while the handoff is pending (for example, 
increase priority to get it assigned to a receiver sooner by bumping an active handoff) or 
while it is active (for example, increase priority to avoid its getting bumped by another 
handoff). 

 

Tip After Priority, receiver assignment depends on the order in which the receivers are 
listed/installed. For example, when all active handoffs have the same priority and a handoff 
with a higher priority enters the queue, it bumps the handoff on the first receiver on the list. 
Receiver order is determined by entries in the configuration_file. 

 
The log’s priority setting for a pending handoff is used to determine when it is assigned to a 
handoff receiver, given the priorities of all pending and active handoffs. 

 
The log’s priority setting for an active handoff is used to determine whether other handoffs in 
the queue bump it before its duration expires. 

 
The log’s priority setting for a completed handoff is the priority setting that was active when 
monitoring ended for that handoff. 

 
 

Handoff Log Duration 

This applies to handoff setup parameters in the: 
 

• “View > Energy History Pane" on page 158 

• “Display > Trace (Setup)" on page 515 
 

as well as column descriptions in the 
 

• “View > Handoff Log Pane" on page 134 and “View > Handoff Receivers 
Pane" on page 128. 

 

Duration is the amount of time a frequency is to be monitored before its status changes 
to completed and the handoff receiver takes another assignment from the queue. This 
value is assigned to a handoff when it is put in the handoff queue. 

 

This value is listed in the “View > Handoff Log Pane" on page 134 as follows: 
 

• For a pending handoff, this is the amount of time the handoff receiver will 
stay tuned to the frequency if no handoffs with higher priority are put in 
the queue. 

 

• For a completed handoff, this is the amount of time the handoff receiver 
was tuned to the assigned frequency. 

 

• Minimum duration: 1 second 

• Maximum duration: 86400 seconds (24 hours) • Resolution: 1 second 
 

To set this value before the handoff: 
 

See “Display > Trace (Setup)" on page 515 for trace handoffs. 



View > Handoff Log Pane 

Handoff Log Status 
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See “Search > Alarms Setup > Modify Single Alarm > Alarm Tasks > Handoff Receiver 
Alarm Task" on page 419 and “Process Overview" on page 42. 

 

See “View > Energy History > Right-Click Menu" on page 188 for handoffs from the 
“View > Energy History Pane" on page 158. 

 

To change this value for a pending entry in the handoff log, see “Handoff Log Popup 
Menu" on page 143. 

 

To change this value for an active handoff, see “View > Handoff Receivers Pane" on 
page 128. 

 
Handoff Log Frequency 

 

The frequency of the handoff assignment. This value may have been measured at the 
peak of detected energy, it may have been assigned as part of “Search > Detection Setup 
> Energy > Bandwidth Hints" on page 348, or it may have been a user-defined value 
specified as part of an alarm task definition in “Search > Alarms Setup > Modify Single 
Alarm > Alarm Tasks > Handoff Receiver Alarm Task" on page 419. 

 
Handoff Log Bandwidth 

This is the bandwidth value associated with the handoff session. 
 

• When the handoff status is released, unable, or pending, this value reflects 
the setup value for the source that requested it (for example, trace handoff 
setup). 

 

• When the handoff is granted (becomes active), the bandwidth value may 
be rounded up to the receiver’s next largest acceptable setting. 

 

• When the handoff status is active, the bandwidth value reflects the 
receiver’s current setting (which may be changed by the operator). 

 

• For a bumped or completed entry, the bandwidth value indicates the 
bandwidth value in use at the time of release. 

 
Handoff Log Detect 

This applies to handoff setup parameters in the: 
 

• “View > Energy History Pane" on page 158 

• “Display > Trace (Setup)" on page 515 
 

as well as column descriptions in the 
 

• “View > Handoff Log Pane" on page 134 
 

Detection is the method used to demodulate the signal. The detection types available 
depends on the capabilities of the installed handoff receivers. The types displayed in the 
log and detection selection lists may include others 

 

The list of standard types is: 
 

• None 

• AM: amplitude modulation 

• FM: frequency modulation 

• CW: continuous wave 
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View > Handoff Log Pane  

 

Handoff Log Popup Menu 
 

• LSB: lower side band 

• USB: upper side band 

• ISB: independent sideband (LSB and USB on left and right channels.) 

• Log: log modulation 

• Pulse: pulse modulation 

• WFM wideband FM 
 

To set this value before the handoff: 
 

• See “Display > Trace (Setup)" on page 515 for trace handoffs. 
 

• See “Search > Alarms Setup > Modify Single Alarm > Alarm Tasks > 
Handoff Receiver Alarm Task" on page 419 and “Process Overview" on 
page 42. 

 

• See “View > Energy History > Right- Click Menu" on page 188 for handoffs 
from the “View > Energy History Pane" on page 158. 

 

• To change this value for a pending entry in the handoff log, see “Handoff 
Log Popup Menu" on page 143. 

 

• To change this value for an active handoff, see “View > Handoff Receivers 
Pane" on page 128. 

 

See “Configure > Handoff Receivers" on page 250. 

 
Comments 

 

Comments may be added in the handoff receiver control box while the signal is being 
monitored (status=active). The maximum length of the comment is 15 characters. 
Comments can be entered only once and disappear when the duration expires. 

 

 

Handoff Log Popup Menu 
 

Path: In the “View > Handoff Receivers Pane" on page 128, select one or more pending 

handoff log entries with the left mouse button, click the right mouse button. 

View > Handoff Receivers Pane (Right Mouse Button Menu) 

 

This allows you to assign a handoff receiver to the same settings that appear 
for an entry in the log or, for an active entry, release or change the priority, 
duration, or detection settings originally specified in the dialog boxes for 
“Display > Trace (Setup)" on page 515 or “Search > Alarms Setup > Modify 
Single Alarm > Alarm Tasks > Handoff Receiver Alarm Task" on page 419. 

 

1. “Handoff Verification" on page 143 

2. “Handoff Release Verification" on page 144 
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View > Handoff Log Pane  

 

Handoff Verification 
 

3. “Handoff Log: Priority" on page 145 

4. “Handoff Log: Detection" on page 145 

5. “Handoff Log: Duration" on page 145 

To add the Handoff Log Pane to the main window, see “Display > Layout" on page 512 
 

 

Handoff Verification 
 

View > Handoff Receivers 

 

1. Select one or more entries with the left mouse button. 

2. Click the right mouse button. 

3. Click Handoff. 
 

When you select Handoff, this menu confirms the request before it hands off the selected 
signals. 

 

• Yes confirms the handoff. 

• No cancels the handoff. 
 

 

Handoff Release Verification 
 

View > Handoff Receivers 

 

To release a handoff receiver: 

1. Select one or more pending handoff log entries with the left mouse button. 

2. Click the right mouse button. 

3. Click Release. 
 

When you select Release this menu confirms the release request before it releases signals 
that are pending in the handoff log. 

 

• Yes confirms the release and the status is changed to Released in the 
Handoff Log. 

 

• No cancels the release and the status is not changed. 
 

 

Handoff Log: Priority 
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View > Handoff Log Pane  

 

Handoff Log: Detection 
 

This menu allows you to change the priority of a pending handoff log entry. To change 
the priority setting for one or more pending signals in the “View > Handoff Log Pane" on 
page 134. 

 

1. Select one or more pending handoff log entries with the left mouse button. 
 

2. Click the right mouse button anywhere inside the “View > Handoff Log 
Pane; an option list appears containing time values. 

 

3. Select a new priority value from the list by clicking it. 
 

 

Handoff Log: Detection 
 

This menu allows you to change the detection type of a pending handoff log entry. To 
change the detection setting for one or more pending signals in the “View > Handoff Log 
Pane" on page 134. 

 

1. Select one or more pending handoff log entries with the left mouse button. 
 

2. Click the right mouse button anywhere inside the “View > Handoff Log 
Pane; an option list appears containing time values. 

 

3. Select a new detection value from the list by clicking it. 
 

 

Handoff Log: Duration 
 

This menu allows you to change the duration of a pending handoff log entry. To change 
the duration setting for one or more pending signals in the “View > Handoff Log Pane" 
on page 134. 

 

1. Select one or more pending handoff log entries with the left mouse button. 
 

2. Click the right mouse button anywhere inside the “View > Handoff Log 
Pane; an option list appears containing time values. 

 

3. Select a new duration value from the list by clicking it. 
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View > Text Editor Pane 

Handoff Log: Duration 
 

 

View > Text Editor Pane 
 

View > Text Editor Pane 
 
 
 
 
 
 
 
 
 
 

The Text Editor Pane contains a text editor. The text editor can be used to view and 
modify ASCII text files such as saved state files, log files, or search band database files 
as well as create new files such as reports. 

 

The Text Editor Pane File Pull-Down Menu allows opening and saving text files on the 
system hard disk and printing to the system printer. When a file is open in the editor, its 
name appears after the words Text Editor: centered above the text area. 

 

• To load an existing file, select File > Open and specify the directory and 
filename. 

 

• To add text, place the cursor anywhere in the text editor window and 
click. Type the new text. Line wraps occur only where there are end- of- 
line characters (when you press Enter). 

 

• To select text, place the mouse cursor at one end of a segment of text, 
click and hold the left mouse button, move the cursor to the other end of 
the segment, and release the mouse button. This action is called wiping 
text. 

 
Holding down the Shift key and clicking the left mouse button selects all 
text between its present position and its previous position. 

 

• To select a word, place the cursor anywhere on it and double- click. 

• To select a line, place the cursor anywhere on it and triple- click. 
 

• To select all text in the file, place the cursor anywhere in the text area 
and click rapidly, 4 times. 

 

• To delete text, use the Backspace key to remove single characters on the 
left side of the cursor position. 

 
Use the Delete key to remove single characters on the right side of the 
cursor position. 

 
Select the text then press the Delete key. 

• To toggle between insert and overwrite modes, press the Insert key. 
 

• To move text, select it and drag it (click and hold the middle mouse 
button) to the destination, then release it. 

 

• To copy text, select it and then press the Ctrl key and drag it (click and 
hold the middle mouse button) to the destination. 



176 

 

 

View > Text Editor Pane 

File Pull-Down Menu 
 

• To save the text you are working on, click File > Save. 
 

The first time you save a new file, you must specify a filename. 
 

If you specify a filename that already exists, the file will be overwritten 
with the text file. A message appears before this happens to assure that it 
is what you want to do. 

 

• To print the file, select File > Print. 
 
 

 
File Pull- Down Menu 

 

New clears a file from the text editor. 
 

Open opens a file for editing. 
 

Save writes a copy of the file to the disk using the same file name that it was opened 
with. Use save to update disk files that already have names. If it is a new file that has not 
yet been named, a prompt is displayed that requires entry of the path and filename. 

 

Save As writes a copy of the file to the disk, prompting for a directory and filename. 
Print causes the system line printer manager to print the text file. The system printer 
must be properly configured and specified in the print file. See the example file 
(C:\E3238s\d.print) for further explanation. 

 

Text Editor Warnings 
 

• A warning appears when the editor contains a text file and changes have 
not been saved before clicking File > Open or File > New. 

 

• To save the file, click Cancel and then save the file. 

• To continue (and lose the text file changes), click OK. 
 

• A warning appears when Agilent N6820ES Signal Detection and 
Monitoring Solutions is closed while there is a text file that has been 
changed and the changes have not been saved. 

 

• To save the file, click Save and specify a directory and filename. 
 

• To continue shutting down the program without saving the text file 
(and lose the text file changes), click Lose. 
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View > Command Line Pane 

File Pull-Down Menu 
 

 

View > Command Line Pane 
 

View > Command Line Pane 
 

 
 

The Command Line Pane allows commands to be executed at the Command Line entry 
field and display a log of the commands that have been issued. This log of the commands 
may be saved as a file. See “File > Log Files" on page 105. 

 

Auto Scroll is a check box that, when selected, scrolls the text in the command line log 
as necessary so that the latest commands issued appear in the log text area. 

 

Command Line is the text line in which commands are entered. Commands can be 
typed or selected from a list in the Command Reference dialog box. 

 

Command Reference is a button used to display the dialog box for the “View > 
Command Line > Command Reference" on page 149. 

 

 
Note Each Command Line Log entry requires 80 bytes of memory. The number of entries in 

the log view is limited as defined by the commandLineHistoryLength resource variable 
in the E3238s. See also, “Application Resources" on page 19. 

 
When the number of log entries reaches the limit, new entries cause the oldest entries to 
be discarded/lost from memory. To avoid losing this information, turn on the log-to-file 
feature; all entries are then written to a file on the system disk. See “File > Log Files" on 
page 105. 

 
• To add this pane to the main window, see “Display > Layout" on page 512 

and “View > Command Line Pane (Option ASD)" on page 148. 
 

• To create a file containing this log, see “File > Log Files" on page 105. 

• To clear the Command Line Log, see “Edit > Clear Log" on page 112. 
 

• To receive help on this or any pane, click Help or press Shift+F1 to 
activate context- sensitive help and click in the pane. 
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View > Command Line > Command Reference 

File Pull-Down Menu 
 

 

View > Command Line > Command Reference 
 

View > Command Line > Command Reference 

 
 

Search is a text line that allows you type in a string of characters and find the pattern in 
the command names. The list is searched from beginning to end and stops on the first 
match found. Every time a change is made to the pattern in the text line, the search is 
repeated. To search again for the same pattern, select Next. 

 

Next is a button that lets you find other matching patterns in the command names if the 
last command name isn’t the one you were looking for. You can click it multiple times to 
search through the list of commands. 

 

Commands lists the commands that may be executed at the command line. Use the 
scroll bar to move up and down through the list or the Search/Next features above it. 

 

When a command entry is selected, its syntax appears in the lower pane. 
 

Double-clicking a command brings up the detailed description window. This is the same 
as clicking Description at the bottom of the window. 

 

You can drag the commands to the command line with the middle mouse button. 
 

Syntax displays the syntax of the command selected in the Commands list. This gives 
the forms of the command and a description of acceptable parameters. 
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View > Command Line > Command Reference 

Query Dialog Boxes 
 

Description displays the Command Reference Help explanation of the command 
selected in the Commands list. A shortcut for bringing up the Command Reference Help 
for a particular command is to double-click the command in the Commands listing. 

 
 

A detailed description of commands is contained file: 
\E3238s\manuals\command_ref.pdf. 

 
 
 

Query Dialog Boxes 
 

When the command is a query, the information requested is displayed in a 
popup dialog box as shown below for the tunerInfo? query. 

 
 

View > Command Line (Example of Query: tunerInfo?) 
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View > Toolbar 

View > Toolbar (Search Receiver Configuration Toolbar Icons) 
 

 

View > Toolbar 
 

 

Toolbar Icons, N684x RF Sensor Platform 
 

“Configure > Antennas" on page 207 Configure > 

RF Sensor (Search Receivers) “Configure > System 

Reference" on page 253 
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View > New Energy Log Pane 
 

View > New Energy Log Pane 
 

 
The New Energy Log Pane lists peaks of new energy the first time that they appear and 
keeps a running count of the total number of entries in the log. 

 

Entries (Number of entries in the log.) “Full” means that it has reached capacity and 
some entries have been shifted out of the log. 

 

Time of Intercept This is the date and time of the first intercept (the first time the energy 
was detected. For information about the total number of intercepts and the time of the 
last intercept, see “View > Energy History Pane" on page 158. 

 

Frequency The frequency of the energy the first time it was detected. This value may be 
at the peak of the detected energy, or it could be the center of a predefined band within 
which the energy was detected. See “Process Overview" on page 42 and “Search > 
Detection Setup > Energy > Bandwidth Hints" on page 348. 

 

Bandwidth The energy bandwidth on the first detection. This value may have been 
measured or copied from “Search > Detection Setup > Energy > Bandwidth Hints" on 
page 348, if the frequency fell in an active hint. For information on the current, 
maximum, minimum, or average bandwidth values, see “View > Energy History Pane" 
on page 158. 

 

Amplitude The amplitude of the energy as measured when the intercept occurred. For 
information on the statistical values, see “View > Energy History Pane" on page 158. 

 

Auto Scroll (in the lower right of the pane) keeps the latest entries visible by scrolling 
through the log. 

 

 

Note Each New Energy Log entry requires 60 bytes of memory. The number of entries in the 
log view is limited as defined by the newEnergyLogViewLength resource variable in the 
E3238s. See “Application Resources" on page 19. 

 
When the number of log entries reaches the limit, new entries cause the oldest entries to 
be discarded/lost from memory. To avoid losing this information, turn on the log-to-file 
feature; all entries will be written to a file on the hard disk. See “File > Log Files" on 
page 105. 

 

Tip To add this pane to the main window, see “Display > Layout" on page 512. 
 

To create a file containing this log, see “File > Log Files" on page 105. 
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To clear the New Energy Log, see “Edit > Clear Log" on page 112. 

To receive help on this or any pane, select “Help Pull- Down Menu" on page 
597 or press Shift+F1 to activate context- sensitive help and click in the pane. 
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View > Alarm Log Pane 

Toolbar Icons, SpectrumDF V2 Platform (Wideband DF Platform) 
 

 

View > Alarm Log Pane 
 

View > Alarm Log Pane 
 

 

The Alarm Log Pane displays a log of triggered alarms. 
 

Alarms The number of alarms in the log. “Full” means that it has reached capacity and 
some entries have been shifted out of the log. 

 

Time of Intercept This is the date and time of the intercept that caused the alarm. 
 

Frequency The measured frequency of the detected energy peak. 
 

Alarm The alarm number. See “Search > Energy History Filter (Option ASD)" on page 
355. 

 

Type Either energy or signal alarm. 
 

Description The description or name of the alarm as entered in the dialog box of “Search 
> Alarms Setup > Modify Single-Alarm" on page 363. 

 

Auto Scroll (in the lower right of the pane) keeps the latest entries visible by scrolling 
the log as new additions appear. 

 

Note Each Alarm Log entry requires 90 bytes of memory. The number of entries in the log 
view is limited as defined by the alarmLogViewLength resource variable in the E3238s. 
See “Application Resources" on page 19. 

 
When the number of log entries reaches the limit, new entries cause the oldest 
entries to be discarded/lost from memory. To avoid losing this information, 
turn on the log- to- file feature; all entries will be written to a file on the 
system disk. See “File > Log Files" on page 105. 

 

Tip To add this pane to the main window, see “Display > Layout" on page 512. 
 

To create a file containing this log, see “File > Log Files" on page 105. 
 

To clear the Alarm Log, see “Edit > Clear Log" on page 112. 
 

To receive help on this or any pane, select “Help Pull-Down Menu" on page 597 or press 
Shift+F1 to activate context-sensitive help and click in the pane. 
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View>EnergyHistoryPane  

 

Toolbar Icons, SpectrumDF V2 Platform (Wideband DF Platform) 
 

 

View > Energy History Pane 
 

Figure 83 View > Energy History Pull- Down Menus 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To use the pull- down menus of the Energy History Pane 

• “View > Energy History > File Pull- Down Menu" on page 160 

• View > Energy History > Edit Pull- Down Menu" on page 162 

• “View > Energy History > View Pull- Down Menu" on page 166 

• “View > Energy History > Tools Pull- Down Menu" on page 182 

• View > Energy History > Right- Click Menu" on page 188 

To print/save/clear/show Energy History entries 

• Printing entries -  See “File > Print". 

• Saving entries -  See “File > Print To File". 

• Clearing entries -  See “Edit > Clear Energy History". 

• Showing entries in a trace -  Set the grid type to New Energy. 
 

To change which feature/parameters are displayed 
 

See “View > Energy History > Edit > Format (Column Setup)" on page 163. Up to eight 
feature/parameters can be displayed for each entry in the Energy History Pane. 

 

To display all feature/parameters for a selected entry 
 

See “View > Energy History > View > Entry" on page 167. 
 

To display an energy history plot of one of the feature/parameters 

See “View > Energy History > View > Plot" on page 175. 
 

To link one of the feature/parameters to a particular trace marker 
 

See “View > Energy History > Tools > Marker Link" on page 186. 
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View > Energy History Pane 

View > Energy History > File Pull-Down Menu 
 
 

 
View > Energy History > File Pull- Down Menu 

 

Figure 84 View > Energy History > File Pull-Down Menu 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

“View > Energy History > File > Load" on page 160 

“View > Energy History > File > Save" on page 160 

“View > Energy History > File > Close" on page 161 

 

View > Energy History > File > Load 
 

Load is used to read a file containing Energy History data from a file on the system disk. 
Loading an Energy History file removes the existing feature/parameter statistic data in 
the Energy History. You are prompted with a question to assure that this is your intention 
before the data is overwritten. 

 

When you load an Energy History file that contains custom features, be sure that the 
same feature/parameter-defining library programs are loaded in the same order as were 
loaded when the file was created. The Agilent N6820ES Signal Detection and 
Monitoring Solutions tracks user-defined feature/parameters with an index/counter that 
is assigned based on the order that they are loaded; for example, the order they are listed 
in the configuration file. 

 
View > Energy History > File > Save 

 

Save writes the feature/parameter data in the Energy History to a file on the system disk. 
Saving Energy History data to a file creates an ASCII file containing all the 
feature/parameter statistics in scientific notation using a comma-separated-value format. 
To pull the data directly into Microsoft Excel, save the data as a .csv file. To do this, 
select All Files (*.*) as the Save as type: and <filename.csv> for the File name. 

 

Current, Minimum, and Maximum Amplitude data are saved as volts squared. Use the 
following formula to convert to dBM. dBM=10*Log10(20*V2). 

 

For Average Amplitude, use dBM=10*Log10(20*V2/Intercepts) 
 

% Occupancy is not saved as part of the standard Energy History data. To calculate the % 
Occupancy, divide Intercepts by Number Sweeps. 



View>EnergyHistoryPane 
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View > Energy History > File Pull-Down Menu 
 

The First Intercept and Last Intercept saved values are saved as the number of seconds 
from the epochal date of January 1, 1970. The following formula will convert a saved 
intercept value into a Greenwich Standard Time (Month/Day/Year Hour:Second) format. 
GST time = (Saved Intercept Value/86400)+25569. 

 

For example, to change GST to Pacific Standard Time you need to subtract 8 hours or 1/3 
of a day. PST time = (Saved Intercept Value/86400)+25569-0.33333 

 
View > Energy History > File > Close 

 

Closes the Energy History file. 
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View > Energy History > Edit Pull-Down Menu 

View > Energy History > File Pull-Down Menu 
 

 

View > Energy History > Edit Pull- Down Menu 
 
 

 
Figure 85 View > Energy History > Edit Pull-Down Menu 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

“View > Energy History > Edit > Format (Column Setup)" on page 163 

“View > Energy History > Edit > Add Entry" on page 164 

“View > Energy History > Edit > Delete Entry" on page 165 
 

“View > Energy History > Edit > Clear" on page 165 



188 

 

 

View > Energy History > Edit > Format (Column Setup) 

View > Energy History > File Pull-Down Menu 
 

 

View > Energy History > Edit > Format (Column Setup) 
 

View > Energy History > Edit > Format (Column Setup) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Energy History Column Setup dialog box is used to specify what 
feature/parameters appear in the columns of the Energy History Pane. While there are 
many fields that can be displayed, only the first eight columns listed in the Displayed 
group appear in the Energy History Pane. 

 

To add a column entry to the displayed energy history group 
 

Select the name of a column from the Available group and click the horizontal arrow. 
 

To remove a column entry from the displayed energy history group 
 

Select the name of a column from the Displayed group and click the horizontal arrow. 
 

• OK implements the changes made and closes the dialog box. 

• Apply implements any changes and leaves the dialog box open. 

• Cancel closes the dialog box without making any changes. 
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View > Energy History > Edit > Add Entry 

View > Energy History > File Pull-Down Menu 
 

 

View > Energy History > Edit > Add Entry 
 

View > Energy History > Edit > Add Entry 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Energy History Add Entry dialog box is used to add an entry to the Energy 
History Pane. This may be used to define alarm conditions that require energy history 
entries to monitor for No Signal conditions. See “Search > Alarms > Energy Definition". 

 

Single Entry 
 

To add one entry to the Energy History Pane, click the radio button associated with this 
selection, and enter values for the frequency and bandwidth with the buttons at the right. 

 

Load from Bandwidth Hint 
 

To add all entries in a defined “Search > Detection Setup > Energy > Bandwidth Hints", 
click the radio button associated with this selection and enter the number associated with 
the Bandwidth Hint you want. The hint status must be active and channelize = Yes. 
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View > Energy History > Edit > Delete Entry 

View > Energy History > File Pull-Down Menu 
 

 

View > Energy History > Edit > Delete Entry 
 

View > Energy History > Edit > Delete Entry 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

When Delete Entry is selected and before any data is cleared, a prompt is displayed 
acting as a two-step verification process which helps reduce the chances of making an 
error. 

 

• Yes allows the energy history entry deletion process to continue. 

• No cancels the energy history entry deletion process. 
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View > Energy History > Edit > Clear 

View > Energy History > File Pull-Down Menu 
 

 

View > Energy History > Edit > Clear 
 

Figure 89View > Energy History > Edit > Clear 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

When Clear is selected and before any data is cleared, a prompt is displayed acting as a 
two-step verification process which helps reduce the chances of making an error. 

 

• Yes allows the energy history clearing process to continue. 

• No cancels the energy history clearing process. 
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View > Energy History > View Pull- Down Menu 
 

View > Energy History > View Pull-Down Menu 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
“View > Energy History > View > Entry" on page 167 

“View > Energy History > View > Plot" on page 175 
 

“View > Energy History > View > Status Bar" on page 179 
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View > Energy History > View > Entry 
 

Figure 91View > Energy History > View > Entry 
 

 
This selection opens a dialog box that lists all the feature/parameter information for a sin- 

gle entry from Energy History. Any of the values displayed in this dialog box may be 

used to trigger an alarm. See “Search > Alarms > Single-Alarm Setup". 

To select an entry, click on a row in the Energy History Pane. 
 

Note When an Energy History Entry is linked to a trace marker, the trace marker 
appears at the peak of the entry selected (for example, clicking a different 
entry moves the trace marker). Also, moving the marker to another peak 
causes the Energy History Entry information to track the selected entry if it 
falls within the span of an existing entry. See “View > Energy History > Tools 
> Marker Link" on page 186. 

 
The amplitude, bandwidth, duration, and user-defined feature/parameters may be displayed 
as graphic profiles with the “View > Energy History > View > Plot" on page 175. 

 
The detection counter is incremented when energy is detected on two consecutive sweeps; 
for example, not on first intercept. When the sweep is stopped or the sweep setup is changed, 
any pending detections are cleared. 

 
The accuracy of the duration values depends on how frequently the energy’s frequency is 
swept. The calculation assumes the energy is present continuously between intercepts and 
stopped at the time of the last intercept if energy is not detected on the current sweep. 

 
The minimum and average duration values are updated only after a valid detection; the 
maximum duration is always updated. 
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Energy History Entry 
 

• Energy Limits of an Energy History Entry 
 

• Frequency is the energy’s center frequency, recorded at the first intercept. If this 
value falls into an active frequency range in “Search > Detection Setup > Energy > 
Bandwidth Hints" and channelize is active, the value recorded is the center of the 
band rather than the measured frequency of the peak. 

 

• Bandwidth is the “current bandwidth” value of the “first intercept” event. The value 
is either the energy’s measured bandwidth, given the bandwidth amplitude specified 
in “Search > Detection Setup > Energy > Energy Criteria" or a predetermined value 
from the “Search > Detection Setup > Energy > Bandwidth Hints", if the peak is in an 
active frequency range. This bandwidth value is used to determine if a peak belongs 
in this entry or is a new peak. The accuracy of the measured value depends on 
resolution (RBW). 

 

• Location of an Energy History Entry 
 

Any location on Earth can be described with latitude and longitude values. These two 
values can be used to specify a position on a map (also referred to as "coordinates" on a 
map). 

 

Longitude and Latitude are two angles, measured in degrees, "minutes of arc" and 
"seconds of arc" and are denoted by the symbols ( °, ', " ). For example, 45° 40' 19" 
means an angle of 45 degrees, 40 minutes, and 19 seconds. A degree contains 60 minutes 
of arc and a minute contains 60 seconds of arc. 

 

• Altitude - is the height of the antenna above sea level. 
 

• Longitude - lines of longitude are lines of constant longitude ("meridians") that 
extend from the north pole to the south pole. 

 

• Latitude - are parallel lines that encircle the earth perpendicular to the lines of 
longitude. The longest circle is along the equator (and has a latitude value of 
zero). While at the north pole and south pole, the lines of latitude, represented as 
circles, shrink to a point and have a latitude value of 90° at the north pole and -90° 
at the south pole. (See http://www-istp.gsfc.nasa.gov/stargaze/Slatlong.htm.) 

 

• Heading - specifies the direction that the platform being used is pointing toward or 
facing relative to true north; the heading can be thought of as the “direction you are 
pointing or heading”. 

 

• Elevation - specifies the elevation that a signal of interest is emitting from. 
 

Elevation is part of the direction result for an HF DF system (azimuth and elevation). Elevation 
is returned in meters and is only available on selected HF DF systems; it is not available on 
V/UHF DF systems. 

http://www-istp.gsfc.nasa.gov/stargaze/Slatlong.htm.)


195 

 

 

 

Location of an Energy History Entry 
 

Latitude 
 
 
 
 
 
 
 
 

Longitude 

 
 

First Latitude Specifies the latitude of the system the first time 

this energy was intercepted. Stored, but not 

displayed 
 

Last Latitude Specifies the latitude of the system the last time 

this energy was intercepted. 

 
 
 
 
 
 
 
 

Heading 

 

First 

Longitude 
 
 

Last 

Longitude 

 

Specifies the longitude of the system the first 

time this energy was intercepted. Stored, but not 

displayed 
 

Specifies the longitude of the system the last time 

this energy was intercepted. 

 
 
 
 
 
 
 
 

Altitude 

 

First Heading Specifies the heading of the system the first time 

this energy was intercepted. Stored, but not 

displayed 
 

Last Heading Specifies the heading of the system the last time 

this energy was intercepted. 
 

 
 

First Altitude Specifies the altitude of the system the first time 

this energy was intercepted. Stored, but not 

displayed 
 

Last Altitude Specifies the altitude of the system the last time 

this energy was intercepted. 
 
 
 
 
 
 

 

Statistics of an Energy History Entry 
 

 
 

Statistics 
 
 

Intercepts Specifies the number of times the energy was 

intercepted. See “Search > Alarms > Alarm 

Criteria > Duration (Timing Diagram)”. 
 

First Intercept  Specifies the timestamp of the first time this 

energy was intercepted. 

It is relative to epoch time. (12:00 AM 1/1/1970) 
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Last Intercept   Specifies the timestamp of the last time this 

energy was intercepted. 

It is relative to epoch time. (12:00 AM 1/1/1970) 
 

Number 

Sweeps 
 

Percent 

Occupancy 

 

Specifies the number of times the system had a 

chance to intercept the signal. 
 

Specifies the occupancy of the energy which is 

Intercepts divided by Number Sweeps. It is 

returned as a percent between 0 and 100. 
 

Detections Specifies the number of times that the energy 

was transitioned from not being detected, to 

being detected, and then not being detected. See 

“Search > Alarms > Alarm Criteria > Duration 

(Timing Diagram)” 
 

 
 
 
 

Features of an Energy History Entry 
 

 
 

Frequency 
 
 

Current Specifies the center frequency of the energy. 

While the search is stopped, this field is blank. 
 

Maximum Specifies the maximum frequency of the energy. 

Average Specifies the average frequency of the energy. 

Minimum Specifies the minimum frequency of the energy. 

 

 
 
 
 
 

Bandwidth 
 
 
Current Specifies the bandwidth of the energy entry that 

was used during the energy detection process. It 

may be smaller than the average, maximum, or 

minimum bandwidth of the entry. While the 

search is stopped, this entry is blank. 
 

Maximum Specifies the maximum bandwidth of the energy 

when it was intercepted. Returned in Hertz. 
 

Average Specifies the average bandwidth of the energy 

when it was intercepted. Returned in Hertz. 
 

Minimum Specifies the minimum bandwidth of the energy 

when it was intercepted. Returned in Hertz. 
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Amplitude 
 
 

Current Specifies the measured amplitude of the energy 

on the latest sweep. While the search is stopped, 

this entry is blank. 
 

Maximum Specifies the maximum amplitude of the energy 

when it was intercepted. Returned in dBm. 
 

Average Specifies the average amplitude of the energy 

when it was intercepted. Returned in dBm. To 

derive the energy’s average amplitude value, 

divide this value by the number of intercepts for 

this signal. 
 

Minimum Specifies the minimum amplitude of the energy 

when it was intercepted. Returned in dBm. The 

amplitude is measured only when an energy is 

detected, so this is the smallest amplitude 

recorded for an intercept of this energy. 
 
 
 
 
 
 

Duration 
 
 

Current Specifies how long the energy has been present 

without interruption. 

 
Duration is calculated as the difference in time 

between the first intercept and the latest 

intercept during which time the energy was 

detected on every sweep. No duration value 

exists until there are two consecutive intercepts. 

While the search is stopped, this entry is blank. 
 

Maximum Specifies the maximum duration of the energy. 

This is the duration that the energy was 

continually intercepted. Returned in seconds. 
 

Average Specifies the average duration of the energy. This 

is the duration that the energy was continually 

intercepted. Returned in seconds. 
 

Minimum Specifies the minimum duration of the energy. 

This is the duration that the energy was 

continually intercepted. Returned in seconds. 

 
As explained for “Current Duration,” one 

intercept, with no intercept on the previous 

sweep or the next, has no duration value. 
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View > Energy History > View > Plot 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Energy History Plot dialog box displays any single feature versus the frequency 
span of one of the traces or a span you define manually. Display this dialog box by 
clicking Plot on the “View > Energy History Pane" on page 158. 

 

1. Feature data to be plotted. 
 

The feature data types are described in “View > Energy History > View > 
Entry" on page 167. Measured analog data types can be graphically combined 
into groups called profiles. These are: 

 

• Amplitude 

• Duration 

• Bandwidth 

A profile plot displays a vertical line for each entry. 

• The low end of the line is minimum value, 

• the highest end is the maximum value, 

• the green dot on the line is the average value, and 

• the white dot is the current amplitude. 

2. “Energy History Plot Y- Axis Scaling" on page 177 
 

3. “Energy History Plot X-Axis Scaling" on page 178 
 

4. Amplitude auto- scale button. 

5. These buttons synchronize the frequency scale with a trace. 
 

6. This line indicates the trace’s marker position, if on, or the selected entry 
in the energy history. 

 

To change the data to be plotted, select an entry from the scrolled list at the right. 
 

To manually define the plot scale 
 

1. Click either a Y- axis button (item #2) or an X- axis button (item #3). A 
new dialog box appears. 

 

2. Change the scale settings. 
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3. Click “OK” to apply the change and close the dialog box or click “Apply” 
to apply the change and leave the dialog box open. 

 

Note The plot colors can be modified in the E3238s resource file with *plotColor 
commands. See “Application Resources" on page 19. 
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Energy History Plot Y-Axis Scaling 

View > Energy History > File Pull-Down Menu 
 

 

Energy History Plot Y- Axis Scaling 
 

View > Energy History > View > Plot (Y-Axis Scaling) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This dialog box is used to specify the Y-axis scale for the Energy History Plot. You can 
display this box by clicking in either of the Plot Y Scale buttons on the “View > Energy 
History > View > Plot" on page 175. 

 

To specify the energy history scale with min/max values 
 

1. Click the button corresponding to the parameter you wish to change. A 
new dialog box appears. 

 

2. Make sure the mouse cursor is in the new dialog box. 

3. Change the value using a numeric value only (don’t enter units). 

4. Click OK. 
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Energy History Plot X-Axis Scaling 

View > Energy History > File Pull-Down Menu 
 

 

Energy History Plot X- Axis Scaling 
 

Figure 94View > Energy History > View > Plot (X-Axis Scaling) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This dialog box is used to set the X-axis (frequency) scale of the energy history plot. You 
can display this box by clicking in either of the Plot X Scale buttons on the “View > 
Energy History > View > Plot" on page 175. 

 

To select automatic frequency scaling, click the radio button of the trace whose 
frequency scale it should match. 

 

To display data for frequency ranges that do not correspond to trace frequency spans, set 
the scale to start and stop frequencies entered manually: 

 

1. Click the radio button in the Manual Scaling field. The numbers on the 
scale buttons become active. 

 

2. Click the X Minimum (or Maximum) button. A new dialog box appears. 
 

3. Enter the new value in the box. The cursor must be in the box while you 
type. 

 

4. Click OK. The new value should appear on the button face. 
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View > Energy History > View > Plot (Scale Value) 

View > Energy History > File Pull-Down Menu 
 

 

View > Energy History > View > Plot (Scale Value) 
 

View > Energy History > View > Plot (Scale Value) 
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View > Energy History > View > Status Bar 

Energy History Full 
 

 

View > Energy History > View > Status Bar 
 

View > Energy History > View > Status Bar 
 
 
 
 
 
 
 
 
 
 

Status 
Bar 

 

 
 
 
 

The Status Bar adds an additional information to the bottom of the Energy History Pane 
that displays statistics related to Active Energy and Past Energy along with how much 
disk space the active and past energy are using. 

 
 

 
Energy History Full 

 

View > Energy History (Notice Energy History is Full) 

 
 
 

This dialog box appears when the number of entries in the Energy History 
exceeds the maximum allowed. 

 

Note Each Energy History entry requires approximately 128 bytes of memory. The number of 
entries in the pane is limited by the maxEnergyHistorySize resource variable in the 
configuration file. The default is 5000. 

 
Another way to control the number of entries is to implement filters that limit 
new entries and/or delete existing entries. See “Search > Energy History Filter 
(Option ASD)". 

 
Don’t show this dialog box again when the energy history gets full, new entries are 
lost/ignored and no warning is given. 
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View > Energy History > View > Status Bar 

Energy History Full 
 

This resets when the application is restarted. 
 

Disable Energy Detection stops the creation of new entries. This may be re-enabled in 
“Search > Detection Setup > Energy Tab". 

 

Clear Energy History deletes all of the entries in the database. This has the same effect as 
described in “Edit > Clear Energy History" and “View > Energy History > Edit > Clear" on 
page 165. When the number of entries reaches the limit, new entries will not be added until 
some or all of the current entries are deleted: individual entries can be deleted with “View > 
Energy History > Edit > Delete Entry" on page 165. 

 

Do Nothing closes the warning dialog box. New entries will continue to be ignored. Another 
method that can be used to minimize the total number of energy history entries is the use of 
the energy history filters. 

 

Verify Energy History Recall This dialog box is displayed to point out that recalling an 
Energy History file clears the feature data currently in the Energy History. To avoid losing 
this data click No, save the current Energy History in another file, and then load the desired 
Energy History file. 
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View > Energy History > Tools Pull-Down Menu 

Energy History Full 
 

 

View > Energy History > Tools Pull- Down Menu 
 

View > Energy History > Tools Pull-Down Menu 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Handoff: displays the frequency of the entry that is to be handed off to a handoff receiver. 
Handoff remains grayed out until an entry is selected from the Energy History Pane. Handoff 
Receivers must be designated in the configuration file before starting the Agilent N6820ES 
Signal Detection and Monitoring Solutions software. 

 

“View > Energy History > Tools > Handoff Setup" on page 183 

“View > Energy History > Tools > Marker Link" on page 186 
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View > Energy History > Tools > Handoff Setup 

Handoff Log Priority 
 

 

View > Energy History > Tools > Handoff Setup 
 

View > Energy History > Tools > Handoff Setup 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

When you click Handoff Setup, another menu appears that allows you to set the Priority, 
Detection, and Duration parameters for signals handed off from the Energy History Pane. 

 

• “Handoff Log Priority 

• “Handoff Log Detect" on page 184 

• “Handoff Log Duration" on page 184 
 

 

Handoff Log Priority 
 

A handoff is given a Priority level when it is handed off. If more than one handoff is 
pending (waiting in the queue to be assigned to a handoff receiver), the handoff with the 
higher priority setting goes first. If the priority of two pending handoffs is the same, the 
handoff with the earlier request goes first. 

 

The priority levels are: 
 

• Critical priority handoffs have the highest priority. When a Critical priority handoff is 
put in the handoff queue, it will bump any lower-priority handoff being monitored. 

 

• High priority handoffs are superseded only by Critical priority handoffs. Critical priority 
handoffs can bump a High priority handoff. When a High priority handoff is put in the 
handoff queue, it will bump any Medium or Low priority handoff being monitored. 

 

• Medium priority handoffs can bump Low priority handoffs, but any High and Critical 
priority handoffs will be handed off before a Medium priority handoff. Handoffs with 
High and Critical priority will bump a Medium priority handoff being monitored. 

 

• Low priority handoffs are handed off in the order they are put in the handoff queue when 
there are no pending handoffs with higher priority. If a handoff with higher priority is 
handed off while a low-priority handoff is being monitored, it is bumped; the handoff 
receiver tunes to the higher-priority handoff. 



208 

 

 

View > Energy History > Tools > Handoff Setup 

Handoff Log Detect 
 

The priority can also be changed while the handoff is pending (for example, increase 
priority to get it assigned to a receiver sooner by bumping an active handoff) or while it 
is active (for example, increase priority to avoid its getting bumped by another handoff). 

 

 

Handoff Log Detect 
 

Handoff Log Detect is the method used to demodulate the signal. The detection types 
available depends on the capabilities of the installed handoff receivers. The types 
displayed in the log and detection selection lists may include others. 

 

The list of standard types is: 
 

• None 

• AM: amplitude modulation 

• FM: frequency modulation 

• CW: continuous wave 

• LSB: lower side band 

• USB: upper side band 

• ISB: independent sideband 

• Log: log modulation 

• Pulse: pulse modulation 

• WFM wideband FM 
 
 
 

Handoff Log Duration 
 

Handoff Log Duration is the amount of time a frequency is to be monitored before its 
status changes to completed and the handoff receiver takes another assignment from the 
queue. This value is assigned to a handoff when it is put in the handoff queue. 

 

This value is listed in “View > Energy History > Tools > Handoff Setup" on page 183 as 
follows: 

 

• For a pending handoff, this is the amount of time the handoff receiver will 
stay tuned to the frequency if no handoffs with higher priority are put in 
the queue. 

 

• For a completed handoff, this is the amount of time the handoff receiver 
was tuned to the assigned frequency. 

 

• Minimum duration: 1 second 

• Maximum duration: 86400 seconds (24 hours) 

• Resolution: 1 second 
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View > Energy History > Tools > Marker Link 

To link a trace marker to entry in the Energy History Pane 
 

 

View > Energy History > Tools > Marker Link 
 

View > Energy History > Tools > Marker Link 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Marker Link allows one of the feature/parameters to be lined to a particular trace 
marker. 

 

When the Energy History is linked to a trace marker, the marker appears at the peak of 
the entry selected in the Energy History Pane (for example, clicking a different entry 
moves the trace marker). Also, moving the trace marker to another peak causes the 
Energy History Entry information to track the selected entry if it falls within the span of 
an existing entry. 

 

 

To link a trace marker to entry in the Energy History Pane 
 

1. Set up energy detection. 

2. Add the Energy History Pane to the main window. 

3. Click one of the entries (lines) in the Energy History Pane. 
 

4. Click the right- mouse button anywhere in the Energy History Pane’s list 
area to display a popup menu. 

 

5. Continue to hold the mouse button down and move the cursor down to 
the Marker Link entry and release the button. The display should now 
appear as shown in Figure 101. 

 

6. Click the entry for the trace you wish to select. 
 

When a trace is selected and its marker is on (see “Display > Trace (Setup)" 
on page 515), the marker moves to the frequency of the entry selected in the 
Energy History Pane 
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View > Energy History > Tools > Marker Link 

To link a trace marker to entry in the Energy History Pane 
 

Linking a Trace Marker to the Energy History Pane 
 

 
 
 

Also, when the marker is moved (in the trace) to a frequency value within the 
bandwidth of an entry in the Energy History Pane, that entry is selected 
(highlighted) in the pane. 
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View > Energy History > Right-Click Menu 

To link a trace marker to entry in the Energy History Pane 
 

 

View > Energy History > Right- Click Menu 
 

View > Energy History > Right-Click Menu 
 

 

Right-Click Menu appears when the right-mouse button 

is clicked anywhere in the Energy History Pane.  

 

 
The right- click menu appears when the right- mouse button is clicked 
anywhere in the Energy History Pane. 

 

“View > Energy History > Edit > Delete Entry" on page 165 

“View > Energy History > Edit > Add Entry" on page 164 

“View > Energy History > Tools > Marker Link" on page 186 

“View > Energy History > Tools > Handoff Setup" on page 183 

The right- click menu is used as a shortcut to: 

1. Identify the selected entry’s frequency. 
 

2. Add a signal to the handoff queue. Set the handoff’s priority, detection, 
and duration. 

 

3. Delete an entry from the history listing. 
 

4. Add an entry to the Energy History Pane. This may be useful for defining 
alarm conditions that require energy history entries to monitor for No 
Signal conditions. 
See “View > Energy History > View > Entry" on page 167. 

 

5. Pick a trace whose marker is coupled to entry selection. See “View > 
Energy History > Tools > Marker Link" on page 186. 

 

6. Specify handoff settings (priority, detection, and duration) for handoffs 
performed from this pane. 
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View > Signal Database Pane  
Figure 103View > Signal Database Pane  

 

 
 

 
The Signal Database Pane displays the signal information collected by narrow-band 
signal processing assets. These assets are described in “Understanding the DSP Block 
Diagram" on page 26. See the processing diagram in “Process Overview" on page 42. 

 

The maximum number of entries in the Signal Database is specified in the E3238s 
Resources file with the variable signalDatabaseSize. By default, the maximum number 
is 500,000. When this limit is reached, no new signals are added to the database. 

 

The signal processing activity and channel control appears in “Configure > Signal 
Processing Configuration" on page 267. 

 
Types Pull- Down Menu (Right- Side of Signal Database Pane) 

 

Depending on the selection from this menu, different headings/columns of information 
are displayed from the signal database: 

 

“Signal Database Column Headings for All Types 

“Signal Database Column Headings for Recorder 

“Signal Database Column Headings for DF 

 

Signal Database Column Headings for All Types 
 

Time is the date and time that the signal was identified. 
 

Frequency is the frequency associated with the signal. This can mean different things for 
different types of signals. 

 

Duration is a value whose definition depends on the signal class and/or type as 
determined by the user-defined library. For typical signals, it is the time the signal was 
“up”, but for a DF signal it may mean something else. 

 

Class is one of the three signal processing activities: 
 

• Signal Identification 

• Location (for example, Agilent N6854A Geolocation Server software) 

• Collection 
 

Type is a designation given the signal by the library used to process this signal. It is used to 

sort signals in the database with the Type Menu. 

 
When the All Types selection is active, only the common characteristics are displayed in 

the listing.  

 
Signal Database Column Headings for Recorder 
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Time is the date and time that the signal was identified. 
 

Frequency is the frequency associated with the signal. This can mean different things for 
different types of signals. 

 

Duration is a value whose definition depends on the signal class and/or type as 
determined by the user-defined library. For typical signals, it is the time the signal was 
“up”, but for a DF signal it may mean something else. 

 
Signal Database Column Headings for DF 

 

Time is the date and time that the signal was identified. 
 

Frequency is the frequency associated with the signal. This can mean different things for 
different types of signals. 

 

Duration is a value whose definition depends on the signal class and/or type as 
determined by the user-defined library. For typical signals, it is the time the signal was 
“up”, but for a DF signal it may mean something else. 

 

Quality is the quality of the signal... 

Azimuth is the azimuth of the signal... 

Bandwidth is the bandwidth... 

Site Lat is the latitude... 

Site Long is the longitude... 

Heading is the heading... 

Reports Pull- Down Menu When the view is set to DF, a Reports Pull-Down Menu is 
available that allows the DF signals in the database to be displays as a DF Activity Report 
that can be printed. 

 

By Frequency displays the report with signals sorted by frequency. 

By Azimuth displays the report with signals sorted by azimuth. 
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File Pull- Down Menu allows you to perform file manage operations: save, load, 
merge, or export a signal database file (.sdb). 

 

Figure 106View > Signal Database > File 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Load loads a previously- saved database file and replaces the current 
contents of the Signal Database Pane.  

 

View > Signal Database > File > Load (Options) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Save allows the current database to be written to a system file in a form that can be 
reloaded. 
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• Merge allows you to load a previously-saved file, adding it to the current contents of the 
database.  

 

• Export causes the contents of the signal database to be saved to a file in comma- 
separated variable (.csv) format; this format supports use with a spreadsheet. 

 

• Print appears in the menu if a printer is configured for the system (the file print 
exists in the e3238s directory) and the textPrintCommand is given within it. 

 

• Modify Entry exists only if it has been implemented in the user-defined library for a 
given signal type. The action it allows is defined by that code. 

 

• Delete Entry is used to delete the selected entry. 

• Clear is used to delete entries in the Signal Database Pane. 
 

Note Database Loss This message appears when information in the Signal Database Pane may be 
lost because the user selected to exit while unsaved database data exists. 

 
Save allows you to save the information using the Save/Load/Merge/Export Signal Database 
commands. 

 
Lose means to continue the exit process without saving the signal database information; the 
contents of the current database are lost. 
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View > Visual Alarms Pane 

To link a trace marker to entry in the Energy History Pane 
 

 

View > Visual Alarms Pane 
 

View > Visual Alarms Pane 
 

 
 

This pane is used to display visual alarm indicators as well as text that could 
describe the situation and give instructions as defined in “Search > Alarms 
Setup > Modify Single Alarm > Alarm Tasks > Visual Setup (Visual Alarm 
Task)" on page 407. 

 

Note To make visual alarms viewable, add the Visual Alarms pane to the Agilent N6820ES 
Signal Detection and Monitoring Solutions window using the “Display > Layout" 
on page 512. 

 

This area (inside the dashed line) displays the alarm icons for the active alarms. 
 

This area displays alarm information when a triggered alarm icon is clicked. The 
information is the alarm’s number, its name/description, and instruction text, 
if any has been defined. 

 

Each icon represents an alarm that has a visual “task” defined and selected in the 
Tasks section of the dialog box for “Search > Alarms Setup > Modify Single- 
Alarm" on page 363. 

 

This icon represents a triggered alarm. Clicking on this icon displays the alarm 
information in area #2. It may also be set to rearm the alarm’s trigger. 

 

This icon represents an alarm that is not triggered. 
 

Note If an alarm’s trigger type is “Once,” and the Clear Alarm parameter is set, the trigger may 
be cleared (rearmed) by clicking the alarm’s icon in this pane. 
See “Search > Alarms Setup > Modify Single Alarm > Control" on page 367 
and “Search > Alarms Setup > Modify Single Alarm > Alarm Tasks > Visual 
Setup (Visual 
Alarm Task)" on page 407. 

 

Tip Audio alarms may also be used to sound an alert when an alarm occurs. See “Search > 
Alarms Setup > Modify Single Alarm > Alarm Tasks > Audible Setup (Audio 
Alarm Task)" on page 412. 
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View > Frequency Lists Pane  

 

To use frequency lists 
 

 

View > Frequency Lists Pane 
 

View > Frequency Lists Pane 
 

 
 
 

The Frequency Lists Pane is used to create, display, and modify 

frequency lists. 

“View > Frequency Lists > Frequency List (Heading)" on page 197 

“View > Frequency Lists > Resolution (Heading)" on page 198 

“View > Frequency Lists > Merge Freq (Heading)" on page 198 

“View > Frequency Lists > Compare Freq (Heading)" on page 198 

“View > Frequency Lists > Load List (Button)" on page 199 

“View > Frequency Lists > Merge List (Button)" on page 199 

“View > Frequency Lists > Save List (Button)" on page 200 

“View > Frequency Lists > Modify List (Button)" on page 201 

“View > Frequency Lists > Add Freqs (Button)" on page 202 

“View > Frequency Lists > Delete Freqs (Button)" on page 203 

 

To use frequency lists 
 

Frequency lists are used in a number of ways: 

• as alarm criteria (for example, in list #1, or not in list #1) 

• as a trace grid (See “Display > Trace > Grid Type" on page 531.) 
 

• Lists can be changed by an alarm task (values added to or deleted from a 
list) 

 

• Lists also can be used in user- defined programs. So frequency list 
information could be employed as a source of information for an energy 
feature calculation or to specify energy filter activity. 

 

 

Parameters Affecting Frequency List Entries 
 

The three parameters that affect how frequency entries are entered and 

used are: 

Resolution - entries are rounded to the nearest multiple of this value. 
 

• Merge Frequency - provides another “resolution” parameter. The combination 
of  the Resolution and Merge settings allows a strategy where one 
parameter (Resolution) can be used as a base which is never exceeded and 
the other  (Merge) can be adjusted according to need. Frequency values 
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View > Frequency Lists Pane  

 

View > Frequency Lists > Frequency List (Heading) 
 

may be manually added/deleted in the Frequency List Pane or as the 
result of an alarm task. Any new values are rounded by both Resolution 
and the Merge frequency settings before they are entered in a list. 

 

• Compare Frequency - A value used to evaluate alarm criteria. 

Left- Side Pane, List Table The left-side text area of the Frequency List 

Pane is a table of frequency lists: 
 

• As many as 10 lists may be defined, but the number of frequencies within a list is 
unlimited. 

 

• A list is identified by both a number and a name or label. 

• The contents of a selected list appears in the text area on the right. 
 

• A list may be defined by loading information from a file on the system disk. Use 
Load List to replace the list contents or Merge List to combine the contents of a 
file with the selected list. 

• A list’s name, Resolution, Merge Freq, and Compare Freq settings are changed with 

Modify List. 
 

 
Right- Side Pane, List Contents The right-side text area of the Frequency List Pane 
shows the entries of the selected list (highlighted) at the left. You may add or 
delete entries to this list with Add Freqs and Delete Freqs. 

 

 

View > Frequency Lists > Frequency List (Heading) 
 

Frequency List contains a column of lists that are identified by a number and name. The 
name may be modified with Modify List. 

 

See “View > Frequency Lists > Modify List (Button)" on page 201. 
 

Since the list number is part of the identifier, the name need not be unique. 
These identifiers appear in the dialog box (under Description, Feature, 
Frequency) for “Search > Alarms Setup > Modify Single- Alarm" on page 363 
and in “Display > Trace (Setup)" on page 515. 

 

 

View > Frequency Lists > Resolution (Heading) 
 

Resolution is the spacing of the frequency values in the list. For example, given a 
resolution of 100 Hz, valid frequency values exist only every 100 Hz. When 
other values are added to the list, they are rounded up or down to a multiple 
of 100. 

 

The Resolution value may be changed by clicking a list entry and then clicking 
Modify List below it. 

See “View > Frequency Lists > Modify List (Button)" on page 201. 
 

 

View > Frequency Lists > Merge Freq (Heading) 
 

Merge Freq is the frequency value used to sort new (added) entries into valid list 
values. This is typically equal to or greater than the Resolution value. 

 

The Merge Freq value may be changed by clicking a list entry and then 
clicking Modify List below it. 
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View > Frequency Lists Pane  

 

View > Frequency Lists > Compare Freq (Heading) 
 

See “View > Frequency Lists > Modify List (Button)" on page 201. 
 

 

View > Frequency Lists > Compare Freq (Heading) 
 

Compare Freq is used to determine whether a frequency value exists in the list during 
the process of checking alarms. Consider this to be the “footprint” of the 
energy’s frequency for the sake of determining whether the alarm value exists 
in the list. The comparison checks for existence of entries in the list freq ± 
compare_freq/2 where freq is the frequency of the energy that caused the 
alarm. The value of Compare Freq is typically equal to the Merge Freq or 
larger. 

 

The Compare Freq value may be changed by clicking a list entry and then 
clicking Modify List below it. 

See “View > Frequency Lists > Modify List (Button)" on page 201. 
 

 

View > Frequency Lists > Load List (Button) 
 

View > Frequency Lists > Load List 

 
 

Load List is used to load a file containing a frequency list. When a frequency list is 
loaded from a file, the list’s Resolution, Merge, and Compare frequency 
settings are replaced by those in the file. 

 

 

Frequency Lists > Merge List (Button) 
 

Figure 111View > Frequency Lists > Merge List 

 
 

Merge List is used to select and load a frequency list file, adding (merging) its contents 
to those already in the selected list. When the list is merged, the Resolution, 
Merge, and Compare frequency values in the file are ignored. 
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View > Frequency Lists > Save List (Button) 
 

The file merging process is different from other load processes, however. When 
a frequency list file is merged with one of the frequency lists in the “View > 
Frequency Lists Pane" on page 196, the name and parameter information in 
the file are ignored and the frequency values are added to the selected list 
according to the Resolution and Merge Frequency rounding values that are 
active for the selected list. 

 

A frequency list file is an ASCII file containing: 

• a name (like “List #1”) 

• a resolution value 

• a merge value 

• a compare value 

• a list of frequency values (in Hz) 
 

name:Pagers 

resolution:-1 

merge:12500 

compare:-1 

929512500 

929537500 

929562500 

929612500 

929662500 

929712500 

929737500 

The negative values for Resolution and Compare indicate that the Merge value 
is used for these settings. 

 

 

View > Frequency Lists > Save List (Button) 
 

View > Frequency Lists > Save List 

 
 

Save List allows you to save the selected list as a file. You can also preserve the list 
information by saving the current state with “File > Save Mission Setup" on 
page 96. 
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View > Frequency Lists > Modify List (Button) 
 

View > Frequency Lists > Modify List (Button) 
 

View > Frequency Lists > Modify List 

 
 

Modify Frequency List dialog box is used to change the Name, Merge Frequency, 
Resolution, or Compare Frequency values of the selected frequency list. 

 

Name is an identifier or short description. It appears with the list number wherever 
frequency lists are listed (alarm criteria and trace grid). 

 

Merge Frequency is a rounding value used to place frequencies in a list. 

Resolution is one of two rounding values used to place frequencies in a list. 

Compare Frequency is used to compare values in the list to alarm criteria. 

 

To change frequency list settings 
 

1. In the Frequency Lists Pane, select the frequency list entry you wish to 
modify (click on it and it becomes highlighted). 

 

2. Click Modify List at the bottom of the pane. The dialog box shown above appears. 
This dialog box was designed to make it easy to use the merge frequency 
value for both the resolution and compare frequency settings. 

 

3. Make the necessary changes. To use a value other than the Merge 
Frequency value for either Resolution or Compare Frequency, 202 Agilent 
N6820ES Signal Detection and Monitoring Solutions click the 1- of- N 
(radio) button beside the labeled button and enter the new value in the 
Frequency Entry dialog box. 
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View > Frequency Lists > Add Freqs (Button) 
 

Frequency Entry 

 
 

4. Click OK. 
 

A resolution or merge value of 0 Hz allows any frequency to be entered. When 
you change a list’s merge value, existing entries in the list are not modified to 
fit the multiple pattern; only new entries are constrained. 

 

 

View > Frequency Lists > Add Freqs (Button) 
 

View > Frequency Lists > Add Freqs 

 
 

Add Freqs allows you to add frequency values to the selected list. 

To add one or more frequency values to a list: 
 

1. Select the frequency list entry you wish to modify from the Frequency 
Lists Pane (page 105) (click an entry and it becomes highlighted). 

 

2. Click the Add button at the bottom of the pane (the dialog box shown 
above appears). 

 

3. Click in the text area of the dialog box and enter the new values. 

4. Click a button at the right side to select frequency units. 

5. Click OK. 
 

Note The new values must be a multiple of the merge frequency. Values that are within 1/2 the 
merge range of an existing entry create no new entry. Values more than 1/2 
the merge range above or below an existing entry are entered at the next 
multiple above or below the entry. New entries are added at the closest 
multiple of the Merge Freq. 
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View > Frequency Lists > Delete Freqs (Button) 
 

These values aren’t saved unless you save the state (see “File > Save Mission 
Setup" on page 96) or save the individual list as a file. 

 

The number of entries in a frequency list is unlimited. 
 
 
 
 

View > Frequency Lists > Delete Freqs (Button) 
 

Delete Freqs deletes selected frequency values from the list. 

To delete one or more frequency values from a list: 

1. Select a list in the left pane. Its entries appear in the right pane. 
 

2. Select one or more frequency values that you wish to delete. You can use 
the Shift or Ctrl buttons with the mouse button to select multiple entries. 
Shift is used to select contiguous selection and Ctrl for non- contiguous 
selection. 

 

3. Click Delete. 

 
Defining or Changing Frequency List Files 

 

A frequency list can be stored on the system disk. These files have a .frq extension and 
are in ASCII format. Such a file can be created or modified with an editor like 
Notepad. 

 

Each list the following attributes: 

• a name (like “List #1”) 

• a resolution value 

• a merge value 

• a compare value 

• a list of frequency values (in Hz) 
 

Note Frequency lists are part of the mission state which may be saved and recalled from the 
“File Pull- Down Menu" on page 91. They may also be saved as individual files 
that can be recalled. If you create frequency lists in the pane and don’t save 
the mission state or save the work in files, the frequency list information is 
lost when the program stops running. 

 
The information saved in the state file is the frequency information; not 
filenames containing the frequency lists. 
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View > Frequency Lists > Delete Freqs (Button) 



 

 

The Configure Menu 
 
 
 
 
 
 
 

 

 
 

The Configure menu contains entries used to define the configuration of the 
installed hardware.  For information about the components in this system, see 
System Block Diagram (page 23). 

 

A The dash- line indicates that this is a tear- off menu. Click the top of the 
menu and the menu gets its own window so that it does not disappear after a 
selection. 

 

1. Antenna Configuration (page 226) 

2. Search Receivers (page 227) 

3. Handoff Receiver Configuration (page 271) 

4. System Reference (page 274) 
 

The installed hardware is defined by commands in the e3238s.n6841.cfg 
file. These commands are executed when the program first runs and must 
correctly define the installed hardware before you can use the program to 
change hardware settings. 

 

See Hardware Configuration (page 16) and the N6820ES Installation and 
Configuration Reference for details. 

 

Note Configuration changes interrupt searching and data may be lost. 
 

To save a hardware configuration for later recall or to load a previously saved 
hardware configuration, see the discussion of Mission Setup Sections (page 
132). 



 

 

Antenna Configuration 
 
 
 

Antenna Configuration 
 

Toolbar Icon 
Path: Configure, Antennas ... 

 

 
 
 

 
 
 
 
 

This box is used to display information about the antennas. If your system 
has more than one antenna, you may use an RF switch module to select one. 
See Switch Configuration (page 228). 

 

Antennas are configured using the site file. See the default site file, 
d.e3238s.site for information about the file syntax. At startup, the N6820ES 
Signal Monitoring System reads the site file and uses the antenna 
configuration described there. 

 

For information about the components in this system, see “Hardware Configuration” on 
page 16. 

 
Notes • To define/view connections between antennas and the search receiver, see 

Switch Configuration (page 228). 

• Antennas are selected for use in the General Search Setup (page 290) 
dialog box. 



 

 

 
 
 

Search Receiver 
 

N6841A RF Sensor Setup 
 

 Toolbar Icon 
Path: Configure, Search 
Receivers 

 
 

This dialog box allows you to view and configure settings for the N6841A RF 
Sensor Search Receiver.    

 

1. Model and Host Name:   Displays the model number and network host 
name (or IP address) of the RF Sensor.   The host name is specified in the 
configuration file typically located at C:\E3238s\N684x_RF_ 
Sensor\e3238s.n6841.cfg. 

 

2. Setup: The setup button displays specific settings for one RF Sensor.   In a 
multiple channel system, a Setup button will appear for each RF sensor. 

 

3. Sensor Management Tool:   Press this button to start SMT, a software tool 
to configure and manage RF sensors. 

 

4. Sweep Results Protocol: Displays the network being used to transfer 
spectrum sweep results from the RF Sensor to the N6820ES application. 
Default is "TCP/IP".  This can be switched to "UDP" by changing parameter 
in the configuration file (typically C:\E3238s\N684x_RF_ 
Sensor\e3238s.n6841.cfg) UDP may allow slightly faster sweep rates, but 
lost data will not be re- transmitted. 

 

5. Pacing: Selects the pacing method used to control the RF sensor sweep 
rate.  Pacing automatically adapts the sweep rate to match the network 
performance and the ability of the N6820ES application to process 



 

 

sweep results. The possible setting are: 
 

• Sweep Handshake: The next sweep is not started until after the data 
from the previous sweep has been delivered to the N6820ES 
application. This handshake will reduce sweep rate performance. 

• Data Throttle:  The RF Sensor sweeps as fast as possible, but the rate 
at which it can transmit network data is regulated by the N6820ES 
application.  The data rate throttle is automatically reduced whenever 
loss of network data is detected, or when the N6820ES application is 
too busy to process data.  This setting provides optimum sweep rate 
performance.  

• Add Averages:   The RF Sensor sweeps as fast as possible, but the 
number of averages is adjusted by the N6820ES application to pace 
the system. This has the effect of automatically increasing the 
number of averages specified in the Search Setup dialog box.  Because 
spectrum averaging is performed in the RF Sensor’s FPGA, increasing 
the number of averages reduces the network data rate.  This setting 
provides optimum sweep rate performance and optimizes probability- 
of- intercept.  Peak Averaging Type is recommended. 

• None:   Pacing is disabled.  This is not recommended when using UDP 
because it may results in excessive data loss. 

 

6. Data Rate: This reports the measured rate of network data received 
from the RF Sensor. 

 

7. Driver Revision:   Revision of the RF Sensor platform driver software. 

8. Library Revision: Revision of the lower level RF Sensor library 
software. 

 

  



 

 

 

N6841 RF Sensor Setup 
 
 

 
 

This dialog box allows you to view and configure settings for a specific RF 
Sensor Search Receiver.  The settings in this dialog box are common to all 
receivers. 

 

1. Model, Host Name, IP Address:   Displays the model number, network host 
name, and IP address of the RF Sensor.  The host name is specified in the 
configuration file typically located at C:\E3238s\N684x_RF_ 
Sensor\e3238s.n6841.cfg. 

2. Firmware Version:  Displays the version of the software installed in the RF 
Sensor.   Use the Agilent RF Sensor Management Tool to update this 
software. 

3. Status:  Reports the RF Sensor status.  This should normally display "OK". 
"Over Temperature" indicates the operating temperature has been exceeded. 
"Frequency Unlock" indicates a hardware failure.   "Time questionable" 
indicates the sensor is configured to use GPS or IEEE 1588 as a time sync 
source, but the time is not accurate. Use SMT or the RF Sensor web page 
to get more information. 

4. UHF Preamp:   Setting this "On" enables the RF Sensor UHF pre- amplifier for 
frequencies between approximately 750 MHz and 1800 MHz. Select "On" to 
optimize sensitivity in this band.   Select "Off" to reduce overloads. 

5. Receiver Gain:   Controls the distribution of gain and attenuation between 
the RF and IF amplifiers in the RF Sensor. 

a. "Normal:   This is the nominal setting recommended for most 
applications. "Low Noise: Use this setting to improve sensitivity in a 
quiet RF environment.  This may increase intermodulation distortion. 



 

 

b. "Low Distortion:  Use this setting to reduce intermodulation distortion 
in a busy RF environment.  This may increase noise. 

6. RF Sensor Web Page:  Use this button to quickly launch a web browser to 
view the RF Sensor web page. 

7. Network Performance: This box reports measured network performance 
parameters for this RF Sensor. 
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Handoff Receiver Configuration 
 

Toolbar Icon 
Path: Configure, Handoff Receivers 

 

 
 

 
 

This dialog box allows you to configure the installed handoff receivers as 
specified in the e3238s.n6841.cfg file. 

 

1. # (receiver number):   This number is specified in the e3238s.n6841.cfg 
file as part of the resource name used to define each of the parameters 
described below: 

 

For Windows 
 

handoffRx1.driver: C:/e3238s/HD_8712.dll 

handoffRx1.interface: rs232,COM1,9600 

handoffRx1.label: HF Rx 
 

 
This number is used in the Handoff Receiver Pane (page 70) and the 
Handoff Log Pane (page 75) to identify individual handoff receivers.   Each 
receiver may also be assigned a name as described in the following 
discussion. 

 

2. Receiver Name:   The handoff receiver name is specified in the 
e3238s.n6841.cfg file by the handoffRx1.label line.   It may also be 
specified with a  command in the Command Line Pane (page 115). 

 

The name may be as long as 31 characters. 
 

3. Model:  The handoff receiver model is specified in the e3238s.n6841.cfg 
file by the handoffRx1.model line.   It may also be specified with a 
command in the Command Line Pane (page 115). 

 

4. Address:   This number is specified in the e3238s.n6841.cfg file 
by the handoffRx1.interfaceParm line.   It may also be specified 
with a command in the Command Line Pane (page 115). 
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5. Rx Pool:   The receiver pool is a status indicating availability. 

In means the receiver is available for signal handoff. 

Out means the receiver is not available for signal handoff. 
 

• You can remove a handoff receiver from the pool to gain direct control 
for manual operation.   While it is out of the pool, the search receiver 
will not assign signals to it. 

• Any receiver that is taken out of the pool should be reset when it is 
returned to the pool.   Open the handoff receiver setup dialog box and 
click the Reset Receiver button. 

• If a signal is handed off with a frequency or detection type that is not 
supported by any of the installed handoff receivers, it is assigned a 
status of unable.   See Handoff Status (page 76). 

• If a handoff occurs with a frequency or detection type that is supported 
only by a handoff receiver that is out of the pool, the signal is assigned 
pending status until the receiver is returned to the pool.   If detection 
type is the only constraint, changing the detection type to a value 
supported by one of the installed receivers (in the pool) allows it to be 
assigned to another receiver. 

• To change the detection value for a pending entry in the handoff log, 
see Detection (page 84). 

 

6. Interactive Yes/No:   Interactive receivers allow the handoff receiver 
parameters (frequency, detection, duration, priority) to be changed by the 
user while the receiver is processing a signal or while it is unassigned. 

 

When a receiver is interactive, buttons with up/down arrows appear on 
the pane that may be used to adjust settings or values while listening to 
the output. 

 

Yes means the controls are active in the Handoff Receiver Pane (page 70). 
 

7. Releasable Yes/No:  Releasable receivers allow the user to release a signal 
being monitored before completion of the specified duration.   When a 
receiver releases a signal, the receiver is available for another signal 
assignment. 

 

A user can release a receiver when the signal is determined to be of no 
interest or its examination is complete and the receiver can be reassigned. 

 

When this setting is No, the Release button does not appear in the handoff 
receiver pane.   See Handoff Receiver Pane (page 70). 

 

8. Setup:   Setup is different for each type of handoff receiver. This button 
calls the dialog box appropriate for the installed model. 

 

When the Setup and control buttons (up/down arrow buttons) do not 
appear in the receiver pane, it is because the Interactive setting is No. 

 

Handoff 
Receiver 

Information 

To display help text for a handoff receiver, click the Setup button and then 
click the Help button in the dialog box that appears. The handoff receiver 
must appear as a resource in the e3238s.n6841.cfg file. 

 

See Also The Installation & Configuration Reference for information on installing 
hardware and editing configuration commands in the ‘e3238s.n6841.cfg’ 
file. 
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Note The default number of handoff receivers is 16.   This may be changed to 
support as many as 100 receivers by setting the maxHandoffRxs parameter in 
the E3238s resource file. 
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System Reference 

Time [From Computer] 
 

 

System Reference 
 

 
Toolbar Icon 
Path: Configure, Handoff Receivers 

 

 

 
 
 
 
 

System Reference, in addition to displaying the system time, displays whether 
the platform is fixed, parked, or moving. Whether the location of the system is 
obtained from the GPS or from manual latitude, longitude, and altitude values 
input by the user. The heading can also be derived from either the compass or 
from a manual heading and a declination value input by the user. 

 

 

Time [From Computer] 
 

This is the current timestamp taken from the computer in the form of year, 
month, day, hour, minute, second, and tenth of a second. 

 

 

Platform 
 

• Fixed is used for fixed sites or other relatively permanent installations 
such as antenna towers and buildings. The platform is only measured at 
startup time. 

 

• Parked is used for vehicle mounted systems where they will be driving 
from one location to another and then parking to do their measurements. 
In this mode, the initial platform location is set just like it is in the Fixed 
mode. However, the platform location is updated each time the sweep is 
started; only the very first segment is used. 

 

• Moving is not currently supported and will be implemented in a future 
release due to the algorithm development to combine multiple azimuths 
based on different locations. 
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System Reference 

Location 
 

This mode will be used for vehicle mounted systems where they will be 
measuring while driving. In this mode, the platform location will be 
continually updated with every segment’s location data. 

 

 

Location 
 

• Manual is selected when you want to manually enter the latitude, 
longitude, and altitude of the current platform. 

 

• GPS is selected when the latitude, longitude, and altitude is supplied from 
the GPS system for the current platform. 

 
GPS Location is the latitude, longitude, and altitude of the sensor 
(antenna / DF system) making the measurements. 

 
Any location on Earth can be described with latitude and longitude values. 
These two values can be used to specify a position on a map (also referred 
to as "coordinates" on a map). 

 

• Latitude and Longitude are two angles, measured in degrees, 
"minutes of arc" and "seconds of arc" and are denoted by the 
symbols ( °, ', "   ). For example, 45° 40' 19" means an angle of 
45 degrees, 40 minutes, and 19 seconds. A degree contains 
60 minutes of arc and a minute contains 60 seconds of arc. 

 

• Latitude is represented as lines of different size circles on a globe of 
the Earth. The longest circle is along the equator (and has a latitude 
value of zero). While at the north pole and south pole, the lines of 
latitude, represented as circles, shrink to a point and have a latitude 
value of 90° at the north pole and −90° at the south pole. 

 

• Longitude ("meridians") are represented as constant lines that extend 
from the north pole to the south   pole on a globe of the Earth; like the 
pieces of an orange after it has been peeled. 
(See http://www- istp.gsfc.nasa.gov/stargaze/Slatlong.htm.) 

 

• Altitude specifies the height position of the antenna in meters, relative 
to sea level; the altitude can be below sea level or above sea level. 

 

 

Heading 
 

• Manual is selected when the user manually enters the heading and 
overrides heading from the system. 

 

• Compass is selected when heading is from the system compass. 
 

Compass Heading: 
 

• Heading specifies the direction that the platform being used is pointing 
toward or facing relative to true north; the heading can be thought of as 
the “direction you are pointing or heading”. When a GPS system is used, 
the heading is corrected by the GPS system to be true north (°). 

 

• Declination specifies the correction between magnetic north and 
true north. 
Site Name is a field that allows you to assign a unique/custom name to 
the site being used as the reference. 

http://www-istp.gsfc.nasa.gov/stargaze/Slatlong.htm
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Heading 
 

 

The Search Menu 
 

 
 
 
 
 
 
 
 

 
 

 
The Search menu contains entries used to configure the search parameters 
and to start and stop search activities.   This is a tear- off menu.   Click the 
top of the menu and the menu gets its own window so that it does not 
disappear after a selection. 

 

1. Search On/Off (page 286) starts or stops sweeping (searching). 
 
 

2. Search Type (page 287) defines whether the search has one or more 
bands. 

 

3. Search Setup depends on the Type selection. 

• General Search Setup (page 290) defines a single- band sweep. 
• Directed Search Setup (page 291) defines a multi- band sweep. 

 

4. Energy Detection (page 309) is used to define criteria used to intercept 
(detect) energy: threshold, peak and bandwidth criteria. 

 

5. Energy History Filter (page 332) is used to limit the number of entries in 
the energy history which improves performance. 

 

6. Alarms Setup (page 336) is used to define alarms and the tasks associated 
with them, such as snapshot capture and signal handoff. 

 

7. Direction Finding (page 395) is only available when the optional DF library 
is installed. 

 

8. Modulation Recognition (page 402) is only available when the optional Mod 
Rec library is installed. 
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Search On/Off 
 

Toolbar Icon (Red = off, Green = on) 
Path: Search, Search On/Off 

 

 
This entry in the Search menu is a toggle key used to start and stop 
searching.   When search is off, other parts of the application and other 
programs run faster but no energy or alarm processing occurs. 

 

• To define a search, see General Search Setup (page 290). 
• For a description of the main window, see Introduction (page 9). 
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Search Type 
 

Toolbar Icon 
Path: Search, Type ... 

 
 

 
 

1. Search Type This defines whether the sweep parameters are set for the entire sweep or by 
bands. This selection affects the Search Setup dialog box and should be made 
before doing any configuration of the search setup. 

 

General search sweeps between two frequency values.   You can specify 
antenna, attenuation, RBW, shape factor, and averaging. This method is used 
to characterize the spectral environment as is typical at the beginning of a 
new mission.   See General Search Setup (page 290). 

 

Directed search extends the concept of general search. The sweep is broken 
up into bands, where each band has its own start and stop frequencies and 
different selections for antenna, attenuation, RBW, shape factor, and averaging 
can be specified for each band.   In addition, sweep ratio, description, and 
active status can be specified for each band. 

 

Directed search is used to optimize resources by allowing the search receiver 
configuration to be tailored to specific parts of the spectrum after the general 
search has identified areas of interest.   See Directed Search Setup (page 291). 

 

Directed search allows: 

• skipping parts of the spectrum to improve sweep speed 
• using optimized antennas for certain bands 
• optimizing RBW, averaging, and shape factor for each band 
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• scanning some bands more often than others to increase the revisit rate 
on high- priority bands 

 
2. Sweep Mode This allows you to sweep continuously or stop periodically based on sweep 

count. 
 

Continuous   specifies that the search sweep is not automatically stopped. 

Counter  specifies that the search stops after the specified number of sweeps. 

• To set the count, see Sweep Count Entry on page 285. 
• To restart the search, click the Search On/Off button.   See page 282. 

Interval   specifies the amount of time between individual sweeps. 

• To set the interval time, see Sweep Interval Entry on page 285. 
• The maximum interval time is 1 hour (3600 seconds). 

 

 
Note When the time for a single sweep is greater than the specified sweep interval, 

this setting has no effect on the sweep rate. 
 

When the sweep interval is very large, the system may appear to be stopped. 
 

 
3. Sweep Range Sweep Range appears only when the configuration includes multiple tuners. 

See   Multiple Tuner Switch Configuration (page 232). 
 

This selection appears when a single- channel system has multiple tuners. 
Each choice corresponds to one of the tuners installed. 

 

• The 0- 4MHz entry corresponds to no tuner; the values represent the 
baseband span of the ADC installed (either 0- 4 MHz or 0- 8 MHz). 

• The 2 MHz to 32 MHz entry corresponds to a WJ9119 tuner. 
• The 2 MHz to 2.65 GHz entry corresponds to an 89431 tuner. 

 

These selections are defined in the e3238s.n6841.cfg file. See also, 
Multiple Tuner Switch Configuration (page 232). 

 

4. Tuner Sweep 
Control 

This allows you to lock the tuner so that the IF output can be operated 
with a DDC receiver.    

 

Lock Tuner allows you to stop the system from sweeping by parking   the 
tuner LO at a fixed frequency.   This should be used when the tuner’s IF 
output is used to create fft spectral data AND stream IQ for audio or recording 
simultaneously.  Locking the tuner does not stop the search; it restricts the 
search to the span of the tuner. 

 

When the Lock Tuner button is checked, the tuner’s local oscillator does not 
sweep frequency.   This is required when the tuner output is shared with a 
DDC.  

 

Note Locking the tuner causes the N6820ES software to not check the search 
frequency parameters to see if they are valid. If, in the General Search Setup 
dialog box, you set a start or stop frequency outside the tuner’s range, the 
values will not be corrected by the software until the tuner is unlocked. 
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Sweep Count Entry 

Sweep Count Entry 

 

 

 
 

This dialog box allows you to enter a value for sweep count. 
 

The sweep count is the number of sweeps after which sweeping stops.   This 
occurs when the Sweep Mode is Counter which is selected in the Search Type 
dialog box. 

 

 

Sweep Interval Entry 
 
 

 
 

This dialog box allows you to enter a value for sweep interval. 
 

The sweep interval is the time between individual sweeps.   This occurs when 
the Sweep Mode is Interval which is selected in the Search Type dialog box. 
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General Search Setup 

Sweep Interval Entry 
 

 

General Search Setup 
 

Toolbar Icon 
Path: Search, Type, General; Search, Setup 

 

 
 

 

This dialog box is used to set up general search sweeps.  Set the Search Type 
(page 287) to General before selecting Search, Setup. 

 

1. Frequency Entry (page 295) 

2. Antenna (page 298) 

3. Tuner Attenuation (page 299) 

4. RBW (page 300) 

5. Shape Factor (page 300) 

6. Averaging (page 301) 

 
• OK makes the specified changes and closes the dialog box. 
• Apply makes the specified changes and leaves the dialog box open. 
• Cancel closes the dialog box; no changes are applied. 

 

Note Sweep frequencies may also be specified via marker positions.   See Marker 
Popup Menu (page 69). 
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Sweep Interval Entry 
 

 

Directed Search Setup 
 

Toolbar Icon 
Path: Search, Type, Directed; Search, Setup 

 

 
 
 

 
 

This dialog box is used to set up search sweeps.   It’s appearance depends on 
the Search Type (page 287).   You should select the search type before 
configuring the sweep. 

 

To print this, see Printing the Directed Search Band Table (page 308). 

1. Band number (1 to 100; use Scroll Bars (page 133) to scroll list) 

2. Status (page 298) 

3. Frequency Entry (page 295) 

4. RBW (page 300) 

5. Shape Factor (page 300) 

6. Averaging (page 301) 

7. Sweep Ratio (page 303) 

8. Tuner Attenuation (page 299) 

9. Antenna (page 298) 

10. Description (page 294) (not displayed in above figure; see Display (page 
307)) 

11. Single- Band Search Setup (page 293) (if only 1 band is selected) 

12. Multi- Band Search Setup (page 305) (if more than 1 band is selected) 

13. Sort Bands (page 306) 

14. Compress Bands (page 307) 

15. Display (page 307) 
 

• OK makes the specified changes and closes the dialog box. 
• Apply makes the specified changes and leaves the dialog box open. 
• Cancel closes the dialog box; no changes are applied. 

 

Note To save a search setup for later recall or to load a previously saved search 
setup, see the discussion of Mission Setup Sections (page 132). 
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Sweep Interval Entry 
 

To change parameter values for one or more bands, 

1. Select the band(s) to modify. 
 

• To select one band, click anywhere on the line (in the list) and then 
click the Modify- Single- Band button (or double- click the line). 

 

• To select multiple bands: 
 

• To select contiguous lines, click and hold the left mouse button, then 
move it up or down the list; or click the first, then press and hold 
the  Shift key and click the last. 

 

• To select non- contiguous lines, press and hold the Ctrl key and click 
the lines. 

 

• To select all bands: 
 

i. Press the Ctrl+Home key.   This takes you to the top of the list and 
selects the first line. 

 

ii. Press Shift- Ctrl+End. 
 

2. Click the Modify- Single- Band button.   (“Single” is “Multiple” if more than 
one band is selected.)   This displays the Single- Band Search Setup (page 
293) or the Multi- Band Search Setup (page 305) dialog box. 

 

3. Modify the parameters you wish to change.   (See dialog boxes noted in 
previous step.) 

 

4. Click OK. 
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Single- Band Search Setup 
 

Path: Search, Type, Directed; Search, Setup 

 

 

 
This dialog box appears when one entry in the directed search setup list is 
selected (click any parameter in the row) and you click the Modify Single 
Band button.   It calls a dialog box that allows you to modify all the 
parameters that appear in the list for a single band. 

 

1. Description (page 294) 

2. Frequency Entry (page 295) 

3. Band Database (page 296) 

4. Status (page 298) 

5. Antenna (page 298) 

6. Tuner Attenuation (page 299) 

7. RBW (page 300) 

8. Shape Factor (page 300) 

9. Averaging (page 301) 

10. Sweep Ratio (page 303) 
 

• OK makes the specified changes and closes the dialog box. 
• Cancel closes the dialog box; no changes are applied. 

 

Sweep frequencies may also be specified via marker positions.   See Marker 
Popup Menu (page 69). 
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Description 
 

This field allows you to describe the band or add a comment. The description 
appears in the list when “Description” is selected in the Display section of the 
Directed Search setup dialog box. 

 

This text also appears, along with the band number, when the mouse’s 
Directed Search Band feature is used in a trace.   See the discussion of the 
Mouse’s Left Tab (page 466). 

 

The description text can contain as many as 39 characters. To change the 
description: 

 

1. Move the cursor into the text box; it should change into a text cursor that 
looks like an I- beam. 

 

2. Position the cursor between characters and click. 
 

3. You can now add characters by typing or delete them by pressing the 
Delete or Backspace keys. 

 

To replace several characters at once, “wipe” them by moving the cursor 
across them while holding down the mouse button and then releasing it. All 
selected characters are replaced by whatever you type. 

 

Note Band descriptions may be deleted when you compress the bands.   See 
Compress Bands (page 307). 
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Frequency Entry 
 

 
 

This dialog box appears when you click a button to enter a frequency or a 
bandwidth.   To enter a value: 

 

1. Enter the frequency value in the text box. The mouse cursor must be 
somewhere in the Frequency Entry dialog box while you type. 

 

2. Click one of the frequency units radio buttons or type h, k, m, or g to 
select Hz, kHz, MHz, or GHz, respectively. You can also enter floating- 
point numbers in the form 1.23e4. 

 

3. Click OK, or press the Enter/Return key. 
 

 If the frequency values are outside the frequency range of the selected 
Antenna (page 298) a warning message is displayed. 

When the search type is directed, the sweep may be defined by more than 
one frequency band.  Frequency bands may overlap and gaps in the frequency 
coverage are allowed.   If the frequency bands overlap, the other parameters 
are evaluated so that the sweep occurs smoothly, using the more stringent 
settings. 

 
 

Example 
 

When two bands share a frequency range but have different RBW or average 
settings, the lower RBW value and the higher number of averages are used. 

  The Directed Search Setup list can be “cleaned up” so that overlapping 
frequencies are broken out.   See Compress Bands (page 307). 

  When the search type is general, the frequency span may be quickly changed 
using the Tune- to- Trace entry in the Trace Popup Menu (page 456). 

Note  Using the Frequency Entry dialog box you can set a search limit frequency 
that is outside of the tuner’s range. If the tuner is unlocked, the N6820ES 
software corrects the out- of- range entry as soon as the “Apply” button is 
clicked. If, however, the tuner is locked, the values are not checked and the 
erroneous value is not corrected. When the tuner is later unlocked, the values 
are checked and the erroneous value is corrected 
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Band Database 

 

 
 

The band database feature is used to define bands by selecting a definition 
from a list.   You can add band definitions to a database (list) or create new 
ones.   The band database is a computer file containing comma- separated- 
values (csv) that define the band setup.   An example is the frequency.csv file 
included with this product. These files can be loaded into the text editor to 
print or change.   The information fields are description, start frequency, stop 
frequency, RBW, and shape factor. 

 
Open This button calls the Filename Entry (page 140) dialog box that lets you load 

a comma- separated variable (csv) signal database file like frequency.csv. 
 

To read a band definition from an existing database: 
 

1. Click Open and select the database file 
(frequency.csv may be found in C:\e3238s). 

 

2. Click Display, which opens a dialog box. See following illustration. 
 

3. Double- click anywhere in line of the entry you want from the database. 
(Or click once on the line and then click OK.) 

 

You can make a new band database by specifying a filename that doesn’t 
already exist and then adding band definitions to it. 

 

• To create a new database file, click Open and specify a filename that does 
not already exist. 

• To add an entry to a database, set up the band definition including 
comments, and click Write instead of Display. 
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Display After a database has been opened, this button displays the database to read 
an entry into the Band Setup dialog box. 

 

 
 

To display a database listing: 
 

1. If “Display” is ghosted, open a database file.   (See previous discussion on 
how to open a database file.) 

2. Click the Display button to display the database. 

3. Click anywhere on the line of the band description you want to use. (The 
dashed focus line around a selection indicates that only one list item may 
be selected at a time.) 

4. Click OK (or double- click in the previous step). 
 

Write Use this button to add the band defined in the setup dialog box to an open 
database file.   A search band database file must be open before you can add 
to it. 

 
Status 

 

This field exists only when the Search Type (page 287) is directed. 
 

• Active means the parameters defined in this band are a part of the 
search. 

• Inactive means that this band are not part of the search. 

 
Antenna 

 

This is a list of active antennas to choose from.   The N6841A RF Sensor has a 
built-in 2 X 1 solid state RF switch and therefore, two different antennas can be 
specified with no external switching.   See System Block Diagram (page 23) for 
more information. 

 

The antennas’ active status, name, gain, and frequency range are assigned in 
Antenna Configuration (page 226).   Only active antennas appear in the list. 

 

If the search frequency span is not within the antenna’s frequency range (as 
specified in the antenna configuration), a warning message is displayed. 



298 

Directed Search Setup 

Single-Band Search Setup 

 

 

 

When the search type is directed, different antennas may be used for 
different parts of the spectrum by using multiple bands to define the sweep 
and specifying a different antenna for each band. 

 

Note If a band has ’no antenna’ specified, the search receiver uses the last antenna 
specified (it doesn’t switch). 
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Tuner Attenuation 
 

Specifies the amount of attenuation used. 

If your system has more than one search receiver (multiple channels) see 
Muti- Channel Attenuation Offset (page 526). 

 

Attenuation 
Ranges 

• N6841A RF Sensor attenuation range is from -16 to 34 dB 

A negative attenuation value is gain. 
 

The attenuation should be selected so that signal energy at the ADC input do 
not result in an overload condition.   This also assumes you know what signal 
levels to expect from the antenna.    

 

Notes • Tuner overloads are not detected by the N6820ES system. 
 

• ADC overloads are detected; they are indicated in the application window 
by changing the Trace Identifier (page 54) background color to red. Also, if 
the marker is on and its location is in a sweep segment created with 
overloaded ADC data, “OVLD” appears in the Marker Readout (page 61). 

 

• When an ADC overload is detected, the tuner is probably overloaded, too. 
You should increase the tuner attenuation to bring the ADC input signal to 
just below the range setting.    

 

For more information, see Antenna Configuration (page 226), System Block 
Diagram (page 23), and ADC Input Range under Setting Sweep Measurement 
Parameters (page 27). 
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RBW 
 

Resolution bandwidth (RBW) is the smallest bandwidth energy that the 
analyzer can resolve (distinguish from other energy around it).   Smaller 
resolution bandwidths give better resolution but also require more memory and 
may slow the sweep, depending on the installed equipment and other settings, 
like averaging.   See Setting Sweep Measurement Parameters (page 27). 

 

Advanced Note The  RBW  resource  size  is  set  in  the  e3238s  resource  file.  The default  resource  is 
8,000,000 points.   Each magnitude value is 4 bytes so this is roughly equivalent to 
32  MB  of  memory.    This  setting  limits  the  RBW×span  value;  as  RBW  gets  smaller, 
the  span  that  can  be  stored  decreases.    For  smaller  RBW  settings  the  memory 
usage  may  be  calculated  by  dividing  the  span  by  the  bin  spacing.  See  the 
discussion  in  Application  Resources  (page  17)  and  the  discussion  of  data  storage 
versus  RBW  in  Setting  Sweep  Measurement  Parameters  (page  27). 

 
Bin Spacing is the frequency spacing between spectral components in an IF 
output signal.   RBW is derived from the values of shape factor and bin 
spacing such that, given the shape factor filter characteristic, bin spacing is 
proportional to resolution bandwidth (RBW).  When the search setup is saved 
with Save Mission Setup (page 129), the values saved are shape factor and bin 
spacing; not RBW. 

 
Shape Factor 

 

Shape Factor is a characteristic of a bandpass filter defined as the ratio of 
the bandwidth at 3dB to the bandwidth at 60dB.   Shape factor is sometimes 
called selectivity. 

 

The shape factor setting affects the resolution bandwidth values available; 
when you change the shape factor, the list of values for RBW change.   You 
should always select shape factor before selecting the RBW. 

 

See the discussion under Setting Sweep Measurement Parameters (page 27). 



Directed Search Setup 

Single-Band Search Setup 

301 

 

 

 

Averaging 
 

Averaging is used to increase the probability of intercepting a signal of 
interest.   Select the type of averaging used and the number of averages to 
take. 

 
Average Type • Off means no averaging is used.   The number of averages has no effect 

until one of the other types is selected. 
 

• RMS (root mean squared) is a power average that reduces the variance of 
each point’s magnitude.   It does not lower the noise floor.   Using larger 
numbers of averages results in larger reduction of random energy but can 
also slow the sweep rate.   See the following advanced note on overlap 
processing. 

 

 
 

where n is the number of samples to average together 
 

 
Use RMS averaging to find energy in a noisy environment or to find weak 
energy near the noise floor.   Do not use RMS averaging to search for 
transient signals. 

 

For RMS averaging, the larger the number of averages, the more the noise 
variance is reduced and the easier it is to distinguish weak signals if they 
are not transient.   Increasing the number of averages may also slow the 
sweep rate, depending on the equipment installed and other settings, like 
RBW. 

 

• Peak averaging displays the largest amplitude value for each frequency 
value.   The number of averages is the number of samples taken.   Use this 
averaging type for transient signals. 

 

For Peak averaging, the number of averages specifies how many samples to 
take while keeping track of the largest signal values.   Increasing the 
number of averages increases the probability of intercepting a transient 
signal. 
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Averages This is the number of samples taken to calculate the selected average type. 
This number is used differently for each type of averaging.  See the discussion 
under Setting Sweep Measurement Parameters (page 27). The menu values 
that are marked with an asterisk (*) indicate values that permit overlap 
processing, described in the next section. 
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Overlap 
Processing 

The N6841A RF Sensor uses overlap processing to offer more averaging 
without impacting measurement speed.

 

Advanced Note              Averaging is performed by collecting multiple blocks of data (the number of blocks 
is determined by the number of averages selected) and passing it all to the onboard 
FPGA. The FPGA performs as many FFTs and average calculations as required 
before sending the spectral data over the network to the host PC.    See the  following  
figure. 

 

 
 

Each block is converted to magnitude data with the FFT function and the 
results are averaged together to get the trace value.   The number of FFTs is 
always the same as the number of averages.    

 
Sweep Ratio 

 

This field exists only when the Search Type (page 287) is directed. 
 

The sweep ratio specifies how often the band is swept with respect to the 
overall sweep rate.   This allows you to sweep one band more often than 
another. 

 

1/1 is the highest setting. Choosing a number like 5 results in a ratio of 1/5, 
which means the band is swept once every 5 times that a band set at 1/1 is 
swept.   To improve the sweep rate for a band, set its sweep ratio to 1/1 and 
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set the other bands’ sweep ratios to a number greater than one. The bigger 
the number, the more times a band is skipped being swept and the more time 
is spent sweeping bands with lower sweep ratios. 
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Multi- Band Search Setup 
 

Path: Search, Type, Directed; Search, Setup 

Multi-Band Search Setup 

 

 

This dialog box functions the same as the Single- Band Search Setup (page 
293) except that you can’t modify frequency or description information. 

To modify a field for more than one band: 
 

1. Select the bands to modify (in the Directed Search Setup (page 291) dialog 
box). 

 

2. Click Modify Multiple Bands (in the Directed Search Setup (page 291) 
dialog box). 

 

3. Click the button left of the field name; the labels on the pull-down 
lists become active. 

 

4. Pull down the option list and select a new value. 
 

5. Repeat the previous two steps for any other parameters you wish to 
modify. 

 

6. Click OK. 
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Sort Bands 
 

Path: Search, Type, Directed; Search, Setup, Sort 
 

 

 
This dialog box allows you to pick the sort criteria and direction of the sort 
and allows limiting it to active bands. 

 

1. Sort On is a list of sort parameters.   This is the primary sort value.   Pick 
the parameter you want the bands sorted by. 

 

• Start Frequency sorts the bands by the value of their start frequency. 
• Center Frequency sorts the bands by the value of their center 

frequency. 
• Stop Frequency sorts the bands by the value of their stop frequency. 

 

If two bands have the same primary sort value (for example, if you select 
Start Frequency and the bands have the same start frequency), the sort 
algorithm uses the secondary sort value to determine the order. See the 
following list: 

 

2. Direction specifies either increasing or decreasing frequency values. 

3. Bands allows you to include or exclude the bands whose status is inactive. 
 

4. Sort:   After setting the above parameters, click this button to perform the 
sort. 
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Compress Bands 

Compress Bands 

 

This button reorganizes the Directed Search Setup list so that bands with 
overlapping frequencies are redefined.  This breaks out the parameters so that 
changes in sweep parameters other than frequency are more easily identified. 

 

Band compression may break up existing bands and create new bands or it 
may combine existing bands.   After the compression, there may be more 
bands or fewer.   See following note. 

 

Note                   Band Descriptions may be deleted by the sort.  If you compress the bands and 
don’t like the results, click the Cancel button and no change will be made. To 
start over, open the Search Setup dialog box. 

 
If the compression creates new bands and the total number of bands exceeds 
100, an error message is displayed that recommends manually changing the 
bands. 

 
 

Display 
 

The Display selection allows you to choose what is displayed in the search 
band list. 

 

Parameters means all of the search band parameters appear in the list.  When 
this is selected, band descriptions are not displayed. 

 

Descriptions means the descriptions are displayed in the list.   When 
Descriptions is selected, the parameters that are not displayed are: 

• average type 
• number of averages 
• sweep ratio 
• tuner attenuation 
• selected antenna 
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Printing the Directed Search Band Table 
 

Printing the Directed Search Band Table 
 

   The Drag- and- Drop Cursor 
 

To print all or part of the search band table: 
 

1. Make sure the text editor pane is active.  See Display Layout (page 422) to 
add or remove panes from the main window. 

 

2. Put the table heads in the text file (optional). 

a. Click on any column head in the table (like RBW) with the middle 
mouse button. 

 

b. Hold the button down (the cursor turns into the drag- and- drop icon). 

c. Drag it to the text editor pane. 

d. Release the mouse button. 
 

3. With the mouse cursor in the text editor pane, press the Enter key to 
move the text cursor (looks like “I”) to the beginning of a new line. 

 

4. Select the bands you wish to print. 

• To select all bands: 

• Click the first band, scroll to the end and Shift+click the last band. 
 

• Click and hold on the first band, move the mouse cursor to just 
below the table window (the list scrolls up), release when the last 
band is selected. 

 

• Press Ctrl+Home on the keyboard (move to top of list and selects first 
band), then press Shift+Ctrl+End. 

 

• To select contiguous bands, click a line in the table with the left mouse 
button and hold, drag the mouse either up or down to select contiguous 
bands, and release the button when you get to the last one you want. 

 

• To select non- contiguous bands, press and hold the Ctrl key and then 
click individual bands. 

 

• To deselect bands, press and hold the Ctrl key and click selected bands. 
 

5. Using the middle mouse button, click any of the selected bands and hold 
the button down (the cursor turns into the drag- and- drop icon). 

 

6. Move the mouse to the text editor pane. 

7. Release the mouse button. 
 

8. Print the file from the text editor as described under File Menu (page 
114). 
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Energy Detection 
 

Toolbar Icon 
Path: Search, Detection Setup... 

 

 

 
 

If your system has more than one search channel installed (option EMC) see 
also the discussion on Energy Detection Dialog Box (page 522). 

 

This dialog box is used to set parameters that detect a signal of interest in the 
measured frequency span. It has two tabs, Threshold and Energy. 

 

It has four components: 
 

1. Energy Detection – a check box that controls whether energy detection is 
active. When detection is active, detection entries are made in the Energy 
History Pane (page 88). 

2. Threshold Tab – This tab displays controls that allow you to control the 
threshold for energy detection. 

3. Energy Tab -  This tab allows you to control the values used to define 
transmitted energy. 

4. Features Tab -  This is allows you to control optionally loaded features. 
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5. Direction Tab -  This tab allows you to control the energy analysis of the 
direction finding option. 

 
Tip No energy is passed to the Energy History Pane (page 88) or the Alarms if 

“Energy Detection” isn’t enabled.   See Process Overview (page 33). 
 

 

Threshold Setup 
 

Path: Search, Detection Setup, Threshold, Off 
 

 
 

 
 
 
Threshold Modes Off means the threshold is not applied. In this case energy bandwidth is 

calculated using the bandwidth criteria described in Energy Criteria (page 
320). 

 

Level (page 311) specifies one value for the entire search range. 
 

Auto (page 313) specifies threshold values based on sweep values to 
approximate the real- time noise floor. 

 

Environment (page 315) uses threshold values defined by measuring the 
environment (can be stored in a file). 

 

File (page 318) uses threshold values stored in a file. 
 

Channel (page 319) specifies that the threshold values are derived from 
another receiver channel. This menu option is only available if multiple search 
receivers are enabled in the e3238s.n6841.cfg file. 
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Tip • Pick a threshold before turning on the energy detection.   If you turn on 
Energy Detection before turning on a threshold, the energy criteria settings 
are used, by themselves, to define energy.   This may create unexpected 
results, like one detected signal whose bandwidth is the same as the entire 
sweep span. 

 

 
 

General 
Information 

Threshold is an amplitude reference that affects the trace display and energy 
detection.  It also plays a role in determining a signal’s measured bandwidth. 
See Energy Criteria (page 320). 

 

The threshold settings affect a trace depending on the trace type: 
 

• For a spectrum trace, the threshold is represented as either a line at the 
threshold value or as a value below which the trace line is not displayed. 
This is selected in the Trace Setup (page 424) dialog box. 

 

• A color spectrogram trace is not affected by the threshold setting. 
 

• If the trace type is spectrogram, the threshold must be on for the trace 
display be meaningful.   See Trace Setup (page 424). 

 

The threshold definition is used, with the energy criteria, to define what 
signals are detected.   If threshold is off, only energy criterion is used.   See 
Energy Detection (page 309). 

 

The selected threshold mode appears on the Mode button. To change the 
mode: 

 

1. Click the mode button; a list of options appears 

2. Click the new mode; the dialog box changes to reflect the selected mode 

Changes made to threshold settings are implemented immediately, and appear 
in the traces (if Threshold Presentation isn’t “Off” in Trace Setup (page 424)) 
so you can see the effects of changes. 

To change the color of the threshold line, see Colors (page 471). 

 
Level 

 

Path: Search, Detection Setup, Threshold, Level 
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Threshold Level is a slider control used to specify one value for threshold for 
the entire search range. 

 

To change the level setting: 

• Click and drag it horizontally with the mouse. 

• Click it and then use the keyboard’s left- arrow and right- arrow keys. 
 

• To move it 1 dB, click in the area between the slider button and the end 
of the slide bar.   Holding the mouse button down scrolls the value. 

 

• To jump the button to a spot on the slide bar, position the mouse cursor 
where you want it to be and click the middle mouse button. Holding the 
mouse button down allows you to drag the slider button. 

 

For information on other threshold modes, see Threshold Setup (page 310). 
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Auto 
 

Path: Search, Detection Setup, Threshold, Auto 
 

 

 
 

 
 
 

 
 

Auto threshold approximates the noise floor of the environment in real time. 
This creates a time- varying or non- level noise floor.   The Auto threshold 
calculations make its sweep slightly slower than Level threshold. 

 

A sweep is composed of anywhere from 1 to 8192 steps or data segments that 
are placed end- to- end to form a trace. Each of these steps is broken into a 
user- defined number of threshold segments and an average is calculated for 
each. These average values are used as the threshold value for the entire 
segment. 

 

The threshold value for each segment is the energy value smoothed with a 
moving average, bounded by the calculated average value and the user- 
specified minimum energy level, and raised by the user- specified margin value. 
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The user- specified smoothing value is used to calculate a moving average, 
where the value is the number of segments either side of the segment whose 
threshold value is being calculated.   If the smoothing value is set to 1, no 
smoothing is applied. 

 

Threshold 
Margin 

Range:   0 to 30 dB.   This specifies the difference between the calculation 
values and the threshold values used, in dB above the trace. 

 

Number of 
Segments 

Range:   1 to 20.   This specifies the number of threshold segments per sweep 
segment.   The larger the number, the more the threshold tracks the trace. 

 

Smoothing 
Factor 

This specifies the number of points used in a moving average. The threshold 
line is created using a moving average and limited by the noise floor estimate 
calculated for each threshold segment. 

 

• To create a threshold that tracks the noise floor as close as possible, 
choose the largest number of segments and the smallest smoothing value. 
This combination can be used to detect the most energy, depending on the 
threshold margin setting. 

 

• To get the smoothest threshold line, choose the smallest number of 
segments and the largest smoothing factor.   This combination may “hide” 
valid signals. 

 

Minimum Signal 
Level 

Range:  - 200 dBm to 50 dBm. This specifies the smallest amplitude value used 
in the calculation. Calculated values less than this are changed to the 
minimum value. 

 

For information on other threshold modes, see Threshold Setup (page 310). 
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Environment 
 

Path: Search, Detection Setup, Threshold, Environment 
 

 
 

This threshold is a sample of the sweep raised by a margin value. 
 

Threshold 
Margin 

This slider control is used to specify how much to raise the threshold above 
its original value.   The selected value is only used at the time you acquire the 
threshold data.   After the data is acquired, this slider control has no effect in 
the current threshold. 

 

Environment 
Control 

This is a group of controls used to create a threshold based on measurements 
taken with the N6820ES Signal Intercept and Collection Software. 

 

• Clear/Idle is a radio button that clears an existing threshold definition and 
idles (deactivates) the creation process. 

 

• Manual Acquire is a radio button that starts acquiring environment data 
and creating a threshold definition.   To end the acquisition, click Apply. 

 

• Timed Acquire is a radio button used to acquire environment data for a 
given period of time.   The time is entered in the Seconds text box 
beforehand.   When the time period elapses, the threshold definition is 
automatically applied.   To change the time value, click in the text box and 
enter the new value. 

 

• Apply is active when Manual or Timed Acquire are used. It is used to end 
a Manual Acquire and can end a Timed Acquire before the specified time 
elapses. 

 

Save Threshold This button calls the Save Threshold (page 317) dialog box, which allows you 
to save the current threshold definition.   Files created this way may be 
recalled with the threshold type:   File (page 318). 
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For information on other threshold modes, see Threshold Setup (page 310). 
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Save Threshold 
 

Path: Search, Detection Setup, Threshold, File, Save Threshold 
 

This dialog box is part of the Energy Detection (page 309) when the threshold 
type is Environment.   It is called by pressing the Save Threshold button. 

 

 
 

This dialog box is much the same as most other Filename Entry (page 140) 
dialog boxes except that it allows you to specify saving the file in binary or 
ASCII format. 

 

The default format is binary, which has a 3:1 file size advantage. Binary files 
cannot be edited or modified. 

 

Saving in ASCII format creates a file that may be viewed and modified with 
an editor such as vi or emacs. The commands that define the threshold are 
described in Appendix A: User- Defined Threshold (page 559). 
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File 
 

Path: Search, Detection Setup, Threshold, File, Save Threshold 

 

 
 

This threshold type uses a file from the system disk as a threshold. 
Threshold files are created by saving to file in the Threshold Environment 
(page 315) dialog box or they may be created as described in Appendix A: 
User- Defined Threshold (page 559). 

 
Threshold Offset This slider is used to add an offset value to the definition loaded with the 

Filename button.   The offset value may be positive or negative. 
 

Filename This button calls the Filename Entry (page 140) dialog box, which allows you 
to specify a file containing a threshold definition.   Such a file may be created 
in the Appendix A: User- Defined Threshold (page 559) mode with the Save 
Threshold button or with an editor as described in Appendix A: User- Defined 
Threshold (page 559). 

 

Note You may specify a threshold file when the Threshold Mode is not File but the 
specified file is not loaded until the Threshold Mode is set to File. 

 
When a mission setup has a threshold filename specified, and the mission 
setup is saved, what is saved is the filename; not the threshold data. If that 
state file is loaded later, be sure the threshold file is also present (e.g., when 
creating a quick configuration to be used on other systems). 

 
For information on other threshold modes, see Threshold Setup (page 310). 
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Channel 
 

 

 
 
 

This threshold type uses energy levels from secondary search receiver 
channels as a threshold.   For these additional channels to be available, the 
system must be configured for multi- channel operation as described in the 
Installation and Configuration Reference under Multi- Channel Hardware 
Installation. 

 
 

When the channel option is selected, the Energy Detection (page 309) dialog 
box displays the Threshold Channel menu shown above. When you click on the 
Channels menu, you can select which channels the energy threshold is derived 
from. In the example above, the system is set up with four receivers. Receiver 
1 is directed to Trace A. 

 

The menu allows you to choose a single channel for a threshold value, or to 
choose a combination of channels. If a combination is chosen, the threshold 
value is the highest value of the combined channels 

 

Threshold 
Margin 

This slider control is used to specify how much to raise the threshold above 
its original value.   The selected value is only used at the time you acquire the 
threshold data.   After the data is acquired, this slider control has no effect in 
the current threshold. 

 

For information on other threshold modes, see Threshold Setup (page 310). 
 
 
 
 
 

Energy Setup 
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Path: Search, Detection Setup, Energy 
 

 
 
 
 

The Energy History tab contains five areas or buttons: 
 

1. Energy Criteria -  Determines the criteria that a signal must meet to 
qualify as "detected energy." 

 

2. Hints -  Allows you to specify areas of a bandwidth to search. 
 

3. Energy History -  This area displays a summary of the current energy 
history. It also allows you to modify the Energy History setup. 

 

4. Modify Energy History -  Allows you to modify the Energy History Setup. 
 

5. Default Settings button -  Clicking this button returns all setting in the 
Energy Setup tab to their default settings. 

 
Tip Clear unwanted energy history entries either with the Clear Energy History 

(page 148) (clears all entries) or with the Delete Entry selection from the 
Energy History > Right- Click Menu (page 106) (clears single entries). 

 
Energy Criteria 

 

Path: Search, Detection Setup, Energy 
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Peak is an amplitude value used to define how much larger a signal must be 
than the threshold (see Threshold Setup (page 310)) or any of the nearby 
nulls to qualify as “detected energy.” 

 

This parameter setting affects marker peak searches and may be used to 
trigger alarms.   See “Amplitude” under Single- Alarm Setup (page 338). 

 

Bandwidth is amplitude setting used to calculate a signal’s bandwidth. 
 

 

 

The Bandwidth criterion is an amplitude value used to determine the 
bandwidth of the detected energy. 

 

1. The detected frequency and amplitude are used as a reference point. 

2. The bandwidth criterion setting (in dB) is used to calculate bandwidth. 

3. The calculated bandwidth is the narrower of following two cases: 
 

• where the sweep data falls to a level equal to the detected amplitude 
value minus the specified bandwidth criterion. 

• where the sweep data crosses the threshold on either side of the 
detected frequency. 

 

4. The frequency value listed in the energy history is the value at the center 
of the calculated bandwidth (not the detected peak’s frequency). 

 
The frequency and bandwidth values (fnew  and BWnew) are passed to the 
energy history.   To enter the data correctly, it must be determined whether 
this should be added as a new entry or used to update an existing entry. 
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Energy history entries are organized by their frequency value.   Each entry 
represents a range with no overlap of range between entries.   The first- 
intercept frequency and bandwidth values for each entry are kept and used 
for comparison with proposed new entries as follows: 

 

• If fnew  falls within the range of an existing entry, the new data is used to 
update the existing entry. 

 

• If fnew  does not fall in the range of an existing entry and there is no 
overlap, a new entry is added using the first- intercept values “as- is”. 

 

• If fnew  does not fall in the range of an existing entry but the range 
represented by BWnew  overlaps the range of an existing entry, the new 
bandwidth is modified so that there is no overlap (BWadj), the frequency is 
modified to be at the center of the new bandwidth range (fadj), and a new 
entry is added having first- intercept values of fadj  and BWadj. 

When the trace grid type is Handoffs (handoff frequencies) or Energy History, 
the bandwidth value is displayed visually in the trace pane as a band of color 
either side of the grid line.   You may have to zoom in on the signal to see it 
if the bandwidth is very small compared to the frequency range being 
displayed in the trace.   See figure below.   See Trace Setup (page 424) to pick 
grid type and Mouse Features (page 507) for information on how to zoom 
scale. 

 

 
 

Notes • The handoff queue is a first- in- first- out list that shifts out the oldest 
entries when it gets   full.   See Handoff Log Pane (page 75). 

• Advanced:   To increase the number of entries in the handoff list, modify 
the resource handoffLogViewLength.   See Handoff Log Pane (page 75). 

• For information on the different ways signals can be handed off, see 
Handoff Log Pane, Handoff Source (page 77). 



Energy Detection 

Energy Setup 

323 

 

 

 

Example This example illustrates how these parameter settings affect energy detection. 
 

 
 
 

Peak Criterion = 15 dB 
 

1. This peak is below the threshold setting; it does not meet the peak 
criteria. 

 

2. This peak meets the peak criteria. 

3. This peak meets the peak criteria. 

4. This peak meets the peak criteria. 
 

5. This peak exceeds the threshold level but by less than the specified peak 
criteria, so it does not meet the peak criteria. 

 

6. This peak meets the peak criteria. 

7. This peak meets the peak criteria. 
 

8. The amplitude of a peak must exceed the lowest nearby null by the peak 
criteria; the null above this one is not 15 dB below the peak, so it does 
not meet the peak criteria. 

 

9. Since the previous peak is not a detectable peak, the null used to define a 
peak is the one between 7 and 8.   Therefore, this peak meets the peak 
criteria. 

 

10. This peak exceeds the threshold level but by less than the specified peak 
criteria, so it does not meet the peak criteria. 

 

Since there is no null above this peak, it does not meet the peak criteria. 
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Bandwidth Hints 
 

Path: Search, Detection Setup, Energy, Bandwidth Hints ... 
 

 
 

This dialog box is used to define parts of the spectrum where signals have 
known center frequencies and bandwidths.   It allows you to specify the 
bandwidth and, optionally, frequency values that are recorded in the New 
Energy Log and the Energy History for energy detected in these bands.  When 
a new peak is detected (one not yet in the Energy History), the values 
recorded for frequency and bandwidth may be those calculated in the Energy 
Detection process or predefined values in Bandwidth Hints. 

 

To change parameter values for one or more table entries, 

1. Select the hint(s) to modify. 
 

• To select one hint, click anywhere on the line (in the list) and then 
click the Modify- Single- Band button (or double- click the line). 

 

• To select multiple hints: 
 

• To select contiguous lines, click and hold the left mouse button, then 
move it up or down the list; or click the first, then press and hold 
the  Shift key and click the last. 

 

• To select non- contiguous lines, press and hold the Ctrl key and click 
the lines. 

 

• To select all hints: 
 

i. Press the Ctrl+Home key.   This takes you to the top of the list and 
selects the first line. 

 

ii. Press Shift- Ctrl+End. 
 

2. Click the Modify- Single- Hint button. (“Single” is “Multiple” if more than 
one hint is selected.) This displays the Single- BW- Hint Setup (page 325) 
or the Multiple- BW- Hints Setup (page 326) dialog box. 

 

3. Modify the parameters you wish to change.   (See dialog boxes noted in 
previous step.) 

 

Click OK. 
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Single- BW- Hint Setup 
 

Path: Search, Bandwidth Hints ... 
 

 
 

Bandwidth hints are defined in Single- BW- Hint Setup (page 325). 

This dialog box appears when one entry in the Single- BW- Hint Setup (page 
325) dialog box is selected (click anywhere in the row) and you click the 
Modify Single Hint button.   It calls the dialog box displayed above, which 
allows you to define or modify a bandwidth hint entry. 

 
Description This field allows you to describe the bandwidth hint or add a comment. To 

enter or change text in the description, click anywhere in the text box and 
then type. The mouse cursor must be within the bounds of the dialog box 
while typing. The number of characters is limited to 32. 

 
Status Active means when new energy is detected between the start and stop 

frequency values, the bandwidth value in the bandwidth hints table is used 
instead of the calculated bandwidth. Also, if Channelize is on, the value used 
for the energy’s center frequency in the Energy History Pane (page 88) and 
the New Energy Log is calculated to be the center of the band. 

 
Start Frequency This value defines the beginning of the frequency range for which bandwidth 

values are specified rather than measured.   When you click the Start 
Frequency button, the Frequency Entry (page 295) dialog box appears. 

 
Stop Frequency This value defines the end of the frequency range for which bandwidth values 

are specified rather than measured.   When you click the Stop Frequency 
button, the Frequency Entry (page 295) dialog box appears. 

 
Bandwidth This is the bandwidth value used in the energy statistics when the hint is 

active.  When you click the Bandwidth button, the Frequency Entry (page 295) 
dialog box appears. 

 
Channelize Yes means the signal’s center frequency is a specified value rather than the 

measured value.   The value is that of the band’s center.   The bands are laid 
out from the start frequency to the stop frequency.   There are as many bands 
as will fit between the two, with any excess in the last one extending beyond 
the stop frequency.   For more information about the automated search 
process, see Process Overview (page 33). 
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Multiple- BW- Hints Setup 
 

Path: Search, Bandwidth Hints ..., (select 2 entries), Modify Multiple Hints 
 

 

This dialog box functions the same as the Single- BW- Hint Setup (page 325) 
dialog box. 

To modify a field for more than one hint: 
 

1. Select the hints to modify (in the Directed Search Setup (page 291) dialog 
box). 

 

2. Click Modify Multiple Bands (in the Directed Search Setup (page 291) 
dialog box). 

 

3. Click the button left of the field name; the labels on the pulldown lists 
become active. 

 

4. Pull down the option list and select a new value. 
 

5. Repeat the previous two steps for any other parameters you wish to 
modify. 

 

6. Click OK. 
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Energy History Setup 

 

 
 

 
 

The Energy History Setup Dialog Box is divided into four sections: 
 

1. Active Energy Setup (page 324)Active Energy Setup (page 328) -  This area 
controls how active energy events are entered into the energy history. 

 

2. Active to Past Energy Transition (page 325)Active to Past Energy 
Transition (page 329)-  This area controls the transition of an entry from 
active to past energy. 

 

3. Past Energy Setup (page 329) -  This area controls how large a memory 
space is devoted to past energy events. 

 

4. Past Energy Removal (page 330) - This area controls how long (in seconds) 
past energy entries are retained. 
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When energy is detected during the energy detection process an entry is 
placed in the Active Energy list. The entry will stay in the Active Energy list 
until removed by any of several methods. 

 

 
 
 

Active Energy Setup 
 

The Active Energy Setup area has the following controls. 
 

Clear on Sweep 
Stop 

When selected, the Active Energy list is cleared when the sweep is stopped. If 
Past Energy is enabled, the Active Energy list entries are copied to the Past 
Energy. 

 

Enable Dynamic 
Entries 

When selected, an Active Energy Entry is allowed to change its bandwidth and 
center frequency on subsequent intercepts as long as it doesn't overlap 
adjacent entries in the Active Energy list. The default mode is to set the 
center frequency and bandwidth only on the first detection. 

 

Maximum 
Number Entries 

Clicking this button displays a dialog box that allows you to select the 
maximum number of simultaneous entries in the Active Energy list. When this 
limit is reached a warning dialog box appears and the pending entry is 
discarded. Overall system performance can be affected by entering too large of 
number. 

 

Minimum 
Storage Time 

Clicking this button displays a dialog box that allows you to set the amount of 
time to store the raw energy information for each Active Energy entry. The 
raw energy information consists of the timestamp, location information 
(Latitude, Longitude, Altitude, and Heading), Frequency, Amplitude, and 
Bandwidth.  For every new intercept, a Raw Energy entry is created until the 
minimum storage time is reached. Once the minimum storage time is reached, 
a new Raw Energy entry is not created, but the oldest is over written. A value 
of zero turns off the storage of Raw Energy entries. 
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Maximum 
Memory Usage 

Clicking this button displays a dialog box that allows you to set the maximum 
memory size that the Active History can grow to. It includes the size of all the 
Raw Energy entries created. 

 
Active to Past Energy Transition 

 

The second area of the dialog box is labeled "Active to Past Energy 
Transition." This area controls how Active Energy entries are removed from 
the Active Energy list. 

 

There are three selection boxes in this section. Clicking on a selection box in 
this area enables the criteria. Multiple criteria can be selected. 

 

After X Seconds 
of inactivity 

Commonly called the Age Filter. When this is selected, if an Active Energy 
hasn't been detected in a specified time, it is removed and placed in the Past 
Energy list. Clicking on the Seconds button in this selection displays a dialog 
box that allows you to specify the permitted length of inactivity. 

 

When duration 
exceeds X 

Seconds 

Commonly called the Duration Filter. When this is selected, if an Active Entry 
has been detected continuously for a specified time, it is removed and placed 
in the Past Energy list. Clicking on the Seconds button in this selection 
displays a dialog box that allows you to specify the permitted duration. 

 

After X Seconds Commonly called the Observation Filter. Once an Active Energy has existed for 
a specified time, it is removed and placed to the Past Energy list. Clicking on 
the Seconds button in this selection displays a dialog box that allows you to 
specify the permitted duration. 

 

Note In previous releases of this software this functionality was implemented using 
Post Filters. The two methods can coexist. When they are used together, the 
Post Filters are executed before these built- in filters are executed. 

 
 

Past Energy Setup 
 

The third frame, labeled "Past Energy Setup," controls the setup of the Past 
Energy list. 

 
Use Past Energy Selecting this enables the Past Energy list. If it is disabled, all Active Energy 

that would pass to the Past Energy list is deleted. 
 

Maximum 
Number Entries 

This sets the maximum number of simultaneous entries in the Past Energy 
list. Once this limited is reached, the oldest entries are removed. Clicking on 
the button in this selection displays a dialog box that allows you to specify 
the maximum number of entries. 

 

Maximum 
Memory Usage 

This sets the maximum memory size that the Past History can grow to. It 
includes the size of all the Raw Energy entries created. Once this limited is 
reached, the oldest entries will be removed. Clicking on the button in this 
selection displays a dialog box that allows you to specify the maximum 
memory size. 
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Past Energy Removal 
 

After X Seconds When selected, any Past Energy that has been present for longer than X 
seconds is removed. If it is unselected, the Past Energy will grow to 
either the maximum allowable number or maximum memory size and 
then the oldest entries are removed. Clicking on the button in this 
selection displays a dialog box that allows you to specify the permitted 
duration. 
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Toolbar Icon 
Path: Search, Energy History Filter 
Option: ASD, User Programming 

 

 
 
 

Background Energy features (characteristics such as frequency, amplitude, bandwidth, 
number of detections, etc.) may be filtered with user- defined, library programs 
before and after they enter the Energy History database. These programs are 
discussed in the N6820ES ASD Programming Guide 
(\E3238s\manuals\program_guide.pdf). 

 

The dialog box shown above is used to control both the pre-filtering and 
post- filtering configuration.   The top half contains the pre-filter controls and 
the bottom half contains the post- filter controls.   The filters shown in the list 
area are example programs furnished with option ASD. 

 

The figure below shows the process diagram centered on the Energy History 
block. The entire system process is discussed under Process Overview (page 
33). 
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The filter programs are written to limit the number of entries in the Energy 
History by either: 

 

• blocking their entry with the energy filter, also called pre-filter 
• removing existing entries with the post- filter 

 

As many as 16 filter functions may be loaded but the maximum number of 
active filters is 5 of each type (pre-filter and post- filter).   Each library 
program may contain both (or either) pre-filter and post- filter functions. 

 

The library program(s) must be listed in the e3238s.n6841.cfg 
configuration file as in the following example: 

 

energyHistoryFilter: C:/e3238s/lib/filterAGE.dll, \ 

C:/e3238s/lib/filterTEST.dll 
 

Dialog Box 
Components 

1. The Enable button is used to turn the filtering on and off. 
 

2. The filter list shows which filters are loaded, describes their function and 
parameter settings, if there are any. 

 

3. The Modify Filter buttons are used to choose which filter functions are 
used and specify their parameter values.   If no filter functions are listed 
or  selected, this button appears ghosted to show that it is inactive.   For 
more  information about the filter modifications, see: 

 

• Energy History Pre- Filter (page 334) 

• Energy History Post- Filter (page 335) 
 

4. The Logic buttons define whether all filter conditions must be met or any 
one condition is sufficient to (for the pre-filter) be added to the Energy 
History list or (for the post- filter) to be removed from the Energy History 
list.   The filter functions return either ‘keep’ or ‘discard’ results.   The 
filter  functions are called sequentially until the selected logic function is 
satisfied,  as follows. 

 

• And means, for the signal to be added to (pre-filter) or removed from 
(post- filter) the Energy History list, all listed filter functions must be 
satisfied.   The first one to return a ‘discard’ result is the last one called. 

 

• Or means the signal may be (pre-filter) added to or (post- filter) 
removed from the Energy History list when it satisfies any listed filter 
function. The first one to return a ‘keep’ result is the last one called. 

 

Adding or 
Changing a 

Filter 

To add a filter function to the list or change parameter values: 
 

1. Click the filter listing you wish to change.   The row is highlighted as 
shown in the first figure above. 

 

2. Click the Modify Filter button.   Another dialog box appears that allows 
you to add or change the filter function and specify its parameter values, 
if there are any.   See Energy History Pre- Filter (page 334) or Energy 
History Post- Filter (page 335). 
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Energy History Pre-Filter 
 

Energy History Pre- Filter 
 

 

 
 

This dialog box appears when you click the Modify Pre- Filter button in the 
Energy History Filter (page 332) dialog box. 

 

Note                      The entries in the option menu depend on the libraries that were loaded when 
the N6820ES program started running. The libraries used to create the figure 
above were loaded with the following two lines in the e3238s.n6841.cfg 
file: 

 
For Windows 
energyHistoryFilter: C:/e3238s/lib/filterAGE.dll, \ 

C:/e3238s/lib/filterTEST.dll 

 
The energy history filter library files may contain either pre-filter or post- 
filter definitions or both. 

 
The contents of this dialog box are determined by the library program written 
by someone other than the people that developed the N6820ES system.   The 
figure above illustrates an example program provided with option ASD, User 
Programming. 

 

For information about how your filters work, see the documentation provided 
with the library programs. 

 

For information about how to create energy history filter programs, see the 
N6820ES ASD Programming Guide1. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 See the \E3238s\manuals\program_guide.pdf file. 
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Energy History Post- Filter 

Energy History Post-Filter 

 

 

 
 

This dialog box appears when you click the Modify Post- Filter button in the 
Energy History Filter (page 332) dialog box. 

 

Note                       The entries in the option menu depend on the libraries that were loaded when 
the N6820ES program started running. The libraries used to create the figure 
above were loaded with the following two lines in the e3238s.n6841.cfg 
file: 

 
For Windows 
energyHistoryFilter: C:/e3238s/lib/filterAGE.dll, \ 

C:/e3238s/lib/filterTEST.dll 

 
The energy history filter library files may contain either pre-filter or post- 
filter definitions or both. 

 
The contents of this dialog box are determined by the library program written 
by someone other than the people that developed the N6820ES system.   The 
figure above illustrates an example program provided with option ASD, User 
Programming. 

 

For information about how your filters work, see the documentation provided 
with the library programs. 

 

For information about how to create energy history filter programs, see the 
N6820ES ASD Programming Guide1. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 See the \E3238s\manuals\program_guide.pdf file. 
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Alarms Setup 
 

Toolbar Icon 
Path: Search, Alarms Setup ... 

 
 
 

 
 

This dialog box is used to define alarms.  There may be as many as 100 alarm 
definitions.   These may be saved and recalled as part of the Mission Setup. 
To save just the alarms, deselect all other parts of the mission definition in 
the Save Mission Setup (page 129) dialog box. 

 

The list of alarms contains 100 entries.   Each of these can be defined 
individually and the Description, Status, Trigger, and Priority settings can be 
modified in groups.   To move up and down through the list, use the Scroll 
Bars (page 133) at the right side of the list area. 

 

The columns of the list are fields defined in the dialog box you call. For more 
information about these fields, see Single- Alarm Setup (page 338). 

 

To change the definition of one or more alarms: 

1. Select the alarm to modify. 
 

• To select one alarm, click anywhere on the line (in the list) and then 
click the Modify- Single- Alarm button (or double- click the line). 

 

• To select multiple alarms: 
 

• To select contiguous lines, click the first entry, press and hold the 
Shift key and click the last. 

• To select non- contiguous lines, use the Ctrl key and click the entries. 

• To select all alarms: 
 

i. Press the Ctrl+Home key.   This moves to the top and selects the first 
line. 

 

ii. Press Shift- Ctrl+End. 
 

2. Click the Modify- Single- Alarm button. (“Single” is “Multiple” if more than 
one alarm is selected.) This displays the Single- Alarm Setup (page 338) or 
the Multiple- Alarm Setup (page 379) dialog box. 

 

3. Modify the parameters you wish to change. 



336 

Alarms Setup  

 

Energy History Post-Filter 
 

4. Click OK. 
 

Clear Trigger is used to rearm a triggered alarm.   When an energy alarm’s 
trigger type is “Once,” the alarm status changes from Active to Triggered when 
the alarm triggers. 

 

To rearm the alarm’s trigger: 

1. Select the alarm by clicking anywhere in the row. 

2. Click the “Clear Trigger” button. 
 

When you clear the alarm the alarm’s status changes back to “Active” 
indicating that it will cause an alarm when the defined alarm condition 
occurs. 

 

• To save the alarm definitions, see Save Mission Setup (page 129). 
 

• To load a set of previously- saved alarm definitions (part of a Mission 
state), see Load Mission Setup (page 127). 

 

• For information about how the system detects energy, see Process 
Overview (page 33). 
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Single- Alarm Setup 
 

This dialog box is used to configure individual alarm definitions.  The features 
shown vary depending on the alarm Type selection that is selected in the 
upper right- hand corner of the dialog box (see figure below).   The two types 
are: 

 

• Energy 

• Signal 
 

For an explanation of the difference between Energy Alarms and Signal 
Alarms, see Search System (page 33). 

 

The following figure is an example Energy Alarm Setup.   Minor differences 
exist when the Alarm Type is Signal, as explained in the discussions of each 
component. 

 

 
 
 

The discussion is broken into the following components: 

1. Description and Alarm Type (page 338) 

2. Control (page 340) 

3. Definition (page 342) 

4. Tasks (page 354) 

 
Description and Alarm Type 
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Description This is a text entry you can use to describe the alarm with up to 32 
characters.   It can be used as a name or a place to hold a brief comment. 
The description appears in the alarms list.   See Alarms Setup (page 336). 

 

To change the description: 
 

1. Move the cursor into the text box; it should change into a text cursor that 
looks like an I- beam. 

 

2. Position the cursor between characters and click. 
 

3. You can now add characters by typing or delete them by pressing the 
Delete or Backspace keys. 

 

To replace several characters at once, “wipe” them by moving the cursor 
across them while holding down the mouse button and then releasing it. All 
selected characters are replaced by whatever you type. 

 
Alarm Type This is used to define the alarm as either an Energy or a Signal alarm. 

• Energy alarms are defined by criteria found in the Energy History. 
 

• Signal alarms are defined by criteria found in the Signal Database.  
 

See Process Overview (page 33) for more information. 

The differences between Energy and Signal alarm types are as follows: 
 

• In the Control block, the Trigger choices are different.   See Alarm Control 
(page 340). 

 

• Also in the Control block, energy alarms may be defined by multiple 
events; signal alarms are defined as single events. 

 

• In the Definition block, the Feature choices are different.   Energy alarm 
features are those found in the Energy History Pane (page 88).   Signal 
alarm features are those found in the Signal Database Pane (page 107). 
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Control 
 

These settings are the high- level definition of the alarm. 

 

 
 

 
Status The alarm status defines whether the alarm definition is checked. This 

parameter appears in the Alarms Setup (page 336) dialog box.   You can 
modify this value for several alarms in the Multiple- Alarm Setup (page 379) 
dialog box. 

 

• Active means when the criteria described by the alarm definition is met, 
the alarm is triggered and recorded in the alarm log, and any associated 
tasks are launched.   See Tasks (page 354). 

 

When an active energy alarm with trigger type “Once” is triggered, the 
status displayed in the Alarms Setup (page 336) dialog box changes from 
“Active” to “Triggered.”   To clear the trigger, see Alarms Setup (page 336). 

 

• Inactive means this alarm definition is ignored when energy is detected. 
 

Trigger This setting constrains the number of alarms triggered by limiting when an 
active alarm condition is checked. 

 

• Always:  The alarm occurs whenever the energy criteria is met, 
without constraint. 

 

• Per Sweep:  The alarm occurs only the first time the alarm is triggered in 
a sweep.  The trigger is re- armed at the beginning of each sweep. 

 

This selection is available only when the Alarm Type is Energy. 

• Once:  The alarm functions differently depending on the Alarm Type: 

• Energy:  The alarm occurs only the first time the alarm conditions are met. 
You must manually clear the trigger before it can trigger again. See 
“Clear Trigger” in the Alarms Setup (page 336) dialog box. 

• Signal:  The alarm triggers only once per database entry. 
 

• Signal Up the alarm occurs when the signal transitions from not- present 
to present in the signal database. 

 

This selection is available only when the Alarm Type is Signal. 
 

Note                       Do not use Signal Up when the signal type includes a character string because 
the signal- up transition occurs before the string is decoded.  In this case, use 
Once or Always.   See Signal Id under Definition (page 342). 

 
• Signal Down the alarm occurs when the signal transitions from present to 

not- present in the signal database. 
 

This selection is available only when the Alarm Type is Signal. 
 

• Signal Up/Down the alarm occurs when the signal transitions to either 
present or not- present in the signal database. 
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This selection is available only when the Alarm Type is Signal. 
To trigger an alarm on new energy, see New Energy under Definition (page 
342). 
To modify this parameter for more than one alarm, see Alarms Setup 
(page 336). 

 
Events An alarm is composed of one to four events; usually only one is used.   This 

selection specifies whether the alarm is composed of one event or more than 
one.   Each event is defined by a set of feature parameters.   When the Events 
setting is Single, the alarm definition is the same as the event definition. 

 

• Single means only one event need be defined to describe an alarm.   This 
is the default selection. 

 

• Multiple means as many as four events may be defined and logically 
combined to define an alarm condition.   The first event is the same event 
used for single event. 

 

Multiple- event alarms can be used when more than one set of energy settings 
are required to detect an alarm condition.   See Multiple- Event Alarm Setup 
(page 377) for more information. 

 
Priority This defines the importance of an alarm.   This information is used to settle 

contention for a limited resource such as a handoff receiver.   The alarm with 
the higher priority gets whatever it needs to complete the defined task. 

 

To modify this parameter for more than one alarm, see Alarms Setup (page 
336). 
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Definition 

 

 
 

 
Schedule This selection specifies when the alarm conditions are monitored. 

• Continuous means the alarm is always monitored. 
• Band: the alarm is monitored between start and stop times specified in 

hours and minutes. See Schedule Setup (page 350). 
• Hourly: the alarm is monitored starting at a specified number of minutes 

past the hour for a duration specified in minutes.   See Schedule Setup 
(page 350). 

• Daily: the alarm is monitored starting at a time specified in hours and 
minutes, for a duration specified in hours and minutes. See Schedule 
Setup (page 350). 

 
Feature An alarm performs one or more tasks when one or more entries in the Energy 

History database satisfies (matches) the alarm’s criteria. 
 

An alarm definition is composed of from one to four events, each of which 
may be defined by one or more signal features.   Usually, an alarm is defined 
by one event, but as many as four may be used.   See Multiple- Event Alarm 
Setup (page 377).   To define an alarm condition: 

 

1. Select a signal feature 

2. Select a feature Type (page 351) (depends on feature) 

3. Select the Criteria (page 351) (greater than, etc.) 

4. Select the boundary values (depends on criteria) 
 

An energy feature is a measured characteristic, like frequency or amplitude. 
Energy feature statistics are tracked and displayed in the Energy History Pane 
(page 88).   Signal statistics are tracked in the Signal Database Pane (page 
107). 

 

For Energy Alarms, features used to define the alarm criteria are: 

• Energy Types 
• Frequency 
• Bandwidth* 
• Amplitude* 
• Duration* 
• Intercepts 
• Detections 
• Occupancy 
• Location 
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• Confidence 
• Count 
• Power 
• Universal 
• Custom features. See Search System (page 33). 

*statistic profile includes current, minimum, average, and maximum values 
 

Notes • User- defined feature extraction is supported with option ASD, User 
Programming. See Process Overview (page 33). 

• If you define an alarm that depends on custom feature values, make sure 
that it is enabled in the Energy Detection dialog box.   No values are 
calculated for features that are disabled in the Energy Detection dialog 
box.   See Energy Detection (page 309). 

 

For Signal Alarms, features used to define the alarm criteria are: 

• Signal Id 
• Location 
• Collection 
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Energy Types 
 

The alarm criteria may be defined based on various energy conditions or 
types.   When the selected alarm Feature is Energy, a button appears beneath 
it labeled Type.   The   types of energy are as follows: 

 

• New Energy means that the alarm is triggered only when the energy 
characteristics meet the alarm criteria on the first intercept. 

 

Care should be taken when using New Energy since most of the feature 
values are being initialized.   For example, First Energy is incompatible 
with setting intercepts > 1 because this combination cannot occur. 

 

• Once Energy means that the alarm is triggered the first time the alarm 
definition is satisfied, which does not necessarily occur on the first 
intercept  (for instance, when the alarm definition specifies intercepts > 4). 

 

This selection constrains the number of alarms triggered to (at most) one 
per energy history entry.   If an entry is removed (e.g., by post filter 
activity) and returns, the alarm condition for Once is reset such that the 
limiting effect of this selection is reduced. 

 

The alarm can be constrained further by setting the alarm’s trigger to 
Once.   See Trigger (page 340). 

 

• Each Energy means the energy triggers the alarm every time it reappears; 
i.e., it goes away and comes back (there was no intercept on the previous 
sweep and there is one on the current sweep). 

 

• Any Energy means any energy that meets all the alarm criteria can trigger 
the alarm without regard to whether it has been detected before. 

 

• No Energy means the alarm is triggered when the energy, as defined by 
an entry in the Energy History Pane (page 88), is not detected and its 
other statistics, as previously recorded in the Energy History, meet the 
alarm criteria.   See also, ASD Impact on Search Processing Loop (page 36). 

 

• Energy Up means that the alarm is triggered when the status transitions 
from not detected to detected. This has the same effect as selecting Each 
Energy. 

 

• Energy Down means that the alarm is triggered when the status 
transitions from detected to not detected (i.e., detected on the previous 
sweep and not detected in the current sweep). 

 

The following figure illustrates how the energy types affect alarm triggering. 

The default Energy Type is Once.   See also, Feature Value Ranges (page 349). 
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All Feature types depend on information in the Energy History Pane (page 
88).   For the special case in which an entry does not exist where you want 
one, you may manually add an entry with the Add feature in the Energy 
History > Right- Click Menu (page 106).   To change the Energy selection, click 
the button and select from the list. 

 
Frequency 

When the alarm Feature is Frequency, two buttons appear beneath it. 

• Type is a list as follows: 
 

• Current means the measured frequency value of the current energy 
intercept. 

• Energy History indicates the first- intercept value of the energy history 
entry.   See the discussion on comparing and modifying first- intercept 
values under Energy Criteria (page 320). 

 

• Criteria allows you to pick ranges as defined in Criteria (page 351). 

Pick an entry from the list and set the appropriate boundary values with 
Frequency Entry (page 295). 

 
Bandwidth 

 

This parameter specifies the bandwidth characteristics of the alarm event. 
The energy bandwidth is determined either by the Bandwidth Criteria setting 
in the Energy Detection (page 309) dialog box, or by the parameters in the 
Single- BW- Hint Setup (page 325) dialog box, when the energy falls into an 
active frequency range. 

 

When Bandwidth is the selected Feature, buttons appear beneath it labeled 
Type and Criteria. Set the boundary values with Frequency Entry (page 295). 

 
Amplitude 

When Amplitude is the selected Feature, buttons appear beneath it labeled 
Type and Criteria.   Set boundary values with Amplitude Entry (page 352). 
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Duration 
 

Specifies the time energy is detected on every sweep.   This differs from 
Intercepts in that intercepts is the number of sweeps in which the energy was 
detected.   See the following illustration. 

Timing Diagram 
 

 
 

 
 
 

When Duration is the selected Feature, buttons appear beneath it labeled Type 
and Criteria. Set the boundary values with Duration Entry (page 353). 

 

• Of the four statistic types, current and maximum duration values are 
updated on every sweep in which energy is detected. 

• Minimum and average duration values are updated when the energy goes 
away. 

• The first time the energy appears it generates maximum and average 
values, but no values for minimum or average duration. 

 

The Duration feature interacts with the Energy feature.   The following figure 
shows when each energy type alarms when Duration is set to between 0.4 and 
0.8 seconds. 
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Intercepts 
 

Specifies how many times the energy has been detected (see the 
Timing Diagram (page 346)).   This is tracked by counting the 
number of updates for an entry in the Energy History Pane (page 
88). Set the boundary values with Numeric Entry (page 353). 

 
Detections 

 

This specifies the number of times the energy has appeared for an 
uninterrupted period of time and then goes away (see the Timing 
Diagram (page 346)).  This is tracked by monitoring activity in the 
Energy History Pane (page 88).   Each time energy appears that was 
not present on the previous sweep, the Detections value is 
incremented. 

 

When the sweep is stopped or the sweep parameters are changed 
with the energy still active, the Detections value is decremented, 
since the energy didn’t go away.   When the energy is detected on 
one sweep and the sweep is stopped before it is detected again, the 
Detection value is zero.   Set the boundary values with Numeric 
Entry (page 353). 

 
Occupancy 

 

This specifies what percentage of the time the energy has been 
detected. Set the boundary values with Numeric Entry (page 353). 

 
Signal Id 

 

This is the signal type.   This is determined by MR1 Modulation 
Recognition and registered in the Signal Database.    

 

This is available only when the Alarm Type is Signal. 
 

Also, a signal type may include specific setup criteria, which may 
be defined in a Setup dialog box.   For example, an alarm may be 
defined such that an FSK signal causes an alarm only when a 
certain symbol rate is detected. 

 

Location 
 

This is signal source information such as is provided by Agilent’s 
N6854A Geolocation Server software.   The type and setup details are 
defined by the user and depend on the area being monitored.  
Detailed setup guidance is provided in this manual.. 

 

This is available only when the Alarm Type is Signal. 
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Collection 
 

This is information associated with the collection of I Q  signal data. This 
alarm format will notify the user when a recording has been made that contains 
a specific text string in the file name.  This string is established during the setup 
of the Energy Alarm which creates the recording.   See the example below. 
 

 
 
If, for example, you wanted to initiate an alarm alerting the operator that 10 
recordings had been made from a specific Alarm, the “Counter” field of the file 
name setup could be used as a string criterion in a collection alarm.  As the 
number of recordings from any alarm increments, the counter will increment in 
each file name.  When the counter reaches “10”, the Collection Signal Alarm will 
trigger. 

 

Collection is available only when the Alarm Type is Signal. 
 

Note            To see a graphic representation of the frequency and amplitude criteria as 
currently specified for all active alarms, see Grid Types under Trace Setup 
(page 424). 

 
Feature Value 

Ranges 
The following tables show valid feature values, types, and boundaries for each 
of the Energy Feature types. 

 
New Energy (Alarm criteria checked first time energy is detected) 

Frequency Current energy frequency 

Bandwidth Current, Min, Max, and Avg are initial BW 

Amplitude Current, Min, Max, and Avg are initial Ampl 

Duration Current, Min, Max, and Avg are set to zero 

Intercepts Always 1 

Detections Always 1 

Occupancy Always 100% 
 

 
Once, Each, Up, or Any Energy (alarm triggered each time energy is 

detected) 

Frequency Current energy frequency 

Bandwidth Current, Min, Max, or Avg Bandwidth 

Amplitude Current, Min, Max, or Avg Amplitude 

Duration Current, Min, Max, and Avg Duration 

Intercepts > 1 

Detections > 0 

Occupancy between 0% and 100% 
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vg BW Amplitude −600 dBm or Min, Max, or Avg Ampl 

Duration 0.0 or Min, Max, or Avg Duration 

Intercepts > 1 

Detections > 0 

Occupancy between 0% and 100% 



Alarms Setup 

Single-Alarm  Setup 

350 

 

 

 

Schedule Setup 
 

This dialog box allows you to enter a schedule value for an alarm definition.  
It appears when you click the Schedule Setup... button in the Single- Alarm 
Setup (page 338) dialog box.   The appearance of this dialog box varies 
depending on the schedule mode selected.   Time values are in a - hour format. 

 

The following illustration is an example. 

 

 

To define a schedule: 

1. Click the mode button.   The list of mode types appears. 

2. Click the entry for the type of schedule you want to use. 

3. Change the numbers in the text boxes to set the start/stop or 
start/duration values as described in Definition (page 342). (The 
Continuous schedule has no numeric parameters.) 

4. Click OK to finish the entry and apply the values. 
 

Notes • You can use Band to specify start and stop times within a 24- hour day 
but the band can’t span midnight.   When the start time is in one day and 
the stop time is in the next, (i.e., stop < start) the values are switched 
such that they fall within the same day. 

 

• To specify a schedule that spans midnight, use Daily which uses a start 
time and duration. 
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Type 
 

The four energy characteristic types are Current, Minimum, Average, and 
Maximum.   These are the energy statistics displayed in the Energy History 
Pane (page 88). 

 

• Current is the value from the most recent sweep. 
• Minimum is the smallest value recorded. 
• Average is the average of all recorded values. 
• Maximum is the largest value recorded. 

 
Criteria 

 

The entries in this list define type of range limits used to define the alarm 
value as follows: 

 

• Any means the alarm event definition is satisfied by energy detected 
anywhere in the swept frequency range.   No boundary values are required. 

 

• Greater Than means the range is defined as all values greater than a 
value.   When “Greater Than” is selected, another button labeled Boundary 
1 appears beneath it that is used to enter the value. 

 

• Less Than means the range is defined as all values less than a specified 
value. When “Less Than” is selected, another button labeled Boundary 1 
appears beneath it that is used to enter the value. 

 

• Between means the range is defined as all values between two specified 
values.   When “Between” is selected, two more buttons appear beneath it 
that are used to enter the values. These are labeled Boundary1 and 
Boundary 2. 

 

• Except means the range is defined as all values outside a range specified 
by two values.   When “Except” is selected, two more buttons appear 
beneath it that are used to enter the values.  These are labeled Boundary1 
and Boundary 2. 

 

• In List appears when the feature being defined is Frequency.   This means 
the frequency must “match” an entry in the specified frequency list. 
“Match” means the frequency lies within the merge range of a listed 
frequency.   See Frequency Lists Pane (page 118). 

 

Note When a match occurs, the frequency value used as the alarm frequency is that 
of the frequency list entry, not the frequency of the detected energy.   For 
example, for detected energy at 1,000,370 Hz and a list entry of 1 MHz with a 
merge range of 1 kHz, there is a match and the alarm frequency is 1 MHz; not 
1,000,370 Hz. 

 
• Not In List appears when the feature being defined is Frequency.   This 

means the frequency list entries are frequencies to ignore; energy at these 
frequencies do not trigger the alarm.   The frequency value is compared 
with the specified frequency list entries using the merge range of the list. 
If the frequency value falls in the range of a frequency list entry ±merge_ 
range.   See Frequency Lists Pane (page 118). 
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Frequency Entry 
 

This dialog box is used to enter a frequency or bandwidth value.   The 
Frequency Entry dialog box (shown below) appears when you click a 
frequency button. 

 
 

 
 
 
 
 
 
 
 
 
 
 

To change the value: 
 

1. Enter the frequency value in the text box.   (The mouse cursor must be 
somewhere in the Frequency Entry dialog box while you type.) 

 

2. Click one of the frequency units radio buttons or type h, k, m, or g to 
select Hz, kHz, MHz, or GHz, respectively. You can also enter floating- 
point numbers in the form 1.23e4. 

 

3. Click OK, or press the Enter/Return key. 
 

Amplitude Entry 
 

This dialog box is used to enter an amplitude value.   It appears when you 
click an amplitude button in a dialog box. 

 

 
 

To change the value: 
 

1. Click the amplitude button you want to change. The Amplitude Entry 
dialog box appears.   (See previous figure.) 

 

2. Enter the amplitude value in the text box.   (The mouse cursor must be 
somewhere in the Amplitude Entry dialog box while you type.) 

 

3. Click one of the amplitude units radio buttons. 
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4. Click OK, or press the Enter/Return key. 
 

Duration Entry 
 

This dialog box is used to enter a duration value as part of an alarm event 
definition.   It appears when the Feature is Duration, Criteria is Greater Than, 
and you click the Boundary button in Single- Alarm Setup (page 338). 

 

 

To change the value: 
 

1. Enter the number of seconds in the text box.   (The mouse cursor must be 
somewhere in the entry dialog box while you type.) 

 

2. Click OK, or press the Enter/Return key. 
 

Numeric Entry 
 

This dialog box allows you to enter a numeric value as part of an alarm event 
definition. (Note that the text above the text box will change to be 
appropriate to the type of value you must enter.) 

 

 
 

To change the value: 
 

1. Enter the number in the text box.  (The mouse cursor must be somewhere 
in the entry dialog box while you type.) 

 

2. Click OK, or press the Enter/Return key. 
 

User- Defined Feature Boundary Entry 
 

This dialog box allows you to enter a floating- point value as part of an alarm 
event definition.   The value is a boundary for a user- defined feature.   The 
units and range of acceptable values is defined by the library program. 

 

To change the value: 
 

1. Enter the number in the text box.  (The mouse cursor must be somewhere 
in the entry dialog box while you type.) 

 

2. Click OK, or press the Enter/Return key. 
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Tasks 
 

This part of the Single- Alarm Setup (page 338) dialog box is used to specify 
the tasks to launch when an alarm is triggered. 

 

The supported tasks are: 

• Handoff Task (page 355) 
• Visual Task (page 357) 
• Audio Task (page 358) 
• Frequency Snapshot Task (page 359) 
• Time Snapshot Task (page 360) 
• Frequency List Alarm Task (page 367) 
• DF Alarm Task (page 367) 
• MR1 Alarm Task (page 374) 
• Perform a user- defined task.   See Alarm Tasks in N6820ES 

ASD Programming Guide1. 

 
Alarm Processing Timing 

 

Alarm tasks are launched as soon as the critical energy information is 
intercepted rather than waiting for the end of a sweep.   Each sweep is 
composed of multiple data segments that are processed individually, from 
interception through alarms, before the next segment is measured.   See the 
following process diagram. 

 

 
 
 
 
 

1 See the \E3238s\manuals\program_guide.pdf file. 
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Handoff Task 
 

 
 

This dialog box is used to specify the handoff receiver and its settings as part 
of an alarm definition.   To activate handing off a signal when an alarm 
triggers, click the button associated with this task in the Single- Alarm Setup 
(page 338) dialog box. See the discussion under Process Overview (page 33). 

 

Frequency and 
Bandwidth 

These frequency values may come from the alarm (the frequency of the energy 
that caused the alarm) or it may be a user- specified value. 

 

If the Control, Events setting is Single, your choice is between Alarm and 
User.   If the Events setting is Multiple, the value may specified by any of the 
four events used to define an alarm condition.   See Events under Control 
(page 340). 

 

To change this parameter: 

1. Click the appropriate button.   An option list appears. 

2. Click one of the entries in the menu.   If you select “User,” the button to 
its right becomes active. 

3. To select a user- defined frequency value, click the button and select a new 
value in the Frequency Entry (page 295) dialog box. 

 

4. Click “OK.” 
 

Duration This selection specifies how long the handoff receiver should monitor the 
signal in seconds.   This value may be changed after the signal is handed off. 
See Handoff Log Pane (page 75) for more information. 
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Detection This selection specifies the type of detection used by the handoff receiver. 
This may have some impact on which receiver the signal is handed to.   The 
detection type can be changed after the signal is handed off.  See Handoff Log 
Pane (page 75) for more information. 

 

When the Alarm Type is Signal (see description on Description and Alarm 
Type (page 338)) this entry appears as shown below. 

 

 

 
 

The detection mode is either User or From Alarm 
 

• User is used to specify a user- defined selection as is normal for Energy 
alarms. 

 

• From Alarm specifies using the detection type derived by a Signal 
I.D. alarm. 

 
Handoff Mode This selection specifies whether the handoff occurs for every alarm that 

occurs (always) or occurs only for signals that are not listed in the handoff 
log (new). 

 

When the handoff mode is new, a signal frequency is checked against all 
frequency values in the handoff log defined by the logged signal’s detected 
frequency and its bandwidth.   A signal is new only when it does not fall 
within the bandwidth of any signal in the handoff log. 

 

Handoff 
Receiver 

This selection specifies which handoff receiver should be used to monitor the 
signal. The label includes the name of the handoff receiver designated in the 
e3238s.n6841.cfg file with the handoffRx.label command. 

 

Record Specifies whether or not to record the audio signal from the handoff receiver. 
This applies only when an audio recorder system is connected to the handoff 
receiver’s audio output; it is not part of the N6820ES system. 

 
AGC Controls the Automatic Gain Control (on/off) if the receiver has it. 

 
Manual Gain Specifies the initial gain in dB for the receiver. 

 
BFO Specifies the initial beat frequency offset (BFO) for the receiver. 

 
Comment This a comment field that may be used to record notes. Limit: 15 characters. 
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Visual Task 
 

This dialog box is used to define the icons and text that appear in the Visual 
Alarms Pane (page 112) as part of an alarm definition. 

 

 
 

Panes are added to or removed from the main window in the Display Layout 
(page 422) dialog box. Icons appear in the pane only if they are active. The 
icons are graphic (picture) files stored on the system disk. 

 

Only alarms with an active status have an icon displayed in this pane.   When 
the alarm is triggered, the icon changes and whatever text was entered for 
that alarm is displayed in the text area. 

 

There are two picture (icon) files associated with an active alarm, but only 
one is displayed at a time.  The Active Icon Filename button is used to specify 
the icon file used when the alarm is not triggered. When the alarm triggers, 
that icon is replaced with another icon, selected with the Triggered Icon 
Filename button. 

 

For more information about the dialog box that appears when you click these 
buttons, see Filename Entry (page 140). 

 

Note For an overview of this task and its place in the system, see Process Overview 
(page 33). 
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Audio Task 
 

This dialog box is used to specify a sound file and the volume settings 
required to cause an audible alarm. 

 

 

 
Filename Calls the Filename Entry (page 140) dialog box to specify the sound file used 

when this alarm is triggered. 
 

The Windows audio API supports .wav, .avi, and any other files supported by 
your Windows multi- media player. 

 

 
 

 
Volume (%) This slider control sets the volume of the sound signal. 

 

Test Audio 
Output 

Press this button to try the audio task setup. 

 

Note The system audio may also be redirected, like the GUI display, to another 
XWindows system when the program is started.   See the discussion Exporting 
Display and Audio under Starting the Program (page 19) for more information. 

 
For an overview of this alarm task and its place in the system, see Process 
Overview (page 33). 
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Frequency Snapshot Task 

This dialog box defines the snapshot capture criteria. 

 

 
 

Frequency and 
Bandwidth 

These frequency values may come from the alarm (the frequency of the energy 
that caused the alarm) or it may be a user- specified value. 

 

If the Control, Events setting is Single, your choice is between Alarm and 
User.   If the Events setting is Multiple, the value may specified by any of the 
four events used to define an alarm condition.   See Events under Control 
(page 340). 

 

To change this parameter: 

1. Click the appropriate button.   An option list appears. 

2. Click one of the entries in the menu.   If you select “User,” the button to 
its right becomes active. 

3. To select a user- defined frequency value, click the button and select a new 
value in the Frequency Entry (page 295) dialog box. 

4. Click “OK.” 
 

Notes • If the bandwidth selection is “From Alarm,” the captured data bandwidth 
is twice measured bandwidth, to assure an adequate representation of the 
entire signal (not just to its 6 dB points).   The measured bandwidth value 
appears in the Energy History Pane (page 88) and the Alarm Log Pane 
(page 87). See also, Calculate Bandwidth under Energy Detection Process 
(page 34). 

• The frequency capture occurs at the end of the sweep in which the alarm 
conditions are met.   The captured data is taken from the current sweep 
data before the next sweep begins. 

 
Filename This button displays the current definition of the snapshot filename construct. 

Click the button to open a dialog box in which you can redefine the construct 
in terms of a variety of parameters.   See Alarm Snapshot Filename (page 
362). 

 

Data files are saved in the Snapshot Directory (page 136) with the name 
given. 
See the ASD Programming Guide1  for information on the snapshot data 
format. 
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Time Snapshot Task 
 

This dialog box is used to capture a piece of time data when an alarm is 
triggered.   See notes. 

 

 
 

Frequency and 
Span 

These frequency values may come from the alarm (the frequency of the energy 
that caused the alarm) or it may be a user- specified value. 

 

If the Control, Events setting is Single, your choice is between Alarm and 
User.   If the Events setting is Multiple, the value may specified by any of the 
four events used to define an alarm condition.   See Events under Control 
(page 340). 

 

To change this parameter: 

1. Click the appropriate button.   An option list appears. 

2. Click one of the entries in the menu.   If you select “User,” the button to 
its right becomes active. 

3. To select a user- defined frequency value, click the button and select a new 
value in the Frequency Entry (page 295) dialog box. 

4. Click “OK.” 
 

Notes • If the span selection is “From Alarm,” the span used is twice the 
measured bandwidth, to assure an adequate representation of the entire 
signal (not just between its 6 dB points). 

• The capture occurs at the end of the current sweep and sweeping is 
suspended until the capture is complete.   The time required is a function 
of the span used and number of samples specified. 

• The data can be demodulated and played with a companion product called 
Snapshot Radio. 

 
Samples This is the number of ADC samples you wish to capture.   The size of the 

capture file is determined by the ADC memory (installed) and data precision 
setting.   See ADC Configuration (page 257).   This setting, combined with the 
sample rate, determines the duration. 

 
Duration This is the amount of time represented by the data file.   The value depends 

on the span (which determines sample rate). 
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When the span is specified as “from alarm” the duration can’t be specified 
because the sample rate isn’t known until the alarm is triggered. 

 
Attenuation This is the tuner (downconverter) attenuator setting used to collect the time 

data.   When the capture is complete, the setting returns to whatever is 
specified in Tuner Attenuation (page 299). 

 
Filename This button displays the current definition of the snapshot filename construct. 

Click the button to open a dialog box in which you can redefine the construct 
in terms of a variety of parameters.   See Alarm Snapshot Filename (page 
362). 

 

Data files are saved in the Snapshot Directory (page 136) with the name 
given. 

See the ASD Programming Guide1  for information on the snapshot data 
format. 
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Alarm Snapshot Filename 
 

 
 

This dialog box is used to define the alarm snapshot filename using the 
parameters shown in the figure above.   The text field at the top shows the 
current construct.   Data files are saved in the Snapshot Directory (page 136). 

 

The filename is made up of as many as ten fields which may contain the 
following individual components.   To define a snapshot filename: 

 

1. In one of the 10 fields (rows) specify a parameter type by clicking one of 
the buttons in the Type column and selecting from the list. shown above. 
The field types are described in the following discussion. 

 

2. (Optional) Some of the parameters can be modified.   To do so, click the 
button next to the one you clicked in step one and make the changes. 

 

3. Repeat as necessary to define the other fields in the snapshot filename. 
 

Empty This disables the field. 
 

Text This is any fixed string. The default text for an alarm snapshot the alarm 
number for frequency snapshots and the word “snapshot” for time snapshots. 

 

To change the text field, click the button which displays the current setting. 
In the figure above, the button displays the “alarm001” string.   See Text Field 
Entry (page 447). 

 
Counter Counter   is an integer value that   increments with each filename created. 

See Counter Field Entry (page 447) 
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Date Places the date and time in the filename.   See Date Field Entry (page 448) 
 

Frequency For time snapshots, only.   Specifies the center frequency at which the data is 
taken.   To collect time data, the downconverter is parked at the marker 
frequency. 

 
Sample Rate For time snapshots, only.   Specifies the effective sample rate at which the 

data is taken. 
 

Span For time snapshots, only.   This is the span value specified in the Time 
Snapshot Task (page 360). 

 
Duration For time snapshots, only.   Specifies the time over which the data was taken. 

 

This value may calculated rather than specified directly.   See the discussion 
under Time Snapshot Task (page 360). 

 
Priority This is the alarm’s priority as specified in the alarm setup.   See the 

discussion of Control in the Single- Alarm Setup (page 338) section. 
 

The choices are Low, Medium, High, and Critical. 
 

Channel Specifies the search receiver channel used to gather the data. Most search 
systems are single- channel. The N6841A RF Sensor provides the ability to 
have more than one search channel (up to four) and facilitate simultaneous 
acquisition of snapshots across all channels. 

 
Extension This is the typical period- three- letter filename extension that most filenames 

use.   See Filename Extensions (page 133). 
 

• Time snapshot files get the extension .cap (short for capture). 

• Frequency snapshot files get the extension .fss (for frequency snapshot) 

There is no choice here other than whether or not to use the appropriate 
extension (and we recommend that this always be the last field).   But, if you 
want a different extension, you can specify a text field containing the 
characters you want. 

The snapshot file data format is described in the Command Reference1. 
 

Write Mode Specifies how the file is created on the disk. 
 

• Write Once means that the specified filename is used only the first time 
the snapshot button is clicked.   When a file with the same name already 
exists, no snapshot data is collected.  If the filename consists of fields that 
change (e.g., counter or date) then new files are created.   To get the effect 
of collecting only one file, you must use filename fields that do not 
change. 

 

• Write Over means that, if the filename exists, the data in the file is 
replaced with new data.   If the filename consists of fields that change 
(e.g., counter or date) then new files are created.   To get the effect of 
having only one file that is overwritten, you must use filename fields that 
do not change. 

 

 
 

1 See the \E3238s\manuals\command_ref.pdf file. 
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• Write New means that the new files do not overwrite existing files.  When 
a file with the same name exists, an extension is added in the form _1, _ 
2, etc.   So if a file named alarm001.cap exists and the filename definition 
specifies that another file of that name is created, the new file is named 
alarm001.cap_1 and the next would be alarm001.cap_2. 
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Time Snapshot Status 
 

This dialog box appears when a time snapshot capture begins if the time to 
capture and write the data to disk is more than one second. The time is a 
function of the number of samples and span requested. 

 

 
 

The snapshot process may be started in two ways: 

• As an alarm task; see Tasks (page 354).  To set up the alarm snapshot, see 
Time Snapshot Task (page 360). 

• From the camera icon in a trace pane.   See Marker Snapshot (page 64) 
and Trace Snapshot Setup (page 438). 

 
Snapshot Setup Indicates the specified frequency and span values and the duration value 

calculated from them. 
 

Note • All search activity stops while time snapshot data is collected. 
 

• The total time to complete the operation also includes the time required to 
write the data to disk, which depends on the IO path back to the 
controller and typically occurs at a rate of about 3 MB per second. 

 
Filename This indicates the name given the file when it is saved to disk. 

 
Status This is a running update of the number of samples taken and the total 

requested.   This is also indicated graphically by the slider gauge and 
percentage reading. 

 
Time Left This indicates the time remaining on the snapshot in progress. 

 

Pending 
Snapshots 

This shows the number of snapshot requests are waiting to be processed. 
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Stop Snapshot 
Save 

This stops the collection of time data and writes the collected data to the 
disk.   This allows the operator to terminate the snapshot early if necessary; 
e.g., the signal goes away.   Note that the process may continue for some time 
while the data is moved from the snapshot memory to the disk. 

 

If another snapshot is pending, its collection begins after the stopped 
snapshot data is saved to disk. 

 

Stop Snapshot 
Don’t Save 

This button stops the collection such that no data is written to disk.   This 
allows the operator to terminate the snapshot more quickly than the 
Stop/Save button. 

 

If another snapshot is pending, its collection begins immediately. 
 

Cancel All 
Snapshots 

This stops the snapshot in progress without saving the data and clears the 
pending queue.   This allows you to resume the search operation quickly. 
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Frequency List Alarm Task 
 

This dialog box is used to modify a system frequency list by either adding a 
frequency to the list or removing one.  The controls allow you to select one or 
the other as well as the list to be modified. 

 

 
 

There is a parameter called Compare Frequency that determines how the 
alarm criteria is compared to the values in a frequency list.   See the 
discussion under the Frequency Lists Pane (page 118). 

 
DF Alarm Task 

 

This dialog box is used to initiate a direction finding task when the alarm 
conditions are met. 

 

 

 
The DF Alarm Task dialog box has three parameters that the user can specify. 
One, two, or all three of these parameters can match the ones used to trigger 
the alarm; or any or all of them can be specified separately. 

 

Frequency The frequency of the signal given to the DF task. 

Bandwidth   The bandwidth of the signal given to the DF task. 
 

Duration   The duration of the signal given to the DF task. This is a three 
element menu. The choices are From Alarm, From User, and Up/Down. The 
first two selections operate as described above. The third option allows you to 
specify that the DF task be active when the signal transitions up or down. 
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Recording Filename 
 

 

 
 

This dialog box is used to define the filename when recording is enabled. The 
text field at the top shows the current construct. Data files are saved in the 
Snapshot Directory (page 136). 

 

The filename is made up of as many as ten fields which may contain the 
following individual components.   To define a snapshot filename: 

 

1. In one of the 10 fields (rows) specify a parameter type by clicking one of 
the buttons in the Type column and selecting from the list. shown above. 
The field types are described in the following discussion. 

 

2. (Optional) Some of the parameters can be modified.   To do so, click the 
button next to the one you clicked in step one and make the changes. 

 

3. Repeat as necessary to define the other fields in the snapshot filename. 
 

Empty This disables the field. 
 

Text This is any fixed string. The default text for an alarm snapshot the alarm 
number for frequency snapshots and the word “snapshot” for time snapshots. 

 

To change the text field, click the button which displays the current setting. 
In the figure above, the button displays the “alarm001” string.   See Text Field 
Entry (page 447). 

 
Date Places the date and time in the filename.   See Date Field Entry (page 448) 
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Frequency For time snapshots, only.   Specifies the center frequency at which the data is 
taken.   To collect time data, the downconverter is parked at the marker 
frequency. 

 
Sample Rate For time snapshots, only.   Specifies the effective sample rate at which the 

data is taken. 
 

Duration For time snapshots, only.   Specifies the time over which the data was taken. 
 

This value may calculated rather than specified directly.   See the discussion 
under Time Snapshot Task (page 360). 

 
Priority This is the alarm’s priority as specified in the alarm setup.   See the 

discussion of Control in the Single- Alarm Setup (page 338) section. 
 

The choices are Low, Medium, High, and Critical. 
 

Azimuth Specifies the line of bearing as is provided by a direction- finding system.  See 
Azimuth (Text) Entry (page 372). 

 
Extension This is the typical period- three- letter filename extension that most filenames 

use.   See Filename Extensions (page 133). 
 

• Time snapshot files get the extension .cap (short for capture). 

• Frequency snapshot files get the extension .fss (for frequency snapshot) 

There is no choice here other than whether or not to use the appropriate 
extension (and we recommend that this always be the last field).   But, if you 
want a different extension, you can specify a text field containing the 
characters you want. 

The snapshot file data format is described in the Command Reference1. 
 

Write Mode Specifies how the file is created on the disk. 
 

• Write Once means that the specified filename is used only the first time 
the snapshot button is clicked.   When a file with the same name already 
exists, no snapshot data is collected.  If the filename consists of fields that 
change (e.g., counter or date) then new files are created.   To get the effect 
of collecting only one file, you must use filename fields that do not 
change. 

 

• Write Over means that, if the filename exists, the data in the file is 
replaced with new data.   If the filename consists of fields that change 
(e.g., counter or date) then new files are created.   To get the effect of 
having only one file that is overwritten, you must use filename fields that 
do not change. 

 

• Write New means that the new files do not overwrite existing files.  When 
a file with the same name exists, an extension is added in the form _1, _ 
2, etc.   So if a file named alarm001.cap exists and the filename definition 
specifies that another file of that name is created, the new file is named 
alarm001.cap_1 and the next would be alarm001.cap_2. 

 

 
 
 

1 See the \E3238s\manuals\command_ref.pdf file. 
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This dialog box appears when you click a button to enter a frequency or a 
bandwidth. 

 

To enter a value: 

1. Enter the frequency value in the text box. 
 

2. Click one of the frequency units radio buttons or type h, k, m, or g to 
select Hz, kHz, MHz, or GHz, respectively. You can also enter floating- 
point numbers in the form 1.23e4. 

 

3. Click OK, or press the Enter/Return key. 
 

Bandwidth Entry 
 

 

 
 

This dialog box appears when you click a button to enter a bandwidth value. 

To enter a value: 

1. Enter the frequency value in the text box. 
 

2. Click one of the frequency units radio buttons or type h, k, m, or g to 
select Hz, kHz, MHz, or GHz, respectively. You can also enter floating- 
point numbers in the form 1.23e4. 

 

3. Click OK, or press the Enter/Return key. 
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Duration Entry 
 

 

 
 
 

This dialog box appears when you click a button to enter a (time) duration 
value. 

 

To enter a value: 

1. Enter the duration value in the text box. 
 

2. Click one of the frequency units radio buttons or type s, m, u, or n to 
select Sec, mSec, uSec, or nSec, respectively.   You can also enter floating- 
point numbers in the form 1.23e- 4. 

 

3. Click OK, or press the Enter/Return key. 
 

Numeric Entry 

 

 
 

This dialog box appears when you click a button to enter a numeric value. 

To enter a value: 

1. Enter the value in the text box. 
 

Integer values (such as intercepts or detections) allow only numeric 
characters (0- 9) and the + and - characters. 

 

Floating- point numbers may (such as percent occupancy) consist of the 
characters 0- 9, +, - , and e or E which indicates exponential (scientific) 
notation such as 3.45e6. 

 

2. Click OK, or press the Enter/Return key. 
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Azimuth (Text) Entry 

 
 

 
 

This dialog box is used to define part of a recording filename. To 

enter a value: 

1. Enter the azimuth filename definition in the text box.   The format is 
specified in printf() syntax.   As shown above, the entry 

AZ_%03.0f_deg breaks down as follows: 

• AZ_ and _deg are text; what you see is what you get. 
• %03.0f is printf() syntax specifying a floating- point value of at least 

three digits, no digits after the decimal.   The leading zero causes 
values   less than 99 to be padded with one or more leading zeros. 

2. Click OK, or press the Enter/Return key.
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MR1 Alarm Task 
 

This dialog box is used to initiate a Module Recognition task when the alarm 
conditions are met. 

 

 

The MR1 Alarm Task dialog box has five parameters that the user can specify. 
These parameters are associated with the task that is added to the modulation 
recognition Mod Rec Pending List (page 403).  Several of these parameters can 
match the ones used to trigger the alarm; and some of them can be specified 
separately. Select “From Alarm” to obtain the value from the energy of the 
signal that generated the alarm. Select “From User” to force the parameter to 
a fixed value. 

 
Frequency The frequency of the signal given to the Mod Rec task. 

 
Bandwidth The bandwidth of the signal given to the Mod Rec task. The Bandwidth value 

and the Oversampling value determine the sample rate. 
 
Oversampling The oversampling rate of the signal given to the Mod Rec task. The 

Oversampling value and the Bandwidth value determine the sample rate.  This 
value is a decimal number between 0.5 and 4. 

 
Duration The duration of the pending request given to the MR1 task. This is a three 

element menu. The choices are From Alarm, From User, and Up/Down. The 
first two selections operate as described above. The third option allows you to 
specify that the MR1 task be dropped when the signal energy transitions up 
or down. 

 

The duration value limits the age of the request for modulation recognition 
and limits the time spent processing the modulation recognition task. It is 
similar to the Aging value in the Mod Rec Pending List (page 403), but also 
applies after a signal is assigned to a channel for processing. 

 

The Up/Down setting allows you to remove the Mod Rec request immediately 
if the energy transitions from present to not present. 

 
Blocksize This menu defines the blocksize of data processed by the Mod Rec task from 

1024 complex pairs to 1,048,576 complex pairs in powers of two. 
 

A blocksize of at least 4096 complex pairs is required to recognize some 
digital modulation formats. 

 

A blocksize of 8192 complex pairs improves recognition of signals with a 
narrow bandwidth relative to the sample rate. 

 

Larger blocksizes take longer to process. 
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Frequency Entry 
 

 
 

This dialog box appears when you click a button to enter a frequency or a 
bandwidth. 

 

To enter a value: 

1. Enter the frequency value in the text box. 
 

2. Click one of the frequency units radio buttons or type h, k, m, or g to 
select Hz, kHz, MHz, or GHz, respectively. You can also enter floating- 
point numbers in the form 1.23e4. 

 

3. Click OK, or press the Enter/Return key. 
 

Bandwidth Entry 

 

 

 
This dialog box appears when you click a button to enter a frequency or a 
bandwidth.  This value and the Oversampling value determine the sample rate 
for modulation recognition processing. 

 

To enter a value: 

1. Enter the frequency value in the text box. 
 

2. Click one of the frequency units radio buttons or type h, k, m, or g to 
select Hz, kHz, MHz, or GHz, respectively. You can also enter floating- 
point numbers in the form 1.23e4. 

 

3. Click OK, or press the Enter/Return key. 
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MR1 Over Sampling Entry 
 

 

 

 
This numeric entry field allows you to specify the oversampling rate. (Can be 
set from 0.5 to 4).  This value and the Bandwidth value determine the sample 
rate for modulation recognition processing. 

 
MR1 Duration Entry 

 

 

 
 

This dialog box appears when you click a button to enter a duration value. 
The duration value limits the age of the request for modulation recognition 
and limits the time spent processing the modulation recognition task. It is 
similar to the Aging value in the Mod Rec Pending List (page 403), but also 
applies after a signal is assigned to a channel for processing. 

 

To enter a value: 

1. Enter the duration value in the text box. 
 

2. Click one of the frequency units radio buttons or type s, m, u, or n to 
select Sec, mSec, uSec, or nSec, respectively. You can also enter floating- 
point numbers in the form 1.23e- 4. Numeric values greater than 9999 are 
converted to scientific notation. 

 

3. Click OK, or press the Enter/Return key. 
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Multiple- Event Alarm Setup 

Multiple-Event Alarm Setup 

 

Path: Search, Alarms, select an alarm, set Events = Multiple 
 

 

 
 

To define an alarm composed of multiple events: 
 

1. Change the Events selection in the Single- Alarm Setup (page 338) dialog 
box to “Multiple.” Two components are added to the Definition pane, as 
above. 

 

2. Click the Equation Setup button and specify the number of events and 
how they are logically combined to define the alarm event. 

 

3. Click an Event Select Button and define it as discussed in Definition (page 
342). 

 

Repeat this last step for each of the events that make up the alarm 
definition. 
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Multiple-Event Alarm Setup 
 

Equation Setup 
 

Path: Search, Alarms, select an alarm, set Events = Multiple, Equation Setup 
 

 

 
 

This dialog box is used to define an alarm with two to four event conditions. 
Each event has its own energy characteristics definitions and the events are 
combined logically to form an equation with AND/OR operators. 

 

Logical results depend on the logic operators as follows: 

• And means the alarm condition is satisfied when the events defined on 
both sides of the logic button are true. 

 

• Or means the alarm condition is satisfied when either event next to the 
logic button is true. 

 

• Parentheses are used to show precedence.   Operations inside the 
parentheses are performed first.   The precedence settings cannot be 
changed. 
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Multiple- Alarm Setup 

Multiple-Alarm Setup 

 

Path: Search, Alarms, select 2 or more alarms, Modify Multiple Alarms 
 

 
 

This dialog box is used to modify parameters for more than one alarm. It is 
part of the Alarms Setup (page 336) dialog box. 

 

1. Select 2 or more alarms as described under Alarms Setup (page 336). 
 

2. Click the selection buttons to specify which of the three parameters you 
wish to modify. 

 

3. Change the parameter settings for the selected parameters. 

4. Click OK. 
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Assign Channel(s) 
 

 

Direction Finding 
 

Toolbar Icon 
Path: Search, Direction Finding ... 
Option: EDF 

 

 

 
 
 
 
 
 
 
 
 

 

This window displays the processing associated with direction finding activity. 

Note that direction finding is not available with option - 113. See Software 
Options (page 10). 

The Direction Finding dialog box is composed of two major sections: 

1. DF Pending List (page 396) 

2. DF Status Display (page 398) 
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DF Pending List 
 

 

 

The DF Pending List displays a list of signals that are waiting to be processed 
by a Direction Finding subsystem. Signals in the pending list from the main 
screen by clicking the marker button Task DF (page 65).   You can also 
configure an alarm task to place a signal in the Pending List as described in 
DF Alarm Task (page 367). 

 
a. Frequency of the DF assignment in the pending list. 

 

b. Priority  of the DF assignment in the pending list.  This can be 
changed by selecting it and clicking the Modify button or right- clicking 
as shown above. 

 

c. Delete   removes the highlighted entry from the Pending List.   If no 
entry is selected (highlighted), this button is ghosted (indicates that it 
is. 

 

d. Modify displays a dialog box used to change the priority of the selected 
item(s). See DF Modify Pending Signal (page 397). 

 

e. Setup displays the DF Setup Pending Signal (page 397) dialog box. This 
allow you to set queue parameters: Aging, Max Queue Length, and 
Merge Frequency. 

 

f. The Pending List popup menu is displayed by selecting one or more 
signals in the list, then right- click (and hold) the highlighted signal. 
This pop- up menu is used to delete the entry from the list or change its 
priority. 
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DF Modify Pending Signal 

DF Pending List 

 

 

This dialog box is used to change the priority of a signal waiting in the DF 
Signal Processing Pending queue. 

 

When the dialog box displays, click on the Priority menu to select the desired 
priority, then click OK. 

 
DF Setup Pending Signal 

 

This dialog box defines the properties of the DF Signal Processing Pending 
Queue. 

 

 

 
 

 
Aging  Specifies whether signals are removed from the pending queue after a period 

of time and the time value. This allows you avoid processing signals that are 
known to have short duration after they have been in the pending queue too 
long. Aging can also be accomplished by setting the DF Alarm Task (page 367) 
duration value. 

 

Max Queue 
Length 

Specifies the maximum number of entries allowed in the pending signal queue. 
When the system has more entries for the pending list than are allowed by 
this setting, the new entries are ignored. 

 

Merge 
Frequency 

Specifies a frequency range within which multiple entries are recognized as 
one.   If a new signal appears within this range of any of the assigned (active) 
or pending entries, the new entry is ignored. 

 

This value is applied to both the high and low sides of the tuned frequency, 
not centered on it. 
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DF Status Display 
 

 

 
 

 
 
 
 
 
 

The DF Status Display displays the results of the DF process.   The DF Status 
Display is composed of: 

 

a. DF Display Menu selects the manner in which the results of the DF 
task are displayed.   See DF Display Menu (page 399) 

 

b. Status Display displays the results of the DF task. 
 

c. Frequency Display displays the center frequency of the currently active 
signal. 

 

d. Bandwidth Display displays the bandwidth of the currently active 
signal. 

 

e. Duration Display displays the duration of the currently active signal. 
 

f. Assign Button displays the Assign DF (page 399), which is used to 
change the attribute(s) of a selected channel. 

 

g. Release Button changes the status of an assigned channel from active 
to idle. 

 

h. Declination Button displays the DF Declination Entry (page 401), which 
is used to describe the system’s declination. 

 

i. Setup Button displays the DF Setup dialog box which is used to set 
parameters for the DF process. 

 

This dialog box varies depending on the DF subsystem installed.   See 
the operation documentation for your DF system. 
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DF Display Menu 
 

The Display Menu controls how the results of the DF Process are displayed in 
the DF Status Display Window. The menu has three selections: 

 
Compass The Compass selection displays a compass rose which shows the direction 

determined for the processed signal. To the left of the compass rose is a 
histogram showing signal strengths through a full 180 degrees. To the right of 
the compass rose is a signal quality bar. The signal quality bar indicates, on a 
scale of 0 to 1, the quality of the signal indicated by the compass rose. 

 
Histogram The Histogram display shows signal activity through a full 360 degrees. The 

left side of the display is 0 degrees and the right side of the display is 360 
degrees.   The Histogram display differs from the Direction display in that, 
signals that are detected remain displayed as time passes. 

 
Direction The Direction display shows recent signal activity through a full 360 degrees. 

The left side of the display is 0 degrees and the right side of the display is 
360 degrees. The Direction display differs from the Histogram display in that, 
as time passes with no new activity the signal indications shrink and 
disappear. 

 
Assign DF 

 

 
 

Frequency   specifies the frequency of the signal to be assigned for direction 
finding processing. 

 

Bandwidth Entry   specifies the frequency of the signal to be assigned for 
direction finding processing. 

 

Duration   specifies the time to be spent processing the assignment. 

• When this is set to 0, a single DF pass is performed. 
• Values larger than 0 cause multiple DF passes, the average of which is 

entered in the signal database, when Database is enabled. 
 

When multiple readings were used to determine the end result, a quality value 
(based on standard deviation) is also entered with the result. 

 

Priority. defines the channel’s priority level within the channel list.   The 
available values are:   Low, Medium, High, Critical. Changing the priority could 
be used to avoid having the channel assignment changed (bumped) by a signal 
with a higher priority. 

 

Database   specifies whether the results are added to the Signal Database. 
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This numeric entry dialog box is used to specify the system’s longitude. 
Enter a value from +180 to - 180. 

 
DF Latitude Entry 

 

 

 
 

This numeric entry dialog box is used to specify the system’s latitude. 
Enter a value from +90 to - 90. 
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DF Declination Entry 
 

 

 
 

This numeric entry dialog box used to specify the system’s declination. 
Enter a value from +180 to - 180. 

 

The magnetic declination (or magnetic variation) at any point on the earth is 
an angle that must be added or subtracted in converting between the direction 
of the indicator on a magnetic compass and the direction of the earth's lines 
of longitude. 
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DF Status Display 
 

 

Modulation Recognition 
 

Toolbar Icon 
Path:   Search, Modulation Recognition ... 
Option: MR1 

 

This section describes the MR1 modulation recognition library. This window 
displays the processing associated with modulation recognition activity. 

 

Note that modulation recognition is not available with option - 113. See 
Software Options (page 10). 

 

 
 
Note                This dialog box may be created by a user- defined library that differs from the 

library used to create the box documented here. If so, what appears here may 
differ from the your dialog box. 

 
The Module Recognition dialog box is composed of four major sections: 

1. Mod Rec Pending List (page 403) 

2. Active List (page 404) 

3. Monitor Display (page 413) 

4. Results (page 414) 
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Mod Rec Pending List 

Mod Rec Pending List 

 

The Pending List displays a list of signals that are waiting to be assigned to a 
Modulation Recognition process. You place signals in the pending list from the 
main screen by clicking on the marker button Task Mod Rec (page 66). You 
can also configure an alarm task to place a signal in the Pending List as 
described in MR1 Alarm Task (page 374). 

 

 
 

Frequency shows the pending signal’s frequency. 
 

Priority shows the pending signal’s current priority.   This can be changed 
with the Modify button or using the popup menu. 

 

The Pending List popup menu is displayed by selecting one or more signals in 
the list by clicking on it, then right- clicking on that highlighted signal. This 
pop- up menu allows you to delete the entry from the Pending List or change 
that entry’s priority. 

 

Beneath the Pending List are three buttons: 
 

a. Delete Clicking on this button removes the highlighted entry from the 
Pending List. If no entry is selected (highlighted), this button has no 
effect. 

 

b. Modify Clicking on this button displays a dialog box used to change the 
priority of the selected item(s). 

 

c. Setup Clicking on this button displays the Mod Rec Setup Pending 
Signal (page 404) dialog box. This allow you to set queue parameters: 
Aging, Max Queue Length, and Merge Frequency. 
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Mod Rec Modify Pending Signal 
 

 
 

This dialog box is used to change the priority of a signal waiting in the Signal 
Processing Pending queue. 

 

When the dialog box displays, click on the Priority menu to select the desired 
priority, then click OK. 

 
Mod Rec Setup Pending Signal 

 

This dialog box defines the properties of the Signal Processing Pending Queue. 
 

 
 
 

Aging  Specifies whether signals are removed from the pending queue after a period 
of time and the time value. This allows you avoid processing signals that are 
known to have short duration after they have been in the pending queue too 
long. Aging can also be accomplished by setting the MR1 Alarm Task (page 
374) duration value. 

 

Max Queue 
Length 

Specifies the maximum number of entries allowed in the pending signal queue. 
When the system has more entries for the pending list than are allowed by 
this setting, the new entries are ignored. 

 

Merge 
Frequency 

Specifies a frequency range within which multiple entries are recognized as 
one.   If a new signal appears within this range of any of the assigned (active) 
or pending entries, the new entry is ignored. 

 

This value is applied to both the high and low sides of the tuned frequency, 
not centered on it. 

 

 

Active List 
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This is the list of current signal processing channel assignments. 
 

 
 

The Active frame displays the currently active signals being processed by the 
Mod Rec software. It is composed of a channel list and several buttons. These 
are described in the following paragraphs. 

 

The Channel list is composed of: 

Chan is the channel number.   Channels are assigned to signal types when the 
N6820ES program first starts. The MR1 library is limited to one channel. 

 

Frequency describes the channel’s tuned center frequency.  This may be from 
a signal alarm or it may be assigned manually by clicking the entry and then 
clicking the Assign Channel(s) (page 390) button. 

 

Bandwidth describes the channel bandwidth. This value can be taken from a 
signal alarm or it can be assigned manually. 

 

Sample Rate describes the rate at which the signal is sampled. This rate is 
calculated from the bandwidth and oversampling. This rate can be changed by 
specifying oversampling. 

 

Blocksize is the size of the data block upon which the modulation recognition 
process works. The blocksizes range from 1024 complex pairs to 1,048,576 
complex pairs in powers of two. 

 

Priority defines the channel’s priority level. 
 

Note Locked channels begin processing when the sweep starts.   Channels that are 
not locked begin processing when they are assigned.   If you stop the sweep 
and restart it, unlocked channels will not start processing when the sweep 
restarts.  When channels are manually assigned, lock them to assure that they 
start and run properly. 

 
Status the channel is either Active (processing) or Idle (unassigned). 

Idle- to- Active transition occurs when: 

• Signal assignment enters the Pending list (if not locked) 
• Manual assignment or reassignment occurs 
• Sweep is turned On (if locked and a frequency is associated with it) 

Active- to- Idle transition occurs when: 

• Age release occurs (if not locked). 
• No- signal (if not locked; also has a time delay like age) 
• Manual release occurs 
• Sweep is turned Off (i.e., the search receiver stops sweeping) 
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The buttons on the Active frame are: 
 

a. Assign displays the Modulation Recognition Assign (page 407) dialog 
box, which is used to change the attribute(s) of a selected channel. 

 

b. Release changes the status of an assigned channel from active to idle. 
 

c. File displays the Playback Control (page 392) dialog box which allows 
you to process a previously captured signal.  The playback files must be 
first   selected and loaded with the Assign Mod Rec dialog box. 

 

d. Lock changes the priority of a channel so that it won’t be assigned a 
different frequency. 

 

e. Unlock changes the priority of a locked channel so that it may be 
reassigned. 

 

f. Setup displays the Modulation Setup dialog box, which is used to set 
parameters for the recognition process.   See Signal Recognizer Setup 
(page 410). 
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Modulation Recognition Assign 
 

This dialog box allows you to change the Modulation Recognition channel’s 
parameters or to process a captured signal stored in a file. 

 

 

 
The Live Data Clicking this button assigns live data to the channel. Clicking on this button 

also activates the Frequency and Bandwidth boxes. 
 

Frequency Entry. Click in this box, then type in the frequency of the signal 
you are assigning to the Modulation Recognition process. 

 

Bandwidth Entry. Click in this box, then type in the bandwidth of the signal 
you are assigning to the Modulation Recognition process. 

 
File Data button Clicking on this button to assigns time data from a snapshot capture file to 

the channel. Clicking on this button also activates the Filename, Single Step, 
and Continuous Loop option in the dialog box. 

 

Filename Entry. Click in this box, then type the filename of the file that you 
wish to assign to the Modulation Recognition process. You can also use the 
Filename browser button to pop up the filename browser box. 

 

Single Step Button. Click on this button to play the data recorded in the file 
through the Modulation Recognition process a single time. 

 

Continuous Loop. Click this button to play the data recorded in the file 
through the Modulation Recognition process repeatedly. 

 
Over Sampling This numeric entry field allow you to specify the oversampling rate. (Can be 

set from 0.5 to 4.) The actual sample rate is proportional to the bandwidth 
multiplied by the oversampling setting, but is limited to the capabilities of the 
ADC. 
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Priority Menu This menu defines the channel’s priority level within the channel list. The 
available values are:   Low, Medium, High, Critical. Changing the priority could 
be used to avoid having the channel assignment changed (bumped) by a signal 
with a higher priority. 

 
Blocksize Menu This menu defines the blocksize of data processed by the Mod Rec task from 

1024 complex pairs to 1,048,576 complex pairs in powers of two. A blocksize 
of at least 4096 complex pairs is required to recognize some digital 
modulation formats. A blocksize of 8192 complex pairs improves recognition of 
signals with a narrow bandwidth relative to the sample rate. Larger blocksizes 
take longer to process. 

 
Database Menu This menu allows you to enable saving the results of the Mod Rec task signal 

information in the signal database. 
 

Duration Entry This entry allows you to specify the maximum length of time to process the 
modulation recognition assignment. Processing can end earlier than the 
duration time if Database is enabled and the signal is identified. 
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Modulation Recognition Active Setup 
 

 

The Modulation Recognition Active Setup dialog box allows you to set or 
specify the following values. 

 

Snapshot 
Interval 

This menu specifies how often the system stops the search to take a snapshot 
(collect time data).   To take the snapshot the system reconfigures the tuner 
and ADC, which interrupts the sweep. The values allowed are every sweep, 
every second, third, fifth, tenth, and 20th sweep. 

 

Decision Criteria This menu   specifies whether the recognition process uses a specific number 
of measurements (specified in the box just beneath) to assess the signal of 
interest, or uses a simple majority vote. 

 

• Number of Measurements   when this menu option is selected, the Mod 
Rec task processes that number of measurements. It then classifies the 
modulation type based on the type that is reported most frequently. 

 

• Simple Majority   when this menu option is selected, the Mod Rec task 
continues making measurements until more than half the results report 
the  same modulation type. If no type attains a majority, the measurements 
continue until the duration expires. 

 
Measurements This numeric entry box specifies the number of measurements the recognition 

process uses to determine the modulation type. 
 

Algorithm Specific Setup. This button displays the Signal Recognizer Setup 
(page 410) Dialog Box. 
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Signal Recognizer Setup 
 

 

 
 

This dialog box controls the parameter settings for the modulation recognition 
algorithm being used.   In the MR1 library the parameters are: 

 
Auto Tuning When Auto Tuning is ON, the algorithm can recognize signals that are not 

centered within the frequency span. For this feature to function properly there 
should be no other signals within the frequency span and the signal of 
interest should occupy at least 1/10 of the frequency span. 

 

When Auto Tuning is OFF, the Mod Rec task must be assigned with an 
accurate frequency (within 5% of the frequency span) and the signal should 
occupy at least 33% of the frequency span. 

 
Equalizer This enables a “blind” equalizer.   This process builds and applies an 

equalization filter.   The equalization filter can improve detection of high- 
density digital modulation types that have become distorted.  This equalization 
filter can slow Mod Rec processing, so it should only be used when the 
modulation type “Unknown Digital” is reported.   See Modulation Type (page 
414). 

 
Burst Detect Burst Detect enables the recognition signals with bursts of modulation, such 

as Time Division Multiple Access (TDMA) signals. When Burst Detect is On, 
the modulation recognition algorithm only analyzes the portion of the time 
record that contains the burst. When Burst Detect is Off, the entire time 
record is processed. A larger BlockSize may be needed when Burst Detect is 
On. 

 
Squelch Sets the minimum signal- to- noise ratio (SNR) for modulation recognition 

results. Signals with an SNR below this value are classified as unknown. A 
default value of 2 dB is recommended.  In difficult environments (for example, 
installations rich in computer spurs) larger values can help reduce the number 
of false identifications.   Squelch values larger than 5 dB inhibit the 
recognition of low SNR signals. 

 

Adjacent 
Channel 

Interference 
Filter 

Allows recognition of signals when adjacent channels are occupied. When 
enabled, the NRC algorithm constructs a tight filter around the signal nearest 
the frequency span’s center and processes that signal.   The signal of interest 
should occupy at least 10% of the frequency span.   In this mode the NRC 
algorithm cannot estimate the channel's noise level, so you must enter a Noise 
Floor value for the SNR computation (described below). 
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When the Adjacent Channel Interference Filter is off, the algorithm uses the 
spectrum outside the signal- of- interest to automatically estimate the noise 
level. 

 

Note                    Adjacent Channel Interference Filter can be used only on signals with single- 
peak spectra. It cannot be used on FSK or other multi- peak signals because 
it selects the peak nearest the frequency span center as the signal- of- interest 
and rejects the other valid signal peak or peaks. 

 
 

Detect Margin When the Adjacent Channel Interference Filter is enabled, this value is used 
to determine the presence of signal.   Detect Margin is the level in dB above 
the Noise Floor value required for a signal to be detected and recognized.   A 
default value of 5 dB is recommended.   If you need to recognize only strong 
signals, this value can be raised by several dB to increase throughput. 

 
Noise Floor When the Adjacent Channel Interference Filter is enabled, the algorithm uses 

this value as a noise level estimate for the channel.   This noise level is used 
in the computation of SNR and is the reference level for Detect Margin.  
Units are in dB of noise power density. 

 

To measure the noise floor, use the procedure described in Measuring the 
Noise Floor (page 412). 
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Measuring the Noise Floor 
 

Agilent provides a special marker pane that can be used to measure the noise 
floor. To display this pane, click the Display Layout (page 422) button and 
select the Noise Marker entry for the pane beneath the Trace A pane. 

 

Note You must enable the Noise Marker Pane by uncommenting out the following 
line in the C:\E3238s\e3238s.n6841.cfg file. 
userPane: C:\e3238s\lib\noiseMarker.dll 

 

 
 

The following procedure assumes that Trace A is displayed and the marker in 
Trace A is on. To determine the noise floor: 

 

1. Position the marker on the noise floor between signals. 
 

2. Click the Restart Averaging button and wait for two or three sweeps to 
occur. 

 

3. Read the Noise Density value from the Noise Marker pane, then enter this 
value into the Noise Floor entry box of the Signal Recognizer Setup (page 
410). 

 

The Noise Density measurement requires averaging of accumulated values 
gained on successive sweeps. With every sweep you should see less change in 
the Noise Density value. 

 

The averaging is an exponential algorithm. If you have changed the feed or 
sweep rate recently, there will be a lot of measurement data that is unusable. 
To clear this information, click on the Restart Averaging button. 

 

Note that just moving the marker restarts the averaging process. If you haven’t 
changed the signal or sweep setup, you don’t need to click the Restart 
Averaging button 
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Monitor Display 

Monitor Display 

 

The Monitor Display section of the Module Recognition screen shows the 
spectrum of the current active signal. 

 

 
 

The Display section has the following elements: 

• Spectrum Menu 
• Display window 
• Trace Scale Values 
• Amplitude Autoscale Button 
• Frequency Full Scale Button 

 
Spectrum Menu This display currently has only one entry, Spectrum. 

 
Display Window The Display Window displays the spectrum of the signal being processed by 

the Mod Rec task. 
 

Trace Scale 
Values 

The numbers at the left side of the trace screen describe the amplitude range 
of the spectrum trace type. The numbers at the bottom of the trace screen 
describe the frequency range of the trace.   These values can be changed by 
clicking on any of the values, or by clicking the scale buttons. 

 
 

Amplitude 
 Autoscale 

Button 

This button appears in the bottom- left corner of a trace pane. It sets 
the minimum and maximum amplitude values so that all of the trace is 
displayed.  This button does not change the frequency span. 

 
 

Frequency Full 
 Scale Button 

 

This button appears in the bottom- left corner of a trace pane.   It sets 
the trace’s frequency scale to match that of the snapshot bandwidth. 
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Results 
 

 

 

The Results frame displays the result of the modulation recognition process. 
The results are displayed as a histogram, or bar chart. The following displays 
show the current status of the active signal: 

 
Modulation Type This is the best estimation of the type of modulation being used by the signal. 

The modulation type and notes related modulation types are listed in 
Modulation Types. 

 
Frequency This is the center frequency of the signal. 

 
Bandwidth This is the bandwidth of the signal. 

 
SNR This is the signal- to- noise ratio of the signal. When the Adjacent Channel 

Interference Filter in the Signal Recognizer Setup (page 410) is off, the SNR is 
automatically computed from the noise level of the spectrum adjacent to the 
signal. When the Adjacent Channel Interference Filter is on, the SNR is 
relative to the value entered for ACI Noise Floor. 

 
Symbol Rate This is the symbol rate for digital modulation formats. 

 
Deviation Deviation is the peak frequency deviation for FSK formats. This value can be 

converted to FSK tone spacing using the following rules: 
 

• MSK or FSK: Multiply the deviation value by 2 

• 4- FSK: Multiply the deviation value by 2/3 

• 8- FSK: multiply by 2/7 
 

Clear/Refresh Beneath the histogram are located the following buttons. 
 

• Clear Clicking the Clear Button clears the results display and the results 
list. 

 

• Results Clicking the Results button pops up the Mod Rec Results Dialog 
Box. 
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Results Dialog Box 

Results 

 

 
 

The Modulation Recognition Results Dialog Box displays a scrolling list of 
results of the Mod Rec task. This dialog box displays the same information as 
that displayed to the left of the Histogram, but in form that allows you to 
scroll back through entries. This information is captured in the signal database 
if the signal database is enabled. 
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Modulation Types 
 

The MR1 library attempts to categorize signals as one of the following types: 
 

Analog Modulation Types: 

Modulation Type Description 

AM 
(Amplitude 
Modulation) 

 
 
 
 

 
AM DSBSC 
(Amplitude 
Modulation/Double 
Side- Band 
Suppressed 
Carrier) 

LSB 
(Lower Single 
Side- Band) 

 

 
USB 
(Upper Single 
Side- Band) 

 

 
Analog FM 
(Analog Frequency 
Modulation) 

Amplitude modulated RF carrier.   Usually carries speech, 
music, or other audio.   Can also carry analog data, such 
as telemetry, fax, or imagery such as slow- scan television 
(SSTV).   Wider bandwidth AM (wider than normal audio 
bandwidths of 4 – 25 kHz) probably carries data.   May be 
identified as Pure Carrier during silences or low- level 
modulation inputs. 

Similar to AM, but with the carrier suppressed to achieve 
greater power efficiency.   Requires special carrier- 
insertion receiver processing to retrieve intelligible 
speech/traffic. May be identified as NOISE or UNKNOWN 
during silences or low- level modulation inputs. 

 

 
Similar to AM, but with carrier and the upper side- band 
suppressed.   More likely to carry speech than any form of 
analog data.   May be identified as NOISE or UNKNOWN 
during silences or low- level modulation inputs. 

Similar to AM, but with carrier and the lower side- band 
suppressed.   More likely to carry speech than any form of 
analog data.   May be identified as NOISE or UNKNOWN 
during silences or low- level modulation inputs. 

Frequency modulated RF carrier.   Usually carries speech, 
music, or other audio.   Can also carry analog data, such 
as telemetry, imagery, or sensor data.   Can also carry 
digital data, such as multi- tone modulations or multi- level 
FSK if other than 2, 3, 4, or 8FSK.   May be identified as 
Pure Carrier during silences or low- level modulation. 

Manual Morse Morse code at word- per- minute (WPM) rate ranging from 
35 WPM to 150 WPM.   May be identified as Pure Carrier 
during tune- up (long dash), and NOISE or UNKNOWN 
during long keying pauses. 

Machine Morse Morse code at word- per- minute (WPM) rate ranging from 
35 WPM to 150 WPM.   May be identified as Pure Carrier 
during tune- up (long dash), and NOISE or UNKNOWN 
during long keying pauses. 

Noise This message indicates that the algorithm failed to detect 
any signal structure, or found only very weak structure 
with noise characteristics dominating.   Often indicates a 
very low SNR input. 
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Analog Modulation Types-  cont. 

Modulation Type Description 

Pure Carrier Unmodulated carrier, indicative of idle signal or signal 
during tune- up.  Other modulation types may be identified 
as Pure Carrier if the Bandwidth (which controls Sample 
Rate) is too large. 

Unknown This message indicates that algorithm detected signal 
structure, but could not find a clear match to any of the 
supported modulation types.   Often indicates low SNR or 
co- channel interference (overlapped signals).   Can also 
indicate signal distortion, such as caused by multipath 
reception.   Some modulation types may be identified as 
Unknown if the Bandwidth (which controls sample rate) is 
too small, causing a portion of the signal spectrum to be 
missed. 

Unknown Digital This message indicates that algorithm acquired carrier and 
symbol sync, but was unable to resolve the constellation of 
the signal due to severe spreading of the constellation 
points. Constellation spread is usually caused by low SNR, 
co- channel interference, distortion effects such as 
multipath reception, or combinations of these factors.  The 
signal could be any form of QAM or any form of PSK, or 
an unsupported digital signal.   Enabling the Equalizer 
(page 410) filter may allow detection. 

 

 
 

Digital Modulation Types -  Phase Shift Keying: 

Modulation Type  Description 

BPSK 
(Binary Phase- 
Shift Keying) 

QPSK 
(Quadrature 
Phase- Shift 
Keying) 

Two- level phase- shift keying (PSK) used to transmit digital 
data at 1 bit per symbol. Related to QPSK, 8PSK. Used in 
satellite links. 

Four- level phase- shift keying (PSK) used to transmit digital 
data at 2 bits per symbol.   Used in satellite links. 

PI/4 QPSK Modified QPSK with a 45- degree constellation phase- 
reference shift on alternate symbols.   Widely used (for 
example by IS- 136 “digital AMPS” cellular) to transmit 
digital data at 2 bits per symbol with tighter sidelobes than 
standard QPSK. 

8 Level PSK Eight- level phase- shift keying (PSK) used to transmit 
digital data at 3 bits per symbol 

16 Level PSK Sixteen- level phase- shift keying (PSK) used to transmit 
digital data at 4 bits per symbol.  Requires high SNR at the 
receiving node to achieve a reliable data link. 
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Digital Modulation Types – Frequency Shift Keying: 

Modulation Type  Description 

FSK 
(Frequency- Shift 
Keying 

 
 
 
 
 
 
 
 
 

MSK 
Minimal- Shift 
Keying 

Two- level frequency- shift keying (FSK) used to transmit 
digital data at 1 bit per symbol by switching between two 
frequencies.   Also called Binary FSK (BFSK).   Includes 
coherent (continuous phase) FSK and non- coherent FSK, 
without distinction.   Covers a wide range of modulation 
index (D/B), ranging from D/B=0.35 to D/B=20.   D/B 
represents the frequency deviation to bit rate ratio.   The 
frequency deviation (also called frequency shift) is the 
separation between the mark and space frequencies, and 
the bit rate is the signal keying rate.   Related to MSK. 

Minimal- shift keying (MSK) is defined as binary FSK with 
D/B value less than or equal to 0.6.   This is a modern, 
spectrally efficient (narrowband) form of FSK.   This 
includes Gaussian minimal- shift keying (GMSK) such as 
used by GSM, as well as staggered QPSK (SQPSK) signals. 

3 Level FSK Three- level frequency- shift keying used to transmit digital 
data at 1 bit per symbol.   The third state is used either as 
a  resting frequency or to send parity information to help 
detect or correct errors 

4 Level FSK Four- level frequency- shift keying used to transmit digital 
data at 2 bits per symbol using 4 frequencies.   Used by 
some paging protocols. 

8 Level FSK Eight- level frequency- shift keying used to transmit digital 
data at 3 bits per symbol. Used in the HF radio Automatic 
Link Establish (ALE) protocol. 
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Digital Modulation Types – Other: 

Modulation Type  Description 

OOK 
(On- Off Keying) 

Two- level pulse amplitude modulation (PAM) used to 
transmit digital data at 1 bit per symbol.   Also referred to 
as two- level amplitude shift keying (ASK).   Includes signals 
with two nonzero amplitude levels, as well as those where 
one of the amplitude levels is zero, corresponding to a 
signal OFF state. 
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4PAM Four- level pulse amplitude modulation (PAM) used to 
transmit digital data at 2 bits per symbol.   Also 
referred to as four- level amplitude shift keying (ASK).  
Includes signals with four nonzero amplitude levels, as 
well as those where one of the amplitude levels is 
zero, corresponding to a signal OFF state. 

16 QAM Quadrature amplitude modulation (QAM) with a square 
(4 x 4)16- level constellation, used to transmit digital 
data at 4 bits per symbol. Often found on digital 
modems or high- capacity digital data links. 

32 QAM Quadrature amplitude modulation (QAM) with a non- 
square 32- level constellation, used to transmit digital 
data at 5 bits per symbol.   Constellation is 6 x 6 with 
the four corners removed.   Often found on digital 
modems or high- capacity digital data links. 

64 QAM Quadrature amplitude modulation (QAM) with a square (8 
x 

8) 64- level constellation, used to transmit digital data 
at 6 bits per symbol.   Requires higher SNR for reliable 
data communications.   Often found on digital modems 
or high- capacity digital data links. 

128 QAM Quadrature amplitude modulation (QAM) with a non- 
square 128- level constellation, used to transmit digital 
data at 8 bits per symbol.   Requires high SNR and a 
low distortion channel for reliable data 
communications.   Often found on digital modems or 
high- capacity digital data links. 

256 QAM Quadrature amplitude modulation (QAM) with a square 
(16 x 16) 256- level constellation, used to transmit 
digital data at 8 bits per symbol.   Requires high SNR 
and a low distortion channel for reliable data 
communications.   Often found on digital modems or 
high- capacity digital data links. 

V.29 A form of Quadrature amplitude modulation (QAM) 
often used for facsimile transmissions.
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The Display Menu 
 
 
 
 
 
 
 

 

 

 
This menu contains entries used to configure the display. 

 

A This is a tear- off menu.   Click the top of the menu and the menu gets its 
own window so that it does not disappear after a selection. 

 

1. Display Layout (page 422) is used to add or remove panes. 

2. Trace Setup (page 424) is used to configure the traces. 

3. Trace Scaling (page 458) is used to set trace scaling. 

4. Mouse (page 466) is used to set mouse features in trace panes. 

5. Colors (page 471) is used to set trace color configurations. 
 

To save a display setup for later recall or to load a previously saved display 
setup, see the discussion of Mission Setup Sections (page 132). 
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Display Layout 
 

         Toolbar Icon 
Path: Display, Layout 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Display Layout controls what is displayed in the application window.  For 
information about the N6820ES window, see N6820ES Main Window (page 45). 

 
Active Layout The buttons at the top are used to quickly change the window configuration. 

Each of the 6 buttons may be defined by the user to specify a set of panes for 
the window; i.e., the content of the active panes.   This allows you to store 
several of your “favorite” display configurations and quickly change from one 
to another. 

To define one of the six layouts: 

1. Select a layout number at the top. 
 

2. Change the panes to the desired configuration.   (Select from the option 
menu.) 

 

3. Click either Apply or OK. 
 

You can pick the active layout with a shortcut from any trace pane as shown 
at the right in the figure above.   See Display Layout in Trace Popup Menu 
(page 456). 

 

Layout configurations are saved as part of the mission state file in the 
“Display” section.   You can set the active layout configurations and then save 
it with Save Mission Setup (page 129).   To save only the display configuration 
settings, disable all but the Display section.   You can also define more than 
one set of 6 settings, saving each as a mission state file under a unique name 
and then load whichever you need with the Load Mission Setup (page 127) 
command. 
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Pane Types The window may contain as many as eight panes.   The types of panes are: 

• A Trace Pane (page 52) 
• The Handoff Receiver Pane (page 70) 
• The Handoff Log Pane (page 75) 
• The Text Editor Pane (page 113) 
• The Command Line Pane (page 115) (part of option ASD) 
• The Tool Bar (page 50) 
• The New Energy Log Pane (page 86) 
• The Alarm Log Pane (page 87) 
• The Energy History Pane (page 88) 
• The Signal Database Pane (page 107)  
• The Visual Alarms Pane (page 112) 
• The Frequency Lists Pane (page 118) 

Note If the command line is not in the list of panes, edit the E3238s file and 
change “False” to “True” in the line that reads: 

 
*commandLineEnabled: False 

 
If a pane is on but does not appear in the window, the window is not large 
enough to show all the active panes. 

 
 

To Add a Pane With this dialog box displayed, a pane may be added to the application 
window as follows: 

 

1. Click a pane button that is off.   A list appears. 

2. Click the list item you wish to add. 

3. Click “OK.” 
 

To Change a 
Pane 

You can change the contents of a pane as follows: 

1. Click the pane button you wish to change.   A list appears. 
 

2. Click the new pane type.   If the item name is ghosted, it is already being 
displayed in another pane.   Open that pane and turn it off, first. 

 

3. Click “OK.” 
 

To Delete a 
Pane 

To delete (remove) a pane from the application window, follow the procedure 
given above for changing a pane and select “Off” as the pane type. 
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Trace Setup 
 

         Toolbar Icon 
Path: Display, Trace (or click the Trace Identifier (page 54)) 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

This dialog box is used to change the configuration of the trace elements. 
Trace elements may also be changed with the Trace Popup Menu (page 456). 

 

1. Trace Selection (page 426) 

2. Channel (page 426) 



Trace Setup 

425 

 

 

Software Option Elements 
 

3. Trace Type (page 427) 

4. Threshold Presentation (page 428) 

5. Grid Type (page 429) 

6. Grid Frequency List (page 431) 

7. Marker On/Off (page 431) 

8. Marker Link (page 433) 

9. Direction 

10. Handoff Receiver Link (page 434) 

11. DF System Link (page 451) 

12. Mod Rec Link (page 453) 

13. Trace Handoff Settings (page 435) 

14. Trace Snapshot Setup (page 438) 

15. Trace DF Setup (page 452) 

16. Trace Mod Rec Setup (page 454) 
 

Note Elements numbered 9 through 12, and 14 and 15 appear only when their 
corresponding software option has been installed and activated in the 
e3238s.n6841.cfg configuration file. See Hardware Configuration (page 
16). 

 
 

Software Option Elements 
 

If you have installed certain software options, these options can provide 
additional elements to the Trace Setup dialog box. These options include 
handoff receivers, which adds the Handoff Receiver Link (page 434) and the 
Trace Handoff Settings (page 435). The Direction Finding option adds the DF 
System Link (page 451) and the Trace DF Setup (page 452). Finally, the 
Modulation Recognition option adds the Mod Rec Link (page 453) and the 
Trace Mod Rec Setup (page 454). 



Trace Setup 

426 

 

 

Trace Selection 
 

Trace Selection 
 

 
 
 

The settings displayed in the Trace Setup dialog box depend on which trace is 
selected at the top of the dialog box. The letters A, B, C, and D correspond 
to the trace panes with the same names. See Trace Identifier (page 54). One 
and only one trace may be selected at a time. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Tips • Always select the trace before changing any other selection in this dialog 
box. 

 

• To add or remove a trace pane from the window, see Display Layout (page 
422). 

 

• To select a trace, click the corresponding radio button.   The button that 
appears to be filled is “selected.” 

 

• To display the settings for a particular trace, select the trace. 
 

 

Channel 
 

 
 
 
 

This selection specifies which search receiver channel data is displayed in the 
trace pane.   Multiple search channels are supported by the N6841A RF 
Sensor. 
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Trace Type 

Trace Type 

 

 
 
 
 

This selection defines the trace type for the selected trace. It may also be 
selected from the Trace Popup Menu (page 456). 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

1. A color spectrogram trace displays frequency versus amplitude using color 
or shades of gray to indicate amplitude levels. The threshold configuration 
has no effect on this trace and no grids are used. When the marker is on, 
it appears as a vertical line in a color spectrogram trace. 

• When you click the right mouse button in the color bar at the left side 
of this trace, a popup menu appears with which you may select the type 
of Color Map and the Number of Colors.   See illustration. 

• The Color Maps include two color maps and two gray- scale maps. 
• Number of Colors ranges from 2 to 128, depending on the resource 

variable maxSpectrogramColors. See the discussion of resources in 
Application Resources (page 17) and Color Maps under Starting the 
Program (page 19). 

• Both the color map used and the number of colors in a color 
spectrogram can be specified in the Colors (page 471) dialog box. 

2. A spectrogram trace displays frequency versus whether the amplitude is 
above the threshold setting; a boolean value, True or False.   The Y axis is 
time.   Each sweep is a straight line that moves up slightly as the next 
sweep begins so that a history of signal activity is displayed. 

 

When you select spectrogram, make sure the threshold is on.   See 
Threshold Setup (page 310).   When the marker is on, it appears as a 
vertical line in a spectrogram trace. 
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Threshold  Presentation 
 

3. A spectrum trace displays frequency versus amplitude, one sweep at a 
time.   The threshold may appear as a line.   See Threshold Presentation 
(page 428). 

 

To change the color of the spectrum line, see Colors (page 471). 
 

Note Changing the horizontal size of the application window erases all existing 
spectrogram traces.   Changing the vertical size of the trace pane affects only 
how many spectrogram traces are displayed. 

 

Advanced Note The amount of time represented in the spectrogram depends on the value of the 
spectrogramBackingStoreSize resource.   It is limited by the amount of 
installed memory (RAM) and has an effect on display speed. If the display needs 
to be repainted, only the lines saved in memory are re- displayed.   See the 
discussion in Application Resources (page 17). 

 
 

Threshold Presentation 
 

 
 
 
 

This selection may also be made from the Trace Popup Menu (page 456). 

A Threshold Setup (page 310) can be displayed on the trace in several ways. 

• Off means that no indication of threshold level is displayed. 

• Line means the threshold level is represented with a line. 
 

• Mask means the trace is not displayed when the signal amplitude is less 
than the threshold level. 

 

Note When the trace type is spectrogram, the threshold settings are inactive. 
 

The threshold line is a layer in the trace pane.   The color may be changed 
and the relative order of the layers changed in the Display, Colors (page 471) 
dialog box. 
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Grid Type 

Grid Type 

 

 
 
 
 
 

The trace grid is the line pattern in the trace area background. 

• Off means no grids are displayed. 

• Graticules means that the trace display has a rectangular grid. 
 

• Handoffs means that vertical lines appear at frequencies of signals that 
have been handed off.   Also, active signals are flagged as shown in the 
following illustration and the width of the vertical lines indicates the 
bandwidth criteria setting.   See Signal Handoff Status (page 76) and 
Energy Criteria (page 320). 

 

The “grid” lines are removed when the handoff log is cleared. See Clear 
Log (page 146). 

 

 
 
 
 
 
 
 
 
 

• Energy History means that vertical lines appear at the frequencies of the 
signals in the Energy History pane.   See the figure in the discussion of 
Energy History > Tools > Marker Link (page 104).   To clear or reset the 
grid lines, use Clear Energy History (page 148) in The Edit Menu (page 
145). 

 

• Alarm Regions means that parts of the spectrum monitored by active 
alarms’ amplitude and frequency settings are colored with the grid color in 
the trace.   See following figure.   If multi- event alarms are defined, each 
event’s region is displayed.  See Multiple- Event Alarm Setup (page 377) for 
more information. 
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Grid Type 
 

• Frequency List means that vertical grid lines appear in the trace as 
defined in one of the frequency lists.   The name of the list appears in the 
upper right- hand corner of the trace as shown in the following figure. 

 

The frequency lists may be viewed and managed in the Frequency Lists 
Pane (page 118).   Since entries in the lists can be added or deleted by 
alarm tasks or user- defined library calls, these grid lines may change 
dynamically.   To select the list that defines the grids, see Grid Frequency 
List (page 431). 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
Note The grid lines are a layer in the trace pane.  Grid color and layering (whether 

the grid overlays other layers) are defined in the Display Colors (page 471) 
dialog box. 

 
Energy history signals are defined by the threshold and signal criteria settings 
in the Energy Detection (page 309) dialog box. 
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Grid Frequency List 

Grid Frequency List 

 

 
 

 
 

This menu allows you to select one of the defined frequency lists as a grid. 
Frequency lists may be defined with any ASCII editor such as vi, saved in a 
file, and loaded in the Frequency Lists Pane (page 118). 

 

Besides defining trace grids, frequency lists may be used as alarm criteria or 
in user- defined libraries such as feature extraction. 

 

Frequencies may be added or deleted to/from a list by an alarm task. See 
Frequency List Alarm Task (page 367). 

 

 

Marker On/Off 
 

A marker is part of the Trace Pane (page 52).   It is used to read frequency 
and amplitude information from a trace.   When the marker is on, the Marker 
Readout (page 61) and Marker Function Buttons (page 63) appear below the 
trace.   The frequency information may be used to select signals to handoff. 
Marker functions (peak searching) are affected by the threshold settings.   The 
left mouse button can be used to display a marker if it is off.   See Mouse 
(page 466). 

 

When the trace type is spectrum, a marker appears as a small cross hair 
symbol on the trace. When the trace type is spectrogram, the marker 
is a vertical line. 

 

When a marker is on, a Marker Readout (page 61) appears below the trace as 
well as the marker search buttons and the marker handoff button.  The text in 
the marker readout may be dragged to the text editor with the middle mouse 
button.   See Mouse (page 466).   The position of the marker may be changed 
by pointing and clicking the mouse or by using the Marker Function Buttons 
(page 63).   The marker frequency may be assigned to a handoff receiver by 
dragging it with the middle mouse button. 

 

When the marker is off and the frequency scale is zoomed (the span displayed 
in the trace is smaller than the entire scan) a horizontal scroll bar appears 
below the trace.   You can change the spectrum displayed by moving the scroll 
bar.   See Scroll Bars (page 133). When the marker is on, the scroll bar is not 
displayed. See Trace Popup Menu (page 456) for another way to access trace 
marker control. 
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Marker Bandwidth 
 

Marker Bandwidth 

 
 
 
 
 
 
 
 
 
 

The Marker Bandwidth button displays the Marker Bandwidth dialog box. The 
Marker menu in a trace pane displays the Marker Bandwidth menu. Both the 
dialog box and the menu allow you to specify a bandwidth associated with a 
marker. This bandwidth is shown on the spectrum trace as a pair of lines, one 
on either side of the marker, that display the defined bandwidth. 

 

The Marker Bandwidth menu gives a choice of six predefined bandwidths. The 
Marker Bandwidth dialog box allows you to set an arbitrary bandwidth. 



Trace Setup 

433 

 

 

 
 

Marker Link 

Marker Link 

 

The Marker Link feature allows the markers in multiple traces to move 
together. Each trace has a marker link selection. Marker links operate as a 
one- way link, so that if trace A has a link to Trace B, any marker movement 
in Trace A causes the marker in Trace B to follow it. However, any marker 
movement in Trace B will not occur in Trace A unless Trace B has also had 
its marker linked to Trace A. 

 

The Marker Link feature also affects linking for handoffs, signal processing, 
direction finding, and modulation recognition (if those options are active).   If 
Trace A has a marker link to Trace B and a handoff link to Rx 1, and Trace 
B has a handoff link to Rx 2, any marker movement in Trace A moves the 
marker in trace B and retunes the both Rx 1 and Rx 2 handoff receivers. 

 

Center Marker allows linked traces to keep their new marker values in the 
center of the X- axis. When the Center Marker box is selected, the link traces 
will have their x- axis scale adjusted to keep the marker in the middle of the 
trace. This will occur only if the linked trace span is greater than the link’s 
source trace, the x- axis of the traces are identical, or the frequency ranges of 
the traces overlap enough so that markers are visible in both traces. 
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Handoff Receiver Link 
 

Handoff Receiver Link 
 

 
 

 
 

This selection can also be made very quickly from the Trace Popup Menu 
(page 456). 

 

The marker can be used to tune a handoff receiver.  This selection determines 
which handoff receiver is linked to the trace marker. 

 

When a trace’s marker is linked to a handoff receiver, you can tune the 
handoff receiver to any frequency in the trace by moving the marker to it; i.e., 
point and click or by using the “peak” buttons. 

 

The handoff receivers are identified by number as they are assigned in the 
Handoff Receiver Configuration (page 271) dialog box.   This effect can be 
extended to selecting signals in the Energy History Pane (page 88) if the 
Energy History’s Marker Link is established with the same trace as the 
handoff receiver link.   See Energy History > Tools > Marker Link (page 104) 
and the following figure. 

 

 

 
 
 
 
 
 
 
 
 

 
Note that the frequencies are the same for the marker and the first handoff 
receiver.   When trace A is linked to receiver 3, changing the marker position 
changes the receiver’s frequency. 
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Trace Handoff Settings 
 

Path: Display, Trace Setup, Handoff Setup 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

The trace markers may be used to handoff signals. When a signal is handed 
off from the trace marker, the trace’s marker frequency is used to specify the 
carrier center frequency for the handoff receiver. This dialog box is used to 
specify the other handoff settings. For more detail about handoff parameters, 
see Handoff Log Pane (page 75). 

 
Priority This is the priority assigned to a signal when it is handed off.   When more 

than one signal is waiting for a handoff receiver (pending), this setting 
determines which goes first.   When the priority of two pending signals is the 
same, the signal with the earlier request goes first. When a signal is put in the 
handoff queue with a higher priority than the signal currently being 
monitored, the active signal is bumped.   See Handoff Status (page 76) for 
descriptions of pending, active, and bumped. 

 

• For more information, see Handoff Priority (page 79). 
• Priority also can be set for signals handed off from the Alarms Handoff 

Task (page 355) dialog box. 
• To change this value for a pending entry in the handoff log, see Handoff 

Log Popup Menu (page 83). 
 

Bandwidth The handoff receiver’s bandwidth.   When you click this button, the Frequency 
Entry (page 295) dialog box appears, which allows you to change the value. 

 

The marker’s frequency value is used as the carrier center frequency to tune 
the handoff receiver. 
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Trace Handoff Settings 
 

Duration Specifies how long the handoff receiver should monitor the signal. Values in 
the list range from one second to 24 hours. This value may be changed after 
the signal is handed off. 

 

• For more information, see Handoff Duration (page 80). 
 

• To change this value for a pending entry in the handoff log, see Handoff 
Log Popup Menu (page 83). 

 
Detection The detection type used to demodulate the signal.  The types available depend 

on the handoff receivers installed.   The standard types are: 
 

• None 
• AM: amplitude modulation 
• FM: frequency modulation 
• CW: continuous wave 
• LSB: lower side band 
• USB: upper side band 
• Log: log modulation 
• Pulse: pulse modulation 

See Handoff Detect (page 81) for more information. 
 

Handoff 
Receiver 

A list of installed handoff receivers that can be used to specify a particular 
radio, or “Any Radio”.  To change the selection, click the button to display the 
list and select the radio to which you want this trace to be handed off. 

 

For information about the installed handoff receivers see Handoff Receiver 
Configuration (page 271). 

 

Record A button used to specify whether to record the handoff receiver output.   This 
applies only if you have an audio recorder system connected to the handoff 
receiver’s audio output; it is not part of the N6820ES system. 

 

AGC is a button used to specify whether to use the handoff receiver’s 
automatic gain control (AGC) feature.   This applies only if the specified 
handoff receiver has an AGC feature.   For information about a handoff 
receiver’s features, see Setup under Handoff Receiver Configuration (page 
271). 

 
Manual Gain A button used to specify the handoff receiver’s IF gain when the automatic 

gain control (AGC) is off.   This applies only if the specified handoff receiver 
has an adjustable manual gain feature.   For information about a handoff 
receiver’s features, see Setup under Handoff Receiver Configuration (page 
271). 

 

To change the value, click the button and the Amplitude Entry (page 352) 
dialog box appears. 

 
BFO This button is used to specify a frequency value for the handoff receiver’s beat 

frequency oscillator (BFO) feature.   This applies only if the specified handoff 
receiver has a BFO feature.   For information about a handoff receiver’s 
features, see Setup under Handoff Receiver Configuration (page 271). 

 

To change the value, click the button and the Frequency Entry (page 295) 
dialog box appears. 
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Comment This text area is used to record a brief comment about the handoff setup that 
is saved in the handoff log.   Limit is 15 characters.   See Handoff Log Pane 
(page 75). 
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Trace Snapshot Setup 
 

Path: Display, Trace Setup, Snapshot Setup 
Or: Right- click the camera icon at the bottom of the Trace Pane 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This dialog box is used to configure the trace snapshot feature.   This feature 
is used to collect either time or frequency data in a specific trace.   The 
snapshot’s center frequency depends on the position of the trace marker, so 
the trace’s marker must be on.   Snapshot data can also be collected by an 
alarm task as described in Tasks (page 354). 

 

Note                     The snapshot configuration is unique for each trace pane.   If you have more 
than one trace pane displayed, be aware that you must configure each trace’s 
snapshot setup individually.   The default trace snapshot status is Inactive. 

 
The snapshot is triggered by the button with the camera icon.   This 
button appears at the bottom of the trace when the trace’s marker is 
turned on. 

 

Right- click the camera icon to display the setup dialog box shown above. 

The trace snapshot setup dialog box is divided into the following panes: 

1. Time Snapshot (page 439) settings 

2. Frequency Snapshot (page 442) settings 
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Time Snapshot 
 

 
 
 
 
 
 
 
 
 
 

Time snapshots collect ADC sample data (time domain) and store it in a file 
on the controller’s system disk.   The ADC setup is defined follows: 

 

The frequency parameter is taken from the position of the marker in the trace 
in which the snapshot button was pushed. This value is used to configure the 
search receiver to capture time data containing the marker frequency. 

 
Status A button that specifies whether to collect time snapshot data. 

• Active status means that data is collected. 
• Inactive status   means that no data is collected. 

The default setting is Inactive. 

To change the status, click the button. 
 

If the status is Active, data is collected when the snapshot button is clicked 
and the data is written to a system file as specified under Filename.   Time 
data is given a .cap extension. 

 
Span A list of frequency values that specify the span of the time data around the 

marker frequency.   The range depends on which ADC is installed. 
 

To change this setting, click the button and select the new value. 
 

Samples The number of samples to be taken for the time data snapshot. Clicking this 
button displays the Snapshot Duration (page 441) dialog box. 

 

The range of values allowed depends on the ADC model, its configuration, 
and, if an E9830A is installed, its configuration. For more information, see 
ADC Configuration (page 257) and Snapshot Memory (page 261). 

 

When the ADC Data Precision is set to 32- bit, each sample is 4 bytes.   A 
sample size of 2Msamples creates an 8MB file. 

 

When the ADC Data Precision is set to 16- bit, each sample is 2 bytes.   A 
sample size of 2Msamples creates an 4MB file. 

 

To change the Samples setting, click the button and select the new value. 
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 Duration Specifies how much time is spent collecting data, given the values specified 
for span and number of samples.   You may pick either the amount of time 
spent collecting data or the number of samples collected. 

 Duration is a function of the span (which determines the sample rate) so 
when the duration is specified, the number of samples taken varies with the 
span. 

 Conversely, when the number of samples is specified, the duration varies with 
the span. 

 Clicking this button displays the Snapshot Duration (page 441) dialog box. 

 

Attenuation 
 

Specifies the attenuation setting for the front- end tuner (downconverter) to be 
used during the time capture.   This list of values depends on the tuner 
installed.   If the tuner attenuation is not adjustable, this value is not used. 
For more information about your installed tuner, see Tuner Configuration 
(page 235). 

 Normally, the tuner attenuation is specified as part of the Search Setup. See 
General Search Setup (page 290) or Directed Search Setup (page 291) and 
Tuner Attenuation (page 299). 

 

Priority 
 

Determines the order in which snapshot requests are processed when more 
than one request occurs.   When the priority of two snapshot requests is the 
same, the one that occurred first is processed first and the other is put in a 
queue. When a snapshot is in process and another request occurs with a high 
priority, the current snapshot is stopped and the new request begins 
processing. 

 The choices are Low, Medium, High, and Critical. 

Note  None of the changes made in the setup dialog box take effect until you click 
the OK button. Also, no snapshots can be collected while this dialog box is 
open. 

  
 

The capture occurs at the end of the current sweep and sweeping is 
suspended until the capture is complete.   While the data is being collected, a 
window appears with the message “Saving the snapshot” and information 
about percent complete.  The time required to collect the data is a function of 
the span used and number of samples specified. 

  
 

Snapshot files may be loaded and analyzed with the snapview Snapshot 
Viewer program.   See Snapshot Viewer (page 455). 

  
Filename 

 
This button displays the current definition of the snapshot filename construct. 
Click the button to open a dialog box in which you can redefine the construct 
in terms of a variety of parameters.   See Trace Snapshot Filename (page 444). 

  Data files are saved in the Snapshot Directory (page 136) with the name 
given. 

  See the ASD Programming Guide1  for information on the snapshot data 
format. 
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Snapshot Duration 

Path: Display, Trace Setup, Snapshot Setup, Samples 
 

 
 
 
 
 
 
 
 
 
 
 

This dialog box is used to specify the size of the time snapshot capture. You 
may specify either the time or the number of samples to collect. 

 

Duration is a function of the span (which determines the sample rate) so 
when the duration is specified, the number of samples taken varies with the 
span. 

 

Conversely, when the number of samples is specified, the duration varies with 
the span. 

 

The size of the captured file is limited by the hardware configuration. See the 
technical discussion under Snapshot Directory (page 136). 
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Frequency Snapshot 
 

 
 
 
 
 

 
Frequency snapshots collect spectrum data (frequency domain) and store it in 
a file on the controller’s system disk. This is, essentially, the same data as is 
displayed in a trace pane.   The ADC setup is defined follows: 

 

The frequency parameter is taken from the position of the marker in the trace 
in which the snapshot button was pushed. 

 
Status Specifies whether to collect frequency snapshot data. 

• Active status means that data is collected. 

• Inactive status means that no data is collected. 
 

If the status is Active, data is collected when the snapshot button is clicked 
and the data is written to a system file in the Snapshot Directory (page 136) 
as specified under Trace Snapshot Filename (page 444). 

 
Bandwidth This is a frequency value that specifies the amount of spectral data to be 

collected around the marker frequency. 
 

To change this value, click the button and enter a new value in the Frequency 
Entry (page 295) dialog box. 

 
Priority Determines the order in which snapshot requests are processed when more 

than one request occurs.   When the priority of two snapshot requests is the 
same, the one that occurred first is processed first and the other is put in a 
queue. When a snapshot is in process and another request occurs with a high 
priority, the current snapshot is stopped and the new request begins 
processing. 

 

The choices are Low, Medium, High, and Critical. 
 

Filename This button displays the current definition of the snapshot filename construct. 
Click the button to open a dialog box in which you can redefine the construct 
in terms of a variety of parameters.   See Trace Snapshot Filename (page 444). 

 

Data files are saved in the Snapshot Directory (page 136) with the name 
given. 

See the ASD Programming Guide1  for information on the snapshot data 
format. 

 
Notes • None of the changes made in the setup dialog box take effect until you 

click the OK button.   Also, no snapshots can be collected while this dialog 
box is open. 
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• Frequency snapshot requests do not interrupt the search sweep to collect 
data. 

• Snapshot files may be loaded and analyzed with the snapview Snapshot 
Viewer program.   See Snapshot Viewer (page 455). 
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Trace Snapshot Filename 

Path: Display, Trace Setup, Snapshot Setup, Filename 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
This dialog box is used to define the trace snapshot filename construct using 
the parameters shown in the figure above.   The field at the top shows the 
current construct.   Data files are saved in the Snapshot Directory (page 136). 

 

The filename is made up of as many as ten fields which may contain the 
following individual components.   To define a snapshot filename: 

 

1. In one of the 10 fields (rows) specify a parameter type by clicking one of 
the buttons in the Type column and selecting from the list shown above. 
The field types are described in the following discussion. 

 

2. (Optional) Some of the parameters can be modified.   To do so, click the 
button next to the one you clicked in step one and make the changes. 

 

3. Repeat as necessary to define the other fields in the snapshot filename. 
 

Empty This disables the field. 
 

Text This is any fixed string. The default text for a trace snapshot the trace name; 
i.e., traceA, traceB, etc. 

 

To change the text field, click the button displaying the current setting.   As 
shown above the button displays the “traceA” string.   See also, Text Field 
Entry (page 447). 
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Counter Counter   is an integer value that   increments with each filename created. 
See Counter Field Entry (page 447). 

 
Date Places the date and time in the filename.   See Date Field Entry (page 448). 

 
Frequency For time snapshots, only.   Specifies the center frequency at which the data is 

taken.   To collect time data, the downconverter is parked at the marker 
frequency. 

 
Sample Rate For time snapshots, only.   Specifies the effective sample rate at which the 

data is taken. 
 

Span For time snapshots, only.   This is the span value specified in the Trace 
Snapshot Setup (page 438). 

 
Duration For time snapshots, only.   Specifies the time over which the data was taken. 

 
Priority Specifies the priority given in the Trace Snapshot Setup (page 438). 

The choices are Low, Medium, High, and Critical. 
 

Channel Specifies the search receiver channel used to gather the data. Most search 
systems are single- channel. Option EMC provides the ability to have more 
than one search channel. 

 
Extension This is the typical period- three- letter filename extension that most filenames 

use. 
 

• Time snapshot files get the extension .cap (short for capture). 

• Frequency snapshot files get the extension .fss (for frequency snapshot). 

There is no choice here other than whether or not to use the appropriate 
extension (and we recommend that this always be the last field).   But, if you 
want a different extension, you can specify a text field containing the 
characters you want. 

 

The data format of these file types is described in the ASD Programming 
Guide1. 

 
Write Mode Specifies how the file is created on the disk. 

 

• Write Once means that the specified filename is used only the first time 
the snapshot button is clicked.   When a file with the same name already 
exists, no snapshot data is collected.  If the filename consists of fields that 
change (e.g., counter or date) then new files are created.   To get the effect 
of collecting only one file, you must use filename fields that do not 
change. 

 

• Write Over means that, if the filename exists, the data in the file is 
replaced with new data.   If the filename consists of fields that change 
(e.g., counter or date) then new files are created.   To get the effect of 
having only one file that is overwritten, use filename fields that do not 
change. 

 
 

1 See the \E3238s\manuals\program_guide.pdf file. 
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• Write New means that the new files do not overwrite existing files.  When 
a file with the same name exists, an extension is added in the form _1, _ 
2, etc.   So if a file named traceA.cap exists and the filename definition 
specifies that another file of that name is created, the new file is named 
traceA.cap_1 and the next would be traceA.cap_2. 
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Text Field Entry 

Path: Display, Trace Setup, Snapshot Setup, Filename, Text Parameter 
 

 
 

 
 
 
 
 
 

This dialog box allows you to use a text string as part of the snapshot 
filename. 

 
 
 

Counter Field Entry 

Path: Display, Trace Setup, Snapshot Setup, Filename, Counter Parameter 
 

 
 
 
 
 
 
 
 

This dialog box allows you to enter a counter field in the snapshot filename. 
This is typically used to create new filenames when the Write Mode is Write 
New. 

 
Format A text field that contains format information using the printf() syntax. 

 

Examples: _%05d  puts an underscore character at the beginning of the field, 
followed by the counter number (represented by the % sign) and the format is 
a (d) decimal which is five places with leading numbers occupied by zeros. 
Result is _00001, _00002, etc. 

If you leave out the 0 you get spaces; i.e., _%5d creates fields like: _ 1, 
_ 2. 

 
Counter A text field that specifies the value of the next counter value used.  You can 

use this to specify a count that starts at any number or, after taking several 
snapshots, you can check it to determine the next counter value used. 

 

If the value specified here would create a filename that is currently in use, 
the counter value is incremented such that a new filename is created. 

 

If the Write Mode is Write Over, the counter does not increment. 
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Date Field Entry 

Path: Display, Trace Setup, Snapshot Setup, Filename, Date Parameter 
 

 
 
 
 
 
 

 
This dialog box allows you to define the date/time field when it is used in the 
creation of a snapshot filename. 

 

This text line uses the strftime() syntax. The default _%y_%m_%d_%H_%M_%S 

gives the year (last 2 digits), month (2 digits), day, hour (24- hour clock), 
minute, and seconds with the underscore character between each. 

 
 
 

Frequency Field Entry 

Path: Display, Trace Setup, Snapshot Setup, Filename, Frequency Parameter 
 

 
 

 
 
 
 
 
 

This dialog box allows you to define the frequency field when it is used in the 
creation of a snapshot filename. 

 
Format A text field that contains format information using the printf() syntax. 

 
Scalar This field allows you to make the units suffix in the format line work 

properly. 
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Sample Rate Field 

Path: Display, Trace Setup, Snapshot Setup, Filename, Sample Rate Parameter 
 

 
 

 
 
 
 
 
 

This dialog box allows you to define the sample rate field when it is used in 
the creation of a snapshot filename. 

 
Format A text field that contains format information using the printf() syntax. 

 
Scalar This field allows you to make the units suffix in the format line work 

properly. 
 
 
 

Span Field 

Path: Display, Trace Setup, Snapshot Setup, Filename, Span Parameter 
 

 
 

 
 
 
 
 
 

This dialog box allows you to define the span field when it is used in the 
creation of a snapshot filename. 

 
Format A text field that contains format information using the printf() syntax. 

 
Scalar This field allows you to make the units suffix in the format line work 

properly. 
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Duration Field 

Path: Display, Trace Setup, Snapshot Setup, Filename, Duration Parameter 
 

 
 

 
 
 
 
 
 

This dialog box allows you to define the duration field when it is used in the 
creation of a snapshot filename. 

 
Format A text field that contains format information using the printf() syntax. 

 
Scalar This field allows you to make the units suffix in the format line work 

properly. 
 
 
 

Channel Field 

Path: Display, Trace Setup, Snapshot Setup, Filename, Channel Parameter 
 

 
 
 
 
 
 
 

This dialog box allows you to define the channel field when it is used in the 
creation of a snapshot filename. The entry is a text field that contains format 
information using the printf() syntax. 

 

This identifies the search “channel” with which the snapshot data was 
collected in a system that has option EMC, multi- channel search. 
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DF System Link 

DF System Link 

 

 
 

 
This selection is available only when the DF option is installed. This selection 
can also be made very quickly from the Trace Popup Menu (page 456). 

 

When one or more direction finding system(s) are integrated with the 
N6820ES Signal Monitoring System, the marker can be used to task a DF 
system. This setting is used to define which DF system is linked to the 
specified trace. 

 

When a trace’s marker is linked to a DF system, you can assign the DF system 
to any frequency in the trace by moving the marker to it; i.e., point and click 
or by using the “peak” buttons. 

 

When the marker is moved to a new frequency the DF system is tuned to it 
and the processing results are displayed in the Direction Finding (page 395) 
dialog box. 
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Trace DF Setup 
 

Trace DF Setup 
 

Path: Display, Trace Setup, DF Setup 
 

 
 

 
 
 
 
 
 
 
 
 
 

Priority Determines the order in which DF requests are processed when more than 
one request occurs.   The choices are Low, Medium, High, and Critical. 

 

When the priority of two requests is the same, the one that occurred first is 
processed first and the other is put in a queue. 

 

When a request is in process and another request occurs with a higher 
priority, the current processing is stopped and the new request begins 
processing. 

 
Bandwidth This is a frequency value that specifies the amount of spectral data to be 

collected around the marker frequency. 
 

To change this value, click the button and enter a new value in the Frequency 
Entry (page 295) dialog box. 

 
Duration Specifies how much time is spent calculating DF information. 

 
System Specifies which system is linked to this trace (when there is more than one 

DF system integrated with the   N6820ES Signal Monitoring System). 
 
Signal Database Specifies whether to put the DF processing results in the signal database. 

This information is displayed in the Signal Database Pane (page 107). 
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Mod Rec Link 

Mod Rec Link 

 

 
 
 
 

This selections is available only when the Mod Rec option is installed. When 
one or more modulation recognition channel(s) are integrated with the 
N6820ES Software, the marker can be used to task a Mod Rec process.   This 
setting is used to define which Mod Rec channel is linked to the specified 
trace. 

 

When a trace’s marker is linked to a Mod Rec channel, you can assign the 
channel to any frequency in the trace by moving the marker to it; i.e., point 
and click or by using the “peak” buttons. 
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Trace Mod Rec Setup 
 

Trace Mod Rec Setup 
 

Path: Display, Trace Setup, Mod Rec Setup 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
Priority Determines the order in which DF requests are processed when more than 

one request occurs.   The choices are Low, Medium, High, and Critical. 
 

When the priority of two requests is the same, the one that occurred first is 
processed first and the other is put in a queue. 

 

When a request is in process and another request occurs with a higher 
priority, the current processing is stopped and the new request begins 
processing. 

 
Sample Rate This is a frequency value that specifies the amount of spectral data to be 

collected around the marker frequency. 
 

Duration Specifies how much time is spent calculating modulation information. 
 

Block Size Specifies the number of ADC samples in the processing block. 
 

System Specifies which modulation recognition system is linked to this trace (when 
there is more than one such system integrated with the N6820ES 
Software). 

 
Signal Database Specifies whether to put the DF processing results in the signal database. 

This information is displayed in the Signal Database Pane (page 107). 
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Snapshot Viewer 

Trace Mod Rec Setup 

 

A separate application is supplied with the N6820ES Software that allows 
you to view snapshot data, either time or frequency. 

 

To start the program in Windows, select Start, Programs, Agilent E3238S, 
Snapshot Viewer. 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Feature 
Highlights 

• Frequency snapshot data are displayed one segment at a time. 

• Time snapshots may be viewed in either time or frequency domains. 
 

• To move quickly to a place in a large record, drag the slider control above 
the trace area. 

 

• You can step through the data or auto- play it. 
 

• The marker can be positioned anywhere in the trace by positioning the 
cursor and clicking the left mouse button.   Also, Marker- To- Peak and 
Marker- To- Next- Peak buttons are provided below the trace display area. 

 

• Zoom trace scaling may be done with the right mouse button, as shown in 
the figure above; click and hold the right mouse button in one corner of 
the desired scale box, drag it to the opposite corner, and release it. To 
reverse/undo the scale change, double right- click anywhere in the trace 
area. 

 

Data processing features: 

• Resolution 
• Averaging 
• Overlap processing 
• Window type 
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Trace Popup Menu 
 

Trace Popup Menu 
 

Path: Click right mouse button in trace background 
 

 
 
 
 
 
 
 
 
 
 
 
 

This menu appears when you move the mouse cursor to the background of the 
trace you wish to change and click the right mouse button. This allows you to 
change trace setup easily.   See also, Trace Setup (page 424). 

 

 
 

 
 
 
 
 

The trace background area is around the outside of the trace’s display area, 
not including the area occupied by labels (like amplitude and frequency).   If 
the marker is off so that the marker readout area is unoccupied, clicking 
between the frequency labels also displays the menu.   If the trace type is 
spectrogram, no amplitude scale labels appear but the spots they would 
occupy are dead. 

 

Trace Type:   See Trace Type (page 427). 

Threshold:   See Threshold Presentation (page 428). 

Grid Type:   See Grid Type (page 429). 

Grid Freq List:   is active only when the Grid Type is Frequency List.   See 
Grid Frequency List (page 431). 

Marker On/Off:   See Marker On/Off (page 431). 
 

Marker to ...   allows you to quickly set one of the sweep settings (e.g., center 
frequency) to the frequency of the marker.   See Marker Popup Menu (page 69). 

 

Handoff Rx Link:   See Handoff Receiver Link (page 434). 
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Trace Popup Menu 
 

DF System Link: When this menu item is selected, the marker’s frequency is 
used to perform direction finding processing. This has the same effect as 
clicking on the Task DF button. See Task DF (page 65). 

 

Mod Rec Link: When this menu item is selected, the marker’s frequency is 
used to perform modulation recognition processing. See Task Mod Rec (page 
66). 

 

Tune to Trace: If the trace span is not the same as the span of the search 
receiver, as defined in the Search, Setup dialog box, Tune to Trace changes 
the start and stop frequencies in the sweep setup to match the start and stop 
frequencies of the trace.   This gives you the highest update rate (shortest 
revisit time) very quickly. 

 

To return to the previous sweep range, enter the frequency values in the 
Search, Setup dialog box, or (if the start and stop frequencies of the previous 
trace scale matched the sweep span) you can double- click the right mouse 
button in the trace area to return to the previous trace scale.   Then repeat 
the tune- to- trace function. 

 

This entry is active only when the Search Type (page 287) is General. 

See also, Trace Scaling for the right mouse button under Mouse (page 466). 

Display Layout: allows you to choose 1 of 6 pre- defined display layouts.   See 
Active Layout under Display Layout (page 422). 
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Trace Popup Menu 
 

 

Trace Scaling 
 

         Toolbar Icon 
Path: Display, Scaling (see note) 

 
 

 
 

 
 
 
 This dialog box is used to enter values for the amplitude and frequency scales 

of a trace. 

Note  This dialog box is displayed by clicking any of the 4 trace scale labels (either 
amplitude or frequency). 

   

The Trace Scaling selections are made in one of the following areas. Note that 
the Amplitude selections Min/Max and Ref/Div are mutually exclusive. 
Selecting one de- selects the other. 

 
 

Trace 
 

Trace Selection (Scale) (page 460) selects the trace for which scale values are 
displayed in the rest of the dialog box. 

 
 

Amplitude 
 

Clicking the Maximum Amplitude (page 460) entry allows you to set the upper 
amplitude scale value. 

  Clicking the Minimum Amplitude (page 461) entry allows you to set the lower 
amplitude scale value. 

 
 

Ref/Div 
 

Clicking the Reference (page 462) entry allows to set the upper value of the 
trace scale in the Ref/Div mode. 

  Clicking the Per Div (page 463) entry allows you to set the value of each 
graticule division on the trace screen. 
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Trace Popup Menu 
 

Frequency Clicking the Maximum Frequency (page 464) entry allows you to set the upper 
frequency value. 

 

Clicking the Minimum Frequency (page 465) entry allows you to set the lower 
frequency value. 

 

Update from Search Setup   clicking in this box synchronizes the display to 
the search setup. That is, the trace x- axis scaling is changed to match the 
maximum sweep range of the search. This setting is by default active. 

 
Direction Clicking the Minimum button allows you to enter the a minumum value in 

degrees that bounds the lower value of a directional search. 
 

Clicking the Maximum button allows you to enter a maximum value in degrees 
that bounds the upper value of a directional search. 

 

Trace Scaling 
Links 

Clicking a selection box links that trace’s scaling to the currently selected 
trace. Any changes to the currently selected trace are matched by changes in 
the linked trace. In the illustrated example, the current trace is “A.” If the 
trace scaling link for trace “B” were clicked, that trace’s scaling is linked to 
trace “A.” 

 

Trace Scaling links are one- way. If trace “A” has a link to trace “B,” any 
scaling change in trace “A” will occur in trace “B.” However, any scaling 
change in trace “B” will not occur in Trace “A.” 

 

Activation 
Buttons 

• OK makes the specified changes and closes the dialog box. 
• Apply makes the specified changes and leaves the dialog box open. 
• Cancel closes the dialog box; no changes are applied. 

 

Note The trace is displayed with dBm coordinates.   If other units are specified, 
they are converted to dBm on the display trace. 

 
See also:   Amplitude Autoscale Button (page 59), Frequency Full Scale Button 
(page 60), and Mouse Features (page 507). 
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Trace Selection (Scale) 
 

Trace Selection (Scale) 
 

These radio buttons indicate which trace’s scale settings are displayed in the 
button labels. 

 
To Change Scale Perform the following steps: 

1. Select the button to indicate the trace to be changed. 

2. Click the scale button you wish to change for the specified trace. 

3. Enter a value and select units. 

4. Click OK. 
 

Advanced Note The default behavior of trace selection is one- of- many.   If you want to scale more 
than  one  trace  at  a  time,  edit  the  E3238s resource  file  and  change  “True”  to 
“False”  in  the  line  that  reads: 

 

*scale_active_trace.radioBehavior: True 
 
 

Maximum Amplitude 
 

 
 
 
 
 
 
 
 

This dialog box allows you to enter a value for the top of the amplitude scale 
in a trace pane. 

 

1. Select the trace you wish to scale.   See Trace Selection (Scale) (page 460). 

2. Click the Maximum Amplitude button.   The Amplitude Entry dialog box 
appears.   See figure. 

3. Click in the text- entry area. 

4. Type the new value. 

5. Select the units. 

6. Click OK. 
 

Note The trace is displayed with dBm coordinates.   If other units are specified, 
they are converted to dBm on the display trace. 

 
Scale settings may also be changed with the mouse. See Mouse Features (page 
507). 

 

See also: Amplitude Autoscale Button (page 59). 
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Minimum Amplitude 

Minimum  Amplitude 

 

 
 
 
 
 
 
 
 

This dialog box allows you to enter a value for the minimum amplitude scale 
in a trace pane. 

 

1. Select the trace you wish to scale.   See Trace Selection (Scale) (page 460). 

2. Open the Minimum Amplitude dialog box. 

3. Click in the text- entry area. 

4. Type the new value. 

5. Select the units. 

6. Click OK. 
 

Scale settings may also be changed with the mouse. See Mouse Features (page 
507). 

 

See also, Amplitude Autoscale Button (page 59). 
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Reference 
 

Reference 
 

 
 
 
 
 
 
 
 

This dialog box allows you to enter a value for the top of the amplitude scale 
in a trace pane in the Ref/Div mode. 

 

1. Select the trace you wish to scale.   See Trace Selection (Scale) (page 460). 

2. Click the Ref/Div button. 

3. The Amplitude Entry dialog box appears.   See figure. 

4. Click in the text- entry area. 

5. Type the new value. 

6. Select the units. 

7. Click OK. 
 

Note The trace is displayed with dBm coordinates.   If other units are specified, 
they are converted to dBm on the display trace. 

 
Scale settings may also be changed with the mouse. See Mouse Features (page 
507). 

 

See also: Amplitude Autoscale Button (page 59). 
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Per Div 

Per Div 

 

 
 
 
 
 
 
 
 
 

This dialog box allows you to enter a value for the maximum frequency scale 
in a trace pane. 

 

1. Select the trace you wish to scale.   Trace Selection (Scale) (page 460). 

2. Click the Ref/Div button. 

3. Click the Per Div entry. 

4. Click in the text- entry area. 

5. Type the new value. 

6. Select the units. 

7. Click OK. 
 

Scale settings may also be changed with the mouse. See Mouse Features (page 
507). 
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Maximum  Frequency 
 

Maximum Frequency 
 

 

 
 
 
 
 
 
 
 
 

This dialog box allows you to enter a value for the maximum frequency scale 
in a trace pane. 

 

1. Select the trace you wish to scale.   Trace Selection (Scale) (page 460). 

2. Open the Maximum Frequency dialog box. 

3. Click in the text- entry area. 

4. Type the new value. 

5. Select the units. 

6. Click OK. 
 

Scale settings may also be changed with the mouse. See Mouse Features (page 
507). 

 

See also: Frequency Full Scale Button (page 60). 
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Minimum Frequency 

Minimum Frequency 

 

 
 
 
 
 
 
 

 
This dialog box allows you to enter a value for the minimum frequency in a 
trace pane. 

 

1. Select the trace you wish to scale.   See Trace Selection (Scale) (page 460). 

2. Open the Minimum Frequency dialog box. 

3. Click in the text- entry area. 

4. Type the new value. 

5. Select the units. 

6. Click OK. 
 

Scale settings may also be changed with the mouse. See Mouse Features (page 
507). 

 

See also: Frequency Full Scale Button (page 60). 
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Mouse 
 

         Toolbar Icon 
Path: Display, Mouse 

 
 
 

 

 
 
 
 
 
 
 
 
 

This dialog box defines the mouse button functionality in the trace panes, and 
in the trace panes only.   For example, turning off drag- and- drop for the 
middle mouse button does not affect drag- and- drop between other panes (like 
the Search Setup dialog box and the Text Editor Pane; see Printing the 
Directed Search Band Table (page 308); or between the Handoff Log pane and 
a Handoff Receiver pane; see Handoff Log Popup Menu (page 83)). 

 

Each button may control as many as four functions through use of the 
keyboard’s Shift, Ctrl, and Alt keys.   To use the shifted functions, first press 
the appropriate key and then click the mouse button. 

 

For information about general mouse use, see Mouse Features (page 507). The 
Mouse dialog box has four tabs, Left, Middle Right, and Wheel. 

 
Left Tab • Off means the left mouse button has no function. 

• Marker means that the left button affects the position of the trace marker. 
The following comments assume the cursor is in a trace pane’s display 
area. 

 

If a trace does not have a marker turned on, pressing the left mouse 
button while the cursor is in a trace pane displays a marker while the 
mouse button is held down.   The marker’s frequency position follows the 
horizontal position of the mouse and the vertical position follows the 
signal’s amplitude. 

 

If the trace’s marker is on, the marker’s horizontal position changes to 
that of the cursor.   The marker’s frequency and amplitude values appear 
in the marker readout at the bottom of the trace pane.   See Trace Pane 
(page 52). 

 

• Directed Search Band is available only when the Search Type (page 287) 
is directed.   When you click the left mouse button in the trace area, the 
marker appears at the frequency associated with the cursor position and 
text appears at the top of the trace displaying the band number and its 
description field.   See the discussion of Description under Single- Band 
Search Setup (page 293). 
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Minimum Frequency 
 

• Delta Marker is a marker feature that allows you to measure the 
difference in frequency and amplitude between two points in a trace. The 
measured values appear in the marker readout below the trace.   See 
Marker Readout (page 61). 

 

• Delta Threshold Marker is a marker feature that allows you to display the 
threshold level and its delta from the actual spectrum in the marker 
readout area of the trace. This feature only works for the Spectrum display 
type. See Marker Readout (page 61) 

 

The left mouse button is also used to identify a list of entries in the handoff 
log to change settings as discussed in Mouse Features (page 507). 

 
Middle Tab • Off means the middle mouse button has no function. 

 

• Drag and Drop means the middle button can be used to move information 
from the trace area to another pane. 
• From the marker readout to the text editor. 
• From the trace area to the handoff receiver. 
• From the trace area to the Signal Processing Pending Queue. 

 
Right Tab • Off means the right mouse button has no function. 

 

• Trace Scaling means the right mouse button can be used to redefine the 
trace scales. To return to the previous scale, double- click the right button. 
See Zoom Scale for details. 

 

When the trace type is spectrum, both amplitude and frequency scales are 
affected. When the trace type is spectrogram, only the frequency scale is 
affected. 

 

• TraceFrequency Scaling means the right mouse button provides zoom 
scaling that is limited to the frequency scale.   The operator clicks the 
mouse button where they want one end of the frequency scale, then drags 
the cursor to the desired scale, then releases the button. 

 

• Search Rx Tuning is available only when the Search Type (page 287) is 
general.   This function allows you to use the mouse to change the trace 
scaling and change the start and start frequencies of the search sweep. 
This zoom method lets you quickly reset start and stop frequencies to 
focus on a signal of interest and maximize the revisit rate. 

 

See also, Tune To Trace under Trace Popup Menu (page 456). 
 

• Handoff New Energy means the mouse button can be used to handoff 
new signals within the frequency limits specified by the rectangle. 

 

• Handoff All Energy means the mouse button can be used to handoff all 
signals within the frequency limits specified by the rectangle. 

 

Signal detection is described in Process Overview (page 33). 
 

Wheel Tab • Off means the mouse wheel has no function. 

• Marker means that the mouse wheel controls the movement of the marker. 
If the marker is enabled, moving the wheel up will move the marker to the 
right one pixel at a time. Moving the wheel down will move the marker to 
the left one pixel at a time. 
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Minimum Frequency 

 

 

 

• Amp Ref Scale means that the mouse wheel controls the scaling of the 
amplitude reference in the selected trace pane. Moving the wheel up will 
increase both the trace pane’s minimum and maximum values by 1 dB if 
the difference between the minimum and maximum values is greater than 
10 dB or 0.1 dB if the difference is less than 10 dB. Moving the wheel 
down will decrease both minimum and maximum values. The choice of 
amplitude scaling mode, either Min/Max or Ref/Div, has no effect on this 
action. 

 

• Amp Zoom means that the mouse wheel controls amplitude zooming in 
the selected trace pane. If the marker is off, moving the wheel up, will 
increase the pane’s maximum and decrease the pane’s minimum each by 1 
dB if the difference between the two values is greater than 10 dB or 0.1 
dB if the difference is less than 10 dB. Moving the wheel down will have 
the opposite affect. If the Marker is on, the affect will be the same except 
that the scaling range will be centered on the marker value. 

 

• Freq Zoom   if the marker is off, moving the wheel up increases the 
displayed frequency range by 1 grid (10%). Moving the wheel down 
decreases the displayed frequency range by 1 grid (10%). 

 

If the marker is on, the marker frequency is placed in the center of the 
display and the previous frequency range is changed by 10% in the 
direction of the mouse wheel direction. 

 

• Freq Pan   when the mouse wheel is moved up, the start and stop 
frequency are both increased by 1 grid (10%), moving down decreases both 
the start and stop frequency by 1 grid (10%). 
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Other Mouse Actions 

Other Mouse Actions 

 

Besides the actions specified by the Trace Mouse Function dialog box, the 
mouse buttons and wheel can be used in several other ways. See also, Mouse 
Features (page 507). 

 

More Mouse 
Whee
l 

The mouse wheel can be used in the trace scaling labels: 
 

• Vertical Scale Labels   If the amplitude scaling mode is Min/Max, moving 
the wheel within in the vertical scale labels will either increase or 
decrease by 1 dB or.1 dB (dependent on the amplitude range) for that 
particular label. 

 

If the amplitude scaling mode is Ref/Div, moving the wheel in the vertical 
scale labels will either increase or decrease both Min and Max values by 1 
dB   or.1 Db (dependent on the amplitude range.) 

 

• Ref/Div Moving the wheel over the Ref/Div label places the Ref/Div value 
on a 1/2/5 sequence between.1 dB and 20 dB per div. Subsequent wheel 
movement will change the Div value in a 1/2/5 sequence. 

 

• Horizontal Scale Labels   Moving the wheel in the horizontal scale labels 
will either increase or decrease the frequency value for that particular 
value only by half a grid (5%). 

 

The mouse wheel can be used throughout the N6820ES software. The 
following areas accept the mouse wheel inputs: 

 

• Signal Database 

• Energy History Database 

• Log Views 

• Option Menus 

• Scroll Bars 
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Other Mouse Actions 
 

Zoom Scale 
 

 
 
 
 
 
 
 

To zoom a trace scale with the right mouse button be sure the right mouse 
button is set to Trace Scaling.   Then perform the following steps: 

 

1. Imagine a box that defines the new scale settings. 

2. Place the mouse cursor at one corner of the box. 

3. Click and hold the right mouse button. 

4. Move the cursor to the opposite corner of the box (see figure). 

5. Release the mouse button. 
 

You can zoom more than once.   The scale values associated with each zoom 
selection are saved so that you can “unzoom” back through the settings. 

 

To return to the previous scale, double- click the right mouse button in the 
trace display.  If the scale has been zoomed more than once, each double- click 
returns the scale to the previous scale setting in the order they were changed. 

 

To quickly set the trace scale to match the hardware sweep range, click the 
Frequency Full Scale Button (page 60). 

 

To change the sweep settings to match the zoomed trace frequencies, use Tune 
To Trace under Trace Popup Menu (page 456).  This maximizes the revisit rate 
on a zoomed trace by changing the search sweep setup such that the start and 
stop frequencies match those of the trace’s scale.   When you do this the trace 
is no longer zoomed.   To return the sweep to it’s previous start and stop 
frequencies, see General Search Setup (page 290). 
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Other Mouse Actions 
 

 

Colors 
 

         Toolbar Icon 
Path: Display, Colors 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This dialog box has three tabs that are used to specify: 

1. trace elements Color (page 472) 

2. trace elements Layering (page 473) 

3. defining the Color Spectrogram (page 474) 

4. changes all color settings to default values 
 

Note There is no color configuration for other pane types. Advanced users can 
change colors in the E3238s resource file. See Application Resources (page 
17). 

 
Color settings are saved as part of the Display state.   See Save Mission Setup 
(page 129). 
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Color 
 

Color 
 

This pane is used to define the colors of all the elements. 

 

 
 

Element is a list of the trace elements.   The list is: 

• Background 
• Trace (shown selected above) 
• Marker 
• Grid 
• Labels 
• Threshold 

 

The Red, Green, and Blue sliders are used to set the color mix after an 
element is selected from the list. 

 

To define the color mix for a trace element: 

1. Select the element you wish to change from the pulldown list. 

2. Change the slider settings for the colors. 

• For a description of the trace elements, see Trace Pane (page 52). 
• To change the status of trace elements, see Trace Setup (page 424). 

• To change the threshold settings, see Threshold Setup (page 310). 
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Layering 

Layering 

 

This pane is used to define the layering order of the trace elements from 
highest to lowest.  The higher elements overlay the lower ones such that if two 
elements are drawing on the same part of the screen (use the same pixel), the 
element with the higher layer setting is the one that “gets” the pixel. 

 

 
 

To raise the layer order of one element above that of another: 
 

1. Click the option button of the layer level you wish the trace element to 
have.   (To raise Marker to the layer occupied by Threshold, click the 
button Labeled “Threshold.”) 

 

2. Select the trace element from the pulldown list. 

3. Check the new order of the layering. 
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Color Spectrogram 

 

 

 

Color Spectrogram 
 

This pane is used to define the number of colors (or shades of gray) in the 
color maps.   These are used when the Trace Type (page 427) is Color 
Spectrogram. 

 

 

 
 

Color Map   The color map menu contains 2 color maps, 2 gray- scale maps 
and 1 user- defined map.   The user- defined map is defined by pressing the 
User Color Map Setup button and working in the User Color Map Setup 
(page 475) dialog box. 

 

Number of Colors  This slider allows you to set the number of “colors” in the 
color spectrogram between 2 and the maximum amount allowed. 

 

To change the number of colors for all color maps click the slide bar button, 
hold it down, and move it right or left to select the number of colors. 
Clicking in the slider area on either side of the slider button changes it by 
one. 

 

The maximum value is set with the maxSpectrogramColors resource value. See 
the discussion in Application Resources (page 17). 

 

The number of colors used in a color spectrogram may be selected from the 
popup menu that appears when you click the right mouse button in the color 
bar at the left side of a color spectrogram trace.   See the discussion and 
illustration under Trace Type (page 427). 

 

User Color Map Setup This button appears in the Colors (page 471) only 
when the following resource is defined in the E3238s resource file: 

 
*userColorMapEnabled: True 

(The default value is False.) 

When clicked, the User Color Map Setup (page 475) dialog box is displayed. 
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User Color Map Setup 

 

Path: Display, Colors, User Color Map Setup 
(E3238s must contain *userColorMapEnabled: True) 

Color Spectrogram 

This dialog box is used to define the colors in a trace color spectrogram. 
 

Note Make sure the Color Map selection in the Color Spectrogram pane is User. 
Otherwise, the only control that has any effect is Number of Colors. 

 

 
Edit Mode The dialog box changes appearance based on the selected Edit Mode. The 

following figure illustrates the RGB mode. 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
RGB Edit Mode 

 

RGB mode allows you to define the individual color cells in the standard 
red/green/blue color scheme.   To define a color cell: 

 

1. Select the number of colors with the bottom slider.   Notice that the 
number of cells in the Color Cells pane changes with the slider. 

 

2. Click on the cell you wish to define.   (See cursor in figure above.) 

3. Set the color with the Red, Green, and Blue sliders. 

4. Click the next cell and repeat. 
 

You can save a definition or recall a previously- saved map with the buttons in 
the Save/Recall pane at the bottom of the dialog box.   These buttons appear 
only when the Edit Mode is RGB.   Clicking either button displays the 
Filename Entry dialog box as discussed in Filename Entry (page 140). 
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Color Spectrogram 

 

 

 

Hue Range 
 

Hue Range mode allows you define a color map with colors determined by 
selecting the start and stop hues as well as the overall saturation and 
luminance.   You can also rotate the cycle of values with the Rotate slider. 

 

 
 

 
 
 
 
 
 
 
 
 
 

Gray Range 
 

Gray Range mode allows you to define a color map with shades of gray 
determined by selecting the start and stop gray values. You can also rotate the 
cycle of values with the Rotate slider. 

 

 
 

 
 
 
 
 
 
 
 
 
Note If the Color Map selection is not User, the Color Cells display the setup but 

the controls have no effect. 
 

User- defined color maps are not saved as part of the mission state. 
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The Macros Menu 
 

 
 
 
 
 
 
 

The Macros Menu contains entries that allow you to create, edit, and launch 
macro operations. 

 
c 

 
 

 
The Macro menu allows you to define operations and associate those 
operations with function keys or additional toolbar buttons. 

 

The Macro Menu entries are: 

1. Macro Entries (page 479) allows you to execute macros. 

2. Macros ... (select) (page 480) allows you to edit existing macros. 

3. Record New Macro (page 482) allows you to create and record new 
macros. 
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Introduction 
 

A macro file (.mcr) is a superset of a state file (.sta).  It can include all of the 
state commands that are in a state file; additionally it can contain action 
commands like start, stop, markerToPeak, etc. You can assign a state file to a 
Function key or a macro toolbar button. 

 

A macro is always saved in a file and executed from a file. 
 

There are situations in which a macro, recorded with the macro facility must 
be adjusted to produce the desired result. Macros are based on the change of 
system state. If an action results in a change of state, the difference in states 
is what is captured in the macro. 

 

For instance, if you record a macro in which the search sweep span is defined 
by specifying the center frequency and a frequency span, what is recorded in 
the macro is not the action of setting the span frequency relative to the center 
frequency, but the absolute result of the operation, that is, the absolute start 
frequency and the stop frequency. 

 

This may not be the desired effect.   If it is not, the macro must be modified. 
The macro facility has a macro editor that allows the user to edit the content 
of the macro and test it at the same time.   For our example, the 
startFrequency and stopFrequency commands need to be replaced by the 
spanFrequency command to achieve the desired effect. 
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Macro Entries 
 
 
 

Macro Entries 
 
 

 
 

The first eight entries in the Macro menu are reserved for user- defined 
macros. If there is an action associated with that menu entry, that entry is 
active. If there is no action yet associated with a menu entry, that entry is 
greyed out. In the illustration, the entries 1 through 4 are associated with 
action, while entries 5 through 8 are not. 

Clicking on an active menu entry immediately executes that associated macro. 

Note that creating or loading a macro creates a toolbar button with the name 
of the macro, as well as a menu entry. Clicking on the macro toolbar button 
has the same effect as clicking the menu entry. 

 

 
 

Macros can be defined in the N6820ES configuration file, 
e3238s.n6841.cfg. Macros defined in this file are loaded at software 
startup and are immediately available for use. 

 

Macros can also be defined by clicking the Record New Macro (page 482) 
menu entry. 



Macros ... (select) 
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Macros ... (select) 
 

 

 
 

The Macro dialog box allows you to associate a state file with a macro entry, 
record new macros, edit existing macros, and run previously saved macro 
files. The Macro dialog box is composed of: 

 

1. Function Key Area displays the available function keys and the macro 
names associated with them. Clicking an entry in the list selects that 
entry. 

 

2. Macro Area displays the available macros and the names associated with 
those macros. Clicking an a macro entry in the list selects that entry. 

 

3. Assign Macro (page 481) opens the macro filename dialog box allowing 
you to select a state file you wish to associate with the selected function 
key or macro.   This allows to load state files immediately, rather than 
going through the File menu and file dialog boxes. 

 

4. New Macro (page 481) opens a filename dialog box. If you select a macro 
that already exists, that macro is opened in the macro editor box. If you 
enter an unused macro name, a new empty macro of that name opens in 
the macro editor dialog box. 

 

5. Edit Macro (page 484) opens the macro editor box. This button is only 
available when an assigned macro or function key is selected. 

 

6. Clear   the association between a function key or a macro entry and the 
state file or macro to which it has been associated. The macro file is not 
deleted. 
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Assign Macro 
 

7. Run opens the macro filename dialog box. This allows you to run state 
files immediately, rather than going through the File menu and file dialog 
boxes. 

 

 

Assign Macro 
 

 
 

Clicking the Assign button opens the Macro filename dialog box. This box lists 
the macro (.mcr) or state (.sta) files in the currently active directory. Clicking 
on a filename selects that filename. Clicking on the Open button associates 
that filename with the Function Key or Macro button that was selected when 
the Assign button was clicked. 

 

 

New Macro 
 

 
 

Selecting the New button in the Macro dialog box displays the New Macro 
filename dialog box. This box lists the macro (.mcr) or state (.sta) files in the 
currently active directory. Clicking on a filename selects that filename. 
Clicking on the Open button opens that macro or state file in the Macro 
Editor box. Entering an unused name creates a new macro by that name and 
opens the Macro Editor box. 
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Record New Macro 
 

Record New Macro 
 

 
 

This dialog box allows you to record macros from actions performed to an 
operating N6820ES system. 

 

• Macro Name   This box displays the macro name automatically generated 
by the software. The software selects the first unused name from a range 
of Macro1 to Macro256 in the current directory. Alternately, you can click 
the "..." button to the right of the text entry box and browse for another 
name or another directory. 

 

• Function Key   This drop down menu allows you to select a Function key 
to assign to the macro. 

 

• Toolbar   This drop down menu allows you to specify a toolbar button 
name to assign to the macro. 

 

• Keep Command Timing Clicking in this box preserves the pause times 
between commands (start, stop, markerToPeak, etc.). This does not 
preserve pauses between state commands (startFrequency, rbw, 
markerMode, etc.). 

 

Only one macro can playback at a time. You cannot record and playback at 
the same time. 



Macros ... (select) 

483 

 

 

 

 
Stop Recording 

Record New Macro 

 

When you begin recording a macro, there are two ways to end recording. The 
last entry in the macro menu changes to Stop Recording and a Stop Recording 
dialog box appears on the screen. Clicking either one stops the macro 
recording. 

 

 
 

 

Stop Playback 
 

When a macro is playing, there are two ways to halt the macro playback. The 
last entry in the macro menu changes to Stop Playback and a Stop Playback 
dialog box appears on the screen. Clicking either one stops the macro 
recording. 
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Edit Macro 
 

Edit Macro 
 

 

The Macro editor screen allows you to view and edit macros. 

The following buttons are provided on the   Edit Macro pane: 

• Run   Clicking this button saves the contents of the editor window to a 
temporary file, then runs that code.   Remember to save any code changes 
using the Save button before exiting the Edit Macro process. 

 

• Validate Syntax Clicking on this button scans the code looking for syntax 
errors. If the validate process detects errors, it highlights the first error it 
encounters and displays error message. 

 

• Command Reference   Clicking this button pops up the Command 
Reference (page 116) box, allowing you a quick reference to valid 
command forms. 

 

• Save  Clicking on this button saves the current contents of the Edit Macro 
screen to the displayed filename. 

 

• Cancel   Clicking on this button cancels the current editing session. All 
unsaved changes are abandoned. 
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The Utilities Menu 
 

 
 
 
 
 
 
 

The Utilities Menu contains entries that allow you to control access to the 
N6820ES software. 

 

 
 

 
 

The Secure Display entry in the File Menu has text to its right.   This is an 
accelerator description. It allows you to activate the feature very quickly, 
using the keyboard. You can define new accelerators and change existing ones 
as described under Accelerator Keys (page 508) 

 

The Utilities Menu entries are: 

1. Secure Display hides the display. 

2. Configuration Files displays the files that configure the software. 

3. Menu/Toolbars controls access to menu entries. 

4. Socket Connections displays the system names and IP addresses of 
processes connected to the N6820ES system. 

5. Loaded Libraries lists the library extensions that are loaded. 

6. Resources lists the X Window application resource values. 

7. Licensing displays the licensing information for this copy of the 
N6820ES software. 

8. Corrections allows you to apply corrections for various hardware (time 
source, antennas, tuners, etc.). 

9. Simulator controls the Simulator setup. 
 
 
 
 

1. Secure Display (page 483) hides the display. 

2. Configuration Files (page 484) displays the files that configure the 
software. 

3. Menu/Toolbars (page 485) controls access to menu entries. 
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4. Socket Connections (page 487) displays the system names and IP 
addresses of processes connected to the N6820ES system. 

5. Loaded Libraries (page 492) lists the library extensions that are loaded. 

6. Resources (page 493) lists the X Window application resource values. 

7. Licensing (page 494) displays the licensing information for this copy of the 
N6820ES software. 

8. Corrections (page 495) allows you to apply corrections for various 
hardware (time source, antennas, tuners, etc.). 

9. Simulator (page 499) controls the Simulator setup. 
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Secure Display 
 

Accelerator: Ctrl+S 
Path: Utilities, Secure Display 

Secures the display from unauthorized viewing. 
 

To reactivate normal display operation, enter the password of the user logged 
in and running the program. 

 

 
Note Windows XP security policy can interfere with the use of no password in 

locations other than the main console logon.   To resolve this issue, disable it 
as follows: 

 
Control Panel... 

Administrative Tools... 
Local Security Policy... 

Local Policies... 
Security Options... 

 

If the entry listed below is listed as ’Enabled’, double- click it and select 
’Disabled’: 

 

Accounts: Limit local account use of blank passwords to console logon 
only: 

 

When this is disabled, user accounts that have no password can recover the 
secured display without entering a password. 
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Configuration Files 
 
 
 

Configuration Files 
 

Path: Utilities, Configuration Files 
 

 
 

 
 

This dialog box displays the pathnames of the files used to configure the 
operation of the N6820ES software. The Site file and Resource file are not 
required to configure the software, and these files can be reported as not 
found. 
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Menu/Toolbars 
 

Path: Utilities, Menu/Toolbars, (password) 
 

 

This dialog box controls user access to the system features available through 
the menus and toolbar.   The system administrator can use this dialog box to 
disable entries in the main menu bar and popup menus.   Inaccessible features 
appear ghosted in the menus and have no button in the Tool Bar (page 50). 

 

1. Access All Menus activates access to all entries in all menus when clicked. 

2. Menu is an option list used to display any of the menu bar entry menus. 
The list to choose from is the list of names in the menu bar.   The selected 
entry is a menu, and its entries appear for individual selection below the 
button. 

 

3. File Menu is the list of entries in the current selection (File) in the Menu 
list. 

 

4. Popup Menus are menu entries that appear when you click the mouse 
“somewhere special.”   See Mouse Features (page 507). 

 
Note The state defined in this dialog box is not saved in a state file.   The 

disableAccess command1  may be used in the configuration file (e.g., 
e3238s.n6841.cfg) to specify an initial configuration but care should be 
taken to 
restrict user access to the file so that the operator limitations are not 
circumvented.   See the Command Reference   for detailed information. 

 
1  \E3238s\manuals\command_ref.pdf 
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Menu/Toolbars 

Access Password 
 

To change access control: 

1. Click the Menu option button to display the list of menu bar entries. 
 

2. Click the entry in which you wish to change access.   The entries for that 
menu appear in the lower part of the dialog box. 

 

3. Click the checkbox buttons to allow or restrict access. 

4. To make in other menus, repeat the previous steps. 

5. Click OK. 

To quit without changing menu access, click Cancel. 
 

Password 
Protection 

If a password account is created, access control may be changed only when 
that user’s password is used (before displaying this dialog box, the user is 
prompted for a password; see Access Password (page 489)). 

 

If a password account was not created, changes to the access control dialog 
box are not restricted. To define the initial state of Access Control, see the 
e3238s.n6841.cfg file. 

 

Note Only top level menus are controlled.   You cannot selectively change access to 
submenus.   The initial access state may be defined with disableAccess 
commands placed in the e3238s.n6841.cfg file. 

 
Access Control settings are not saved as part of the Mission Setup; see Save 
Mission Setup (page 129). To do so would allow a way to circumvent access 
control. 

 

User- defined menus (part of option ASD) can be controlled like any other. 
 
 

Access Password 
 

Path: Utilities, Access Control 
 

This dialog box appears if a password account exists for the user ‘e3238s’ and 
you click File, Access Control. You must enter a password before the Access 
Control dialog box appears. 

 

Enter the password associated with the user name ‘e3238s’.   If the password 
hasn’t been setup, access to this menu is granted without a password. 

 

To add a user or change the password, see the system administrator. 
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Socket Connections 

Access Password 
 

 

Socket Connections 
 

Path: Utilities, Socket Connections 
Option: ASD   User Programming 

 

 

There are no controls in this dialog box; it merely displays information. 

This Socket Connection dialog box displays: 

1. Server Setup displays the socket server configuration settings (see 
Configuring the Socket Server below) 

 

2. Services   displays, as a series of tabs, the services that are available 
through the socket connections. 

 

3. Connections displays the names and IP addresses of machines that 
currently have a socket connection. 

 

4. Configuration displays the sizes of the socket server’s receive buffer size 
and send buffer size. 

 

5. Spew Ports displays the Spew Port Status (page 492). 
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Socket Connections 

Access Password 
 

Configuring the 
Socket Server 

By default, this feature is inactive in the File menu.   The Socket Server is 
activated and configured with the following commands (from the 
e3238s.n6841.cfg file): 

 

socketServer: Enabled 

maxServices: 1 
maxClientSockets: 0 
socketServerTimerInterval: 5 
e3238sService: e3238s 
e3238sServiceMaxConnections: 4 
e3238sServiceDataBufferSize: 512 
e3238sServiceSendBufferSize: 0 

e3238sServiceRecvBufferSize: 0 
 

To activate the Socket Server, put them in the e3238s.n6841.cfg 
configuration file so that they are executed when the program starts. 

 

Example The example program client in the C:\e3238s\examples\sockets directory 
allows another process/workstation to make a socket connection and issue 
commands.   The commands that subscribe to the information types start with 
“spew” as spewAlarm.   See the following example. 

To subscribe to N6820ES data, 

First:   Both machines must have a line in the /etc/services file: 
 

e3238s 7011/tcp 

Then: 

1. Check that socketServer: Enabled is in the e3238s.n6841.cfg file. 

2. Start the e3238s program. 
 

3. In another window or on another machine, run client, specifying the 
machine running the N6820ES program. 

 
client -f Internet -m mar87s1 

client is an example program in option ASD that shows how to program 
a sockets interface (look for client.c).   If you run this on another machine, 
socketServerSocketFamily: must be Internet.   Unix works only when both 
processes run on the same UNIX machine; Internet works for either case. 

 

4. Issue a spew command; the previous figure shows the results of using the 
following commands (“Enter Command:”   is a prompt from the client 
program): 

 
Enter command: spewSearchSetup: On 
Enter command: spewAlarm: On 

Enter command: spewTimeSnapshotFilename: On 

For a general discussion of the socket server, see Process Overview (page 33). 
See the E3238 ASD Programming Guide (program_guide.pdf) or Command 
Reference (command_ref.pdf) for information on the spew commands.   The 
PDF files are in the \E3238s\manuals directory. 
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Spew Port Status 
 

 

 
 

The Spew Port Status box lists the types of information to which each 
connected machine is subscribed. The numbers at the top of each column 
corresponds to the connections numbered in the status display Socket 
Connections (page 490). 

 

Spew 
Information 

Types 

The types of information that are provided via a sockets subscription service, 
popularly known as “spew” information, are as follows: 

 

• Sweep Status is a report sent when the sweep status changes (starts or 
stops) indicating whether the sweep is active. 

 

• Search Setup is a report sent when the search configuration changes. 
Current configuration settings may be determined by using query 
commands.   This report is triggered when any of the following parameters 
are changed: 
• Search type (directed/general) 
• Start/stop frequencies 
• Bin spacing 
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Spew Port Status 

Access Password 
 

• RBW 
• Antenna 
• Attenuation (tuner) 
• Average mode 
• Number of averages 
• Band number (directed search) 
• Band status (directed search) 
• Sweep interval (directed search) 

 

• Tuner Info is a report sent when any of the tuner setup parameters are 
changed. 
• Tuner span (start/stop frequencies) 
• ADC span 
• ADC sample frequency 

 

• Overload indicates an ADC overload occurred; the ADC input signal 
voltage exceeded the range setting during the time this data segment was 
being sampled.  Information sent to the subscriber includes the frequencies 
associated with the segment’s first and last values. 

• Raw Spectral Data is the frequency- domain (magnitude in Vpk
2) data from 

the measurement hardware (tuner/ADC/DSP). See Spew Raw Data in the 
N6820ES ASD Programming Guide. 

 

• Raw Time Data is the ADC (time domain) data for each segment. 
 

• Energy is a report sent when energy is detected.  Information sent is time 
stamp, frequency, bandwidth, and amplitude. 

 

• New Energy is a report sent when new energy (not already listed in the 
Energy History) is detected.   Information sent is time stamp, frequency, 
bandwidth, and amplitude. 

 

• Energy Alarm is a report indicating that an energy alarm has occurred. 
Information included in the report: 
• Alarm number 
• Alarm name/description 
• Time stamp 
• Mode (cause; e.g., signal present) 
• Frequency 
• Bandwidth 
• Amplitude 
• Detections (number of) 
• Duration 
• Intercepts (number of) 

• Signal Alarm is a report indicating that a signal alarm has occurred. 
 

• Handoff is a report indicating that a handoff entry has been put in the 
receiver queue.   Information in this report includes: 

 

• Frequency 
• Bandwidth (of the signal causing the handoff) 
• Amplitude (of the signal causing the handoff) 
• Duration -  time receiver stays tuned to frequency 
• Priority 
• Detection type 
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• Receiver (which one to use) 
• BFO 
• AGC (on/off) 
• Gain (if AGC off) 

 

• Rcvr Assignment is a report describing handoff receiver assignments 
including: 
• Receiver (a number identifying which receiver got the assignment) 
• Frequency to which to tune 
• Bandwidth (of the signal that caused the handoff) 
• Detection type 

• Time Snapshot is the name of a file containing time snapshot data. 

• Freq Snapshot is the name of a file containing frequency snapshot data. 
 

• User Trace Vector is a type of data used to display trace data on a 
remote process without the huge volume of frequency data used for 
normal trace displays. 

 

• End Of Sweep   sends no data.   When this tag is received it indicates that 
the search receiver has completed the sweep. 

 

• Direction Finding   is the data provided by the optional direction finding 
library. 

 

• Modulation Recognition is the data provided by the optional modulation 
recognition library 

 

• Error is the text of any error dialog boxes shown on any of the 
N6820ES screens. 
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Loaded Libraries 

Access Password 
 

 

Loaded Libraries 
 

Path: Utilities, Libraries ... 
Options: ASD, User Programming 

 

 
 

This dialog box lists the startup configuration file (e3238s.n6841.cfg) and 
the user- defined libraries that are currently loaded. 

 

Hardware 
Configuration 

File 

This entry specifies the file used when the program begins execution to define 
the system hardware.   It also defines the libraries to be loaded as discussed 
in the following.   See Hardware Configuration (page 16). 

 

Other Libraries 
In Use 

Libraries are used to support custom features such as: 

• handoff receiver drivers 
• energy feature extraction 
• energy history filters 
• creating additional exported data types 
• signal type identification 
• menu bar menus 
• window panes 
• generic (other user- defined programs) 

 

To change the libraries that are loaded, you must change the 
e3238s.n6841.cfg file, then stop and restart the e3238s program. 

 

Library programs are part of option ASD (User Programming).   They a r e  
created under the guidelines described in the documentation provided. 

 

See Also Process Overview (page 33) 
 

The Installation & Configuration Reference for information on installing 
hardware and editing configuration commands in the ‘e3238s.n6841.cfg’ 
file. 
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Access Password 
 

 

Resources 
 

Path: Utilities, Resources . . 
 

 
 
 
 
 
 

This dialog displays the X Windows application resource settings and the main 
resource file used to define them. 

 

To create a file containing the default values for these parameters, see 
File, Print To File, Fallback Resources ... 

 

See also Application Resources (page 17). 
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Licensing 

Access Password 
 

 

Licensing 
 

Path: Utilities, Licensing 

 

 

The dialog box displays the licensing information for the N6820ES software. 
The dialog box displays the host license information and a list of the software 
that the license enables. 

 

In the host information is the license number, the hardware identity to which 
the license is locked (host ID or dongle), the ID itself, the license date and the 
expiration date. 



 

 

Access Password 
 

 

Corrections 
 

Path: Utilities, Corrections 
 
 

 
 

 
The corrections utilities allows the N6820ES system to apply corrections for 
a variety of time, frequency, phase, and other hardware artifacts. 

 

Note If “[Partial]” appears after one of the corrections names in this dialog box, the 
N6820ES software was unable to find some correction files that are normally 
installed with the system or extracted from the tuner.   This may indicate a 
need to re- install the N6820ES system software. Until this is done, the 
system will apply other, more general, corrections. 

 
The available corrections include: 

 

• Apply Time Corrections (page 499) this section allows users to apply 
corrections for time snapshot capture and Mod Rec results. 

 

• Apply Frequency Corrections (page 499) this selection allows users to 
apply power spectrum corrections to their N6841A RF Sensor. 

 

• Apply Antenna Corrections (page 499) this selection allows users to apply 
corrections to compensate for antenna and antenna lead variations. 

 

• Apply User Tuner Corrections (page 501) this allows users to apply 
corrections specific to external up or down converters. 

 

• Correction Files (page 501) lists the corrections files currently being used 
by the N6820ES system. 

 

• Frequency Offset (page 501) allows you to correct for a downconverter 
that is not recognized or controlled by the N6820ES system. 
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Apply Time Corrections 
 

Apply Time Corrections 
 

When this is activated, the N6820ES system applies corrections to time- domain 
data.   Time- domain data includes Time Snapshot file data and time records 
used by the MR1 Modulation Recognition option. 

 

Time corrections compensate for the RF response of the tuner and the 
amplitude and phase response of analog and digital filters in the ADC.   Time 
Corrections do not affect search spectrum data. 

 

Time Corrections are enabled by default when the MR1 option is enabled. 
Time corrections should enabled when using MR1 Modulation Recognition to 
recognize digitally modulated signals1  and when using the N6820ES system 
to collect time capture files of digitally modulated signals that will be 
demodulated by another system. 

 

 

Apply Frequency Corrections 
 

When this is activated, the N6820ES system applies frequency- domain 
amplitude corrections to the search spectrum.   These corrections compensate 
for the RF response of the tuner and the response of the analog and digital 
filters in the tuner and ADC.  When enabled, search spectral data is corrected 
before being sent to energy processing or display processing. 

 

Use Frequency Corrections when amplitude accuracy and response flatness 
are important. 

 
Notes • Frequency Corrections do not affect time snapshots or signal processing. 

Also, Frequency Corrections do not affect frequency accuracy. 
 

• You may want to disable corrections when using an Environment 
Threshold that was captured with Frequency Corrections disabled. 

 

• At narrow resolution bandwidths (less than 1 kHz) Frequency Corrections 
may reduce search speed slightly. 

 

• Frequency Corrections must be selected to enable Antenna Corrections or 
Tuner Corrections. 

 

 

Apply Antenna Corrections 
 

Selecting this box directs the N6820ES system to apply antenna corrections 
to the search spectrum.   These corrections compensate for the RF response 
of each antenna.   To use this feature, you must: 

 

• Supply a calibration file for each antenna 
• Turn on Apply Frequency Corrections 
• Turn on Apply Antenna Corrections 
• Select the antenna in Search Setup 

 

Antenna calibration files are usually located in the C:\E3238s\cal directory. 
These text files list the antenna frequency response in dB.  For an example of 
the file format, see C:\E3238s\cal\d.antenna1.cal. After creating a 
1 Especially wide- bandwidth signals. 



 

 

Apply Antenna Corrections 
 

calibration file, add (or un- comment) lines in the N6820ES configuration file 
(usually C:\e3238s\e3238.cfg) to load the antenna calibration file.   For 
example, the following line will load “antenna1.cal” and apply it to the first 
antenna of search receiver 1: 

 

searchRx1.antenna1.calFile: antenna1.cal 



 

 

Apply User Tuner Corrections 
 

Apply User Tuner Corrections 
 

Clicking in this box directs the N6820ES system to apply user- supplied tuner 
corrections to the search spectrum.   Corrections compensate for the RF 
response of the tuner or block downconverter.   To use this feature, you must 

• Supply a calibration file for each tuner 
• Turn on Apply Frequency Corrections 
• Turn on Apply User Tuner Corrections 

 

Tuner calibration files are usually located in the C:\E3238s\cal directory. 
These text files list the tuner frequency response in dB.   For an example of 
the file format, see C:\E3238s\cal\d.tuner1.cal. After creating a calibration 
file, add (or un- comment) lines in the E3538s configuration file (usually 
c:\e3238s\e3238.cfg) to load the tuner calibration file.   For example, the 
following line will load “tuner1.cal” and apply it to the first tuner of search 
receiver 1: 

 
searchRx1.tuner1.userCalFile: tuner1.cal 

 

Correction Files 
 

This button displays a list of the correction files that have been loaded by the 
N6820ES software.  
 

The other entries are the antenna calibration files listed in the configuration 
file. 

 

 

Frequency Offset 
 
 

 
 

Frequency Offset adjusts the displayed frequency values to account for an 
external frequency conversion device such as a block downconverter or 
spectrum analyzer. 

 

This parameter value should be 0 when using a block downconverter that is 
supported and controlled by the N6820ES software. 



 

 

Simulator 

Frequency Offset 
 

 

Simulator 
 

Path: Utilities, Simulator 
 

 

 
 
 

When the command line switch -noHardware is specified, the 
N6820ES simulates the RF environment. The Simulator dialog box 
allows you to configure some aspects of the simulated environment. 

 

The Max Signals slider allows you to select how many simultaneous signals 
are in the simulated environment. The duration of each simulated signal 
is random. 

 

Selecting the Lock Current Signals option causes the current simulated 
signals to not change. 

 

If you have configured the N6820ES with a WDF license, the following 
setup options are available: 

 

• Fixed -  Selecting this option causes the simulation of a fixed- 
frequency, fixed- duration signal. 

 

• Hopper -  Selecting this option causes the simulation of a fixed- 
direction, changing frequency signal. 

 

• Moving -  Selecting this option causes the simulation of a 
changing- direction, fixed- frequency signal. 

 

• PTT -  Selecting this option causes the simulation of a fixed- 
frequency signal that alternates between two different directions. 

 

• Azimuth Noise -  This slider selects the amount of variability 
of the returned azimuth (direction) values.





 

 

The Help Menu 
 

 
 
 
 
 
 
 
 

 
 

This menu contains entries that provide help information.   Help is also called 
whenever you press the F1 function key. 

 

1. Process Overview (page 33) provides an introduction to the system process 
or  data flow. 

 

2. On Context (page 506) provides context- sensitive, quick help on items in 
the window that you select with the mouse. 

 

3. N6820ES Main Window (page 45) provides information about the 
N6820ES window. 

 

4. On Keys (page 507) provides information about using the mouse, function 
keys, mnemonics, and accelerator keys. 

 

5. On Index (page 511) provides the entry point into the online help text, 
starting at the introduction. 

 

6. On Microsoft HTML Help (page 512) provides information on using the 
online help features.   Two online help systems are provided.   If you are 
running the N6820ES on a local Windows system, the Microsoft HTML 
help viewer is provided.   If you are running the N6820ES remotely,   a 
less full- featured online help viewer is provided.  For information on 
using the less full- featured help viewer, see On Help (page 507). 

 

7. About N6820ES (page 510) provides the software version number and 
lists installed options. 



 

 

On Context 
 
 
 

On Context 
 

Accelerator: Shift+F1 

 

 
 

Clicking this entry causes the mouse cursor becomes a pointing hand. You can 
then move that hand so that the pointing finger is over any element on the 
screen. When the hand points to the screen element about which you want 
information, clicking it displays help for that screen element. 



 

 

Mouse  Features 
 

 

On Keys 
 

This entry in the Help menu covers a range of special topics: 

• Mouse Features (page 507) discusses features of the mouse pointer. 
• Accelerator Keys (page 508) discusses using and defining accelerator keys. 
• Function Keys (page 509) discusses using and defining function keys. 
• Mnemonics (page 509) discusses keyboard- based navigation (operation 

without a mouse). 
 

 

Mouse Features 
 

The mouse can be used to make some tasks easier.   The mouse has special 
features within a trace pane that are discussed in Mouse (page 466). 

 

To change the double- click speed, use the multiClickTime resource parameter. 
See “Application Resources” in the Installation and Configuration Reference. 

 

Pointers to mouse features: 

• Zoom scale; see Mouse (page 466) 
• Handoff a Signal (page 507) 
• Copy Marker Readout (page 61) 
• Activate/move a marker; see Marker On/Off (page 431) 
• Handoff a signal in a trace; see Handoff a Signal (page 507) 
• Handoff an entry in the handoff log; see Handoff Source (page 77) 
• Control handoff receivers; see Handoff Receiver Pane (page 70) 
• Activate popup menus: 

• Trace Popup Menu (page 456) 
• Handoff Log Popup Menu (page 83) 
• Color Spectrogram Popup Menu; see Trace Type (page 427) 
• Trace Snapshot Setup Popup Menu; See Trace Snapshot Setup (page 

438) 

 
Handoff a Signal 

 

The middle mouse button can handoff a signal from either the trace or the 
handoff log. 

 
From a Marker The following procedures assume that at least one trace pane and the handoff 

receiver panes are displayed.  See Trace Pane (page 52) and Handoff Log Pane 
(page 75).   To control which panes are active, see Display Layout (page 422). 
It also assumes that the left mouse button controls the trace marker and the 
middle mouse button performs drag- and- drop. 

If a marker is on in the trace, perform the following steps: 

1. Move the marker to the frequency you wish to hand off. 

2. Position the mouse cursor anywhere in the trace. 

3. Click the middle mouse button and hold it. 
 

4. Move the cursor to the handoff receiver you want to handle the signal (in 
the Handoff Log Pane (page 75)). 



 

 

On Keys 

Accelerator Keys 
 

5. Release the middle mouse button. 
 

From a Trace If a marker is not on in the trace, perform the following steps: 

1. Position the mouse cursor near the frequency you wish to hand off. 

2. Click the left mouse button and hold it (marker appears). 

3. Move the marker to the exact frequency (horizontally). 

4. Click and hold the middle mouse button. 

5. Release the left button (optional). 
 

6. Move the cursor to the handoff receiver pane (in the Handoff Log Pane 
(page 75)). 

 

7. Release the middle mouse button. 
 

From the 
Handoff Log 

Only completed signals can be handed off.   See Handoff Status (page 76). 

Perform the following steps: 

1. Click (and hold) anywhere on the log entry with the middle mouse button. 

2. Drag the mouse pointer to the handoff receiver control box. 

3. Release the mouse button. 
 

For information about other ways to handoff signals, see the discussion under 
the Handoff Log Pane, Handoff Source (page 77). 

 

 

Accelerator Keys 
 

An accelerator is a key or key- combination that invokes an action.   If an 
action has an accelerator, it is shown with the action’s label (in a menu, for 
example). 

 

 
 

Accelerator keys may be defined in the E3238s resource file, 
C:>/E3238s/E3238s. 



 

 

 
 

Function Keys 

Function Keys 

 

The function keys are above the number keys on the system keyboard. They 
are labeled F1, F2, ...   F12.   They are a special type of accelerator key that 
can perform functions without using Shift, Ctrl, or Alt.   They can be 
combined with the Shift, Ctrl, and Alt keys to offer more options. 

 

Assigning actions to function keys is described in The Macros Menu (page 
477). 

 

 

Mnemonics 
 

Keyboard mnemonics allow you to navigate the N6820ES menu bar with the 
keyboard instead of a mouse.   Note that each key on the keyboard is unique. 
For example, modifier keys such as the left Alt key and the right Alt key can 
and do function differently. 

 

To activate keyboard- based navigation, press function key F10. 
 

To use the keyboard, move the focus to the element you wish to activate and 
press Enter.   The focus is the element (button or menu item) that will be 
activated when you press Enter.   It is identified with a black box around the 
element. 

 

• Tab moves the focus to the next field. 

• Shift+Tab moves the focus to the previous field. 
 

• Ctrl+Tab moves the focus to the next field; useful in the text editor. A 
tab here goes into the text editor file while Ctrl+Tab is interpreted as a 
keyboard navigation instruction. 

 

• The keyboard arrow keys allow you to move within a field. 
 

 

Windows Keyboard Mapping 
 

In Windows you can map keyboard keys to keyboard functions using Exceed. 
To map keys: 

 

1. Select Start, Programs, Hummingbird Connectivity 10, Exceed, XConfig. 
 

2. Select the Mouse, Keyboard and other Input Devices Icon from the dialog 
box. 

 

3. Enter the keyboard mapping or mouse operation that you prefer in the 
dialog boxes. 

 

4. Validate and apply the changes by clicking the green checkmark in the 
toolbar or by selecting the “Validate and Apply Changes” entry in the 
Actions menu. 
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About N6820ES 

Windows Keyboard Mapping 
 

 

About N6820ES 
 

Path: Help, About N6820ES 
 

 

 
 
 
 
 
 
 
 

This information describes the installed N6820ES Signal Surveyor 4D 
Software. 

 

• Version is the released software version. 

• Date Code is the month/day/year that the executable was created. 



 

 

On Index 

On Help 
 

 

On Index 
 

The On Index menu item provides an entry point into the online help text, 
starting at the introduction.  This provides an entry to the help system that is 
not linked to a specific window, pane, menu, or dialog box. 

 

 

On Help 
 

To learn about using help, choose one of the following hyperlinks: 

• Using the Help Viewer 

• To find a help topic 

• To browse through the help topics 

 
Using the Help Viewer 

 

The Help Viewer displays the online help and provides navigation buttons. 
The two buttons on the top left side allow you to move back and forward 
through previously viewed topics. The four buttons located within the topic 
pane, above and below each topic, allow you to jump to the table of contents, 
index, next or previous topic.   An additional button at the bottom allows you 
to close the Help Viewer. 

 

The colored, underlined text within a topic pane is a hyperlink.   Click on a 
hyperlink to jump to another topic. 

 
To find a help topic 

 

• To view the table of contents, click the TOC button, and then scroll 
through the list using the scroll bar on the side.   The table of contents is 
a list of important topics. 

 

• To view the list of index entries, click the Index button.   Click on a letter 
to jump to that area of the index or scroll using the scroll bar on the side. 
Topics are often indexed under more than one entry. 

 
To browse through the help topics 

• To view the next topic in the browse sequence, click the Next button. 
Topics are arranged in a browse sequence in the same order as the table 
of contents. 

• To view the previous topic in the browse sequence, click the Prev button. 

• To view the topic that was previously displayed, click the Back button. 
Each time you display a new topic, the help system remembers the 
previous topics so you can go back. 

 

• To view the topic that was displayed prior to clicking the Back button, 
click the Forward button. 



 

 

 

 

On Microsoft HTML Help 
 

 

Using the HTML Help Viewer 
 

• On the left side of the window is the Navigation pane. It contains four 
navigational tabs: the Contents tab, the Index tab, the Search tab, and the 
Favorites tab. 

 

• On the right side of the window is the Topic pane. It displays the selected 
help topic, or the default help topic. 

 

• The third pane is the toolbar, which is located below the help window 
title bar. 

 
Getting more out of help 

 

Here are some tips on how to find more information when using the HTML 
Help Viewer: 

 

• To link to another topic, a Web page, a list of other topics, or a program, 
click the colored, underlined words. 

 

• To see if a word or phrase contained in a topic is in the index, select the 
word, and then press F1. 

 

• If you are viewing content from the Web in the Topic pane, you can click 
Stop or Refresh on the toolbar to interrupt a download or refresh a Web 
page. 

 

• If you use a particular help topic often, you can add it to your favorites 
list. 

 

• Right- click the Contents tab or Topic pane for shortcut menu commands. 



 

 

 

To find a help topic 
 

In the Navigation pane, click one of the following tabs: 
 

• To browse through a table of contents, click the Contents tab. The table of 
contents is an expandable list of important topics. 

 

• To see a list of index entries, click the Index tab, and then type a word or 
scroll through the list. Topics are often indexed under more than one 
entry. 

 

• To locate every occurrence of a word or phrase that may be contained in 
a help file, click the Search tab, and then type the word. 

 

Note Click the contents entry, index entry, or search results entry to display the 
corresponding topic. 

 
 

To create a list of favorite help topics 
 

1. Locate the help topic you want to make a favorite topic. 

2. Click the Favorites tab, and then click Add. 
 

Note To return to a favorite topic, click the Favorites tab, select the topic, and then 
click Display. 

 
If you want to rename a topic, select the topic, and then type a new name in the Current 
topic box. 

 

To remove a favorite topic, select the topic and then click Remove. 
 
 

To copy a help topic 
 

1. In the Topic pane, right- click the topic you want to copy, and then click 
Select All. 

 

2. Right- click again, and then click Copy. This copies the topic to the 
Clipboard. 

 

3. Open the document you want to copy the topic to. 

4. Position your cursor where you want the information to appear. 

5. On the Edit menu, click Paste. 
 

Note If you want to copy only part of a topic, select the text you want to copy, 
right- click, and then click Copy. 

 
 

To print the current help topic 
 

Right- click a topic, and then click Print. 
 

Note If you print from the Contents tab (by right- clicking an entry, and then 
clicking Print) you will see options to print only the current topic, or the 
current topic and all subtopics. 



 

 

 

To get help in a dialog box 
 

Click Help in the dialog box or press F1. 

 
To hide or show the Navigation pane 

 

On the toolbar, click Hide or Show to close or display the Navigation pane, 
which contains the Contents, Index, Search, and Favorites tabs. 

 

Note If you close the Help Viewer with the Navigation pane hidden, it will appear 
that way when you open the Help Viewer again. 

 
 

Using accessibility shortcut keys in the Help Viewer 
 

The following keyboard shortcuts can be used for navigation in the HTML Help 
Viewer. The help author who builds a compiled help (.chm) file can specify 
which buttons appear on the Help Viewer toolbar, so some of these options 
may not be available in your version of the viewer. 

 

For the Help Viewer: 
 

To Press 
 

Close the Help Viewer. ALT+F4 
 

Switch between the Help Viewer and other open windows. ALT+TAB 

Display the Options menu. ALT+O 

Change Microsoft Internet Explorer settings. The Internet 
Options dialog box contains accessibility settings. To 
change these settings click the General tab, and then click 
Accessibility. 

ALT+O, and then press I 

 

Hide or show the Navigation pane. ALT+O, and then press T 
 

Print a topic. ALT+O, and then press P 
 

Move back to the previous topic. ALT+LEFT ARROW, or ALT+O, and then press B 
 

Move forward to the next topic (provided you have viewed it 
just previously). 

 

ALT+RIGHT ARROW, or ALT+O, and then press 
F 

 

Turn on or off search highlighting. ALT+O, and then press O 
 

Refresh the topic that appears in the Topic pane (this is 
useful if you have linked to a Web page). 

 

Return to the home page (help authors can specify a home 
page for a help system). 

 

Stop the viewer from opening a page (this is also useful if 
you are linking to the Web and want to stop a page from 
downloading). 

 

F5, or ALT+O, and then press R 

ALT+O, and then press H 

ALT+O, and then press S 

 

Scroll through a topic. UP ARROW and DOWN ARROW, or PAGE UP 
and PAGE DOWN 

 

Scroll through all the links in a topic or through all the 
options on a Navigation pane tab. 

 

TAB 



 

 

 

For the Contents tab: 
 

To Press 
 

Display the Contents tab. ALT+C 
 

Open and close a book or folder. PLUS SIGN and MINUS SIGN, or LEFT ARROW 
and RIGHT ARROW 

 

Select a topic. DOWN ARROW and UP ARROW 
 

Display the selected topic. ENTER 
 

For the Index tab: 
 

To Press 
 

Display the Index tab. ALT+N 
 

Type a keyword to search for. ALT+W, and then type the word 
 

Select a keyword in the list. UP ARROW and DOWN ARROW 
 

Display the associated topic. ALT+D 
 

For the Search tab: 
 

To Press 
 

Display the Search tab. ALT+S 
 

Type a keyword to search for. ALT+W, and then type the word 
 

Start a search. ALT+L 
 

For the Favorites tab: 
 

To Press 
 

Display the Favorites tab. ALT+I 
 

Add the currently displayed topic to the Favorites list. ALT+A 
 

Select a topic in the Favorites list. ALT+P, and then UP ARROW and DOWN 
ARROW 

 

Display the selected topic. ALT+D 
 

Remove the selected topic from the list. ALT+R 
 

 

Note There are also shortcut menu commands that can be accessed through the keyboard. 
 

Shortcut keys also work in secondary and pop- up windows. 
 

Every time you use a shortcut key in the Navigation pane, you lose focus in 
the Topic pane. To return to the Topic pane, press F6. 



 

 

To use full-text search 
 

Using the shortcut menu commands 
 

There are several commands on the shortcut menu that you can use to display 
and customize information. 

 

Command Description 
 

Right-click in the table of contents, and then click Open All.   Opens all books or folders in the table of 
contents. This command only works if the 
Contents tab is displayed. 

 

Right-click in the table of contents, and then click Close All.  Closes all books or folders. This command only 
works if the Contents tab is displayed. 

 

Right-click, and then click Print. Prints the topic. 
 

 

Note These commands can be accessed through the keyboard. You can click 
SHIFT+F10 to display the shortcut menu, and then click the appropriate 
shortcut keys. Or, you can enable Mousekeys. Use a Mousekey combination to 
display the shortcut menu, and then click the appropriate shortcut keys. 

 
 

To use full- text search 
 

1. Click the Search tab, and then type the word or phrase you want to find. 

2. Click List Topics, select the topic you want, and then click Display. 

 
To highlight words in searched topics 

 

When searching for words in help topics, you can have each occurrence of the 
word or phrase highlighted in the topics that are found. 

 

• To highlight all instances of a search word or phrase, click Options on the 
toolbar, and then click Search Highlight On. 

 

Note To turn off this option, click Options on the toolbar, and then click Search 
Highlight Off. 

 
If you are viewing a long topic, only the first 500 instances of a search word 
or phrase will be highlighted. 



 

 

 
 

To customize the Help Viewer 

To customize the Help Viewer 

 

There are a few ways to easily change the size and position of the Help 
Viewer and the panes in the viewer: 

 

• To resize the Navigation or Topic pane, point to the divider between the 
two panes. When the pointer changes to a double- headed arrow, drag the 
divider right or left. 

 

• To proportionately shrink or enlarge the whole Help Viewer, point to any 
corner of the Help Viewer. When the pointer changes to a double- headed 
arrow, drag the corner. 

 

• To change the height or width of the Help Viewer, point to the top, 
bottom, left, or right edge of the Help Viewer. When the pointer changes to 
a double- headed arrow, drag the edge. 

 

• To reposition the Help Viewer on your screen, click the title bar and drag 
the Viewer to a new position. 

 

Note The Help Viewer will appear with the last size and position settings you 
specified when it is opened again. 

 
 

To change formatting or styles for accessibility 
 

1. On the Options menu, click Internet Options, and then click Accessibility. 

2. In the Accessibility dialog box, select the options you want, and then click 
OK. 

 

Note These changes do not apply to the Navigation pane or toolbar of the Help 
Viewer. 

 

This will also change your accessibility settings for Internet Explorer. 
 
 

To change the font size of a topic 
 

• On the Options menu, click Internet Options, and then click Fonts. 
 

Note These changes do not apply to the Navigation pane or toolbar of the Help 
Viewer. 

 

This will also change your font settings for Internet Explorer. 
 
 

To change colors in the Topic pane of the Help Viewer 
 

1. In Microsoft Internet Explorer, on the View menu, click Internet Options. 

2. On the General tab, click Colors. 

3. In the Colors dialog box, select the options you want, and then click OK. 

4. To apply the new color settings, in the Internet Options dialog box, click 
OK. 



 

 

To customize the Help Viewer 
 

Note These changes do not apply to the Navigation pane or toolbar of the Help 
Viewer. 

 

This will also change your color settings for Internet Explorer





 

 



Appendix A: User- Defined Threshold 
 

 

 
 
 
 
 
 

 
The threshold is part of the Process Overview (page 33). The threshold may be 
defined by creating an ASCII file containing commands as defined in the 
following text.   This file can then be loaded as described in the File (page 
318). 

 

The file has a header of either ASCII or BINARY. 
 

block, f1, delta_f, numpoints, p1, p2, ... p[numpoints] 
f1: Starting frequency 

delta_f: Frequency spacing between each point 
numpoints: Number of frequency points 

p[] : Amplitude data points in Vp squared 

If the frequency spacing of the threshold file does not match that of the 
measured data, the threshold is expanded or interpolated, as appropriate. 

 

level, f1, f2, level_dbm 
f1: Starting Frequency 
f2: Stopping Frequency 

level_dbm: Amplitude level in dBm 
 

slope, f1, f2, start_dbm, stop_dbm 
f1: Starting Frequency 

f2: Stopping Frequency 
start_dbm: Starting amplitude level in dBm 
stop_dbm: Stopping amplitude level in dBm 

Example: 
 

ASCII 
Level, 0, 1800000000, -100 
Slope, 900000000, 905000000, -100, -90 
Slope, 905000000, 910000000, -90, -50 
Level, 910000000, 940000000, -50 
Slope, 940000000, 945000000, -50, -90 

Slope, 945000000, 950000000, -90, -100 
 

Note All entries are case insensitive. 
 

If any entries overlap, the earlier entry in the file will be overwritten. 
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A 
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status 336 

task overview 39 
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time 87 

timing 350 

trigger 336 

type 87, 347 

visual task 353 

Alt keys 505 
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alarm 341 
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entry 348 
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configuration 226 

corrections 496 

selection 293 

switch 228 

anti-alias filter 252 
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DF processing 394 

handoff receiver 
alarm task 351 

from log pane 83 
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from trace 503 

playback channel 380 
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handoff receivers 70 

signal processing channels 379 
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tuner 436 

audio 
alarm task 354 

exporting 21 

filename extension 133 
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audio output controls 390 
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band 60 
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scroll 75, 86, 87, 115 

threshold 309 

autoload mission setup 
see Usage options 
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energy statistic 347 
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average load profile 382 

averaging 31, 297 
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background colors 467 
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alarm 338 
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database write 293 
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sorting 302 
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alarm 341 

alarm handoff 351 

bandwidth hints 321 
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criteria 305, 317 

DF processing 448 

DF task 448 

entry 348 

frequency snapshot 355 

handoff setting 431 

hints 320 
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description 321 

setup, multiple 322 

setup, single 321 
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status 321 

stop frequency 321 

mod rec 401 

mod rec setup 370 
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signal 34, 317 

snapshot 137, 438 

basic operation concepts 22 

BFO 71 
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receiver task 352 
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signal processing 25 
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mod rec 370, 401 

board revision 257 
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complex data 137 

compress bands 303 
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file 16 

file used 492 
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preset 134 

save 129 

save/load 132 

state 41 

configure 
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buttons 50 

CS5040 tuner 245 
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handoff receivers 264 
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trace settings 420 
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control 
handoff receivers 72 
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files 498 
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energy detection 316 
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cursor shortcuts 
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collection (signal) 345 
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compression (DSP) 257 
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change 293 
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DDC configuration 258 
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delay 
ADC trigger 252 
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delete 
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queue entry 378 
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description 
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of commands 116 
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detection 84, 432 

alarm 343 

energy, overview 34 

receiver 71 

receiver task 352 

signal, overview 39 

types 81, 352 

DF 
main display 391 

manual assignment 395 

marker task setup 448 

pending 
list 392 

setup 393 

status display 394 

task bandwidth 448 

differential grounding 252 

digital downconverter (DDC) 25 

directed search 283 

band description 290 

band setup 289, 301 

band sort 302 
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preset 134 

save setup 129 
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documentation 
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DF task 448 
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initial configuration 16 
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on/off 427 

overload indicator 62 

popup menu 69 

readout 61 

reference, see delta 
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multiple snapshot setups 64 

narrow-band processing 274 
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pending handoffs 75 

PMC sites (delay) 262 
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post-filter 37 

post-filter, energy history 331 

precision, data (ADC) 251 
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configuration 255 
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time 273 
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program control 487 

programming 555 
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keys 503 
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quit 
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save 
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alarm 338 
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print 141 
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menu 281 

on/off 282 

optimization 283 
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preset 134 
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configuration 227 

system overview 33 

type 283 
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secure display 483 
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password setup 483 
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threshold 310 
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shortcuts 503 

snapshot setup 64 
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show 
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window panes 418 
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configuration 270 
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file menu 109 
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overview 39 

pane 107 

save before exit? 111 
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handoff source 77 
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processing 
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hardware configuration 269 

interruption 274 
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modify 
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monitor 381 

overview 39 
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status 376 
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types 261, 269 
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snapshot 251, 435 
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